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Chapter 1: Introduction
1.1 Preface
The rapid evolution of information technology has brought unprecedented convenience to business growth, while also introducing serious risks and challenges to information protection and management.
Ensuring Information and Data Security
A global information security survey covering more than 7,200 executives across 130 countries and regions shows that effective enterprise security must be targeted, with data protection as the primary concern. The survey found that 56% of respondents reported their organizations lack data loss prevention capabilities, while nearly half of Chinese respondents indicated that, although data loss prevention measures were in place, access authorization controls had not been implemented. 
Today, most business information and data are stored and transmitted as electronic documents. From design drawings to customer information, and from financial records to paperless administrative documents, electronic files significantly accelerate information flow and business processes. However, their inherently open nature—easy to access, copy, and distribute—combined with widespread internet use and the prevalence of portable storage devices, presents unavoidable security challenges.
Difficulty in Evaluating and Controlling System Usage Efficiency
Recent survey results indicate that a large proportion of employees use instant messaging and social media during work hours, with online news sites being the most frequently visited. Even just two hours of unproductive computer use per day per employee can result in significant financial losses. For a company with 50 employees, this could translate into substantial annual costs. In addition, misuse of network and system resources may introduce hidden security risks from the Internet, potentially compromising overall system safety.
Cumbersome System Maintenance and Asset Management
Studies by Gartner and Forrester Research indicate that nearly half of IT departments’ time is spent installing and upgrading software, with 70–80% of IT staff workload devoted to routine PC maintenance. This significantly increases overall network management costs, and unresolved issues can seriously disrupt business continuity.
AnySecura is a powerful tool designed to address these challenges through a modular architecture that integrates behavioral auditing, tiered authorization, access control, centralized management, and transparent document encryption/decryption.
Its document encryption module employs advanced technologies to ensure integrity and availability, while high-speed caching minimizes system performance impact. With high security, stability, and usability, AnySecura is suitable for businesses of all sizes, government agencies, public institutions, and research organizations seeking to protect their confidential information.
1.2 Features Overview
AnySecura is built on system management principles and security best practices, comprehensively addressing potential sources of information breaches or leaks. It safeguards enterprise data from unauthorized access, theft, and malicious modification, enabling organizations to plan and manage information security systematically.
Through flexible and robust management, AnySecura standardizes endpoint behavior while maintaining organizational productivity, enhancing overall execution. Administrators can monitor the status of all computers from a single console and perform system security and asset management tasks efficiently.
The main features of AnySecura include:
Application Control
Logs application usage. 
Tracks usage time and percentage for each application.
Controls application execution.
Web Browsing Control
Logs visited URLs and page titles.
Tracks browsing time and percentage.
Restricts access to specified websites or pages.
Document Operation Control
Records all document operations across different storage devices and types of actions.
Logs deletions and modifications in shared directories by other computers.
Provides flexible permission settings to control reading, modifying, and deleting documents.
Supports backup for important document copy and deletion operations.
Print Control
Logs all print tasks.
Captures complete print images of documents.
Controls printing operations.
Device Control
Manages usage of various computer devices.
Controls any newly added devices.
Network Control
Controls network communications based on client type, network address, and port categories.
Detects unauthorized computers on the network and blocks their access.
Network Traffic Control
Logs network traffic and generates statistics.
Controls traffic according to address and port ranges within specified time periods.
Screen Monitoring
Real-time viewing of client screens.
Records historical screen activity at variable frequencies depending on the application.
Converts historical screen recordings into standard video files for playback.
Email Control
Logs email sending/receiving, including full content and attachments.
Controls email sending according to policy.
Instant Messaging Control
Records chat times, contacts, and message content in popular IM tools.
Controls document sharing via IM.
Backs up outgoing documents.
Asset Management
Automatically scans and records hardware and software assets, tracking changes.
Customizes asset attributes and categories for IT and non-IT assets.
Scans Microsoft product patch installation, distributing and installing updates automatically.
Detects client security vulnerabilities and provides analysis and solutions.
Supports automated software deployment, installation, and document distribution.
Remote Maintenance
Real-time client monitoring and remote operations.
Remote desktop access for assistance.
Supports remote file transfer.
Removable Storage Control
Logs usage of portable storage devices, sets access permissions, and controls read/write access.
Automatically encrypts/decrypts documents on removable devices to prevent unauthorized access.
Risk Statistics and Reports
Multi-dimensional analysis of activities including printing, email, removable storage, document operations, application use, web browsing, and instant messaging.
Visualizes user behavior trends to identify potential risks.
Tiered alert system records incidents and severity when thresholds are exceeded.
Automatically generates periodic reports.
Document Cloud Backup
Backs up client data to a centralized document server for storage and management.
Supports scheduled, triggered, and full-disk backup.
Maintains multiple backup versions as needed.
Software Center
Administrators can add and manage software.
Users can install, upgrade, or uninstall authorized software.
Watermarking and Traceability
Supports on-screen watermarks (full-screen or application window only).
Supports print watermarks for physical documents.
Adds document watermarks automatically or manually for tracking internal and external sharing.
Document Labeling
Monitors and labels documents with classification and sensitivity levels.
Performs full-disk scans for labeled documents.
Controls external transmission based on labels and sensitivity.
Sensitive Content Detection
Defines sensitive information using keywords and regex combinations.
Supports local and remote scanning, including full-disk scans.
Monitors and protects documents containing sensitive content.
Visual Perception
Detects attempts to photograph computer screens.
Automatically blocks the screen, locks the computer, or alerts administrators when violations occur.
Offers flexible unlock methods: automatic unlock when no photography detected, manual click unlock, or facial recognition.
Logs screen capture attempts with user and screen details.
Transparent Document Encryption/Decryption
Automatically enforces encryption for critical documents.
Sets permissions for screenshot, printing, copy/paste, drag-and-drop, and email actions.
Implements tiered access permissions based on organizational hierarchy.
Audits decryption requests for external sharing.
Supports offline and outbound document permission control.
Provides encrypted document operation auditing and backup.
Chapter 2: Installation and Deployment
2.1 Basic Operating Framework
The AnySecura system consists of three main modules: the client module, the server module, and the console module. These can be installed on networked computers according to management requirements.
Client Module: Collects data and enforces system management policies. It is installed on each computer that needs to be managed.
Server Module: Stores system data and management policies. It is typically installed on high-performance computers with large storage capacity.
Console Module: Allows administrators to view system data, configure management policies, and perform real-time maintenance. It is usually installed on administrators’ computers, but can also be installed on the same machine as the server module.
Basic Framework
The basic system framework is illustrated in the diagram below:
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AnySecura is built on a TCP/IP network architecture, allowing flexible extension from local networks to remote and geographically dispersed networks. The server can connect to remote computers via a Virtual Private Network (VPN) or the Internet, enabling centralized management of large and complex networks. The console can also connect to remote servers over the Internet for monitoring branch offices.
Repeater Framework
For larger and more complex networks, a repeater framework can be deployed on top of the basic system. Repeaters are installed in each subnet to manage client connections, while linking to the main server. This ensures smooth communication between clients and the server, proper policy deployment, and normal log uploads to the server. Deploying multiple repeaters can expand the processing capacity of the main server, making the system more suitable for large-scale, geographically distributed network environments.
The system’s repeater framework is illustrated in the diagram below:
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Basic Functions of the Server Module:
Manages all client computers and distributes relevant rules and instructions.
Collects and stores data gathered from clients.
Provides flexible record management, including viewing, archiving, and searching.
Basic Functions of the Repeater Module:
Connects to the main server and obtains authorization, forwarding server rules and instructions to connected clients.
Collects client data and uploads it to the main server.
Basic Functions of the Console Module:
Views and audits client data.
Performs data statistics, analysis, and export.
Monitors client computers in real time and performs system maintenance.
Configures monitoring rules and management policies.
Basic Functions of the Client Module:
Executes various management policies set by the system.
Collects operational data from the client computer.
Periodically sends collected data to the server.
Performs monitoring actions based on instructions from the console.
2.2 Software and Hardware Requirements
Before installing the AnySecura server, a database must be installed. The supported operating systems and recommended hardware configurations for each module are as follows:
	Installation Module
	Basic Computer Requirements

	Database
	SQL Server 2000 SP4 / MSDE SP4 
SQL Server 2005 SP1 / SQL Server 2005 Express SP1 (32/64-bit)
SQL Server 2008/ SQL Server 2008 Express (32/64-bit)
SQL Server 2012/ SQL Server 2012 Express (32/64-bit)
SQL Server 2014/ SQL Server 2014 Express (32/64-bit)
SQL Server 2016/ SQL Server 2016 Express (64-bit)
SQL Server 2019/ SQL Server 2019 Express (64-bit)
SQL Server 2022/ SQL Server 2022 Express (64-bit)

MySQL 5.7 or higher

	Server Module
	OS: Windows2000 SP4 / WindowsXP SP2 / WinServer2003 SP1 / Vista / WinServer2008/ Windows7 / Windows8 / WinServer2012 / Windows 10 / WinServer2019 / Windows11 / WinServer2022
Includes both 32-bit and 64-bit versions of Windows 

Minimum: Pentium 4 2GHz, 2GB RAM, 20GB free disk space
Recommended: Dual/Quad-core Pentium 4, 4GB RAM, 120GB free disk space

	Repeater Module
	OS: Windows2000 SP4 / WindowsXP SP2 / WinServer2003 SP1 / Vista / WinServer2008/ Windows7/ Windows8 / WinServer2012 / Windows10 / WinServer2019 / Windows11 / WinServer2022
Includes both 32-bit and 64-bit versions of Windows 

Minimum: Pentium 4 2GHz, 2GB RAM, 20GB free disk space
Recommended: Dual/Quad-core Pentium 4, 4GB RAM, 120GB free disk space

	Web Server Module
	OS: WinServer2008R2 / WinServer2008 R2 SP1 / WinServer2012 / WinServer2012 R2 / WinServer2016 / WinServer2019 / WinServer2022 / Windows7 /WindowsSP1 / Windows8 / Windows8.1 / Windows10 / Windows11
64-bit version only 

Minimum: Pentium 4 2GHz, 2GB RAM, 20GB free disk space
Recommended: Dual/Quad-core Pentium 4, 4GB RAM, 120GB free disk space

	Document Cloud Backup Server Module
	OS: WinServer2008R2 / WinServer2008 R2 SP1 / WinServer2012 / WinServer2012 R2 / WinServer2016 / WinServer2019 / WinServer2022 / Windows7 /WindowsSP1 / Windows8 / Windows8.1 / Windows10 / Windows11
64-bit version only
Minimum: Pentium 4 2GHz, 2GB RAM, 20GB free disk space
Recommended: Dual/Quad-core Pentium 4, 4GB RAM, 2TB free disk space

	Console Module
	OS: Windows2000 / WindowsXP / WinServer2003 / Vista / WinServer2008 / Windows7 / Windows8 / WinServer2012 / Windows10/ WinServer2019 / Windows11 / WinServer2022
Includes both 32-bit and 64-bit versions of Windows

Minimum: Pentium III 500MHz, 512MB RAM, 256MB free disk space
Recommended: Pentium 4, 1GB RAM, 1GB free disk space

	Client Module
	OS: Windows2000 / WindowsXP / WinServer2003 / Vista / WinServer2008 / Windows7 / Windows8 / WinServer2012 / Windows10/ WinServer2019 / Windows11 / WinServer2022

Includes both 32-bit and 64-bit versions of Windows
Minimum: Celeron II 433MHz, 4GB RAM, 4GB free disk space
Recommended: Pentium 4, 8GB RAM, 8GB free disk space


[image: image3.bmp] Note 
If the Server Module is installed on Windows 2000 SP4, ensure that the “Windows 2000 SP4 Update Rollup (KB891861)” is installed beforehand.
2.3 Installation and Deployment of Server and Console
2.3.1 Database Installation
The server module requires SQL Server 2000 SP4 or later, or SQL Server 2005 SP1 or later. If SQL Server is not available, Microsoft’s free options, MSDE SP4 or SQL Server 2008 R2 Express, can be used.

When using a free database, SQL Server 2008 R2 Express is recommended because it has a larger capacity limit than MSDE and includes a management interface for easier database maintenance.
[image: image4.bmp] Note
MSDE has a 2GB database size limit, while SQL Server 2008 R2 Express allows up to 10GB. Both have some performance limitations, so for larger data volumes, it is recommended to use SQL Server 2000 or 2005 Standard Edition (or higher).
Ensure that SQL Server 2000 has SP4 installed and SQL Server 2005 has SP1 installed. If the server fails to start, check the system logs under Computer Management → Event Viewer → Application Logs to see if it is a SQL Server version issue.
Installing SQL Server 2008 R2 Express
It is recommended to install SQL Server 2008 R2 Express.
Before installation, ensure the operating system has the following components:
1. Windows Installer 4.5
2. .NET Framework 3.5
3. Windows PowerShell 1.0
The installation disc includes Windows Installer 4.5, .NET Framework 3.5, Windows PowerShell 1.0, and the SQL Server 2008 R2 Express installer.
Installation Steps:

1) Run the SQL Server 2008 R2 Express installer to open the SQL Installation Center.

2) In the Installation section, select New installation or add features to an existing installation, wait for processing, accept the license terms, and click Next.
3) Install required components by clicking Install; after successful installation, click Next.

4) In Feature Selection, use the default options and click Next.

5) In Instance Configuration, select the Default Instance. Using a named instance may prevent the server from starting. Keep other settings default and click Next.

6) In Disk Space Requirements, click Next.

7) In Server Configuration, set the SQL Server Database Engine account to NT AUTHORITY\SYSTEM and click Next.

8) In Database Engine Configuration, choose Mixed Mode Authentication, set a password for the sa account, and leave other settings default. Click Next.

9) In Error Reporting, leave the default options and click Next.

10) Start the installation and wait for it to complete.
2.3.2 Installing the Server and Console Modules
After the database installation is complete, the server and console modules can be installed. Follow these steps:

1) Double-click IPguard3.exe, select the installation language, and click OK.

2) The welcome screen will appear. Click Next to continue.

3) The installer will prompt you to confirm the installation path. You can choose a different path if needed. It is recommended to select a drive with sufficient free space for the AnySecura server.

4) The installer will prompt you to select the installation type and components. Choose to install the server and console modules as required, then click Next.

5) Choose the Start Menu folder for shortcuts and click Next.

6) Confirm all settings and click Next. After file copying is complete, the installation finishes. Click Finish to complete the process. The server module will start automatically, and a small icon will appear in the system tray.

During installation, the program will check system requirements, including the operating system and SQL Server version. If the installation cannot proceed, follow the prompts to resolve any environment issues.

Administrators can also install the console module separately on other machines to view data and monitor client computers.

2.3.3 Server Registration
Right-click Service Controller, select Tools → Register, and enter the administrator password to access the registration interface.
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After the server is installed for the first time, AnySecura automatically generates a 30-day trial serial number. The trial serial number does not include encryption functionality.
To activate the full version, the administrator should click the Upgrade button. This makes the Main Serial Number and Extended Serial Number fields editable. Enter the purchased main and extended serial numbers, then click OK. If the serial numbers are valid, the system will display “Serial Number Upgrade Successful” and prompt that the product needs activation. You must obtain a registration code through product registration to activate the product.
Extended Serial Number authorizations include:

Read-only encryption、Transparent encryption、Sensitive information identification、Secure desktop、USB encryption client
If the server hosting AnySecura has Internet access, there are two registration methods:
Online Registration
Fill in your company information in the product registration dialog, including company name, contact person, phone number, and email address. Click Online Registration to automatically receive the registration code. Click Register, and the system will display “Registration Successful”.
Email Registration
You can also register via email. In the product registration dialog, enter your company information, including company name, contact person, phone number, and email address. Click Send Email—a mail window will appear. Verify the information and send the email.
The registration code will be sent to the email address you provided. Once received, copy the code into the designated field and click Register. The system will display “Registration Successful”, completing the registration process.
[image: image6.bmp] Note
The email address entered during the first registration is very important. If you need to register again later, the new registration code will be sent to the initially provided email address.
2.3.4 Setting the System Verification Code
The verification code is a unique identifier for the server and clients, in addition to the serial number. Its purpose is to enhance system security. A client can only be managed by the server if its verification code matches the server’s. It is recommended to set the verification code on the server first and then package the client installation program. This ensures the server’s serial number and verification code are included in the client installer, preventing unauthorized servers from taking control of enterprise clients.
After installing the server for the first time:

Right-click Service Controller and select Tools → Verification Code.Enter the administrator account and password to access the verification code settings. Enter the verification code, confirm it by entering it again, and click OK. The verification code will be successfully set.
By default, the verification code is empty. If a client has no verification code, the server will automatically update all connected clients with the newly set verification code, ensuring consistency between the server and clients.
If the server sets a new verification code later, any client that recognizes a previously set verification code matching its own will automatically update its verification code to match the new server code.
[image: image7.bmp] Warning:
Administrators must remember the verification code. After reinstalling the server or changing the system, you need it to regain control of previous clients. Otherwise, redeployment of the clients may be necessary.
If a client is running but does not appear in the console, check AnySecura Console → Logs → System Events to see if it is due to a verification code validation failure.
2.3.5 Server Logs
Right-click Service Controller and select Tools → Logs to open the operating system’s Event Viewer. Select Application to view the OSERVER3 runtime logs, including server start and stop events, error logs, and more. Administrators can use this information to analyze the server’s operational status.
2.4 Installing and Deploying the Repeater
Computers used for deploying a repeater must have a database installed.
2.4.1 Installing the Repeater Module
After installing the database, the repeater module can be installed by following these steps:
1) Double-click IPguardRelay.exe, select the installation language, and click OK.
2) The welcome screen will appear. Click Next to continue.

3) The installer will prompt you to confirm the installation path. You can choose a different path if needed. It is recommended to select a drive with sufficient space for the AnySecura repeater.
4) Select the database and click OK.

5) Choose the Start Menu folder for shortcuts and click Next.
6) Confirm all settings and click Install. Once file copying is complete, click Finish to complete the installation. The repeater module will start automatically. Since it has not yet connected to any main server and is unauthorized, the tray icon will appear as [image: image8.png]
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2.4.2 Connecting to the Main Server
Right-click the repeater’s tray icon, select Tools → Set Connection Parameters from the context menu, and enter the main server information along with the applicant details in the connection settings window.
	Parameter
	Description

	Main Server Address
	The address of the main server, either an IP or domain name.

	Applicant
	Name of the applicant.


After the repeater connects to the main server, it must be authorized in the console under Tools → Server Management → Repeater Server Management.
2.4.3 Repeater Logs
Right-click Repeater Controller and select Tools → Logs to open the operating system’s Event Viewer. Select Application to view the repeater’s runtime logs, including start and stop events, error logs, and more. Administrators can use this information to monitor and analyze the repeater’s operation.
2.4.4 Viewing Repeater Status
The repeater’s tray icon indicates its current operational status. The possible states are:
	Icon Status
	Description
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	Repeater status unknown
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	Repeater not connected to the server, or connected but not authorized
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	Repeater is starting
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	Repeater connected to the server and authorized
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	Repeater stopped


Right-click the repeater’s tray icon and select Status from the context menu to view more detailed information about the repeater’s current state.
	Property Name
	Description

	Name
	The repeater name displayed in the console under Tools → Server Management → Repeater Server Management. Defaults to the computer name of the machine hosting the repeater. Can be renamed in the console.

	Computer
	The computer name of the machine hosting the repeater.

	Applicant
	The applicant name set when configuring the repeater’s connection parameters.

	Network Address
	The IP address of the machine hosting the repeater.

	Operational Status
	Includes: "Unauthorized, disconnected from main server", "Connected, not authorized", "Connected, authorized".

	Start Time
	The time when the repeater was started.

	Uptime
	The duration the repeater has been running since startup.

	Main Server Address
	The IP address of the main server the repeater is connected to.

	Connection Status
	Shows the repeater’s connection to the main server. Displays "Connected" if successful or "Connection Failed" if there is an issue.

	Last Connection Time
	The most recent time the repeater connected to the main server.

	Authorization Status
	Indicates whether the main server has authorized the repeater: "Authorized" or "Unauthorized".

	Authorization Update Time
	The latest time the main server updated the authorization.

	Connected Clients
	The number of online clients connected to this repeater.


2.5 Installing and Deploying the Web Server
AnySecura supports a browser-based (B/S) management mode. By deploying the web server, administrators can log in from any machine using a browser to perform console-related operations, such as viewing logs, generating reports, and handling approvals.
A computer hosting the web server does not require a database installation.
Installation Steps:：

1)  Double-click AnySecuraWebServer.exe, select the installation language, and click OK.

2） The welcome screen appears; click Next to continue.

3） Confirm the installation path or select a custom location.

4） Configure the server IP and port. The server IP should be the IP of the AnySecura server the web server will connect to. If installed on the same machine, keep the default 127.0.0.1. The port is the access port for the web server, default is 80.

5） Select the components to install:

WebConsole — Web console

WebReport — Web reports

WebApprove — Web approvals

JAVA — Required for Web approvals

OpenOffice — Required for Web approvals

It is recommended to install all components, then click Next.

6） Choose the Start Menu shortcut folder and click Next.

7） Confirm all settings and click Install. After copying files, click Finish to complete the installation. If a Windows Firewall prompt appears for Apache HTTP Server, click Allow Access.

After installation, the web server module starts automatically, and its icon will appear in the system tray [image: image14.png]
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2.6 Deploying the Client Module
The client module can be deployed using several methods: direct installation, remote push, or domain login script installation. Choose the method that best fits your deployment needs.
2.6.1 Installing the Client Module
Direct installation of the client module requires first creating a client installer, which must then be manually run on the target machine. Administrator privileges are required for installation.
The client installer must be packaged on the server machine:
Windows client: On the server machine, go to Start → All Programs → AnySecura → Create Client Installer to open the Windows client packaging tool.

Mac client: On the server machine, go to Start → All Programs → AnySecura → Create Client Installer (Mac) to open the Mac client packaging tool.

Linux client: On the server machine, go to Start → All Programs → AnySecura → Create Client Installer (Linux) to open the Linux client packaging tool.

The interfaces and usage of all three client packaging tools are similar. The following instructions use the Windows client packaging tool as an example.
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The client installer includes the following configurable parameters:
	Parameter
	Description

	Server IP Address
	Default is the current machine's IP. If the server has multiple IPs, enter a valid one.

	Silent Installation
	When checked, the installer runs silently without any interface; if unchecked, it runs normally with UI.

	Interface Settings
	Click to configure the installer interface.

	Installer Title & Icon
	Set the window title displayed during installation. You can choose to include the version number or installer name. You may enter custom text in the input field, supporting multiple languages.
Custom Installer Title Settings:：

1. Set Title for All Languages
Simply enter the text you want to display. For example, entering “agent” will display “agent” as the installer title in all language systems.；

2. Set Title for Specific Languages
Format: language_code=content

Supported language codes:
chs — Simplified Chinese
cht — Traditional Chinese
enu — English
jpn — Japanese
kor — Korean
rus — Russian

Rules:
English (enu) takes priority. If English is set and other languages are not, those languages will display the English content. If other languages are set, they display their respective content.
Examples:
a. enu=agent → Displays “agent” in all languages.

b. chs=客户端;cht=用戶端;enu=agent → Simplified Chinese: “客户端”, Traditional Chinese: “用戶端”, English: “agent”, other languages: “agent”.

c. Agent;chs=客户端;cht=用戶端;enu=agent → Simplified Chinese: “客户端”, Traditional Chinese: “用戶端”, English: “agent”, other languages: “Agent”.

You can choose an icon for the installer by selecting the icon option and clicking the[image: image16.jpg]


 button to browse for a file. Only .ico format files are supported.

	Installer Properties
	Set the file description and product name displayed for the installer.

	Advanced Settings
	Click to access advanced options:

	    Package configuration to a separate file
	If unchecked, configuration is included in the installer
if checked, it is saved in AgentSetup.dat and must be in the same directory as the installer during installation.

	Elevate UAC Privileges
	Installer runs with administrator privileges when checked.

	Installer Password
	Require a password to run the installer.

	User License
	Include a user license agreement; installation proceeds only after acceptance.

	Import Client Policy
	Click the[image: image17.jpg]


 button to select an exported client policy .ipz file from the console (see the “Policy Export” section in the console chapter). After installation, the client will automatically import the policy and synchronize with the server once connected.

For certain features that require a .dat file, you can import it along with the client policy. Place the policy file and the .dat files in the same directory and select all files to include them in the installer. 

	Expiration
	Installer becomes invalid after the specified date/time.

	Username and Password
	If the logged-in user lacks admin rights, provide admin credentials here to ensure successful installation.

	Output Path
	Set the installer filename, format (.exe or .msi), and save location.


Click the “Create Client Installer” button to generate the client installation package.
[image: image18.bmp] 
1. Packaging the installation configuration into a separate file allows the installer to include a digital signature, reducing the risk of false antivirus alerts during installation.
2. Silent installation and advanced settings are not supported when packaging Mac or Linux clients.
3. The options “Silent Installation” and “Elevate UAC Permissions” cannot be selected simultaneously.
2.6.2 Remote Deployment of Clients
For large organizations with numerous and widely distributed computers, manual installation on each machine is time-consuming and inefficient. Remote deployment solves this problem by allowing batch installation of client software without physically accessing each computer.
On the machine with AnySecura Server installed, go to Start -> All Programs -> AnySecura -> Remote Install Client Module to launch the remote installation tool.
This tool supports installation on Windows NT 4.0, 2000, XP (x86/x64), 2003 (x86/x64), 2008 (x86/x64), Vista (x86/x64), and Windows 7 (x86/x64). For Windows 9x or ME machines, clients must be installed locally on the target computer.
Scan Settings：
By default, the system scans all computers within the local subnet. To scan computers in other subnets, open the scan settings dialog via File -> Scan Settings, add the desired IP ranges, and optionally adjust the scanning interval.
The icons in the computer list indicate the following statuses:
	Icon
	Color
	Window NT4 / 2000 / XP
	Window 95 / 98 / Me
	Online
	Agent Installed
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Remote Installation
Select the target computers for client module installation. You can choose multiple machines simultaneously, then click Action → Start Installation to begin. The installation status for each computer will be displayed in the status bar, and all logs can be viewed in the installation log window below.
【Common Issues】
· The currently logged-in user lacks administrative privileges on the target computer. In this case, an error window will appear; provide a username and password with administrator rights on the target machine.
· The target computer does not have the admin share enabled. Open a command prompt (cmd.exe) on the target computer and run net share to check if the ADMIN$ share is active. If not, execute net share ADMIN$ to enable it.
· The target computer cannot access your local shared files. This may be because the Admin$ share on your machine is disabled or the target computer lacks permission to access it.
[image: image25.bmp] Note
1. Mac and Linux clients do not support remote push installation.
2. Due to certain security restrictions in Windows NT networks, remote installation may fail if sufficient permissions are not available. In such cases, install the client directly on the target machine using the AnySecura client installer.
2.6.3 Installation via Login Script
In a domain environment, clients can be installed automatically by modifying the domain login script. When a Windows user logs in to the domain, the script executes and installs the AnySecura client on their machine.
Steps:
1) Locate the LogonScript folder on the installation CD and copy the entire directory to the domain server.
2) On the AnySecura server, create a client installer and name it SAgentInst.exe.
3) Copy SAgentInst.exe into the LogonScript folder on the domain server.
4) Run LgnMan.exe in the domain server’s LogonScript folder to configure the domain login script.
Instructions:
1) After running LgnMan.exe, the interface will display a sorted list of user groups from the domain server. It shows the login script status for each user. A green background on a user icon indicates that the login script already includes the AnySecura client installation command.
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2) Administrators can click the column headers to sort the list and use CTRL or SHIFT to select multiple users. In the menu bar under Tools or via the function buttons, they can set or remove the installation commands.
3) Users with installation commands will trigger the domain login script upon logging in, automatically installing the AnySecura client on their computers.
4) Once the AnySecura client is successfully installed, the administrator can remove the installation commands for those users, restoring their login scripts to the original state.
Button Functions
	Icon
	Function
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	Set installation command – adds the installation command to the selected users’ login scripts.
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	Remove installation command – deletes the installation command from the selected users’ login scripts.
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	Set installation scope – defines the range of computers for domain login script installation using IP addresses or computer names, including both included and excluded ranges; supports cross-subnet addresses.
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	Export – exports the domain script tool list in Web, Microsoft Excel, or text file formats.
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	Refresh – updates the list view.


[image: image32.bmp] Note
Mac and Linux clients do not support installation via domain login scripts.
2.7 Creating the USB Encryption Client
2.7.1 Registration
To use the USB Encryption Client, registration is required. Contact the vendor and provide your main serial number along with the number of USB Encryption Client licenses needed. The vendor will generate the registration file USBALicenseCertFile.dat.
Log in to the console, navigate to Tools → Client Management → USB Encryption Client Management, and in the pop-up window, click Import to select the USBALicenseCertFile.dat file. After importing, the available license count and validity period will be displayed at the bottom of the window.
2.7.2 Creating the USB Encryption Client
Creating the USB Encryption Client involves two main steps:
1.Generating the USB client program files.

2.Turning a specified USB drive into an encrypted client.

Download and extract the USB Encryption Client package. Copy AInstGen_SDUDisk.exe and AKernel3U.e32 to the server installation directory, and copy the UDiskSetup folder to the machine where the USB drive will be created.
Generating the USB Client Program
Run AInstGen_SDUDisk.exe on the server machine to open the creation interface.
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Parameters：
	Name
	Description

	Server IP/Name
	Defaults to the current machine's IP. If the server has multiple IPs, enter a valid one. You can also use a machine name that is reachable.

	Output Path
	Specifies the file name and storage location of the USB Encryption Client installer. The generated file type is .ipk.


Click Create Client Installation File to generate the USB Encryption Client installer.
Creating the Encrypted USB Client
Insert a USB drive into the computer. Run SDUDiskFormatter.exe from the UDiskSetup folder, select the USB drive under removable drives, choose the previously generated USB client installer file, and click Start Creation. Wait for the process to complete.
2.7.3 Authorization
After creating a portable USB Encryption Client, the USB drive must be authorized; otherwise, encryption features will not be enabled.
Open the prepared USB drive and run USDconf.exe. The USB Encryption Client Policy Update Tool will appear. Click Export Removable Disk Info to save the USB’s information as a .uea file.
In the console, go to Tools → Client Management → USB Encryption Client Management. In the management window, click the[image: image34.png]


 button to add USB client authorization, then select the .uea file to authorize the USB.
Once authorized, a USB Encryption Client node will appear under the selected group in the computer tree. Initially, the node will appear gray because it has not yet been used on any computer. The client will inherit the group’s encryption policies by default, but specific encryption policies can also be assigned to it.
2.8 System Upgrade 
2.8.1 Updating Maintenance Code
Maintenance Period
The duration during which the user is entitled to maintenance services.
Maintenance Code
The credential that allows the user to access maintenance services.

After renewing maintenance, the maintenance code must be updated to enable upgrading to the latest product version, access new features, and continue enjoying maintenance services. The maintenance period is embedded within the maintenance code.

When installing the server for the first time, if no maintenance code is available, the system allows a 15-day trial without a code. If the code is still not obtained after 15 days, the console cannot be accessed. Once a maintenance code is acquired, its validity is checked. If the product version’s release date falls outside the maintenance period, product usage will be blocked.

Viewing Maintenance Period
In the console, go to Help → About to view the maintenance period. The period is color-coded according to the current date relative to the expiration date:
	Color
	Description

	Red
	Maintenance period has expired.

	Purple
	Maintenance period is about to expire (1–30 days remaining).

	Blue
	Maintenance period is valid (more than 30 days remaining).


If the maintenance period is about to expire or has already expired, accounts with Product Maintenance Upgrade permission will receive a reminder upon logging into the console.

If there is no maintenance code or if the maintenance period changes, the maintenance code can be updated via either the server or the console.
Updating the Maintenance Code
There are two methods to update the maintenance code:
1. Automatic Server Update – If the server can connect to the internet, it will periodically update the maintenance code automatically. If the server is offline, automatic updates will not work.

2. Console Update – In the console, go to Help → Update Maintenance Service Period, or click Update Maintenance Service Period in Help → About to update the maintenance code.

	Setting
	Description

	Online Update
	Select this option if the console computer can connect to the internet to update the maintenance code online.

	Manual Update
	Select this option if the console computer cannot connect to the internet. Obtain the maintenance code through business channels and enter it manually to complete the update.


2.8.2 Downloading the Upgrade Package
Checking for New Versions
There are two ways to check for new versions:

1. Automatic Check – After logging into the console, the system automatically checks if a new version is available. If an update exists, a prompt window will appear. Administrators can enable or disable this feature in Console → Tools → Options → Upgrade & Maintenance → Automatically Check for Product Updates.

2. Manual Check – Administrators can manually check for updates via Console → Help → Check for Product Updates.

Downloading the Upgrade Package
When a new version is detected, a window will display the update log and a download link. Click the link to download the latest upgrade package.
[image: image35.bmp] Note
If the package’s release date is outside the maintenance service period, the download will be unavailable.
2.8.3 Upgrading the Server and Console
You can upgrade the server and console using an upgrade package. The package can be downloaded directly via Console → Help → Check for Product Updates, or obtained from our support team.
Upgrade Steps:
1) Run the upgrade program. The list will display both the current version and the available upgrade vo’te’oersion. Click [Upgrade] to start the process.
2) Manually start the SECURE SERVER and SECURE UPDATE services (manual start is only required if you are not performing a direct overwrite installation).
[image: image36.bmp] Note
If the upgrade program’s release date is outside the maintenance service period, the upgrade will be blocked.
2.8.4 Upgrading the Relay Server
In the console, navigate to Tools → Server Management → Relay Server Management. If a relay server in the left-hand relay server tree is marked with a (#) symbol, it means that a new version is available for that relay server. Select the relay server you wish to upgrade, right-click, choose Upgrade, and wait for the process to complete.
2.8.5 Upgrading the Client
Clients do not upgrade automatically by default. Go to Tools → Server Management → Client Upgrade Management, and configure upgrade settings according to your operational needs.
2.9 Uninstallation
2.9.1 Uninstalling the Client
When a computer no longer needs the client module, the administrator can uninstall it. There are two uninstallation methods:
Console Uninstallation
For online clients:
Select Control → Uninstall Client in the console to remove the client module. After uninstallation, the client will no longer run. If you want to use the client module on this computer again in the future, you must reinstall it.

For offline clients:
You can generate an uninstallation tool in the console and run it on the client machine to uninstall. The steps are as follows:
1) In the console, go to Tools → Client Tools → Client Offline Assistant Tool.

2) Select Permanently Uninstall Client, then click Next.

3) Configure parameters (execution count, valid time, operation password, export path, program name), then click Finish to export an executable (.EXE) file.

4) Send the generated executable to the client machine and run it to perform the uninstallation.
Client Tool Uninstallation
For completely offline machines that cannot connect to the server, follow these steps:
1) On the client machine, go to Start → Run, enter the command agt3tool secureadv, and open the client tool.
2) Select Uninstall Client, then click Generate Operation Code.
3) A Verify Operation Code dialog will appear — report the original operation code to the administrator.
4) In the console, the administrator goes to Tools → Client Tools → Confirmation Code Generator, enters the client’s operation code, and the system will parse the operation and corresponding client information.
5) The administrator confirms and clicks Generate Confirmation Code.
6) The administrator provides the confirmation code to the client, who enters it to execute the specified operation.
[image: image37.bmp] Note
Difference between Uninstalling and Deleting a Client: Uninstalling a Client – Only removes the client module from the computer. The license count remains unchanged, and the computer will still appear in the console with its logs accessible；Deleting a Client – Includes uninstalling the client and reducing the license count.
2.9.2 Uninstalling Server and Console
First, close the AnySecura server, console, and other related applications. Then, go to the Start menu, select “All Programs -> AnySecura -> Uninstall AnySecura” to uninstall. Alternatively, you can uninstall via “Control Panel -> Add/Remove Programs” by selecting AnySecura.
Chapter 3: Console
3.1 Console Login
3.1.1 Logging In
Launch the console module by double-clicking SConsole.exe in the installation directory or via Start → All Programs → AnySecura → AnySecura Console.

Before starting the console, ensure the server module is running on the network. Upon launch, the console will display the login window.
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The login dialog includes the following fields:
	Field
	Description

	Server
	Enter the server’s IP address or computer name.

	Account
	By default, the system administrator account is admin, and the system auditor account is audit. Additional administrator accounts with different permissions can be added via Tools → Accounts. 

	Password
	The initial passwords for both admin and audit are blank. On first login, a prompt will appear stating “Password cannot be empty.” After clicking OK, a password change dialog will appear. Once a password is set, the console logs in automatically. Subsequent logins require the correct password.
All administrator accounts with empty passwords must set a password before they can access the console.
After logging in, passwords can be changed via Tools → Change Password, but cannot be left blank. Administrators are responsible for securely managing their passwords.

	Remember Password
	Check this option to save the password for future logins.
To clear saved passwords, go to Tools → Options → Console Settings → Basic Settings → Clear Remembered Passwords and click Clear Now. The next login will require entering the password.

	Auto Login
	Checking this option enables automatic login using the last used username and password the next time the console starts.
If you click Clear Saved Passwords under Tools → Options → Console Settings → Basic Settings, automatic login will be disabled for the next console session.


To reconnect to a server, switch to another server, or log in as a different administrator, use Tools → Re-login to restart the console login process.
3.1.2 Change Password
To maintain security, users can change their password to prevent unauthorized access to their account.
After logging into the console, go to Tools → Change Password to open the password change dialog. Enter your current password, then the new password, and confirm the new password by entering it again. Click OK to apply the change. 
Note: This operation only changes the password for the currently logged-in administrator account, which is displayed in the first line of the dialog. 
The new password takes effect once it is validated by the server module.
3.2 Console Overview
After logging in, the console displays the following interface view:
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The console interface consists of the following areas: 
	Interface Area
	Description

	Menu Bar
	Contains all system menus and serves as the entry point for each function.

	Toolbar
	Provides quick access to frequently used functions.

	Computer Panel
	Located on the left, displays all client-installed machines and group info.

	User Panel


	Located on the left, shows all logged-in users on client machines and groups.



	Main Navigation 
Menu


	Below the toolbar, allows quick access to main functions.

	Sub-navigation 
Menu


	Supplements the main navigation for direct access to specific features.

	Function Button
Area


	Below the sub-navigation, includes the current function title and buttons on the right.

	Data Display 
Area


	Core view of the system where all data is displayed.

	Chart Panel
	Available in statistics functions, displays graphs.

	Query Panel
	Present in statistics, logs, instant messaging, and mail records; supports common query conditions.

	Property Panel
	Found in policy control functions, used to set policy attributes.

	Status Bar
	At the bottom, shows the current function’s status.


Computer Panel Icon Meanings
	Icon
	Color
	Meaning
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	Bright Blue
	Client module is running normally
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	Gray
	Client module not running; machine may be off, offline, or blocked by firewall
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	Dark Gray
	Client module has been uninstalled
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	Bright Blue+Clock
	Client module running, but user is away


User Panel Icon Meanings
	Icon
	Color
	Meaning

	[image: image44.png]



	Bright Blue
	User’s client module is running normally
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	Gray
	User’s client module not running; user may not be logged in


Common Log Attributes and Query Conditions
In log records (including event logs, email logs, and instant messaging logs), the following common fields are included:
	Field Name
	Description

	Time
	The precise timestamp of the log entry.

	Computer
	The client machine associated with the log; matches the name displayed in the Computer Panel.

	User
	The user responsible for the log entry; matches the name displayed in the User Panel.


For logs and statistical data, the system provides the following common query conditions:
	Query Condition
	Description

	Time Range
	Specifies the time period for the query. By default, the end time is the current day and the start time is one month prior, so the default query covers the last month.
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	Click the previous icon to view logs from the prior time segment (day, week, or month depending on the current start and end times).
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	Click the next icon to view logs from the next time segment, based on the set time range.
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	Click the reset icon to restore the system’s default time range.

	Time Type
	Predefined in “Category Management -> Time Types” as Working Hours, Break Time, and Weekend Time. Administrators can adjust these or create custom time types for queries.

	Scope
	Click the button on the right to open the scope selection window, allowing queries for a single computer, a group, or the entire network.


3.3 Computer and User Operations
3.3.1 Viewing Basic Information
Select “Statistics -> Basic Information” to view fundamental details of computers, computer groups, users, and user groups.
1） Computer Basic Information
Select a computer in the Computer Panel; the Data Display Area will show the client module’s status on that machine:
	Field Name
	Description

	Name
	The name displayed in the computer tree for management purposes; can be customized. If not changed, it defaults to the computer name.

	Computer
	The actual name of the client machine.



	Network Address


	The IP address used for communication between the
computer and the server.



	Status


	The client’s operational status: Running, Offline, or 
Uninstalled.



	Offline Days


	Number of days the client has been offline.



	Version
	The client software version.



	Operating 
System


	OS version of the client machine.



	Startup Time


	Current startup time of the client; only available when the client is running.

	Last Online Time


	The last time the client communicated with the server.



	Last Activity Time


	The most recent activity time on the client machine.



	Installation Time


	Installation date of the current client version.



	IP/MAC Address


	IP and MAC addresses of all network cards on the computer.



	Last Logged-in 
User


	The current user logged into the machine; idle and 
locked states are also shown.



	Last User Group


	Group information of the current logged-in user.

	Connected Server Address


	The network address of the server or repeater the computer is connected to.



	Server Name


	The name of the server or repeater the computer is connected to.


If multiple users are logged in on the same machine, the console will list all current users and their login times below the Last Logged-in User field.
2） Computer Group Information
Select a computer group in the computer panel to view all machines in the group and their status in the data display area.
If you select the entire network, all computer groups will be displayed. Click the Expand button “[image: image49.png]


” to view the status of all machines within each group.
3) User Basic Information
Select a user in the User panel to view their status in the data display area.
	Field Name
	Description

	Name
	The name displayed for the client in the user tree. This can be customized for easier management; if not changed, it defaults to the user's name.

	User
	The actual username the client is logged in with. For local accounts, it shows the username; for domain accounts, it shows DomainName\Username.

	Status
	The client’s current status, such as Online or Offline.



	Last Online Time


	The most recent time the client was online.



	Last Activity Time


	The most recent activity time for the user on this 
client.



	Last Logged-in Computer
	The last computer the user logged in from. If the user has logged in from multiple computers, the console displays all computers and corresponding login times beneath this field.


If the user has logged in on multiple computers, the console will display all the computers they have accessed along with the corresponding login times beneath the "Last Logged-in Computer" field.
4) User Group Basic Information
In the user panel, selecting a user group will display the status of all users and subgroups within that group. Similarly, when viewing the entire network, clicking the Expand button “[image: image50.png]


” t the top-right of the data display area will show the status of all users.
3.3.2 Display Settings
1） Computer Display Information
By default, all client machines in the computer panel show their computer names. You can customize which information is displayed.
Select the entire network, right-click and choose Display. In the Information Display Settings dialog, check the items you want to show. After restarting the console, the client entries in the computer panel will display the selected information. Available fields include: Name, Computer, IP, MAC, Last Logged-in User Account, Last Logged-in User Name, Client ID.
For extended features, checking the corresponding option will display the relevant authorization icons in the computer panel when the feature is licensed:[image: image51.png]


 represents Sensitive Information Authorization,[image: image52.png]


 represents Visual Awareness Authorization.
2） User Display Information
In the user panel, all users are shown by default with their username; for domain users, the alias is displayed. You can customize which information is shown for users.
Select the entire network, right-click and choose Display. In the Information Display Settings dialog, check the items you want to display. After restarting the console, users in the user panel will show the selected information. Available fields include: Name, Domain\Account, Account.
[image: image53.bmp] Note
This setting is specific to the administrator who makes the change. If an admin modifies the display settings, the changes will be visible whenever they log in on any machine. Other administrators will see their own display settings.
3.3.3 Group Management
In the computer and user panels, all client machines and users initially appear under Ungrouped. To simplify management, administrators can create custom groups to logically organize these computers and users.
Creating a New Group
In the computer panel, select the entire network or an existing group, then choose File → New Group. A new group node will appear in the tree in editable mode. Enter a group name and drag the relevant computers into this group. Administrators can use the same method to create multi-level group structures.

In the user panel, the same process can be applied to manage user groups.
[image: image54.bmp] Tip
Both computer and user panels have a default Ungrouped group. Newly added computers and users are automatically placed in this group. The Ungrouped group cannot be deleted, renamed, or have subgroups created within it.
Assigning or Moving to a Group
To assign computers or users to a specific group, or to move them, select the desired objects, then choose File → Move To and select the target group. The selected computers or users will be moved to the chosen group.
Alternatively, drag-and-drop can be used: select the objects, hold down the left mouse button, and drag them to the target group. This applies to both computers (or computer groups) and users (or user groups).
[image: image55.bmp] Tip
To facilitate grouping, multiple computers or users can be selected simultaneously. For example, in Ungrouped, open Statistics → Basic Information, hold CTRL or SHIFT, and select multiple items to move them to a target group.
3.3.4 Search
The search function allows administrators to quickly locate specific computers or users and view their related data.
Searching for Computers
In the computer panel, select File → Search to open the search dialog. Enter the search criteria, which can include:

Name (as shown in the computer panel)
Computer name (actual system name)
Network IP address
MAC address
The search supports partial matches and multiple keywords separated by semicolons. Computers can also be filtered by group and status, including Online, Offline, Idle, and Locked.

Search results appear in a list below. Double-click a computer to jump directly to its data view. To move one or more computers to another group, select the results, right-click Move To, and choose the target group.
Searching for Users
Switch to the user panel, then select File → Search to open the search dialog. Enter the search criteria, which can include the user’s display name or actual username, including any administrator-defined names. Partial matches and multiple keywords separated by semicolons are supported. You can also filter by user group and status, including Online, Offline, and Idle.

Similar to searching for computers, double-click a user in the results list to view their data. To move one or more users to another group, select them, right-click Move To, and choose the target group.
3.3.5 Deletion
Computers or users that no longer require management or access to historical data can be deleted from the console. Select File → Delete to remove the selected computer(s) or group(s) from the computer or user panel. If a group is deleted, all subgroups and computers within it are included.
Deleting Computers
By default, deletion does not uninstall the client to prevent accidental removal. The administrator must explicitly check Uninstall and confirm to remove the client. When uninstalling more than 10 or 100 machines, a reason and quantity must be provided for confirmation.
Delete only (no uninstall): The client remains on the machine. After deletion, the computer is temporarily moved to the Deleted Group. If the client is online, it will be moved back to its original group immediately; if offline, it will return when next online.

Delete and uninstall: The client will be removed from the machine. After deletion, the computer is placed in the Deleted Group. Online clients are uninstalled immediately; offline clients are uninstalled upon next connection.
When a computer is in the Deleted Group, the main license and any extended feature licenses are reclaimed. If moved back to the original group, the main license is restored, but extended feature licenses are not. Computers in the Deleted Group can access historical logs but cannot display real-time maintenance data. If the main license is full when moving back, the computer is placed in the Unauthorized Group.
Deleting Users
Deleting a user (or user group) removes their information but does not affect license allocation. Deleted users are placed in the Deleted Group and will automatically return to their original group upon their next login.
3.3.6 Restore
Computers and users in the Deleted Group can be restored to their original groups via the console. Select File → Restore to return the selected computers or users to their original groups.
After restoration, the main license will be reallocated regardless of whether the client was uninstalled.
3.3.7 Rename
To simplify management, administrators can rename computers or users for easier identification. Select the computer(s) or user(s) to rename, then choose File → Rename. The updated name will be displayed in the console.
3.3.8 Data Synchronization
When managing many clients, there may be discrepancies in how quickly data libraries and policies are applied to different machines. Administrators can set priority synchronization for specific computers. 
Select the desired computer(s), right-click and choose Data Synchronization → Priority Synchronization. Any changes to libraries or newly created/modified policies will be synchronized to these computers first. To remove priority synchronization, right-click and select Data Synchronization → Cancel Priority Synchronization, and the computer will no longer receive prioritized updates.

3.3.9 Policy Export
When new policies need to be applied to offline clients, the administrator can select the corresponding client node, update the relevant policies, then right-click and choose Export Policies. Specify the file path, click OK, and wait for the export to complete. This exports all policies for the selected computer in .ipz format. Selecting the entire network or a computer group will export the policies for that group.
3.3.10 Clear Sub-node Policies
When a group policy is applied, individual computers or users within the group may have their own specific policies, which take precedence over the group policy. If an administrator wants to revoke these individual policies and enforce the group policy uniformly, the Clear Child Node Policies function can be used, avoiding the need to manually remove policies from each computer or user.
In the console, switch to the specific policy, select the computer or user group whose policies need to be cleared, then right-click and choose “Clear Child Node Policies.” In the dialog that appears, select the target objects to remove the policies, allowing batch deletion of policies from all child nodes within the group.
3.4 Policy Roles
3.4.1 Terminology
Policy Set
A policy set is a collection of multiple policies. Administrators can group frequently used policies into a set and then apply the set to various objects, such as computers, users, or roles.
Role
A role represents a group of objects that share the same policies. A single object can belong to multiple roles. Administrators typically define roles based on departments, such as Marketing or Sales, or by job level, such as Regular Staff or Department Manager. A computer or user can belong to multiple roles and inherit the policies associated with each role.
3.4.2 Basic Operations
Create New
Policy sets and roles must be created manually. In the Roles panel, select the Policy Set node, right-click and choose “New Policy Set” to create a new policy set and assign it a name. To rename a selected policy set, choose File -> Rename from the menu. The same steps apply for creating and renaming roles.
View Basic Information
In the Roles panel, select Statistics -> Basic Information to view the basic details of policy sets and roles.
1）Policy Set Basic Information
Select a policy set in the Roles panel, and its basic information will be displayed in the data view area：

	Field Name
	Description

	Name
	The name of the policy set.

	Group
	The policy set group to which this policy set belongs.

	Notes
	Additional information or remarks about the policy set.

	Roles
	Additional information or remarks about the policy set.


2）Policy Set Group Information
Select a policy set group in the Roles panel, and the display area will show all policy sets and sub-groups within that group.
3）Role Basic Information
Select a role in the Roles panel to view its basic details in the display area：
	Field Name
	Description

	Name
	The name of the role.

	Group
	The role group to which this role belongs.

	Remarks
	Notes or comments about the role.

	Policy Sets
	The policy sets included in this role.


4）Role Group Information
Select a role group in the Roles panel, and the display area will show all roles and subgroups contained within that role group.
Group Operations
1）Create a New Group
In the Roles panel, select a Policy Set node and choose File -> New Group. A new editable group node will appear in the policy set tree. Enter a group name and drag the related policy sets into this group. Administrators can use the same method to create multi-level group structures.
Similarly, when selecting a Role node, you can manage roles by grouping them in the same way.
2）Assign or Change Groups
To assign policy sets or roles to specific groups or change their group, select the desired policy sets or roles, choose File -> Move To, and select the target group. The selected items will move to the designated group.
You can also use drag-and-drop: select the items, hold the left mouse button, and drag them to the target group. The selected policy sets (or roles) will then belong to that group.
[image: image56.bmp] Tip
To simplify grouping, multiple policy sets or roles can be moved simultaneously. For example, select a group, go to Statistics -> Basic Information, hold CTRL or SHIFT, and select multiple items to move them to the designated group.
Adjusting Policy Set Priority
Within a single policy set, policies of the same type are matched in sequence, and the first matching policy takes effect. For multiple policy sets, the priority follows the structure of the policy set tree: from top to bottom, higher positions indicate higher priority. In other words, a policy set located higher in the tree has its policies executed before those lower down.
Go to Statistics -> Basic Information and select the policy set group node. In the right-hand view, you will see all policy sets and groups at the current level. Use the Move Up [image: image57.png]


 and Move Down[image: image58.png]


 buttons to reorder them, thereby adjusting their priority.
[image: image59.bmp] Note
After adjusting the order, click the Save [image: image60.png]


 button to apply the changes.
Copying Policy Sets
In the policy set tree under the Roles panel, right-click a policy set and select Copy Policy Set to duplicate it. The copied policy set inherits the original’s general attributes and contained policies but does not inherit assigned roles or objects.
Searching
The search function allows administrators to quickly locate specific policy sets or roles and view their related information.
In the Roles panel, go to File -> Search to open the search dialog. Enter the search criteria, which support the name (as shown in the policy set tree) and fuzzy matching. The results include both policy sets and roles.
Deleting
Policy sets that are no longer needed can be deleted from the console. Select File -> Delete to remove the selected policy set(s) or group(s) from the tree or list. Deleting a policy set will remove its effects from any assigned roles or objects.
The same method applies to roles; deleting a role also removes its relationships with assigned objects.
Importing and Exporting
In the policy set tree, right-click the Policy Sets node and select Export to open the Select Objects window. You can choose which policy sets to export, including multiple selections. Right-click Import to bring previously exported policy sets back into the Policy Sets node.
In the roles tree, right-click the Roles node to import or export roles using the same method.
[image: image61.bmp] Note
When importing policy sets or roles, any existing items with the same name will not be imported.
3.4.3 Setting Policy Sets
In the Roles panel, select a policy set and go to Statistics -> Policy Roles. The right-hand display shows all objects assigned to this policy set, including computers and users. Objects that have policies applied via the policy set are marked with a small blue flag icon “[image: image62.png]


”。
	Field Name
	Description

	Name
	The name of the assigned computer or user.

	Group
	The group to which the computer or user belongs.


Click the Edit button[image: image63.png]


 to modify the policy set properties.
Click the Export button[image: image64.png]


 to export all computer and user objects assigned to the policy set.
Policy Set
Displays the name of the policy set and its group. You can also add remarks for the policy set here.
Computers & Users
The list shows the computers and users assigned to this policy set. Click the Add button[image: image65.png]


 to assign the policy set to the selected computers or users. Once assigned, these computers and users will inherit the policies within the policy set. Click the Export button[image: image66.bmp] to export all computer and user objects under this policy set.
Roles
The list shows the roles assigned to this policy set. Click the Add button[image: image67.png]


 to assign the policy set to the selected roles. Once assigned, these roles will inherit all policies within the policy set.
3.4.4 Setting Roles
Select a role in the Roles panel, then choose Menu -> Statistics -> Policy & Roles. The right-hand view will display all objects assigned to this role, including computers and users.
	Field Name
	Description

	Name
	The name of the assigned computer or user.

	Group
	The group to which the computer or user belongs.

	Assignment Time
	The time when the object was assigned to this role.

	Last Login
	For computer objects: shows the last user who logged in.
For user objects: shows the last computer the user logged into.
Computer groups and user groups are empty.

	Network Address
	For computer objects: displays its own network address.
For user objects: displays the network address of the computer they logged into.
Computer groups and user groups are empty.


Click the Edit button[image: image68.png]


 to modify the role’s properties.
Click the Export button[image: image69.png]


 to export all computer and user objects under the entire role tree.
General
Displays the role’s name and its group, with an option to add remarks for the role.
Computers & Users
Shows the computers and users assigned to this role. Click the Add button[image: image70.png]


 to assign the role to selected computers and users. Once assigned, these computers and users inherit the policies included in the role’s policy sets. Click the Export button[image: image71.bmp] to export all computer and user objects under the entire role tree.
Policy Sets
Shows the policy sets assigned to this role. Click the Add button[image: image72.png]


 to assign policy sets to the selected role. Once assigned, the role carries all policies included in these policy sets.
[image: image73.bmp] Note
Policies assigned to computers (or groups) and users (or groups) via policy sets or roles are collectively referred to as computer/group role policies and user/group role policies.
Example of Using Policy & Role Function
For internal management, a company may need to differentiate asset usage permissions for employees in different departments. Some assets may be accessible to all departments, while others are restricted to specific departments. For example, to prevent R&D staff from using USB drives and printers, and allow sales staff to use printers but not USB drives, follow these steps:
1. Create two policy sets: “Block USB Usage” and “Block Printer Usage”.
2. Configure the policies for each set: For “Block USB Usage”, set a policy to block all or specific USB drives.For “Block Printer Usage”, set a policy to block all or specific printers.
3. Create roles based on departments, such as “R&D Staff” and “Sales Staff”.
4. Assign the policy sets to the corresponding roles:Assign “Block USB Usage” to both R&D Staff and Sales Staff.Assign “Block Printer Usage” to R&D Staff only.
5. Assign the roles to the appropriate computers or users, applying the policies accordingly.
3.5 Control
Administrators can control computers running the client module through the console. Control is only applicable to computers; it cannot be performed in user mode. The target computer must be online with the client module running.
3.5.1 Sending Notification Messages
To send notifications or commands to client users, use the Send Notification Message feature in the console.
Select the target client computer or group (if a group is selected, all computers within the group will receive the message). Then choose Control → Send Notification Message to open the dialog box. Enter the notification title and content, and click Send. A notification window will appear on the desktops of the target computers.
You can manage preset notification messages. Click the[image: image74.jpg]


 button, and a menu will appear displaying the preset contents. Selecting an item will add it to the notification content box. To manage presets, click Manage in the menu to add, delete, or modify preset messages.
[image: image75.bmp] Note
Offline clients will receive the notification the next time they connect to the server.
3.5.2 Locking/Unlocking Computers
When a client computer shows abnormal behavior or for other administrative reasons, the administrator can lock one or multiple computers to prevent users from using the keyboard and mouse.
To lock a computer, select Control -> Lock Computer. Locked computers cannot use the keyboard or mouse until they are unlocked. The locked status will be shown in the computer's basic information. 

To unlock a computer, select Control -> Unlock. The targeted computer will regain keyboard and mouse access.
For offline clients, locking commands can be sent in advance; the client will be locked upon its next connection to the server.

3.5.3 Log Off Users, Shutdown/Restart Computers
When it is necessary to shut down a computer running the client module, the administrator can use this function. By selecting Log Off User, Restart, or Shutdown from the Control menu, the target computer will execute the command issued by the console. After performing the operation, the client module will exit and will only resume running when the user next logs in.
3.6 Auxiliary Functions
The console also includes several other common functions that are widely used across different modules. These functions provide convenience and efficiency for administrative operations.
3.6.1 Exporting and Importing
Exporting Data
All data views in the console can be exported and saved as electronic documents, including statistics, logs, policies, instant messages, emails, asset management, and more. Some modules may have slight differences in export functionality.
Export Current Page Records
Right-click in the data view and select Export → Export Current Page Records to export only the logs on the current page. By default, 20 records are displayed per page. Administrators can adjust this maximum per-page record count in Tools → Options → Console Settings → Log View.
Export All Matching Records 
Right-click in the data view and select Export → Export All Matching Records to export all records that meet the current search or filter criteria.
Exported documents can be saved in three formats:Text file (.CSV)、HTML file、Excel file (.XLS), provided Microsoft Excel is installed.

Exporting/Importing Policies
Only the policy module supports import functionality. Exporting and importing policies helps administrators configure settings efficiently.
To export policies, select the desired policies, right-click, and choose Export or Export Selected Policies to save them as XML files:

· Export: Exports all policies of the current module for the selected computer(s) or user(s), excluding any inherited policies.

· Export Selected Policies: Exports only the selected policies, which can be one or multiple.
Select the target computer(s) or user(s), right-click, and choose Import to import the policy file. The imported policies must match the current policy type; otherwise, the import will fail. Once imported, policies take effect immediately.
3.6.2 Print and Print Preview
All data views in the console can be printed for record-keeping and future reference. By selecting the menu “File -> Print,” users can print operational statistics, reports, and logs. Selecting “File -> Print Preview” allows users to preview the print layout.
Chapter 4: Statistics
AnySecura generates statistical reports and charts on employees’ application usage, web browsing, and network traffic, providing management with insights to evaluate employee work performance.
4.1 Application Statistics
Application statistics provide powerful analytical capabilities, offering user-friendly summaries and analysis of daily computer activity and application usage. This gives managers reliable data to evaluate employee productivity and includes the ability to export statistical lists.
Select the menu “Statistics -> Applications” to query application usage for a specific time period by computer (group) or user (group). By default, the system displays statistics for the current day. The application statistics interface is divided into four sections: Computer (User) Tree, Data Display, Statistical Charts, and Query Panel.
Function Button Description
	Icon Button
	Description

	[image: image76.bmp]
	Mode button, allowing the administrator to select the application statistics mode.

	[image: image77.png]



	Expand button. If an application category has subcategories, clicking this will expand them; for detailed statistics by item, it expands computers or users within a group. Not applicable for detailed application statistics, in which case the icon appears grayed out.

	[image: image78.png]



	Display Top Items. Defines the number of entries shown in the statistical list, including All, Top 10, Top 20, or Custom. When expanded columns are set for application categories, this icon is grayed out.


By default, the statistics include Startup Time and Work Time. Startup Time refers to the running time of the client machine after booting, while Work Time refers to the time during which the keyboard and mouse on the client machine are actively used.
Application statistics can be divided into four modes:
1. Statistics by Application Category
In application categories, administrators can classify all applications used on client machines, making it easier to generate statistics for each category. The statistical results provide insights into employees’ daily work and departmental work patterns.
Click the Mode button in the function button area and select Mode -> Category Summary. By default, all application categories will be included. The statistical results are displayed in three columns:
	Field Name
	Description

	Category
	The custom category defined in the application classification.

	Time
	The total time client machines spent using applications in this category, sorted by usage time from longest to shortest by default.

	Percentage
	The percentage of work time spent using applications in this category, displayed from highest to lowest by default.


2. Statistics by Application Name
If you need to calculate the usage percentage of specific applications, select Mode -> By Name. This mode lists the total usage time of each application used on the selected computer(s) or group(s) and the percentage of total work time. Statistics by application name are essentially based on application processes. The results clearly show which applications occupy most of the users’ work time, providing insights into user productivity.
3. Detailed Application Statistics
Detailed application statistics are similar to statistics by name but are based on the application’s description rather than the process. For example, if a user runs two different versions of QQ, both using the process qq.exe, statistics by name would combine their usage time as qq.exe. Detailed statistics, however, track each version separately, providing a more precise breakdown.
4. Itemized Statistics
Itemized statistics calculate the usage percentage of different application categories for each computer or computer group. By default, the system tracks boot time and work time. You can add application categories in the Category field of the query panel to include them in the statistics.
For example, to track IM and browser usage for all computers in a group, first select the group, choose Mode -> Itemized Statistics, then add the predefined application categories (IM, Browser, etc.) in the query panel and click Query to get the results. If the group contains subgroups, click the Expand button to view statistics for all computers in the subgroups.

In addition to generating statistical reports, the console also produces graphical charts:
Bar Chart：
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Pie Chart：
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4.2 Web Browsing Statistics
Many employees may browse non-work-related websites during office hours. The web browsing statistics feature allows administrators to track users’ website activity, enabling timely detection of issues and appropriate actions.
Function Button Description
	Icon Button
	Description

	[image: image81.bmp]
	Mode button: Administrators can select the website statistics mode.

	[image: image82.png]



	Expand button: Disabled for website details (icon grayed out); if a website category has subcategories, they can be expanded. For itemized statistics, it can expand computers or users within a group.

	[image: image83.png]



	Display Top Items: Defines the number of items shown in the statistics list, including All, Top 10, Top 20, or Custom. When expanded columns are set by website category, this icon is grayed out.


Web browsing statistics can be divided into three modes:
1. By Website Category
Statistics by website category require that administrators first add categories and their website identifiers in “Category Management → Websites.” This mode allows for macro-level statistics and analysis of different website categories.
By default, all categories’ browsing time is included in the statistics. Websites not assigned to any category are automatically grouped under “Uncategorized.” The list is sorted by browsing time, with websites visited for the longest time appearing first.
2. By Website Details
Statistics by website details list all visited websites, displaying browsing time for each, typically aggregated by domain. To filter by category, administrators can use the query conditions on the right.
If a website has a name set in the website library, it will display as “Website Name – Website”; if not, the domain name is shown directly.
In detail mode, the expand column function is disabled. By default, all websites are included, and the Top Items button can be used to select a subset for display.
3. Itemized Statistics
Itemized statistics calculate browsing time per computer for one or more website categories. Statistics can be generated for a computer group or the entire network.
By default, uncategorized website browsing time is calculated. Administrators can add or modify website categories in the query panel as needed. Clicking the Expand button will expand all subgroups, displaying statistics for all computers.
In addition to generating tabular reports, the console also produces statistical charts:
Bar Chart：
[image: image84.jpg]Time.

OOERCODER

bbs. ag. con
§thbs. peonline. con. cn.
Livel. sports. ton. con
e peonline. con. en
sports. ton. con

o bai du. con

hi dao. bai du. con

sba sports. ton. con





Pie Chart：
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4.3 Network Traffic Statistics
By analyzing network traffic, administrators can quickly identify issues such as network congestion and take appropriate measures. Network traffic statistics include detailed information such as the network addresses of both communication parties, ports, and traffic volume, helping network administrators monitor usage and troubleshoot problems.
Select Menu → Statistics → Network Traffic to view network traffic usage.
Function Button Description 

	Icon Button
	Description

	[image: image86.bmp]
	Mode button, allowing administrators to select the network traffic statistics mode;

	[image: image87.png]



	Direction button, including three traffic directions: total, sent, and received;

	[image: image88.png]



	Expand button, effective when statistics are by computer, allows expanding computers within subgroups;

	[image: image89.png]



	Display Top Items, defines the number of entries shown in the statistics list, including All, Top 10, Top 20, or Custom. When expanding columns by website category, the Top Items icon is grayed out. 


Statistics Criteria
	Field Name
	Descriptiom

	Time and Range
	Common query criteria for all statistics 

	Time and Range
	Refers to the IP addresses of the communication counterpart. Administrators can select an address range from the network address category or directly enter the IP addresses to query, e.g., 192.168.1.1.

	Port Range
	Refers to the ports used by the service during communication. Administrators can select a port range from the port category management or directly enter the ports to query. Entered ports must include the protocol type: TCP or UDP, e.g., TCP:139. If only the port number is entered, the system defaults to TCP.


Network Traffic Statistics can be divided into six modes:
By Address Detail
Statistics by address detail calculate the data traffic for all IP addresses and ports. From the results, administrators can identify which counterpart IP addresses have the highest communication traffic with the client machine within a specific time period, helping to understand the network behavior of that client.
The statistics include the network address and the traffic exchanged with that IP address.
	Field Name
	Description

	Network Address
	This column displays a list of all counterpart IP addresses. If an IP range is specified in the right-side query panel → Address Range, only IP addresses within that range will be listed.

	Total (Aggregate)
	Total represents the traffic for all ports communicating with the IP address. By default, TCP (Total) and UDP (Total) traffic are also calculated separately. If one or more port categories are specified in the right-side query panel → Port Range, only the traffic for the specified port categories will be counted. The term “Total” in parentheses indicates the traffic direction. Click the traffic direction button to choose the direction: Total, Sent, Received.


In practice, administrators can set appropriate address and port ranges according to management requirements to obtain the desired network traffic statistics and charts.
By Port Detail

Statistics by port detail calculate the traffic data for a specified port range across a range of counterpart IP addresses. From the results, administrators can identify which ports on the client machine have higher traffic. If excessive traffic is detected on unauthorized ports, immediate measures can be taken to close those ports.
The statistics include port details and all traffic on each port.
	Field Name
	Description

	Network Protocol
	This column displays the specified port ranges and protocol types, showing the traffic for these ports.

	Network Protocol
	Total represents the traffic on this port across all IP address ranges. By default, the system also calculates Enterprise Network (Total) and Internet (Total) traffic. “Total” indicates the traffic direction, which can be adjusted by clicking the traffic direction button: Total, Sent, Received.


In practice, administrators can set appropriate address and port ranges according to management requirements to generate the desired network traffic statistics and charts.
By Address Category

Statistics by address category calculate traffic on specified network ports based on the classification of network addresses. By default, the system tracks traffic for TCP and UDP protocols, and communication addresses are categorized as Enterprise Network or Internet. Administrators can select other categories in the address range and port range fields in the query panel for customized statistics.

This mode allows administrators to analyze and compare traffic across different network address ranges from a macro perspective for a computer or computer group.
By Port Category

Statistics by port category calculate traffic on specified network addresses based on the classification of network ports. By default, the system tracks TCP and UDP protocol traffic for communication addresses within the Enterprise Network and Internet. Administrators can select other categories in the address range and port range fields in the query panel.

This mode enables administrators to analyze and compare traffic across different network port ranges for a computer or computer group.
By Computer and Address Category

Statistics by computer and address category calculate traffic for a computer or computer group within specified network address ranges. This mode allows administrators to quickly analyze and compare traffic differences between computers or groups in the selected address range.

When analyzing a computer group, clicking the Expand button will show all computers within the group, allowing a comparison of traffic among group members.

Administrators can adjust the query and address ranges in the query panel to obtain meaningful traffic statistics.
By Computer and Port Category

Statistics by computer and port category calculate traffic for a computer or computer group within specified port ranges. This mode enables administrators to quickly analyze and compare traffic differences between computers or groups on selected ports.

When analyzing a computer group, clicking the Expand button will show all computers in the group, allowing a comparison of traffic among group members.
[image: image90.bmp] Note
Network traffic statistics can only be generated by computer; user-based statistics are not supported.
Chapter 5: Logs
AnySecura records various operation logs of client machines, including: user login and logout logs, application logs, website browsing logs, document operation logs, shared document logs, document printing logs, removable storage operation logs, and asset change logs. These detailed logs allow administrators to view nearly all activities performed by users on their machines.
In all log views, the following operations are available:
	Operation
	Description

	Description
	Each log view can be printed or previewed for record-keeping.

	Export Logs


	Export various logs as needed.

	Delete Logs


	In the data view, right-click and select “Delete.” Administrators can choose the deletion mode: delete selected records, delete current page records, or delete all records matching the criteria.

	View Screen History


	While reviewing log records, administrators can view the screen history of a specific log entry. Select a log entry, right-click, and choose “View Screen History” to automatically open the screen history viewer and quickly locate the screen content at the time of the log action. Clients without screen history recording enabled cannot provide screen history.

	Screen History Tracking


	While reviewing logs, right-click and select “Screen History Tracking” to open the screen history tracking window. Clicking on any log or navigating through the log properties pages will automatically switch the screen history display in the tracking window. Clients without screen history recording enabled cannot perform screen history tracking.


5.1 Basic Event Logs
Select the menu “Logs -> Basic Events” to view basic event logs. Basic event logs record client system startup/shutdown, user login/logout, dial-up connections, patch management, and software distribution-related events.
The types of logged operations include the following:
	Operation Type
	Description

	System Startup/Shutdown
	Refers to the client system. The startup/shutdown of the client corresponds roughly to the operating system startup/shutdown.

	User Login
	Logs each user login to the client machine.

	User Logout
	Logs each user logout from the client machine.

	Session Connection
	Logs when a remote desktop session connects to the client machine.

	Session Disconnection
	Logs when a remote desktop session is disconnected from the client machine.

	Activity Start
	Records an activity log when the client machine registers the first keyboard or mouse activity after a period of inactivity. The timestamp is the current time.

	Activity Stop
	Records a stop activity log if no keyboard or mouse activity has occurred for over two hours. The timestamp reflects the last recorded activity time.

	Dial-Up
	Records dial-up and hang-up events when the user establishes a dial-up connection.

	Patch Management
	Logs all patch installations automatically performed by the client for administrative patch deployment, allowing tracking of patch installation status.

	Software Distribution
	Logs execution of software distribution tasks on target machines, facilitating tracking of distribution progress.

	Client Installation
	Logs client installation events. Fresh installations record the newly installed client version, while overwrites log both previous and current versions.

	Client Uninstallation
	Logs client uninstallation events. Uninstalling via the console records the client version prior to removal.

	Client Upgrade
	Logs automatic client upgrades, including version changes.

	Software Uninstallation
	Logs when the client executes software uninstallation tasks.

	Vulnerability Scan
	Logs generated when the client performs vulnerability checks.

	Server Connection
	Logs when the client connects to the server or relay server.

	Server Disconnection
	Logs when the client disconnects from the server or relay server.

	Server Switch
	Logs when the client switches connection to a different server or relay server.


Basic Event Logs contain the following information: operation type, time, computer, user, description, etc. The operation type indicates the type of logged event, such as system startup or user login, while the description provides detailed information about the event.

By default, basic event logs display all entries. Administrators can also set various query conditions for selective and targeted searches.
	Query Condition
	Description

	Time and Range
	General query condition.

	Type
	Refers to the operation type of the basic event logs. The default is “All,” but administrators can specify one or multiple types from the dropdown for querying—for example, to check users who logged into the client machine or patch installation events.

	Description
	Queries based on the log’s description. This is an input field that supports wildcards and fuzzy searches.


5.2 Application Logs
Application logs record the opening and closing of applications on client machines, as well as window and title switch information. Administrators can view these logs through the console.Select Menu → Logs → Application to view all application start/stop logs and window/title switch logs.

Application log types include: Start/Stop, Window Switch, Title Switch.
	Log Type
	Description

	Start/Stop
	Records when applications are started or stopped on the client machine.

	Window Switch
	Records logs when the user switches between application windows.

	Title Switch
	Records logs when the user switches between multiple windows or titles within the same application—for example, switching between multiple tabs in a browser like maxthon.exe.


[image: image91.bmp] Note
Due to the large volume of data, window switch and title switch logs are not recorded by default. You can enable recording of window title changes via Basic Policy → Log Recording Policy.
Application log records include the following attributes: operation type, time, computer, user, application, path/title, and more.

	Attribute Name
	Description

	Operation Type
	Application start/stop and window/title switch events.

	Application
	The process name of the application.

	File Path
	For start/stop operations, records the full path of the application on the client machine.

	Window Title
	For window/title switch operations, records the current window title of the application.


The system displays all application logs by default. Administrators can also set various query conditions for selective and targeted searches.
	Query Condition
	Description

	Path/Title
	Query based on the application's file path or window title.

	Application
	Query by the application's process name; you can either manually enter the name or select a category or specific application from the application categories.


Querying by application includes: manually entering the application name or querying by application category.
1) Manually Entering Application Name
You can directly type the application name you want to query in the input box, for example, qq.exe or *game*.exe.
2) Querying by Application Category
Click the “...” button on the right to open the Application Category window. The left pane shows the application categories, and the right pane lists all applications within the selected category.

To query an entire category, select Application Category on the left, then choose the desired category on the right, and click OK to perform the query.To query a specific application within a category, select the category on the left, find the application on the right, select it, and click OK to query that specific application.
5.3 Web Browsing Logs
Web browsing logs record the websites visited on client computers, allowing administrators to review the browsing activity of users on those clients. Select the menu Logs -> Web Browsing to view all web browsing logs.
Web browsing logs support records from various common browsers, including IE, TT, Maxthon, Firefox, Netscape, Opera, and others.
The logs contain the following information: time, computer, user, title, URL, etc.
	Attribute Name
	Description

	Title
	The title of the visited website.

	URL
	The full URL of the visited website.


[image: image92.bmp] Tip
Right-click Open Website to quickly navigate to the URL in the selected log and view the website details.
Right-click Add to Website Category to add the URL identification information from the log entry to a specified website category.
By default, all web browsing logs are displayed. Administrators can also set various query conditions for selective and targeted searches.
	Query Condition
	Description

	Time and Range
	General query condition.

	URL
	Search browsing activity for a specific URL. Administrators can enter a URL directly or specify a category or website identification from the website classification. Multiple selections are supported using Ctrl+A, Ctrl+Click, or Shift+Click. Manual URL input supports fuzzy search.

	Window Title
	Search based on the window title of the website. For example, entering “Entertainment” will retrieve all logs where the website title contains “Entertainment.”


5.4 Keyword Search Logs
Keyword search logs record operations when a client machine uses search engines to search for keywords, allowing administrators to review the user’s search behavior. Select the menu Logs -> Keyword Search to view all keyword search logs. The logged information includes:
	Attribute Name
	Description

	Search Keyword
	The keyword entered during the search operation.

	Application
	The process name of the application used for the search.

	Domain
	The domain of the searched website.

	URL
	The specific URL of the search result.


Currently supported search engines include: Bing, Baidu, 360 Search, Sogou, Weibo, Zhihu, Douban, and Google.

By default, all keyword search logs are displayed. Administrators can also set various query conditions for selective and targeted searches.
	Query Condition
	Description

	Time and Range
	General query condition.

	Search Keyword
	Search by keyword. Default is all keywords; specific keywords can be entered.

	Application
	Search by the application used. Default is all applications; a specific application name can be entered.

	Domain
	Search by website domain. Default is all domains; a specific domain can be entered.

	URL
	Search by specific URL of the search result. Default is all URLs; a specific URL can be entered.


5.5 Document Operation Logs
Document operation logs record the actions of users on documents from client machines. By reviewing these logs, administrators can monitor document usage, provide reliable clues for investigating data leakage incidents, and enhance the security of electronic document management.
Select the menu Logs -> Document Operation Logs to view the document operation logs. The logged information includes: 
	Attribute Name
	Description

	Operation Type
	Includes: Create, Access, Modify, Rename, Copy, Move, Delete, Restore, Upload, Download, and Burn.

	Source File
	The name of the document being operated on.

	File Type
	The type of the file being operated on.

	File Size
	The size of the document being operated on.

	Path
	The full path of the document. For Copy, Move, or Rename operations, both source and destination paths are recorded.

	Drive Type
	The type of drive containing the document, including: Hard Disk, Floppy, CD/DVD, Removable, or Network Drive. For Copy or Move operations, both source and destination drive types are displayed.

	Application
	The process name of the application used to operate the document.

	Title
	The window title when operating the document.


In document control policies or IM file transfer policies, document backup strategies can be configured. When triggered on the client machine, backup document logs are recorded, marked with a pin icon “[image: image93.png]


”. For example, a copy operation is indicated with “[image: image94.png]


”。
Double-clicking a backup document log opens its detailed properties. Next to the document name is a Copy button, which allows viewing or saving the backup document. Backup documents also support batch export: the right-click menu Export Backup Document can export specified or all backup logs, and Export Logs and Backup Documents can export both the logs and the backup documents simultaneously.

By default, all document operation logs are displayed. Administrators can also set various query conditions for selective and targeted searches.
	Query Conditions
	Description

	Time and Range
	Common query condition.

	Document
	

	Operation Type
	Defaults to all operation types. You can also select one or multiple types from the dropdown for queries, e.g., to search for all documents that were modified or copied.

	Source
	

	Drive Type
	Defaults to all drive types. You can select one or multiple drive types from the dropdown to filter and only view logs from specified drive types.

	File
	The name of the source document. When searching by type, you can select from the provided default types or manually add type names.

	Path
	The path of the source document.

	Target
	Applicable only to operations involving both source and target paths, such as Copy or Move. The following fields are effective for such operations:

	Drive Type
	Defaults to all drive types. You can select one or multiple drive types from the dropdown to filter and only view logs from specified target drive types.

	File
	The name of the target document. When searching by type, you can select from the provided default types or manually add type names.

	Path
	The path of the target document.

	Size
	Specify a file size range to query documents within a certain size range.

	Application
	The name of the application used to operate the document. You can manually input the name or select a category or specific application from the application classification.

	Title
	The window title when operating the document.

	Has Backup Document
	By default, unchecked to display all logs (both with and without backup documents). Checking this box will filter the results to only show logs that have associated backup documents.


5.6 CD/DVD Burning Operation Logs
CD/DVD burning operation logs record information about the user’s use of dedicated burning tools on the client machine. Administrators can review these logs to track users’ burning activities and provide audit trails for investigating potential data leaks.
To view the burning operation logs, select Menu -> Logs -> CD/DVD Burning Operation Logs. The logged details include: 

	Property Name
	Description

	Operation Type
	Includes: Task Start, Burning, Burn Success/Failure, Task Complete.
For a burning task containing N files, the following logs are generated:
①One entry with operation type “Task Start”;
②N entries with operation type “Burning”;
③One entry with operation type “Burn Success” (or “Burn Failure”);
④One entry with operation type “Task Complete”.

	Disc Name
	Name of the disc being burned.

	Disc Type
	Type of disc being burned, CD or DVD.

	File Size
	Size of the file being burned.

	Source File
	Name of the source file for the burning operation.

	Application
	Process name of the application used for burning the file.

	Total File Count
	Total number of files in this burning task. Logs of type “Burning” record only a single file and do not include total file count.

	Copies
	Number of copies burned in this task. Logs of type “Burning” record only a single file and do not include copy count.

	Burner Description
	Description of the burning device.

	Details
	Detailed information of the log entry.


In document control policies, if operation types “Modify” and “Copy/Move to Backup” are enabled, any file burned that triggers these policies will also appear in the document operation logs as a backup burn log, marked with the icon[image: image95.png]


.
The system displays all burning operation logs by default, and administrators can set various query conditions for selective searches.
	Query Condition
	Description

	Time and Range
	Common query condition.

	Type
	Default is all types. You can select one or multiple operation types from the dropdown, including: Task Start, Burning, Burn Success, Burn Failure, Task Complete.

	File
	Name of the document being burned. You can select from the default types or manually add a type name.

	Path
	Source path of the document being burned.

	Size
	Specify a file size range to query burning records within that size range.

	Application
	Name of the application used for burning. You can manually enter a name or select a category/application from the application classification.

	Disc Name
	Name of the disc being burned.

	Disc Type
	Default is all types; options include CD and DVD.

	Burner Description
	Description of the burning device.

	Total File Count
	Total number of files in this burning task.

	Copies
	Number of copies burned in this task.


5.7 Shared Document Operation Logs
Shared document operation logs record actions performed by users from other machines on shared documents of the client machine. By reviewing these logs, administrators can see what external computers have done to local documents.
Select the menu “Logs -> Shared Operations” to view shared document operation logs.
Shared document logs include the following information:
	Attribute Name
	Description

	Operation Type
	Includes: Create, Rename, Modify, Delete. Access, Copy, and Move operations are not supported.

	Remote Host
	The IP address of the external computer accessing the shared files on the local machine.

	Source File
	The name of the local document being operated on by the remote computer.

	Path
	The full path of the local document being operated on by the remote computer.


Shared document logs can be queried based on the following conditions.
	Query Conditions
	Description

	Time and Range
	General query conditions.

	Shared Document
	

	Operation Type
	Query by the type of shared document operation. Default is all; specific types can be selected from the drop-down menu.

	Source
	

	File
	Query which operations were performed on a specific document by a remote machine. Enter the document name; supports fuzzy search.

	Path
	The path of the document on which the remote machine performed operations.

	Target
	Only effective for renamed shared files: specifies the target file and path.

	File
	Name of the document being operated on.

	Path
	Target path of the document being operated on.

	Name
	Query which operations were performed on a specific document by a remote machine. Enter the document name; supports fuzzy search.

	Remote Address or Name
	Query by the IP address or computer name of the remote machine accessing the local shared file.


5.8 Remote Desktop Logs
Remote desktop logs record client operations connecting to remote desktops. By reviewing these logs, administrators can monitor users’ remote activities. Remote desktop logging is disabled by default and must be enabled via “Policy -> Log Recording”.
Administrators must have the permission “Tools -> Account -> Function Permissions -> Logs -> Remote Desktop Logs” to view client remote desktop logs.
Select the menu “Logs -> Remote Desktop Logs” to view remote operation logs. The logged content includes: 

	Attribute Name
	Description

	Operation Type
	Includes: Connect, Disconnect, Remote Create, Remote Access, Remote Copy to Local, Local Copy to Remote, Remote Copy to Mapped Drive, Remote Modify, Remote Rename, Remote Delete.

	Network Address
	The network address of the host the client connected to via remote desktop.

	Remote Host
	The IP and computer name of the host the client connected to via remote desktop.

	Source File
	Name of the document involved in the remote operation.

	File Type
	Type of the document involved in the remote operation.

	File Size
	Size of the document involved in the remote operation.

	Path
	Detailed path of the document involved in the remote operation.

	Application
	Process name of the application used for the remote operation on the document.

	Title
	Window title when the document was operated remotely.


Remote Operation Type Attribute Description:
	Type Name
	Description

	Connect
	Records the client connecting to a host via remote desktop.

	Disconnect
	Records the client disconnecting from a host via remote desktop.

	Remote Create
	Records the creation of a document on the local client via disk mapping from the remote desktop.

	Remote Access
	Records accessing a document on the local client via disk mapping from the remote desktop.

	Remote Copy to Local
	Records copying or cutting a document from the remote desktop directly to the local client.

	Local Copy to Remote
	Records copying or cutting a document from the local client directly to the remote desktop.

	Remote Copy to Mapped Drive
	Records copying or cutting a document to the local client via disk mapping from the remote desktop.

	Remote Modify
	Records modifications made to a document on the local client via disk mapping from the remote desktop.

	Remote Rename
	Records renaming a document on the local client via disk mapping from the remote desktop.

	Remote Delete
	Records deleting a document on the local client via disk mapping from the remote desktop.


5.9 Document Print Logs
Document print logs record printing activities on client machines for later review. Access these logs via Logs → Document Print.

Log Attributes:
	Attribute
	Description

	Printer Type
	Local, shared, network, or virtual printer.

	Print Record (Image)
	Indicates if an image-format print record exists; blank if none.

	Print Record (Text)
	Indicates if a text-format print record exists; blank if none.

	Print Task
	Core content of the print log, usually includes the document name.

	Printer Name
	Name of the printer used.

	Printer Host
	Name of the computer hosting the printer; for network printers, the IP address.

	Paper Size
	Paper size selected during printing.

	Paper Orientation
	Orientation chosen during printing.

	Page Count
	Number of pages in the printed document.

	Page Count (Image)
	Number of pages recorded in image format if enabled; otherwise 0.

	Page Count (Text)
	Number of pages recorded in text format if enabled; otherwise 0.

	Window Title
	Title of the window from which the print was executed.

	Application
	Name of the application used for printing.


Viewing and Saving Print Records
Print control policies can be configured to record the content of printed documents. When a client prints a document subject to these policies, its content is logged. Print logs allow you to view or save this content.
Image Format Records
For print logs with image-format records, a paperclip icon “[image: image96.png]


” is used as an indicator. For example, image-format records from a shared printer are also marked with the “[image: image97.png]


”.
Double-click a log entry or right-click and select “Properties” to view its details. On the right side of the computer column, there is a Copy button, which allows you to either View Print Record or Save Print Record.
Click the Copy button and select View Print Record to open the print viewer. You can zoom in, zoom out, and pan the content. For multi-page print jobs, you can navigate through the pages and save images as JPG files.
Click the Copy button and select Save Print Record to save the print content to a chosen folder. The content is saved as images, with each page stored as a separate JPG file. For multi-page print jobs, multiple image files will be saved. Batch export is also supported: use the right-click menu Export to export selected or all records, or Export Logs and Backup Files to export both the logs and backup documents simultaneously.
Text Format Records
When a print log is selected, the text format of that print job is displayed below. If no text format exists for the selected log, the message “No text print records for this task” will appear.
Document Print Log Query Options:
	Query Condition
	Description

	Time Range
	Standard query filter.

	Printer Type
	Defaults to all. You can select a specific type to filter by local, shared, network, or virtual printers.

	Printer
	Filter by printer name to analyze printing activity for a specific printer.

	Computer
	Refers to the computer hosting the printer. For a local printer, it is the client machine; for a shared printer, it is the remote host, typically shown as an IP address.

	Task Name
	Filter by print task name; supports partial matches.

	Page Count
	Filter by the number of pages to help identify potential printer misuse.

	Application
	Filter by the application used to print the document.

	Window Title
	Filter by the window title at the time of printing.

	Has Print Records
	By default, all logs are shown. Selecting this option filters only logs that have recorded print content.


5.10 Removable Storage Operation Logs
Removable storage logs track all insertions, removals, and operations of portable storage devices on client machines. They provide comprehensive monitoring of usage within the network, enhancing document security.
To view these logs, go to “Logs -> Removable Storage Operations”. The logs include the following attributes: 
	Attribute
	Description

	Operation Type
	Actions related to removable drives, including: insert, remove, create, copy to, move to, rename, restore, delete, access, modify, upload, download, burn, copy out, move out, start XExplore, close XExplore, upgrade success, upgrade failure.

	Network Address
	IP address of the client using the removable device.

	Storage Category
	Category assigned to the removable device.

	Storage Type
	Type of device: encrypted drive, non-encrypted drive, secure USB.

	UDisk ID
	Unique identifier for each removable device; remains unchanged even after formatting.

	Volume Serial Number
	Serial number of the device; may change if the device is formatted.

	Device Description
	Descriptive information about the removable device.

	Volume Label
	Label of the removable drive.

	Source File
	Name of the file involved in the operation.

	File Type
	Type of the file involved in the operation.

	Path
	File path; if moved, displayed as “source path -> target path”.

	Disk Type
	Type of disk involved in the operation: hard drive, CD/DVD, floppy, removable disk.

	Application
	Name of the application used to perform the operation.

	Window Title
	Window title of the application during the operation.

	Notes
	Optional remarks for easier identification, such as user or asset number; default is empty. Enter via right-click “Edit Notes”.

	Device Name
	Name of the removable device.

	Device ID
	Identification number of the device.

	Department
	Department associated with the device.

	User
	Name of the device user.

	Position
	Job title of the device user.

	Contact
	Contact information of the device user.

	Host Information
	Only for secure USB interaction logs: if the machine uploading to the secure USB interaction area is a non-client, its IP is recorded here; otherwise, left empty.


The removable storage logs can be filtered using the following criteria:
	Query Condition
	Description

	Time & Range
	Standard filter for specifying the time period.

	Device
	Query logs for a specific device or category within the storage classification.

	Operation Type
	Default is all; can select Insert or Remove to quickly locate all inserted devices on a client machine.

	Storage Type
	Filter by encrypted or non-encrypted drives; default is all.

	Source Drive Type
	Default is all; can select one or more drive types to filter logs by the source drive.

	Source File Name
	Name of the operated file; supports default type selection or manual entry.

	Source Path
	Source file path.

	Target Drive Type
	Only applies to operations with source and target paths (e.g., copy, move); filter by target drive type.

	Target File Name
	Name of the target file; supports default type selection or manual entry.

	Target Path
	Target file path.

	File Size
	Filter by file size range.

	Application
	Filter by application name; can manually enter or select from application categories.

	Window Title
	Filter by application window title during operation; leaving blank searches all titles.

	Device Name (Registration)
	Query by the registered device name.

	Device ID (Registration)
	Query by the registered device ID.

	Department (Registration)
	Query by the registered department.

	User (Registration)
	Query by the registered user.

	Position (Registration)
	Query by the registered user’s job title.

	Contact (Registration)
	Query by the registered user’s contact information.

	Query Condition
	Description

	Time & Range
	Standard filter for specifying the time period.

	Device
	Query logs for a specific device or category within the storage classification.

	Operation Type
	Default is all; can select Insert or Remove to quickly locate all inserted devices on a client machine.

	Storage Type
	Filter by encrypted or non-encrypted drives; default is all.


5.11 Asset Change Log
The Asset Change Log records hardware and software changes on client machines, helping administrators manage and maintain enterprise asset information.
Select Logs -> Asset Change to view all hardware and software change logs:
	Attribute
	Description

	Operation Type
	Indicates whether the asset was added, removed, or modified.

	Type
	Specifies whether the change is hardware or software related.

	Description
	Describes the asset that has changed.


The Asset Change Log can be queried using the following conditions:
	Condition
	Description

	Type
	Filter by asset type to view hardware changes or software changes separately.

	Operation Type
	Filter by change type: added, removed, or modified assets.

	Description
	Search by asset description to locate specific changes.


5.12 Windows System Logs
Windows logs record system events on client machines for later review. By default, Windows system logs are not recorded and must be enabled via Policy → Log Settings.

Administrators require the permission Tools → Accounts → Function Permissions → Logs → Windows System Logs to view client Windows logs.
Select Logs → Windows System Logs to view policy logs, which include:
	Attribute
	Description

	Type
	The type of system log: Application, Security, or System.

	Source
	The event source of the system log; fuzzy search is not supported.

	Record Count
	Number of records in the log.

	Event ID
	The event ID of the log; fuzzy search is not supported.

	Level
	Log level: Critical, Warning, Detailed, Error, or Information.

	Keyword
	Log keywords.

	Task Category
	Task category of the log; fuzzy search is not supported.

	Details
	Detailed description of the log entry.


[image: image98.bmp] Notes
1. After enabling the policy, only logs from the past 5 days are available in Windows system logs.
2. The Keyword field only displays Audit Success, Audit Failure, or Classic; other values will appear empty.
5.13 Policy Logs
olicy logs record all strategy-related events triggered on client machines, enabling administrators to review user actions.
Select Logs → Policy Logs to view these logs, which include:
	Attribute
	Description

	Alert Level
	Three levels: Low, Important, Critical. Administrators can assign an alert level when configuring the policy.

	Related Policy
	The policy type triggered by actions on the client machine.

	Description
	Details of the client machine’s action and the triggered policy.


Policy logs can be queried using the following criteria:
	Field
	Description

	Minimum Level
	Defaults to all. Selecting “Low” retrieves Low, Important, and Critical logs; “Important” retrieves only Important and Critical logs.

	Policy Type
	Filter by a specific policy type. Only policies for which the administrator has both “Policy Log” permission and “View” permission are displayed.

	Content
	Query based on the description text; supports fuzzy search.


5.14 System Event Logs
Select Logs → System Events to view server startup and shutdown records, unauthorized network access reports, communication errors between server and clients, server time logs, client login conflicts, automatic client log deletions, and email report logs.
System event logs include:
	Attribute
	Description

	Type
	Event categories such as System Status, System Settings, Email Reports, Client Conflicts, New Client Detection, Client Pre-checks, Client Management Info, and Patch Download Info.

	Description
	Details describing the event corresponding to the type.


[image: image99.bmp] Note
If a client cannot connect to the server or communication issues occur, check the system event logs to identify the cause.
Chapter 6: Policies
6.1 Introduction to Policies
Administrators can use policies to restrict client access to computers and networks, ensuring proper usage and improving productivity.
Common Policy Attributes
Policies include multiple attributes. Among them, some are common across all policy types and share the same meaning.
	Attribute
	Description

	Name
	A user-defined description of the policy. It has no impact on execution. When adding a new policy, the console generates a default name, which administrators can modify.

	Policy Level
	Defines the priority of execution: Normal, High, or Critical. When policies of the same type overlap, execution follows the order: Critical > High > Normal. Note that user policies always take precedence over computer policies, regardless of level.

	Time
	Specifies when the policy is active. By default, it applies all day. Administrators can choose a predefined time type (configured in Category Management → Time Types) or define a custom time range directly.

	Mode
	Determines the action taken when policy conditions are met: Deny, Allow, Ignore, or No Action. (See section on modes for details.)

	Action
	Specifies additional responses triggered with the policy, including Alert, Warning, or Computer Lock. These can be applied individually or in combination. (See section on actions for details.)

	Expiration
	Defines when the policy ends. By default, policies are set to Always Active. To set an expiration, enable the option and specify a valid time (later than the current system time). Expired policies are displayed in dark grey with the expiration date shown in red.

	Offline Only
	Determines whether the policy applies only when the client cannot connect to the server (e.g., due to business travel, working from home, or network issues). If unchecked, the policy remains active at all times.

	Advanced Conditions
	Allows policies to be applied only under certain system or device conditions (e.g., OS type, device category). Conditions can be set directly through an expression or selected from the predefined Condition Library in Category Management.


[image: image100.bmp] Note
1. Advanced conditions are supported only by certain policies. Unsupported ones display <None> and cannot be modified.
2. For details on condition syntax and best practices, see Category Management → Condition Library.
Policies can operate in four different modes: Allow, Deny, Ignore, and No Action.
	Mode
	Description

	Allow
	Permits the specified operation. Once a policy matches this mode, the action is allowed and no further policies are evaluated.

	Deny
	Blocks the specified operation. Once a policy matches this mode, the action is denied and no further policies are evaluated.

	Ignore
	Neither explicitly allows nor denies the operation. The policy actions (e.g., alerts, warnings) are executed, but evaluation continues with subsequent policies to determine whether the operation is ultimately allowed or denied.

	No Action
	Neither allows nor denies the operation, typically used in basic or device-specific policies. Once matched, the system takes no allow/deny decision and does not evaluate further policies.


[image: image101.bmp] Note
Some policies may define actions beyond these four modes. Their specific behavior is explained in the corresponding policy sections.
When a client machine triggers a policy, corresponding actions can be executed. Available actions include Alert, Warning, Lock Computer, and Screen Capture.
	Action
	Description

	Alert
	Sends an alert from the client to the server. The console displays a pop-up notification to inform administrators, and the alert is also recorded in the policy log. Administrators can configure whether alert bubbles appear via Tools → Options → Real-Time Alerts → Bubble Settings, and view active alerts under Tools → Alerts. Alerts can be set to three severity levels: Low, Important, and Critical.

	Warning
	Displays a dialog box on the client, notifying the user that a restricted action was attempted. Administrators can customize the warning message shown to end users.

	Lock Computer
	Automatically locks the client machine, preventing any further operations by the user. Administrators can unlock the machine via Console → Control → Unlock.

	Screen Capture
	Captures the client’s screen immediately when a policy is triggered. By default, three screenshots are taken at two-second intervals. Captured images can be reviewed under Screen History.


Policy Matching Priority
Policies follow a firewall-like matching mechanism. Each policy set may contain multiple rules, evaluated in order. The first matching rule is applied. In addition, each object automatically inherits policies from its parent object.

Administrators can define policies at multiple levels: network, group, computer, and user. Objects with assigned policies are marked with a red flag icon“[image: image102.png]


”. The priority of policy matching, from highest to lowest, is: User Policy → User Role Policy → User Group Policy → User Group Role Policy → Computer Policy → Computer Role Policy → Computer Group Policy → Computer Group Role Policy
Inherited policies from parent groups are displayed with a light green background and cannot be modified. For string-based policy fields, wildcards are supported. Multiple values can be entered, separated by a semicolon (“;”) or comma (“,”).
Policy Icon Guide
	Icon Button
	Description
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	New: Click to add a new policy.
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	Move Up: Moves the selected policy up one position.
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	Move Down: Moves the selected policy down one position.
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	Delete: Deletes the selected policy.
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	Cancel: Cancels a new or modified policy.
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	Save: Saves the policy. Changes take effect only after saving.
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	Allow: Indicates the policy mode is Allow.
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	Deny: Indicates the policy mode is Deny.
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	Ignore: Indicates the policy mode is Ignore.
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	No Action: Indicates the policy mode is No Action.
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	Alert: The policy triggers an alert.
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	Warning: The policy triggers a warning.

	[image: image115.png]



	Lock Computer: The policy locks the client computer.
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	Expiration: The policy has a set expiration time.


6.2 Basic Policies
Basic policies are used to regulate operations on networked computers, restricting clients from making unauthorized changes to system settings. This prevents accidental or malicious damage and enhances overall computer security.
Basic policies primarily work by modifying registry values. Unlike device control or other real-time trigger policies, basic policies are state-based, meaning changes or deletions are handled differently from other types of policies.
Supported items under basic policies include: Control Panel, Computer Management, System, Network, IP/MAC Binding, and ActiveX Controls.
Control Panel Items:
	Basic Policy Item
	Description

	Control Panel
	Includes all functions available in the Windows Control Panel.

	Set Display Properties
	Restricts clients from changing desktop settings, screen savers, and desktop appearance.

	Add Printer
	Prevents clients from adding printers.

	Delete Printer
	Prevents clients from removing printers.

	Fast User Switching
	Disables simultaneous login of multiple users via Windows fast user switching (Windows XP only).

	Rename Computer
	Prevents clients from changing the computer name.


Computer Management includes the following five items:
	Basic Policy Item
	Description

	Device Manager
	Restricts clients from using Device Manager.

	Disk Management
	Restricts clients from using Disk Management.

	Local Users and Groups
	Restricts clients from accessing Local Users and Groups in the Control Panel.

	System Services Management
	Restricts clients from managing system services.

	Other Computer Management
	Restricts access to Computer Management tools, Event Viewer, Disk Defragmenter, and Shared Folders.


The System category includes the following five items:
	asic Policy Item
	Description

	Task Manager
	Restricts clients from using Task Manager.

	Registry Editor
	Restricts clients from accessing the Windows Registry.

	Command Prompt
	Restricts clients from using the command prompt (Command.exe in Windows 9x, CMD.exe in Windows NT and later).

	Run Programs in Registry 'Run'
	If set to Deny, programs under the 'Run' key will not start at system boot. A logout or restart is required to take effect.

	Run Programs in Registry 'RunOnce'
	If set to Deny, programs under the 'RunOnce' key will not execute on the next boot. A logout or restart is required to take effect.


The Network category includes the following six items:
	Basic Policy Item
	Description

	Modify Network Properties
	Restricts clients from changing network properties.

	Show “Network Neighborhood”
	If set to Deny, the “Network Neighborhood” icon on the desktop will be hidden; a logout or restart is required to take effect.

	Modify Internet Options
	Restricts clients from changing Internet Options settings.

	Default Network Shares
	If set to Deny, default network shares on the client are disabled.

	Use Network Shares
	If set to Deny, clients cannot access shared documents.

	Add Network Shares
	If set to Deny, clients cannot create new network shares.


IP/MAC Binding
	Basic Policy Item
	Description

	Modify Network IP/MAC
	Restricts clients from changing network IP or MAC settings. Once enabled, the client’s current IP and MAC are saved, and any unauthorized changes are immediately reverted. To modify the IP, this policy must first be disabled.


The ActiveX Controls category includes the following four types:
	Basic Policy Item
	Description

	Chat ActiveX Controls
	Restricts clients from using chat-related ActiveX controls. Users are blocked from using chat functions.

	Media ActiveX Controls
	Restricts clients from using media-related ActiveX controls, typically required for online music or video playback. Blocking this prevents media playback.

	Game ActiveX Controls
	Restricts clients from using game-related ActiveX controls, which are required by some online games. Blocking this prevents such games from running.

	Flash ActiveX Controls
	Restricts clients from using Flash-related ActiveX controls, preventing playback of Flash files.


Others
	Basic Policy Item
	Description

	System Restore
	Prevents clients from using System Restore, stopping them from uninstalling the client via restore points.

	Use Print Screen Key
	Disables the Print Screen key to prevent clients from capturing screen content, reducing data leakage risks.

	Windows Automatic Updates
	Disables Windows Automatic Updates on the client machine.


Policy Example



Suppose your requirement is to prevent IP address changes while at the office but allow changes when working from home or on business trips. An administrator can configure basic policies for the target computers (e.g., the entire network) as follows:
① Set a policy to Deny modification of IP/MAC properties.
② Set an Offline-Only policy to Allow modification of IP/MAC properties.
According to the policy matching rules, the most recently added policy takes precedence. When the client is offline, the offline policy matches first, allowing IP/MAC changes. When online, the offline policy does not match, so the system evaluates the next policy. If conditions are met, the first policy applies, denying any IP/MAC changes.
[image: image117.bmp] Note
Basic policies affecting network IP/MAC configuration, System Restore, and network sharing apply to computers, not individual users.
6.3 Device Control Policies
Device control policies regulate the use of various computer-related devices within an organization. They help standardize how computers access storage and communication devices, preventing confidential information from being leaked through external devices and enhancing enterprise security and management compliance.
Supported device types include Storage Devices, Communication Interface Devices, Dial-up Devices, USB Devices, Network Devices, and Other Devices.
Storage Devices:
	Device Type
	Description

	Floppy Drive
	Controls floppy drives. If disabled, floppy drive access is blocked.

	CD/DVD Drive
	Controls CD-ROM and DVD drives.

	CD/DVD Burner
	Controls the ability to burn discs.

	Tape Drive
	Controls tape drives.

	Removable Devices
	Controls storage devices other than internal hard drives (IDE, SCSI, SATA), including USB drives, external hard drives, memory sticks, smart cards, MO, and Zip drives.

	Non-System Drives
	Applies to all drives except the system drive.

	Portable Devices
	Includes devices such as smartphones.


CD/DVD burning control focuses on restricting disc-burning operations. Supported tools include:
	Device Type
	Description

	Dedicated Burning Tools
	AnySecura’s proprietary disc-burning software.

	Other Burning Tools
	Any disc-burning software other than AnySecura’s proprietary tool.


Mobile smart devices primarily refer to smartphones. Policies can control how these devices connect to client machines. Supported access methods include:
	Device Type
	Description

	Portable Device Mode
	Device connects as a portable device.

	USB Storage Mode
	Device connects as a USB mass storage device (some devices may call this “mass storage mode”).

	Via Phone Management Software
	Device connects using third-party phone assistant software.


Communication interface devices include:
	Device Type
	Description

	Serial Port
	COM port.

	Parallel Port
	LPT port.

	USB Controllers & Connectors
	Universal Serial Bus controllers and hubs.

	SCSI Interface
	SCSI and RAID controllers; used by SCSI hard drives.

	1394 Controller
	IEEE 1394 bus controller (1394 slot), functions similarly to USB.

	Infrared
	Infrared devices.

	PCMCIA Card
	PCMCIA slot, functions similarly to USB controllers.

	Bluetooth Devices
	Bluetooth-enabled devices.

	Modem
	Dial-up device.

	Direct Cable Connection
	Direct connection between two computers via USB, COM, or parallel ports.


Bluetooth devices include:
	Device Type
	Description

	Bluetooth Mouse
	Manages usage of Bluetooth mice

	Bluetooth Headset
	Manages usage of Bluetooth headsets

	Bluetooth File Transfer
	Controls file transfers via Bluetooth devices


Dial-up connections include:
	Device Type
	Description

	Dial-up Connection
	Controls access to dial-up connections


USB devices include:
	Device Type
	Description

	USB Keyboard
	Controls usage of USB keyboards

	USB Mouse
	Controls usage of USB mice

	USB Modem
	Controls usage of USB modems

	USB Imaging Device/Camera
	Controls USB cameras, scanners, and digital cameras

	USB CD-ROM
	Controls USB CD-ROM drives

	USB Storage
	Controls USB storage devices

	USB Hard Drive
	Controls usage of USB hard drives

	USB Network Adapter
	Controls usage of USB network adapters

	Other USB Devices
	Controls USB devices not listed above


Network devices include:
	Device Type
	Description

	Wireless Network Adapter
	Controls usage of wireless network adapters

	PnP Network Adapter (USB, PCMCIA)
	Hot-swappable network adapters

	Virtual Network Adapter
	Non-physical adapters, either motherboard-independent or virtual


Other devices include:
	Device Type
	Description

	Audio Devices
	Sound, video, and game controllers

	Virtual CD/DVD Drive
	Controls usage of virtual CD/DVD drives

	Wireless Networks
	Controls access to specific wireless networks using device descriptions. Leaving the description blank applies to all networks.
Device description format: SSID=<network name>|BSSID=<network address>. You can specify only SSID, only BSSID, or both. Wildcards are supported, and multiple network descriptions are separated by semicolons.
Example: SSID=teclink_11|BSSID=aa-77-dd-00-88; SSID=teclink_10; BSSID=aa-ee-dd-00-88

	Any New Device
	Controls any newly connected device. If set to block, all new devices are disabled.


Policy Example 1
In some companies, listening to music or watching videos during work hours is prohibited. A device control policy can disable audio devices during this time.

Policy: Select the time range as “Working Hours,” set the mode to “Block,” and check “Audio Devices” in the device list. Computers with this policy applied will have their sound cards disabled.
Policy Example 2
To protect sensitive company documents, employees can be restricted from copying files via removable storage or CD/DVD burners.

Policy: Set the mode to “Block” and select the devices to restrict, such as removable drives, floppy disks, CDs, or burners. Computers with this policy applied will be unable to use these devices.
Policy Example 3
Some companies restrict employees to using only internal wireless networks for management purposes. Administrators can set a device control policy for target computers (e.g., the entire network) as follows:
①Block all wireless networks: Set the mode to “Block,” check “Wireless Networks” in the device list, and leave the device description blank.
②Allow internal networks: Set the mode to “Allow,” check “Wireless Networks” in the device list, and specify the company’s internal network information in the device description.
Example:

SSID=teclink_11|BSSID=aa-77-dd-00-88-ff; SSID=teclink_10; BSSID=aa-ee-dd-00-88-cc
After applying the policy, clients can only connect to the following networks:
①Network named teclink_11 with AP address aa-77-dd-00-88-ff
②Network named teclink_10
③Network with AP address aa-ee-dd-00-88-cc
6.4 Application Policies
In companies, administrators may want to restrict certain applications, such as BitTorrent clients, download tools like Thunder, chat software, or games. Application control policies can limit client machines from running these programs.
Applications
By default, newly added policies apply to all applications. Administrators must specify which applications to control. There are three ways to enforce application restrictions:
1. By Process Name  
Administrators can add the application’s executable name, e.g., thunder.exe. The policy works via string matching. If the client renames the program (e.g., thunder123.exe), the policy will not apply. To avoid this, use the second method.
2. By Application Category
Administrators select a category containing all applications to block. Even if the client renames the executable, the policy remains effective as long as the program itself is unchanged.
3. By Execution Path
Administrators can specify a path, e.g., Block APPDIR:e:\*.exe to block all programs on the E: drive. Similarly, to block all programs on the H: drive, set the policy to Block APPDIR:h:\*.exe.
You can also use $UDISK$ to represent USB drives and $CDROM$ for CD-ROMs.

Examples:
APPDIR:$UDISK$:\*.exe — blocks all programs on USB drives
APPDIR:$CDROM$:\*.exe — blocks all programs on CD-ROMs
Services
Application policies can also control the running of services on client machines. When setting the policy, enter the service name in the application field using the format:
SERVICE:ServerName；
Example: To block the service bthserv, enter SERVICE:bthserv in the application field.
Notes:Use English half-width characters when typing.SERVICE must be uppercase; otherwise, the policy will not take effect.ServiceName refers to the service’s actual name, not its display name.
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Blocking all applications will disable most processes. To prevent potential issues, configure this policy with caution.
Warning messages can include the name of the process that triggered the policy. To do this, insert $APPNAME$ in the message. For example, if a policy blocks QQ.exe and the warning is set to: “Company policy prohibits running this process: $APPNAME$”， then when the client tries to run QQ.exe, the message displayed will be: “Company policy prohibits running this process: QQ.exe”。
6.5 Web Browsing Policies
Web browsing policies allow administrators to control employees’ access to websites, block non-work-related or malicious sites, improve productivity, and protect internal network security.
Administrators can add specific websites or control access by website category. Website categories can be configured or modified under Category Management → Website Categories. Similarly, in the application section, administrators can add individual applications or assign an application category; access to specified websites through these applications will then be controlled.
Website names can be full URLs or include wildcards, e.g., *.baidu.com, *mail*, *game*, *.com/mail/*.
Policy Example:
To prevent employees from visiting unauthorized websites, you can create web browsing policies to block these sites or allow access only to specific ones. For instance, to allow access to only certain websites:
① Create a policy to block all websites.
② Create a second policy to allow specific websites (adding all permitted sites).
With this setup, employees can access only the specified websites, while all other sites are blocked.
6.6 Screen Recording Policies
Screen history can record all actions on client machines. Due to large data volumes, recording is disabled by default. Administrators can enable and configure screen recording policies based on actual needs.
Policy Attributes:
	Attribute
	Description

	Application
	Specifies which applications to record. Default is <All>. Administrators can target specific applications of interest.

	Interval
	Sets the time interval between screen snapshots. Default is 15 seconds (i.e., one snapshot every 15 seconds). Valid range: 1–99,999 seconds. Only effective in Record mode.


By setting different recording intervals for different applications, important programs can be recorded more frequently, while less critical programs can be recorded less often or not at all.
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Shorter intervals generate more data. Administrators should adjust the interval according to actual requirements.
6.7 Logging Policy
By default, all client logs are recorded except for window title changes, Windows system logs, and remote desktop logs. Some organizations may not want to record every type of log, such as dial-up or instant messaging logs. Log recording policies allow administrators to control which logs are captured.

The system includes a default policy: all logs are recorded except window title changes, Windows system logs, start/stop activity logs, and remote desktop logs.
To exclude specific logs, create a policy set to Do Not Record, select the logs to exclude, and save the policy.
	Log Item
	Description

	System Startup/Shutdown
	Records system startup and shutdown events in basic event logs.

	User Login/Logout
	Records user login and logout events in basic event logs.

	Start/Stop Activity
	Records application start and stop events in basic event logs.

	Dial-up
	Records dial-up connection events in basic event logs.

	Policy Control
	Records policy alert logs.

	Hardware Changes
	Records hardware changes in asset logs.

	Software Changes
	Records software changes in asset logs.

	Windows System Logs
	Not recorded by default; can be enabled via policy.

	Category
	Specifies system log categories: Application, Security, or System.

	Level
	Specifies system log levels: Critical, Warning, Verbose, Error, or Information.

	Applications
	Administrators can choose to record or not record specific applications, including only those with visible windows. Supports manual entry or selection by application category, with wildcard support.

	Visible Windows Only
	Refers to applications that have a foreground window.

	Applications
	Administrators can specify applications manually or select an application category; wildcards are supported.

	Window Title Changes
	Not recorded by default; can be enabled via policy and applied to specific applications.

	Applications
	Specify applications for window title recording manually or via application category; supports wildcards.

	Web Browsing
	Administrators can exclude certain web browsing logs or record them for specific websites.

	Website
	Enter website addresses manually (supports wildcards) or select from pre-defined website categories.

	Keyword Search
	Administrators can choose to record or exclude searches for specific keywords or set rules based on the search platform’s domain.

	Search Keywords
	Specify keywords for logging; fuzzy matching is not supported. Wildcards are allowed, and multiple keywords can be separated by commas.

	Domain
	Specify the search platform’s domain; fuzzy matching is not supported. Wildcards are allowed, and multiple domains can be separated by commas.

	Document Operations
	Logs document activities. Administrators can exclude certain documents to ensure only relevant logs are captured.

	Drive Type
	Includes Hard Drive, Floppy, CD/DVD, Removable, Network, and Unknown drives. For example, logs from hard drives can be excluded.

	File Name
	Specify file names to include or exclude; wildcards are supported (e.g., *.txt, *.log).

	Application
	Specifies the application performing the document operations.

	Print Operations
	Logs document printing activities on the client.

	Printer Type
	Specify which printer types to include or exclude from logging.

	Application
	Set the application used for printing documents.

	Shared Documents
	Logs operations on shared documents.

	File Name
	Specify the names of shared documents; wildcards are supported.

	Network Address Range
	Specify the IP range of remote machines accessing shared documents; administrators can exclude specific machines from logging.

	Remote Desktop Logs
	Records client remote desktop activities. Not recorded by default; can be enabled via policy.

	Type
	Select which remote actions to record or exclude, including: Connect, Disconnect, Remote Create, Remote Access, Remote Copy to Local, Local Copy to Remote, Remote Copy to Mapped Drive, Remote Modify, Remote Rename, Remote Delete.

	Email
	Records email content. Specific types of emails can be excluded from logging.

	Email Type
	Choose the type of email: Standard, Web, Exchange, or Lotus.

	Sent/Received
	Specify the email direction: Sent or Received.

	Sender
	Specify sender email address; supports wildcards. Matching emails are recorded or excluded based on policy.

	Recipient
	Specify recipient email address; supports wildcards.

	Match Single Recipient
	If checked, policy applies if at least one recipient matches. If unchecked, all recipients must match.

	Email Size (>=KB)
	Emails larger than or equal to the specified size are recorded or excluded.

	Exclude Attachments
	Effective only in Record mode. If checked, email attachments are not recorded. They appear in the console as attached but cannot be viewed or saved.

	Exclude Body
	Effective only in Record mode. If checked, the email body is not recorded and cannot be viewed in the console.

	Instant Messaging
	Records instant messaging content. Administrators can select specific chat tools to monitor.

	Chat Tool
	Select the chat tool(s) for logging.

	Exclude Content
	Effective only in Record mode. If checked, chat content will not be recorded or viewable in the console.

	Removable Storage
	Logs operations on removable storage devices.

	Removable Storage Type
	Specify storage type: encrypted or unencrypted.

	Application Statistics
	Records usage statistics for applications.

	Web Browsing Statistics
	Records web browsing activity statistics.

	Network Traffic Statistics
	Records network traffic data.


6.8 Remote Control Policies
Remote control policies allow administrators to manage whether client machines can be remotely controlled and the method of remote control.
There are two types of remote control: Remote Control and Remote File Transfer. 

At least one of these must be selected to configure the additional policy attributes below:
	Policy Attribute
	Description

	Require Confirmation
	Effective only in Allow mode. If checked, remote control requires user authorization only. If unchecked, both user authorization and password authorization are allowed. Refer to Maintenance → Remote Control for details on these methods.

	Administrator Name
	Controls which administrators logged into the console can perform remote control. For example, restrict certain admin accounts from remotely controlling specific clients or require confirmation. Admin accounts are configured under Tools → Accounts.

	Console IP Address
	Restricts remote control by the IP range of the console machine. For example, limit remote control to consoles within a specific IP range. Entering 0.0.0.1-255.255.255.255, leaving it blank, or providing an invalid range will apply the policy to all IP addresses (<All>).

	Console Name
	Restricts remote control based on the name of the console machine.


Administrator Name, Console IP Address, and Console Name support multiple entries separated by semicolons ‘;’ or commas ‘,’.
6.9 Custom Configuration Policies
Custom configuration policies primarily supplement other policy functions, allowing newly added or minor features to be managed centrally. Each feature has its own attributes, depending on the specific function.

To create a policy, select the target feature from the provided keywords, then set the required values in the properties panel on the right. Notes are optional. If the feature is not included in the existing keyword categories, choose Category: Custom, enter the feature name in the keywords field, and input the corresponding value in the Content section of the properties panel.
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1. Each custom configuration policy is independent.
2. Since custom configuration policies may involve many features not yet included in existing keyword categories, please consult our technical support for guidance on the features and corresponding values.
6.10 System Alert Policies
System alerts provide real-time notifications for changes in hardware, software, and critical system settings, enabling administrators to quickly detect changes within the network and take appropriate action, improving maintainability of LAN computers.
The supported alert items include:
	Alert Item
	Description

	Hardware Changes
	Alerts triggered by any changes in hardware assets, helping administrators maintain network hardware inventory.

	Lock Computer
	If checked, the computer will be locked when a hardware change occurs.

	Device Insertion
	Alerts when an external device is connected, recording the device name.

	Device Removal
	Alerts when an external device is disconnected, corresponding to insertion alerts.

	Storage Device Insertion
	Alerts when a storage device is used, recording the device name to prevent unauthorized use.

	Storage Device Removal
	Alerts corresponding to storage device removal.

	Communication Device Insertion
	Alerts when a communication device is used, recording the device name to prevent unauthorized use.

	Communication Device Removal
	Alerts corresponding to communication device removal.

	Software Changes
	Alerts for addition, deletion, or modification of software assets, aiding software maintenance.

	System Service Changes
	Alerts for addition or removal of system services, assisting in virus or system issue detection.

	Startup Item Changes
	Alerts for addition, deletion, or modification of system startup items to help detect malware or system issues.

	System Clock Changes
	Alerts when the system clock is modified.

	Computer Name Changes
	Alerts when the computer name is changed, notifying administrators and preventing unauthorized operations.

	Network Configuration Changes
	Alerts for changes in network properties to help identify network issues.

	Low Disk Space
	Alerts when system disk space falls below a set threshold.

	Abnormal Disk Power
	Alerts when disk power-on count is abnormal, helping detect unauthorized hard drive use.


The alert details include both the alert type and a descriptive message, enabling administrators to quickly locate and resolve issues.
6.11 Network Traffic Control Policies
Network traffic control policies regulate client machine network usage to prevent congestion, ensure normal operation across the enterprise, and restrict unauthorized downloads or specific port traffic.
Traffic policies apply to computers, not individual users. Policy attributes include:
	Policy Attribute
	Description

	Network Address Range
	Specifies the IP address range of communication peers. Default is {All}. Addresses can be added manually or selected from predefined network categories, represented by {…}.

	Port Range
	Specifies the range of ports used in communication. Default is {All}, including TCP: 0-65535, UDP: 0-65535, ICMP. Custom ports must be prefixed with TCP: or UDP:; otherwise, TCP is assumed. Port ranges can also reference port categories {…}.

	Traffic Direction
	Defines the flow of network traffic. Outbound traffic from the client is "Sent," inbound traffic is "Received." Sent + Received = Total traffic.

	Speed Limit
	Sets the maximum traffic rate in KB/s. Not applicable if the policy mode is Unlimited. In Limit mode, exceeding the limit pauses upload/download until average traffic falls below the threshold. In Ignore mode, speed is not limited, but configured actions (alert, warning, lock computer) will trigger if traffic exceeds the limit.


If the policy mode is Limit, when a client’s traffic in the specified IP range, port range, and direction exceeds the set speed limit, uploads/downloads will be paused until the average traffic falls below the limit, effectively controlling the flow.
If the policy mode is Ignore and no action is configured, the speed limit is inactive. If actions such as alert, warning, or lock computer are set, exceeding the speed limit in the specified IP range, port range, and direction will trigger the configured actions, but traffic will not be restricted.
Policy Example 1:
To prevent client machines from unrestricted Internet access that could heavily consume corporate bandwidth and affect overall network performance, a traffic control policy can be applied to specific machines.
Policy Settings:
· Mode: Limit
· Address Range: Internet

· Port Range: Default or specified ports

· Traffic Direction: Selected direction

· Speed Limit: 20 KB/s

Effect: Clients’ web access and upload/download speeds are limited to 20 KB/s.
Policy Example 2:
Traffic control policies can also block communication between clients and specific IPs or ports. To prevent FTP downloads:

· Mode: Limit
· IP Address Range: {All}

· Port: TCP:21

· Speed Limit: 0 KB/s

Result: FTP downloads from clients are blocked.
6.12 Network Control Policies
Network control policies manage client machine communications with unauthorized computers, block malicious or download-related ports, prevent virus intrusion, and safeguard internal network security.
These policies apply to computers and are ineffective in user mode. Policy attributes include:
	Policy Attribute
	Description

	Communication Direction
	Three options: Bidirectional, Outbound, Inbound. Outbound/Inbound is relative to the client machine; outbound means the client initiates the connection.

	Port Range
	Same as in traffic control policies.

	Network Address Range
	Same as in traffic control policies.

	Is Target a Client?
	Determines whether the remote machine is a client. Only effective if checked; otherwise, this check is ignored.

	Same Group
	Controls communication between client machines in the same group. “Same group” refers to the group of the client applying the policy, excluding parent or subgroups.

	Specific Group
	Controls communication with client machines in a specified group. Only effective if checked.

	Belonging Group
	Specifies the group of the target machine. Required to enable the Include Subgroups option.

	Include Subgroups
	Determines whether subgroups of the specified group are included.

	Application
	Specifies the application allowed to access the network.


Policy Example 1
To protect internal network security, a company may need to block certain malicious or download-related ports. This can be achieved using a network control policy.

· Policy: Mode = Block
· Settings: Specify the target address range and ports to block, e.g., port 80 or port 21.

· Blocking port 80 prevents clients from accessing websites.

· Blocking port 21 prevents FTP downloads.
Policy Example 2
Some departments may have critical computers that should not be accessed by machines outside the department. Network control policies can enforce this.
Policy Steps:
① Create a policy to Block the address range: Local Area Network.
② Create a policy to Allow communication where: Is Target a Client + Same Group.
Effect: Machines in the department can only communicate within their group. Before applying this policy, all departmental machines must be placed in the same group. Any machines outside the department without the client installed should have their IPs added to the allow policy.
Policy Example 3
Network control policies can be combined with access detection to prevent external computers from communicating with internal machines.

· For client-installed internal machines: Set network control policies to allow communication only with corporate computers. External machines cannot access these clients.

· For internal machines without the client: Mark them as Protected in access detection and enable access control. External machines will be considered unauthorized and cannot communicate with these protected machines.
6.13 Email Control Policy
The email control policy prevents the leakage of sensitive corporate information via email while allowing normal email usage. It applies only to outgoing emails; incoming emails cannot be controlled. Currently, it does not support controlling webmail or Lotus email sending.
	Attribute
	Description

	Sender
	Controls the sender’s email address. Supports wildcards and multiple addresses separated by commas (,) or semicolons (;).

	Recipient
	Controls the recipient’s email address, including CC and BCC. Input rules are the same as for Sender.

	Match Single Recipient Only
	If checked, the policy applies if at least one recipient matches; if unchecked, all recipients must match.

	Subject
	Controls the email subject. Input rules are the same as for Sender.

	Contains Attachment
	Controls whether emails with attachments are affected. If checked, only emails with attachments are controlled; if unchecked, all matching emails are affected, regardless of attachments.

	Attachment Name
	If “Contains Attachment” is checked, specify attachment names to control. Input rules are the same as for Sender.

	Email Size (>=KB)
	Controls emails by size. Default is 0 (all emails). Emails equal to or larger than the specified size are affected.


Policy Example 1
To prevent confidential corporate information from being sent via email, attachment control can be applied. Emails containing attachments with specified keywords in their filenames will be blocked.
Policy Setup: Mode: Block → Contains Attachment → Attachment Name: e.g., *keyword*
Emails sent from the client containing attachments with filenames that include “keyword” will be blocked.
Policy Example 2
Some organizations may restrict outgoing emails to approved internal accounts, blocking all other senders. This ensures proper email usage and tighter control over external communications.
Policy Setup:
① Create a policy: Block All Emails
② Create a policy: Allow → Sender: e.g., *@teclink.com.hk
Only emails sent from addresses containing @teclink.com.hk will be allowed.
6.14 IM File Transfer Policy
The IM file transfer policy controls the sending of internal company data through instant messaging tools, ensuring the security of corporate information.
It supports a wide range of IM platforms, including: QQ, ICQ, MSN Messenger, YAHOO, TM, UC, SKYPE, RTX, Neitong, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, Feiqiu, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, WeCom, Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams, and Welink.
OfficeIM and LIMC currently only support message content logging and do not support IM file transfer control.
Policy Attributes:
	Attribute Name
	Description

	File Control
	Enable this to control files sent via IM tools.

	File Name
	Specify the names of IM-transferred files to control. Supports wildcards and multiple entries separated by ; or ,.

	File Size Limit
	Effective only in “Prohibit” mode. Prevents sending files larger than the specified size (0–4,000,000 KB).

	Backup
	Choose whether to back up the specified sent files. Backed-up files can be viewed or saved under Logs -> Document Operations.

	Backup File Min Size (>=KB) / Max Size (<=KB)
	If backup is enabled, set the size range of files to back up. Only files within this range will be backed up.

	Image Control
	Enable this to control images sent via IM tools.

	Backup
	Choose whether to back up sent images.

	Chat Tool
	Select the IM platforms to which this control applies.


Policy Example:
To protect internal data and prevent employees from sending files via IM tools, you can configure an IM file control policy to block documents containing specific keywords while backing up other files.
Policy Setup:
① Create a policy: Allow and enable the Backup option.
② Create a policy: Prohibit with File Name: *keyword*.
With this setup, any file containing the specified keyword will be blocked from being sent, while other files can be sent normally but will be automatically backed up. Administrators can review the backed-up files in the Document Operations log to ensure compliance.
6.15 Upload Control Policy
The Upload Control Policy manages network upload behavior, including sending webmail, posting on forums, and FTP uploads.
Policy Attributes:
	Attribute
	Description

	Transfer Method
	Default is Upload; no other options available.

	Application
	Specify network applications to control; multiple applications can be entered separated by “;”.

	HTTP(S) Protocol
	When checked, upload via HTTP and HTTPS is controlled.

	Size Limit (>=Byte)
	Set the maximum data size allowed for upload. Default is 102,400 Bytes; uploads exceeding this size are restricted.

	Website / Network Address
	Specify target websites or network addresses. Uploads to these sites will be controlled. Default is all websites. Supports manual input (www.example.com), wildcards, “;” or “,” separators, or selecting from a category library.

	FTP Protocol
	When checked, FTP uploads are controlled.

	FTP Size Limit (>=Byte)
	Maximum FTP upload size. Default is 102,400 Bytes; uploads exceeding this size are restricted.

	File Name
	Specify file names to control. Supports wildcards and “;” or “,” separators.

	Network Address Range
	Restricts FTP uploads to specific IP ranges. Default is all addresses. Supports manual input, wildcards, “;” or “,” separators, or selecting from a category library.

	Other Protocols
	When checked, TCP protocol uploads are controlled.

	Other Protocols Size Limit (>=Byte)
	Maximum upload size for TCP uploads. Default is 102,400 Bytes; uploads exceeding this size are restricted.

	Port Range
	Same meaning as in the Traffic Control Policy.

	Website or Network Address
	Specify target websites or network addresses. Default is * to control all sites and addresses. Supports manual input of IP, IP ranges, wildcards, “;” or “,” separators, or selecting from a category library. Example: 192.168.3.1;192.168.1.1-192.168.2.255;www.company.net;*baidu*.

	Attribute
	Description


6.16 Document Operation Policy
The Document Operation Policy restricts client access to confidential documents to prevent data leaks. It also supports document backup to protect important files from accidental loss.
Policy Attributes:
	Attribute
	Description

	Operation Type
	Simplified into Read, Modify, and Delete. Allowing Modify implies Read permission; allowing Delete implies Read and Modify permissions.

	Read
	Grants permission to access the document.

	Modify
	Covers all operations beyond read and delete, including create, rename, edit, copy, move, and restore. Only effective if this option is selected; required for Backup Before Modify and Copy/Move to Backup.

	Delete
	Grants permission to delete documents. Only effective if selected; required for Backup Before Delete.

	Drive Type
	Default is all drive types. At least one must be selected; otherwise, all drives are assumed. Ctrl + A can be used to select/deselect all sub-items.

	File Name
	Specify files to control. Can include paths (e.g., E:\work\* to cover all files in the work folder). Supports wildcards and “;” or “,” separators.

	Backup Before Modify
	Backs up files before modification to prevent malicious or accidental changes.

	Copy/Move to Backup
	Backs up files copied or moved to specified drives, helping track unauthorized transfers of important files.

	Copy/Move from Backup
	Backs up files copied or moved from specified drives, monitoring potential unauthorized exports of sensitive files.

	Backup Before Delete
	Backs up files before deletion to prevent accidental loss of important data.

	Backup File Size (Min >=KB, Max <=KB)
	Sets the size range for files to be backed up, same meaning as in IM File Transfer Policy.

	Application
	Specifies which applications the document operation policy applies to.
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When Drive Type is set to CD/DVD, the policy only applies to operations using dedicated burning software.
Policy Example 1
Some important files should not be freely modified by all users. Access can be allowed while restricting modification and deletion.

Setup: Deny Operation Type: Modify and Delete, specify the document name, and select a backup method. Users can only read the specified files.
Policy Example 2
To prevent accidental deletion or modification of critical documents, the administrator can back up specified files during such operations.

Setup: Allow Operation Type: Modify and Delete, specify the document name, and enable backup. Users can use the files normally, but any modifications or deletions are automatically backed up. Backed-up files can be viewed in the Document Operation Log.
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Enabling backup in document policies may generate a large volume of backup data. It is recommended to precisely target the files to avoid excessive unnecessary backups.
6.17 Print Control Policy
Administrators can manage document printing by specifying printer types and enabling printing for selected applications. This helps prevent leakage of confidential documents and significantly reduces resource waste.
Print Control Policy Attributes：
	Attribute
	Description

	Printer Type
	Four options: Shared, Network, Local, and Virtual. If none are selected, all printer types are considered selected. Saving the policy will automatically select all four types.

	Printer Description
	Set the printer name. Can specify a printer on a networked computer, e.g., \\server\* for all printers on \\server, or SomePrinter for a specific printer.

	Print Job
	Specify the name of the print job; supports wildcards.

	Application
	Specify the application allowed to print.

	Record Print Content
	Optional when the mode is Allow or Ignore; unavailable in Prohibit mode. Selecting this option determines whether print content is logged. If not selected, the next matching policy decides logging.

	Recording Mode
	Default is no logging. Choose Record to save print content.

	Print Log (Image Format)
	When recording mode is Record, print content is saved as images.

	Max Pages Recorded
	Maximum pages to save in image format. More pages consume more storage; adjust based on needs. Logs can be viewed in the console under Logs → Document Print Logs.

	Print Log (Text Format)
	When recording mode is Record, print content is saved as text.

	Max Pages Recorded
	Maximum pages to save in text format. Logs can be viewed in the console under Logs → Document Print Logs.


Policy Example:
To prevent data leaks or printer misuse, a company can restrict client machines’ printing:
Mode: Deny

Printer Type: Shared, Network

Printer Description: Specify printer name

Application: Specify allowed printing application, default <All>
Client machines attempting to print using these settings will be denied.
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Both printer type and printer description must match for the “Printer” condition to be considered matched.
6.18 Removable Storage Authorization Policy
To manage the use of removable drives within the enterprise and prevent leaks of confidential data, administrators can assign different permissions to different drives. Files copied to removable drives can also be encrypted, ensuring they can only be opened in authorized environments.
Before creating policies, administrators should categorize all removable drives in the organization. Refer to Classification Management → Removable Storage Classification for guidance.
Removable Storage Types and Permissions:
	Attribute
	Description

	Removable Storage Type
	Default is “All.” Use the dropdown to select Encrypted Drives, Non-encrypted Drives, or Secure USB Drives. Policies apply only to the selected type.

	Readable
	Allows any application to read the drive in read-only mode. Only if this is selected are the following three attributes effective.

	Auto Decrypt
	Allows files copied from the removable drive to local or network locations via File Explorer to be automatically decrypted. Other applications cannot auto-decrypt.

	Writable
	Allows any application to write to the removable drive. If not selected, copying, saving, deleting, or renaming files on the drive is prohibited. Auto encryption is only effective if this is selected.

	Auto Encrypt
	Prevents any program other than File Explorer from writing to the removable drive. Files copied via File Explorer are automatically encrypted.

	Removable Storage Category
	Default is <All>, covering all drives. To target specific drives, select a category or a specific drive in the classification list.

	Device Description
	Match drives by device description.
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For strict control, set all drives in the network to read-only first.Then, assign department- or user-specific permissions, allowing read/write access only to drives belonging to their category, with automatic encryption/decryption.This ensures drives are usable within departments while preventing unauthorized access from other departments. External drives can be set to read-only.
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If both Document Control Policy and Removable Storage Authorization Policy are configured, the Document Control Policy executes first, followed by the Removable Storage Authorization Policy.


Example:
If a drive is allowed read/write and encryption via the storage policy, but the document policy forbids copying Word files to removable drives, the final result prevents Word files from being copied, while other files are copied with automatic encryption.
6.19 Software Installation Management Policy
The Software Installation Management Policy restricts employees from installing unrelated software and prevents the uninstallation of critical security applications, helping maintain proper software usage across company computers.
Before configuring the policy, administrators should categorize software installation packages and uninstallable software:
· Software installation packages: See Classification Management → Software Installation Packages.

· Uninstallable software: See Classification Management → Software Uninstall.
This policy applies at the computer level and does not support user-level policies.
	Icon
	Description
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	Modify software installation permissions on selected computers
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	Delete software installation permissions on selected computers

	[image: image128.png]



	Export/import policy files or copy the current policy to other clients


Policy Settings:
	Setting
	Description

	Software Installation Control
	Enables control over software installations.

	Enable Software Installation Control
	Must be checked for the installation control to take effect.

	Block the Installation of the Following Software
	Select rules from the installation package library or input manually; matching software will be blocked.

	Allow the Installation of the Following Software (Priority)
	Select rules from the library or input manually; matching software will be allowed. Allow rules take priority if software matches both allow and block rules.

	Software Uninstallation Control
	Enables control over software uninstallation.

	Enable Software Uninstallation Control
	Must be checked for uninstallation control to take effect.

	Block the Uninstallation of the Following Software
	Select or input software to prevent uninstallation.

	Allow the Uninstallation of the Following Software (Priority)
	Select or input software to allow uninstallation. Allow rules take priority if software matches both allow and block rules.


[image: image129.bmp] Notes:
1. Manual input matches software by name exactly. For example, if all installations are blocked but “VMware.exe” is allowed manually, renaming another installation package to “VMware.exe” would bypass the restriction. To prevent this, select packages from the library.
2. The policy can recognize software by company name. Use the prefix COMPANY: when specifying a company. The prefix is case-insensitive, but the colon must be English. Wildcards (*) are supported.Installation control checks the company name of the installation package.Uninstallation control checks the company name of the software.

Chapter 7: Monitoring
7.1 Instant Messaging Content
Instant messaging (IM) monitoring captures chat activity on client machines, providing a key audit trail for accountability, identifying inappropriate conversations, and preventing distractions that may affect work efficiency.
Supported Instant Messaging Tools
The system can record chats from a wide range of instant messaging platforms, including:
QQ, ICQ, MSN Messenger, YAHOO, TM, UC, SKYPE, RTX, Intranet Messenger, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, FeiQiu, OfficeIM, MSNLite, LIMC, Marketing QQ, Enterprise QQ, LianWo LINE, Qunying CC, LYNC, WeChat Work, Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams, and Welink.
Instant Messaging Content Logging
Recorded IM content includes the following fields: 
	Field
	Description

	IM Tool
	The instant messaging platform used.

	Local Account
	The nickname of the local account sending messages.

	Counterparty Account
	The nickname of the recipient or chat partner.

	Start Time
	When the chat session began.

	End Time
	When the chat session ended.

	Chat Type
	Indicates whether the conversation is one-on-one or group chat.

	Message Count
	Number of messages exchanged, reflecting chat volume.

	Chat Content
	Detailed timestamps and message content.


Chat content supports regular expression (regex) searches. Enter the format as R:+<regex>.

· Example: To find chats containing an ID card number, enter R:\d{17}[\d|x]|\d{15}.

· To find chats containing a phone number, enter R:0?(13|14|15|18)[0-9]{9}.
The system also supports viewing sent images and files:

· For files: a clickable file name link opens a standard download window.

· For images: whether sent as files or screenshots, a thumbnail and file name link are displayed. Double-clicking the thumbnail opens the full image; clicking the link opens a download window.
Currently, image and file viewing is supported for: QQ, TIM, WeChat Work, Enterprise QQ, and DingTalk.
Saving Chat Content
Administrators can save chat records for future reference.

· Select one or more records, right-click Export Chat Record, and save as .htm or .xls.

· Using the right-click menu Export Logs, Chat Records, and Backup Files, administrators can export specific or all logs, chat records, and backup files simultaneously.
Chat Content Search
Chat records can be queried using the following criteria:
	Criteria
	Description

	IM Tool
	Search by instant messaging platform. Default is all; a specific tool can also be selected from the dropdown.

	Chat Type
	Search by conversation type. Default is all; can select one-on-one or group chat.

	User ID or Nickname
	Search by either party’s account ID or nickname to locate specific user chats.

	Content
	Search by message content; keyword queries allow quick location of relevant chats.

	Message Count
	Search by the number of messages; specify a range if needed.

	Character Count
	Search by the total number of characters; specify a range if needed.


7.2 Email Content
Email records capture messages sent and received on client machines to allow administrators to monitor email activity and prevent unauthorized content.
Supported email types include: Standard Email, Exchange Email, Webmail, and Lotus Email.

· Standard and Exchange emails: record both sent and received messages.

· Webmail and Lotus email: record only sent messages.
Email Record Details
The contents included in the email record are: 
	Attribute Name 
	Description

	Sent/Received
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 indicates a sent email record, while [image: image131.png]


 indicates a received email record.

	Subject
	The email’s subject line.

	Sender
	The sender’s email address.

	Recipient
	The recipient’s email addresses, including CC and BCC; viewable in the email record properties.

	Attachment
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” indicates the email contains an attachment. The system automatically backs up the attachment, and clicking the “[image: image133.png]


” button allows you to view or save the attached file.

	Size
	The size of the email.

	Body
	Select an email to view its content in the preview pane.


Saving Email Content
Administrators can export email files for archiving or review.

· Select an email and right-click Export Email File to save it as an .eml file, which can be opened directly in Outlook.

· Multiple emails can be selected and exported simultaneously.
Email Search
Emails and their contents can be queried using the following criteria:
	Query Criteria
	Description

	Email Type
	Search by email type. Default is all. You can select a specific type from the dropdown.

	Sent/Received
	Filter emails to include only sent or received messages.

	Sender
	Search by the sender's email address.

	Recipient
	Search by the recipient's email address. You can filter by type: all, To, Bcc, or Cc. Multiple addresses can be entered using “;” or “,”. Only emails matching all specified recipients are included.

	Subject
	Search by email subject, filtering messages containing specified keywords.

	Content
	Search email body for specific keywords to quickly locate relevant messages.

	Contains Attachment
	If unchecked, all emails are included. If checked, only emails with attachments are returned.

	Attachment Name
	Filter emails containing attachments whose filenames include specified keywords.

	Size
	Specify a size range to filter emails within that range.


7.3 Real-Time Screen Monitoring
By selecting Monitor → Screen Snapshot, administrators can view and track the screen of a specific computer or user in real time.
	Icon/Button
	Description
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	Save the current frame as an image file.
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	When a computer has multiple users logged in or a user is logged in on multiple computers, select this to view a specific session's screen.
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	Adjust the snapshot to fit the current window size.
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	Display the snapshot in its original resolution.
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	Enable automatic refresh of the screen snapshot. The refresh interval can be viewed and modified under Tools → Options → Real-Time Info.
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	Stop automatic refreshing of the screen snapshot.


After selecting a target computer, right-click and choose Track to start real-time monitoring. The display area will continuously show the screen changes of the selected computer. To stop tracking, right-click again and choose Track to disable it.

7.4 Multi-Screen Monitoring
Multi-screen monitoring allows administrators to track the real-time screens of multiple computers simultaneously. The display shows a screen matrix ranging from 2 × 2 to 4 × 4. Start multi-screen monitoring via Monitor → Multi-Screen Monitoring.
The system updates screen snapshots automatically at set intervals. After a certain period, it rotates to the next batch of computers, making it easier to monitor multiple machines at once.
Users can use the function buttons to quickly navigate to the first, previous, next, or last page of monitored computer screens. They can click the “[image: image140.bmp]” button to choose which computers or groups to monitor, and use the “[image: image141.jpg]


” utton to enable automatic screen rotation. To view a specific monitored computer in full screen, users can either click the “[image: image142.jpg]


”button or double-click the computer’s screen.
Lock Position
Right-click a computer’s screen and select Lock Position to keep it visible on every multi-screen view. Locked screens have a yellow background with black text. To unlock, uncheck Lock Position in the right-click menu.
Screen Information
Hover the mouse over a screen to display details of the client machine, including computer name, network address, user, and status.
Locate in Computer Tree
Right-click a monitored computer and select Locate in Computer Tree to quickly find its position in the computer management tree.
7.5 Screen History Query
By selecting “Monitor -> Screen History Query”, administrators can view the screen history by default for the current day. Only client machines with screen recording policies enabled will have accessible screen records. Administrators can also apply specific query conditions to quickly locate the desired screen history.
Query Conditions:
	Condition
	Description

	Date Range
	Set the start and end dates to query all screen history within the selected period.

	Computer Name
	Search for screen records of a specific computer. Supports fuzzy search (e.g., entering “TEC” returns all computers with names containing “TEC”).

	Network Address
	Enter a specific IP or IP range (e.g., 192.168.1.100-192.168.1.200) to query the corresponding computer’s screen records.

	Scope
	Select a computer group to query its screen records, including records from deleted groups.


Screen Record Log Attributes: 
	Attribute
	Description

	Date
	The date of the screen record. Screen data is saved per day, with one file per day.

	Computer
	The client machine being recorded.

	Session
	Session ID. For a single logged-in user, the session ID is 0; for a second user, the session ID is 1. Multiple users generate multiple records, one per session. (On Vista, the first user’s session ID is 1.)

	Start Time / End Time
	The start and end time of the screen recording.

	File Name
	The screen data is stored in the SQL database, with the file name displayed as <SQL>.


7.6 Screen History Viewer
After locating the desired screen records, double-click a record or click the [View] button to open the Screen History Viewer, allowing administrators to review the screen history of the selected computer. The Screen History Viewer cannot be launched independently and must be started from the console module.
Interface Overview:
The Screen History Viewer window includes the title bar, menu bar, toolbar, query bar, timeline ruler, image display area, and status bar.
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Display
You can select a specific screen frame using the menu or toolbar buttons, or directly drag the slider on the timeline ruler to view a particular frame.
View Options
Administrators can choose whether to display the toolbar and status bar via the “View” menu. The image display area supports original size, scaled, and full-screen modes, similar to the console module.
Playback Speed
Screen playback speed can be adjusted under View → Speed, with three options: Fast, Normal, and Slow, allowing users to choose based on their preference.
Search
The query bar enables administrators to quickly locate specific screen history records. Searches can be filtered by application, user, screen, or timeline.
	Query Item
	Description

	Application
	By default, all applications’ screen history is played. You can select one or multiple applications from the dropdown to view only their screen history.

	User
	If multiple users’ screens are recorded, you can select a specific user to view only that user’s screen history.

	Screen
	If the client machine has multiple monitors, you can choose a specific screen to view its recorded data.

	Lock Conditions
	Locks the above three query conditions so that only screen data meeting all three criteria is displayed.

	Timeline Ruler
	Shows the timestamp of the current frame. Drag the slider to a specific point to view that frame. Hovering the mouse over the ruler displays basic frame information. Selecting Tools → Window Title Changes shows detailed information for each frame, including time, user, application, and window title.


Export as Video File
Administrators can save selected screen history for future reference. By choosing Tools → Save as Video File, there are four available saving options:
	Save Method
	Description

	By Time
	Save screen data within a specified time range. Drag the slider on the timeline ruler to set the start and end time.

	By Application
	Save only the screen history of specified applications.

	By User
	Save only the screen history of a specified user.

	Save All
	Save the entire screen history.


Export Screen History as Images Frame by Frame
Administrators can export screen history frame by frame as images. By selecting Tools → Export Screen History as Images, there are four export options available:
	Export Method
	Description

	By Time
	Export frames within a specified time range. Drag the slider on the timeline ruler to set the start and end time.

	By Application
	Export only frames corresponding to specified applications.

	By User
	Export only frames corresponding to a specified user.

	Export All
	Export all frames from the entire screen history.


Window Title Change Information
Administrators can view the window title information from screen history. By selecting Tools → Window Title Change Information, the information can be printed via the right-click menu options Print Preview / Print.

The data can also be exported, supporting three file formats:

· Web file (*.htm; *.html)

· Excel file (*.xls)

· Text file (*.csv)

Chapter 8: Remote Maintenance
IT staff spend 70–80% of their time on routine PC maintenance, significantly increasing overall network management costs. Delays in addressing issues can also severely impact productivity. Therefore, reducing unnecessary tasks and improving efficiency allows IT personnel to focus on management and on systems that enhance organizational performance.

AnySecura enables IT staff to monitor remote computers in real time, assisting in diagnosing and resolving issues quickly.
8.1 Remote Maintenance
8.1.1 Application List
Go to the menu Maintenance -> Applications to view the real-time list of applications on client machines, including all running tasks and their status. Active applications are highlighted in dark blue bold text.
	Icon/Button
	Description
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	If multiple users are logged in on the client machine, click this button to select a user and view their application list. In user mode, if the user is logged in on multiple computers, use this button to select a specific computer’s application list.
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	Enables automatic refreshing of the application list. The refresh interval can be set and viewed under Tools -> Options -> Real-Time Information.


End Task
Administrators can remotely terminate application tasks from the console. Select the desired application, right-click, choose End Task, and confirm to close the selected application.
8.1.2  Process List
	Go to Maintenance → Process List to view all current processes on the client machine in real time. Process details include: file name, PID, start time, session ID, CPU usage, CPU time, memory, virtual memory, base priority, handle count, thread count, and path.
Field Name
	Description

	Start Time
	The time when the process was launched.

	Path
	The full path of the process on the client machine.

	Other
	All other columns correspond to the same attributes as those in the operating system’s Task Manager.


The columns in the process list help administrators identify unauthorized processes or potential malware and take prompt action to resolve issues.
	Icon Button
	Icon Button
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	Click to display a hierarchical tree of all processes, showing parent-child relationships.
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	Click to open the module view at the bottom of the window; selecting a process shows all modules loaded by that process.

	[image: image148.bmp]
	Only active in user mode; allows viewing the process list of different computers for the selected user.
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	Functions the same as in the Application List, enabling automatic refresh of the process list.


End Process
Administrators can remotely terminate a specific process from the console. Select the process you want to close, right-click, and choose End Process to terminate it on the client machine.
8.1.3 Performance
By selecting Maintenance -> Performance, administrators can remotely monitor various real-time performance metrics of client machines, including CPU and memory usage. The values for total memory, physical memory, available memory, and kernel memory correspond to the data shown in the client machine’s Task Manager -> Performance tab.
	Icon/Button
	con/Button
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	Active only in user mode; view performance lists of different computers.
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	Same function as in the application list.


8.1.4 Device Manager
Select Maintenance → Device Manager to view the real-time list of devices on client machines, including processors, disk drives, storage volumes, keyboards, mice, network adapters, and other hardware.
	Icon/Button
	Icon/Button
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	Choose how to display the device list: by type, by connection, or show/hide hidden devices.

	[image: image153.bmp]
	Active only in user mode; view devices on different computers.


Disable/Enable Devices
Administrators can remotely disable or enable hardware devices in Device Manager via the console. Select the device, right-click, and choose Disable or Enable to control the device on the client machine.
8.1.5 System Services
Select Maintenance → System Services to view the real-time list of system services on client machines, including name, description, status, startup type, logon account, and path.
	Icon/Button
	Description
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	Active only in user mode; view system services on different computers.


Remote Operations
Administrators can manage services remotely as if working locally. Right-click a service to Start/Stop to change its status, or choose Startup Type → Automatic/Manual/Disabled to set its startup mode.

8.1.6 Disk Management
Select Maintenance → Disk Management to view real-time disk partition information on client machines, including volume label, file system, capacity, free space, and usage percentage.
	Icon/Button
	Description
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	Active only in user mode; view disk management details of different computers.


8.1.7 Shared Folders
Select Maintenance → Shared Folders to view real-time sharing information on client machines, including network shares, sessions, and open files.
	Icon/Button
	Description
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	Displays shared folders on the network.

	[image: image157.bmp]
	Displays current user sessions.

	[image: image158.bmp]
	Displays files currently in use.
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	Active only in user mode; view shared folder information on different computers.


Network Shares
Administrators can view network shares to see which folders are shared on client machines. To secure sensitive data, they can right-click a share and select Stop Sharing to disable it in real time.
Sessions
Switch to Session View to monitor remote access to shared folders on client machines. Details include user, computer, type, open files, connection time, idle time, and guest status. 
If unauthorized access is detected, administrators can right-click the session and select Close Session to terminate it immediately.
Open Files
The open files list shows files on client machines currently accessed by remote users, including file name, user, lock status, and access mode.
Administrators can right-click to Close Open File or Disconnect All Open Files to terminate one or all active file accesses in real time.
8.1.8 Scheduled Tasks
Select Maintenance → Scheduled Tasks to view the real-time list of scheduled tasks on client machines, including name, schedule, application, next run time, last run time, status, last result, and author.
Administrators can delete unauthorized tasks directly from the console. Select the task, right-click, and choose Delete to remove it immediately.
	Icon/Button
	Description
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	Active only in user mode; view scheduled tasks on different computers.


8.1.9 Users and Groups
Select Maintenance → Users and Groups to view all local users and groups on client machines in real time.
Local Users: Includes user name, full name, and description.

User Groups: Includes group name and description.
	Icon/Button
	Description
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	Active only in user mode; view users and groups on different computers.


8.1.10 Software Management
Select Maintenance → Software Management to view the list of software installed on client machines. Administrators can uninstall software remotely via the right-click menu.
Uninstallation Methods：

	Method
	Description

	Default Uninstall
	Uses the software’s own silent uninstall program. If the software does not support silent uninstall, this option is unavailable.

	Advanced Uninstall
	Analyzes the selected software’s installation details via the AnySecura client and removes associated files to ensure complete uninstallation.


8.1.11 Startup Items
Select Maintenance → Startup Items to view the list of startup programs on client machines. Administrators can remove unauthorized startup items remotely via the right-click menu.
8.2 Remote Control
8.2.1 Remote Control
Remote control allows administrators to operate client machines via the console, facilitating network management, troubleshooting, and quick resolution of system issues.
Select a target computer and go to Maintenance → Remote Control. There are two authorization methods: User Authorization and Password Authorization.
User Authorization
After selecting the target machine, the console prompts the remote user for permission. If the user agrees, the administrator gains access to the control interface; if denied, the session ends.
Password Authorization
After selecting the target machine, the console prompts for the remote control password. Entering the correct password grants access; an incorrect password terminates the session.

Passwords are set on the client machine by pressing Shift + Alt + Ctrl + “securerm”, which opens the password setup dialog. Clients with a set password can still use user authorization. However, if policies require mandatory confirmation for remote control, only user authorization is allowed.
Remote Control Interface
When a remote control session is active, the target computer shows “Remote Controlling…” in the top-right corner.
Use the toolbar buttons to adjust screen zoom or switch to full-screen mode. Press F12 to exit full-screen.
The “[image: image162.bmp]” button toggles between 256 colors and true color.
The “[image: image163.bmp]” button locks or unlocks the target machine’s input devices.
The “[image: image164.bmp]” button enables or disables clipboard operations between the console and the target machine.
To send Ctrl-Alt-Del, Ctrl-Esc, or F12 to the remote machine, right-click the AnySecura remote control window’s title bar or its taskbar icon, then select Send Ctrl-Alt-Del, Send Ctrl-ESC, or Send F12 from the menu.
[image: image165.bmp]Note
Remote control supports multi-monitor setups.
8.2.2 Remote File Transfer
Remote file transfer allows administrators to move files between the console and target client machines, enabling quick distribution and improving efficiency.
Like remote control, it supports two authorization methods: User Authorization and Password Authorization. Once authorized, the console opens the remote file transfer window.
Interface Overview
The remote file transfer window includes a title bar, menu bar, toolbar, local resource view, remote resource view, and status bar.

· Local Resource View: Displays files and folders on the console machine.

· Remote Resource View: Displays files and folders on the client machine.

Double-click a folder to navigate to its subdirectory, or enter a file path directly in the address bar to locate files.
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File Operations
Administrators can double-click to enter subdirectories or enter a path directly in the address bar. Use File → Up to return to the parent directory.Basic file operations include creating folders, renaming, and deleting files. These actions cannot be performed in the root directory if the address bar is empty.

Operations in the remote resource view are the same as in the local resource view.
File Transfer
	Transfer Function
	Transfer Function

	Local to Remote
	Select files on the local machine and choose Transfer → Local to Remote to send them to the target client machine.

	Remote to Local
	Select files on the remote machine and choose Transfer → Remote to Local to copy them to the local machine.

	Stop Transfer
	During transfer, select Transfer → Stop to cancel the operation; the status bar will show transfer failure.


Drag-and-drop between local and remote views is supported, and multiple files can be transferred at once. No other operations can be performed while a transfer is in progress.
Get file list
Click the button [image: image167.png]


 in the remote transfer window, configure the file list settings as needed, and click OK to transfer the remote client’s file list to the local machine.
File List Settings:
	Setting
	Description

	File List Path
	Specify the path on the remote client to retrieve the file list. Default is all drives. You can enter a specific path, e.g., D:\test.

	Include Scope
	Files or paths within this scope will be included. Default is empty (all included). Supports manual input with wildcards, e.g., *.doc, C:\*, D:\test\*.txt.

	Exclude Scope
	Files or paths within this scope will be excluded. Default is empty (none excluded). Supports wildcards, e.g., *.doc, C:\*, D:\test\*.txt.

	Include System Directory Files
	By default, files in the Windows system directory are not retrieved. Check to include them.

	Include Program Directory Files
	By default, files in Program Files are not retrieved. Check to include them.

	Save File
	Specify the location to save the retrieved file list. After retrieval, the results are output to this location.


Display Modes
Both local and remote views support Large Icons, Small Icons, List, and Details display modes. Click the display icon on the toolbar to select the preferred layout.
[image: image168.bmp] Note
To transfer files, neither the local nor the remote view can be set to the root directory; otherwise, file transfer is not allowed.
Chapter 9: Security Monitoring
The security monitoring feature allows administrators to set various security conditions. Clients that fail to meet these conditions can be blocked from the network or denied access through the gateway.
9.1 All Security Conditions
Administrators can predefine security conditions to simplify the creation of security policies. When setting a policy, they can directly select from predefined security condition categories.
Go to Security Monitoring → Security Conditions to open the security condition categories window and configure conditions.
	Operation
	Description

	New
	Select Operation → New from the menu to create a new security condition. Enter a non-empty name and configure the required checks to complete the creation.

	Copy
	Select an existing security condition, right-click and choose Copy, or use Operation → Copy from the menu to duplicate it as a new condition.

	Export
	Select the Security Condition Category node in the left view. The right view displays all conditions. Select one or more conditions and click the[image: image169.png]


 icon on the toolbar to save them. Exported files are in XML format only.

	Import
	Click the Import icon [image: image170.png]


 on the toolbar and select a previously exported XML file to import security conditions successfully.


Available security checks include: antivirus software, software installation, program verification, system services, system patches, and other custom checks.
9.1.1 Security Condition Categories
Differentiate between Windows, Mac, Linux, and domestic Xinchuang systems. Security condition categories can be configured according to system type and specific requirements.
9.1.2 Antivirus Software Check
The antivirus check verifies the installation and status of antivirus software on client machines.
Settings：

	Setting
	Description

	Must Run Antivirus
	Enable this option to activate antivirus checks. Only when selected can Must Run at Least One of the Following Antivirus and Virus Database Up to Date be edited and take effect.

	Must Run at Least One of the Following Antivirus
	When antivirus check is enabled:
- Unchecked: Any installed antivirus satisfies the requirement.
- Checked: At least one antivirus selected from the list must be installed.
- If the list is empty or none are selected, any installed antivirus satisfies the requirement.

	Virus Database Up to Date
	When antivirus check is enabled:
- Unchecked: Virus database version is not verified.
- Checked: The virus database must be updated to the latest version to pass the check.

	Description
	Enter text to display as a warning when a client fails the antivirus check. If Show Check Results is enabled in the security policy, the client will receive the check result along with this description.


Adding Antivirus Software
The antivirus list is empty by default and must be manually populated by the administrator.

1. Click the Add button.

2. Enter the antivirus name manually (cannot be empty; wildcards are supported), or select from the dropdown list of available antivirus software.

3. Optionally, enter remarks.

4. Click OK to complete the addition.
9.1.3 Software Installation Check
The software installation check verifies the installation status of software on client machines.
The settings interface includes two lists:

· Must Install Software (the first list)

· Prohibited Software (the second list)

The specific settings are described as follows:
	Setting
	Description

	Must Install All of the Following Software
	Select this option to require that all software in the “Must Install” list be installed to meet the check requirement. If the list is empty or no software is selected, no check is performed.

	Install Any of the Following Software
	Select this option to require that at least one software in the “Must Install” list be installed to meet the check requirement. If the list is empty or no software is selected, no check is performed.

	Prohibited Software
	All selected software in the “Prohibited” list must not be installed to meet the check requirement. If the list is empty or no software is selected, no check is performed.

	Description
	Enter text to display as a warning when a client fails the software installation check. If Show Check Results is enabled in the security policy, the client will receive the check result along with this description.


Adding Software to Lists
The Must Install and Prohibited software lists are empty by default and must be manually populated by the administrator. Both lists are added in the same way.

Click the Add button in the dialog to add software. There are two methods:
Add from Database
The database list displays software information collected by the server. Select the desired software directly, or use search filters to find and select specific software.
Manual Addition
If the required software is not in the database, it can be added manually. Click the Add button [image: image171.png]


 and enter the software’s check attributes to complete the addition.
The software attribute settings are described as follows:
	Attribute
	Description

	Software Name
	Enter the software name; wildcards are supported. This field cannot be empty.

	Company Name
	Enter the software’s company name; wildcards are supported. This field can be left empty, in which case the company name is not checked.

	Operator
	Select an operator from the dropdown. This is only available if a software version is entered. If the version field is empty, the operator is cleared.

	Version
	Enter the software version. Combined with the operator, it defines the matching condition (e.g., ==3.58.1204 means the software version must equal 3.58.1204).


9.1.4 Program Check
The program check verifies the running status of programs on client machines.
The settings interface contains two lists:

· Must Run Programs (the first list)

· Prohibited Programs (the second list)

The specific settings are described as follows:
	Setting
	Description

	Must Run All of the Following Programs
	Select this option to require that all programs in the “Must Run” list be running to meet the check requirement. If the list is empty or no programs are selected, no check is performed.

	Run Any of the Following Programs
	Select this option to require that at least one program in the “Must Run” list be running to meet the check requirement. If the list is empty or no programs are selected, no check is performed.

	Prohibited Programs
	All selected programs in the “Prohibited” list must not be running to meet the check requirement. If the list is empty or no programs are selected, no check is performed.

	Description
	Enter text to display as a warning when a client fails the program check. If Show Check Results is enabled in the security policy, the client will receive the check result along with this description.


Adding Programs to Lists
The Must Run and Prohibited program lists are empty by default and must be manually populated by the administrator. Both lists are added in the same way.
Click the Add button in the dialog to open the addition window. Enter the program’s check attributes as described below.
The program attribute settings are described as follows:
	Attribute
	Description

	Program Name
	Enter the program name; wildcards are supported. This field cannot be empty.

	Operator
	Select an operator from the dropdown. This option is only available if a program version is entered. If the version field is empty, the operator is cleared.

	Program Version
	Enter the program version. Combined with the operator, it defines the matching condition (e.g., ==3.58.1204 means the program version must equal 3.58.1204).

	Remarks
	Optional notes; these are not used as matching criteria.


9.1.5 System Service Check
The system service check monitors the running status of services on client machines.

The settings interface contains two lists:

· Must Run Services (the first list)

· Prohibited Services (the second list)

The specific settings are described as follows:

	Setting
	Description

	Must Run All of the Following Services
	Select this option to require that all services in the “Must Run” list be running to meet the check requirement. If the list is empty or no services are selected, no check is performed.

	Run Any of the Following Services
	Select this option to require that at least one service in the “Must Run” list be running to meet the check requirement. If the list is empty or no services are selected, no check is performed.

	Prohibited Services
	All selected services in the “Prohibited” list must not be running to meet the check requirement. If the list is empty or no services are selected, no check is performed.

	Description
	Enter text to display as a warning when a client fails the system service check. If Show Check Results is enabled in the security policy, the client will receive the check result along with this description.


Adding Services to Lists
The Must Run and Prohibited service lists are empty by default and must be manually populated by the administrator. Both lists are added in the same way.
Click the Add button to open the addition dialog.

Enter the system service name (cannot be empty; wildcards supported).

Optionally, enter remarks.

Click OK to complete the addition.

[image: image172.bmp] Note
When adding a service, enter the service name, not the display name.
9.1.6 System Patch Check
The system patch check verifies the installation status of system patches on client machines.
The specific settings are described as follows:
	Setting
	Description

	Check the Following System Patches
	All selected patches in the system patch list must be installed to meet the check requirement. If the list is empty or no patches are selected, no check is performed.

	Description
	Enter text to display as a warning when a client fails the system patch check. If Show Check Results is enabled in the security policy, the client will receive the check result along with this description.


Adding System Patches to the List
The system patch list is empty by default and must be manually populated by the administrator.
Click the Add button in the dialog to open the addition window. There are two methods to add patches:
Add from Database
The database displays patch information collected by the server.Select the required patches directly, or use search filters to find and select specific patches.
Manual Addition
If the required patch is not in the database, it can be added manually. Click the Add button [image: image173.png]


 and enter the patch attributes.
The attribute settings are described as follows:
	Attribute Setting
	Description

	Patch ID
	The patch ID must be entered as a positive integer.

	Name
	The patch name, optional.

	Notes
	Additional notes as needed; not used as a matching condition.


9.1.7 Domain User Identity Check
The domain user identity check verifies whether the client machine is logged in with the specified domain user account.
Configuration items are described as follows:
	Setting
	Description

	Enable Domain User Identity Check
	Enables the domain user identity check. Only when selected can the “Required Domain Users” and “Prohibited Domain Users” settings be edited and applied.

	Required Domain Users
	Active only when the identity check is enabled. Cannot be empty. Default is *, meaning any domain user is allowed. Format: DomainName\Username. Wildcards are supported. The client must log in with one of the listed domain users to pass the check.

	Prohibited Domain Users
	Active only when the identity check is enabled. Default is empty. Format: DomainName\Username. Wildcards are supported. The client passes the check only if the logged-in domain user is not listed here.

	Notes
	Enter a message to display when the client fails the identity check. If “Show Detection Results” is enabled in the security policy, the client will see both the failure result and this message.


9.1.8 Other Checks
Other checks verify conditions such as client files, registry entries, and similar system elements.
Detailed Settings Description:
	Setting
	Description

	Check Conditions
	The client passes only if all selected conditions in the list are met. If the list is empty or no conditions are selected, no additional checks are performed.

	Notes
	Enter a message to display when the client fails these checks. If “Show Detection Results” is enabled in the security policy, the client will see both the failure result and this message.


Adding Other Check Conditions
The other check conditions list is empty by default and must be manually populated by the administrator.
Click the Add button to open the dialog. Select the type and operator, then enter the specific file name, registry key, or value. Click OK to complete the addition.
Type Settings Description:
	Setting
	Description

	File
	Checks whether a specific file exists. Enter the full path.

	File Version
	Checks a file along with its version. Enter the full path.

	Registry Key
	Checks whether a specific registry key exists.

	Registry Value
	Checks a registry key and its value for more precise verification.


[image: image174.bmp] Note  
The file path string for a condition can include predefined macros, such as:
"tmp" 
temp folder(c:\windows\temp)
"win" 
windows directory(c:\windows)
"sys"
system directory(c:\windows\system32)
"pf" 
program files(c:\program files)
"sd" 
system drive(c:\)
"cf" 
common files(c:\program files\common files)

9.2 Security Check Settings
Select Security Check → Security Check Settings to configure security check policies. These policies verify specified security items on client machines. Clients that fail the checks can have their network access blocked, ensuring compliance with management rules.
Policy Attributes Description:
	Attribute
	Description

	Check Condition
	When adding a policy, you must first select a security check condition. Each policy can include only one condition. Once selected, the condition will be displayed here. Click the[image: image175.png]


 to view an overview of the condition.
Conditions are system-specific: for example, a Windows security condition in a policy applied to both Windows and Linux clients will only be executed on Windows clients.

	Detection
	Options: Detect or Do Not Detect. Selecting Detect triggers a check based on the selected condition. Selecting Do Not Detect disables security checking and related settings below.

	Client Status
	Options: All, Online Only, Offline Only. All executes the policy regardless of client status. Online Only executes only when clients are online. Offline Only executes only when clients are offline.

	Alarm
	Enable to display an alert on the console when a client fails a security check.

	Alarm Level
	Sets the severity of the alarm: Low, Important, Critical.

	Warning
	Enable to show a warning when detection mode is Detect and the check fails.

	Warning Message
	Configure which warning messages are displayed. Warnings appear in both the tooltip bubble and the security check results window.

	Show Detection Results
	Enable to display the detection results.

	Show Detection Details
	Enable to display detailed detection results. When conditions use wildcards or have multiple matches, multiple details are shown.

	Warning Interval
	Sets the interval (in minutes) for warning pop-ups on clients that fail the check.

	Block Network
	Enable to prevent network access when detection mode is Detect and the client fails the check.

	Exception Addresses
	Specify exception addresses, separated by commas. Blocked clients can still access these addresses.

	Block Access
	This option appears only if AnySecura is connected to an access control device. Enable to block clients from network access when they fail the check.


[image: image176.bmp] Note 
When the alarm function is enabled in a security check policy:
1. If a single policy has multiple failed conditions, only one alarm will be triggered, generating a single alert message.
2. If multiple policies fail, only the policy with the highest alarm level will trigger an alert.
9.3 Security Check Logs
Go to the menu Security Check -> Security Check Logs to view the security check log details for computers.
The log includes the following attributes:
	Attribute
	Description

	Result
	The outcome of the security check: either Pass or Fail.

	Computer
	Name of the computer.

	Computer Group
	Name of the group the computer belongs to.

	Time
	Timestamp of the log entry.

	Content
	Details of the check result. If passed, it shows “All conditions passed.” If failed, it lists the unmet conditions and corresponding actions.


9.4 Security Check Status
Console Security Check Status
Go to Security Check -> Security Check Status to view the security check status of clients.
When a single computer is selected, the information displayed includes:
	Content Attribute
	Content Attribute

	Overview of Status
	Check Time: Last check timestamp.
Result: Combined result of all security check conditions.
Action: Current action applied to the client.

	Detailed Results
	Displays the names, results, and actions for all security check conditions in the policy, including each individual check item. Items that pass are collapsed by default; items that fail are expanded to show detailed results.


When selecting the entire network or a specific group, multiple view modes are available for monitoring.
	Icon
	Description
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	Click to select a security check condition; statistics are displayed based on the selected condition.
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	Collapse all expanded nodes; only first-level nodes under the selected item are shown with the current condition’s results. This is the default view.
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	Expand all collapsed nodes; shows all nodes under the selected item with the current condition’s results. Computer icon colors indicate status: bright = online, gray = offline.
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	Display all computers or all computers within the selected group.
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	Display all computer groups.


Client Security Check Status
When a security check policy has “Warning” enabled, a warning icon will appear in the system tray if the client fails the check, along with a pop-up balloon. Double-clicking the tray icon opens the Security Check Results window.
The Security Check Results window includes: Check Status Summary and Detailed Results.
	Content
	Description

	Check Status Summary
	Check Time: Time when the last result was obtained.

Result: Overall result of all conditions.

Action: Current action taken by the client.

	Detailed Results
	Names, results, and actions of all security check conditions in the policy, including failed check items and warning messages. Passed check items are not displayed.


By default, the client performs a security check every five minutes. If the conditions are already met but the Security Check Results window still shows a failure, it may be because the next scheduled check has not yet occurred. In this case, clicking the “Recheck” button in the Security Check Results window will trigger an immediate check and update the results.
Chapter 10: Sensitive Information
The Sensitive Information feature consists of two main components: Sensitive Content and Document Labeling. Sensitive Content allows detection of files containing specific sensitive information, while Document Labeling enables administrators to assign labels and confidentiality levels to documents. Based on sensitive content, document labels, and confidentiality levels, administrators can monitor and manage files selectively, and enforce Sensitive Information Control policies to track the transmission and storage of documents containing sensitive information.
10.1 Enable/Disable Sensitive Content Inspection Authorization
For sensitive information control policies that rely on content-based detection, administrators must enable Sensitive Content Recognition Authorization on client machines for the policies to function. In the console’s Computers section, select the target computer or group (applying to all computers if a group). Right-click and choose Sensitive Content Recognition Management → Enable Sensitive Content Recognition Authorization to activate it. Selecting Disable Sensitive Content Recognition Authorization will revoke the authorization for the selected machines.

After selecting a computer, check the Sensitive Content Recognition Authorization property in the Basic Information panel on the right. If it shows Unauthorized, the authorization is not enabled; if it shows Sensitive Content Recognition Authorized, the authorization is active.
In the console, under Entire Network → View, if Show Sensitive Information Authorization is checked, any computer displaying the [image: image182.png]


 in the Computers list indicates that Sensitive Content Recognition Authorization is enabled for that machine.
10.2 Sensitive Information Exfiltration Control Policy
Administrators can create sensitive information exfiltration control policies to manage document transfers. Once a policy is in place, any file transfer via USB drives, network drives, email, IM, or browsers will be evaluated against the policy. If the file contains sensitive information as defined by the policy, the transfer will be restricted and the action logged. Files that do not match the sensitive information criteria will be transferred without restriction.
Policy Attributes Explanation
	Attribute
	Description

	Action
	Controls the operation for file transfers that trigger the policy.

Options:

Block: Scans file for sensitive content and blocks the transfer; stops matching subsequent policies.

Allow: Scans file and allows the transfer; stops matching subsequent policies.

Ignore: Scans file but ignores the result; continues matching subsequent policies.

No Action: Does not scan the file; equivalent to not controlling sensitive transfers; stops matching subsequent policies.

	Record Screen
	When checked, records the client screen when the policy is triggered. View logs under Sensitive Info → Sensitive Info Logs, right-click → View Screen Log.

	Add Watermark
	Available with the “Watermark & Traceability” module. Apply a watermark template to files triggered by the policy.

	Encrypt
	Available with the “Encryption” module. Can only be enabled if the policy action is Ignore or Allow. Encrypted files follow the specified document permissions and access settings.

	Expiration Date
	Policies are valid indefinitely by default. Enabling and setting an expiration date will deactivate the policy after the specified time.

	Sensitive Info
	Specifies the sensitive content for the policy.

	Sensitive Content
	Select categories from Classification Management → Sensitive Info Library. Clients will scan files to detect matches.

Note: Sensitive content control requires enabling Sensitive Content Recognition Authorization on the client.

	Document Tag
	Files matching the specified document tag are considered matched by the policy.

	Document Classification
	Files with classification within the specified range are considered matched by the policy.

	Match Any Condition
	By default, all conditions must be satisfied. Check this to trigger the policy if any single condition is met.

	File Name
	Documents can be controlled based on file path or name. By default, this is empty, which means all documents are included. Wildcards are supported. 
Specifies document MD5 values for matching. Format: MD5:[full MD5], e.g., MD5:a6616067d6df8a43e171f0e40e79a301. Multiple MD5 values can be separated by’ ;’ or’ ,’. Case-insensitive. Wildcards and fuzzy matching are not supported.

	Min File Size
	Minimum file size in KB.

	Max File Size
	Maximum file size in KB.

	Backup Copy
	When checked, backup triggered files. View under Logs → Document Operation Logs.

	Application
	Specifies the application used for file transfer. Default is all. Can select individual apps or app categories.

	Copy to Removable Drive
	Controls files copied to removable drives.

	Copy to Network Drive
	Control file sending to network shared path; defaults to controlling all network shared paths, customizable support;

	Include Path
	Network paths to include in scanning and policy control. Format: \\server\temp or \\server\temp\*. Do not end with \.

	Exclude Path
	Network paths excluded from scanning and control. Multiple paths supported.

	IM Transfer
	Controls documents sent via instant messaging tools.

	IM Tools
	Supported tools: QQ, ICQ, MSNMessenger, YAHOO, TM, Lanxin, SKYPE, RTX, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, FeiQiu, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, Enterprise WeChat, Activity Message, KK, IMO, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	IM Chat Messages
	Controls the content of messages in IM tools.

	Supported IM Tools
	Supported tools: QQ, ICQ, MSNMessenger, YAHOO, TM, Lanxin, SKYPE, RTX, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, FeiQiu, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, Enterprise WeChat, Activity Message, KK, IMO, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	Send/Receive
	Sets the message direction to monitor. Default is all, meaning both sent and received messages are checked. Can choose to monitor only sent or only received messages.

	Detection Scope
	Determines the scope of messages to check:

• Single Session: Monitors each conversation for the same account individually.

• Merge All Sessions: Combines all conversations of the same account for detection.

	Record Context
	When checked, records the context of sensitive information, viewable in the AnySecura sensitive information log.

	Max Context Entries
	Maximum number of context entries recorded for sensitive information. Default is 5 for each context type; can be adjusted to a custom value.

	ending Emails
	Controls email content matching sensitive information.

	Sender
	Specify email addresses to monitor. Can select from email classification library or enter manually.

	Recipient
	Specify recipient addresses. Can select from email classification library or enter manually.

	Match Any Recipient
	If checked, the policy applies if at least one recipient matches. If unchecked, all recipients must match to trigger the policy.

	Scan Email Body Only
	If checked, only the email body is scanned; otherwise, both body and attachments are scanned.

	Upload Control
	Controls documents uploaded via browsers, Baidu Netdisk, or Weiyun clients that match sensitive content.

	Websites / Network Addresses
	Specify URLs to monitor browser uploads. Supports wildcard (*), e.g., *baidu.com. Multiple URLs can be separated by commas.


[image: image183.bmp] Note 
1. When the policy action is set to “Do Nothing,” all related settings—Audit, Alarm, Warning, Warning Message, Lock Computer, Record Screen, and Sensitive Information—are disabled and cannot be configured.
2. For Sensitive Information External Transfer policies that specify a file name, the document path cannot be identified when sending via email clients; only the file name is used for matching and control.
3. If both a Sensitive Information External Transfer policy and a Document Watermark policy’s “Add Watermark” action are triggered simultaneously, the Sensitive Information External Transfer policy takes precedence, using its selected watermark template.
4. Policies support scanning inside compressed files. If a file within a compressed archive matches the policy, the policy applies to the entire archive during external transfer.
5. Email sending control only scans emails sent via email clients; webmail content and attachments cannot be scanned. To monitor attachments uploaded via webmail, use the Upload Control feature, but the email body cannot be scanned.
10.3 Sensitive Information Local Control Policy
Administrators can configure a Sensitive Information Local Control Policy to manage local documents. Once the policy is set, any newly created, modified, copied, or received file that matches the sensitive information criteria will have its details recorded and trigger actions such as watermarking or encryption.
Policy Attributes Explanation
	Policy Attribute
	Description

	Add Watermark
	Appears if the "Watermark & Traceability" module is purchased. When selected and a watermark template is specified, files triggered by the policy will be watermarked.

	Encryption
	Appears if the "Transparent Encryption" module is purchased. When selected, unencrypted local files matching sensitive content will be encrypted. Security settings for the encrypted file, including permissions and access rights, can be configured.

	Sensitive Information
	

	Sensitive Content
	Select a predefined sensitive information category (configured in "Classification Management > Sensitive Information Categories") as the criteria. The client will scan files to check if the content matches the defined sensitive information.

	Document Tags
	Files whose tag content matches the specified setting here are considered policy matches.

	Document Security Level
	Files whose security level falls within the specified range are considered policy matches.

	Match Any Condition
	By default, all sensitive information conditions must be met simultaneously to trigger the policy. When enabled, meeting any one condition will be considered a policy match.

	File Type
	Specify the local file types to monitor; supports wildcards.

	Include Scope
	Specify directories and file types to scan. Only files in these locations/types will be scanned. Multiple entries are supported. By default, all supported files on local drives are scanned.

	Exclude Scope
	Specify directories and file types to exclude from scanning. Multiple entries are supported.

	Application
	Specify applications that trigger local control actions. Default is <All>.


Directory settings in the Include and Exclude scopes currently support only local drives; network drives are not supported. The directory must be a valid local path on the client machine and supports the wildcard * and the generic path {sd}. For example: {sd}users\*\Documents. Note that * can only represent a single folder level. {sd} represents the system drive root (e.g., C:\) and must be lowercase. The folder name must follow {sd} directly without a trailing backslash.
[image: image184.bmp] Note 
1. For sensitive content control, compressed files are scanned by default to detect sensitive files contained within.
2. If both the AnySecura Sensitive Information Local Control policy and the Document Watermark policy are triggered simultaneously, the Local Control policy takes priority, applying the watermark template specified in the Local Control policy.
10.4 Document Label Policy
Administrators can classify and label internal documents using the Document Label feature. Labels can then be used for document control. In AnySecura, go to Sensitive Information → Document Label Policy to configure policies that automatically tag local documents.
The attributes of a Document Label Policy include:
	Policy Attribute
	Description

	Action
	Controls the operation applied to documents triggering the policy, options include Set or Do Not Set. 
Set: Applies the specified document labels and classification, then continues matching subsequent policies. 
Do Not Set: Does not apply labels or classification, and stops matching subsequent policies.

	Add Document Label
	Select to add the specified document label.

	Label Content
	Specifies the label content to add. Supports formats <LabelName:LabelValue> or <LabelValue>. Multiple labels can be added, separated by semicolons.

	Setting Method
	Defines how labels are applied: 
Append: Adds the policy-defined labels to the document (default). 
Replace: Replaces existing label values with the same label name. If the label does not exist, it is appended.

	Remove Document Label
	Select to remove specified document labels.

	Label Content
	Specifies the labels to remove, using the same format as adding labels.

	Set Document Classification
	Specifies the document’s classification level.

	Classification Options:
	Options include Specified Classification and Automatic Classification:
Specified Classification: Enables the "Select Classification" option, allowing you to choose a specific classification from a dropdown:
No Change: Default, the document's classification remains unchanged.
Unclassified: The document is set as unclassified.
Available Classifications: Set the document to a chosen classification level, ranked from lowest to highest: Public, Internal, Confidential, Secret, Top Secret.
Automatic Classification: Disables manual selection. The document’s classification is automatically set based on the highest classification level of the matched sensitive information categories. If multiple sensitive categories are matched with different levels, the document adopts the highest level.


	Allow Downgrade
	Default (unchecked): The document’s classification will only be updated if it is lower than the policy-specified level. Documents with equal or higher classification remain unchanged.

Checked: Any document that triggers the policy will have its classification set to the policy-specified level, regardless of its current classification.



	Apply to Local Files
	Apply this policy to local files. The policy cannot be saved if this option is not selected.

	Sensitive Content
	This option appears when AnySecura’s sensitive content recognition is enabled. Documents matching the selected sensitive content categories will have the policy’s document tags applied.

	Document Type
	Specify the document types for the policy. You can set inclusion and exclusion ranges, with exclusion taking priority. By default, the inclusion range covers all file types supported by document tags.

	Application
	Specify the applications that trigger this policy. Default is <All>. Only files handled by the selected applications will be controlled.


[image: image185.bmp] Note 
The document tagging feature currently supports the following file types:
1.Office files（*.doc;*.docx;*.xls;*.xlsx;*.ppt;*.pptx）
2.Wps files（*.wps;*.wpt;*.et;*.ett;*.dps;*.dpt）
3.Pdf files
4. Image files（*.jpg;*.jpeg;*.jpe;*.bmp;*.png）
10.5 Document Classification Permission Policy
By default, clients cannot view or modify document classification. Administrators can grant the necessary permissions via Sensitive Information → Classification Permissions.
	Icon
	Description
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	Modify the classification permissions of the selected computer or user.
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	Delete the classification permissions of the selected computer or user.
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	Export or import policy files, or copy the current policy to other clients.


The classification permission settings include the following:
	General Permission
	Description

	Allow Viewing Document Classification
	Check this option to allow clients to view document classification.
Clients with this permission can:
1. Right-click a document to see its classification in the context menu.
2. Open a Microsoft Office or WPS document and view the classification via the COM add-in on the "Home" tab.

	Allow Setting Document Classification
	Checking this option automatically selects Allow Viewing Document Classification and grants clients the ability to view and set document classification.

	Object Classification
	Clients can set a classification equal to or lower than the specified level; they cannot set a classification higher than the specified level.

	Allow Lowering or Removing Document Classification
	If unchecked (default), clients cannot lower or remove the classification when setting it manually. If checked, clients can manually lower or remove the document classification.

	Allowed Document Types
	By default, all document types are selected. You can specify which document types clients are allowed to set classifications for.


[image: image189.bmp] Note 
Only the following document types currently support viewing classification via the COM add-in:
1.Office files（*.doc;*.docx;*.xls;*.xlsx;*.ppt;*.pptx）
2.Wps files（*.wps;*.wpt;*.et;*.ett;*.dps;*.dpt）

10.6 Sensitive Information Logs
Sensitive information logs record files that match sensitive content in full-disk scan tasks, external transmission control policies, and local storage control policies. By reviewing these logs, administrators can track where these files are stored on users’ drives and how users interact with them, providing audit trails for investigating potential data leaks.
Select Sensitive Information → Sensitive Information Logs to view all file operation logs matching sensitive content, including Type, Encryption, Restriction, Warning, Time, Computer, Computer Group, User, User Group, Information Classification, File Name, Path, File Size, and Description.
	Attribute Name
	Description

	Type
	The operation that triggered the scan, including copying to a removable drive, copying to a network drive, IM file transfer, sending emails, creating, modifying, scanning, or uploading documents.

	Information Classification
	All selected information classifications in the policy matched by the file.

	Document Tag
	The document’s tag information.

	Document Classification
	The document’s classification level.

	File Name
	The name of the file.

	File Path
	The file’s location. For browser uploads, the format is: Source Path → Destination Path; for non-browser uploads, only the file’s path is shown.

	File Size
	The size of the file.

	File Access Time
	The last time the file was accessed.

	File Modification Time
	The last time the file was modified.

	Watermark Added
	Indicates whether a watermark was applied to the file by the policy or task.

	Encrypted
	Indicates whether the file was encrypted by the policy or task.

	Restricted
	Indicates that the policy blocked the file from being transmitted externally.

	Warning
	Console displays a warning after the policy is triggered.

	Description
	Records additional details about the operation, such as the tool used for IM transfer or the email details when transmitted via email.


In addition to common filters such as Time, Time Type, and Range, sensitive information logs can also be queried using the following criteria:
	Query Criteria
	Description

	Operation Type
	By default, all operation types are included. You can select one or more types from the dropdown, e.g., newly created or modified documents.

	Information Classification
	By default, all classifications are included. You can select one or more classifications from the dropdown; logs matching any selected classification will appear in the results.

	Document Tag
	The document’s tag content.

	Document Classification
	The classification range of the file.

	Path
	The file’s location.

	Size
	The file size range.

	Document Name
	The name of the file. You can choose from default types or manually add type names when searching by type.

	Has Backup
	Check to query only logs of files with backups.

	Watermark Added
	Check to query only logs of files with watermarks applied.

	Encrypted
	Check to query only logs of encrypted files.

	Restricted
	Check to query only logs of files blocked from transmission.

	Warning
	Check to query only logs that triggered warnings.


[image: image190.bmp] Note 
When a file containing sensitive content or triggering a policy is inside a compressed archive, a separate log entry is created for each file that matches the sensitive content.
Right-clicking a log entry allows you to Print, Print Preview, Export Log, Export Backup Document, Delete Log, or View Screen History.
In the Sensitive Information External Transmission Control Policy, you can configure a backup copy policy. When a client triggers this policy, a backup document log is recorded. Logs with backup documents are marked with a pin icon “[image: image191.png]


”.
Supported backup types include: copying to a removable drive, copying to a network drive, IM file transfer, sending emails, and uploading files.
Double-clicking a backup document log opens its detailed properties. Next to the document name is a “Copy” button, which allows you to view or save the backup document. Backup documents can also be exported in bulk via the “Export Backup Document” option in the right-click menu, either for selected logs or all records.
[image: image192.bmp] Note 
Since backup copies in sensitive information logs actually exist in document operation or email logs, deleting the corresponding backup files from those logs during data cleanup will also remove the copies from the sensitive information logs, making them unavailable for review.
10.7 Document Tag Logs
Document tag logs record the addition of document tags and classifications, including logs triggered by document tag policies and manual additions by clients.
Select Sensitive Information → Document Tag Logs to view these logs. The recorded attributes include:
	Attribute Name
	Description

	Type
	The type of document tag operation, including creation, modification, or manual setting.

	Time
	The time when the document tag or classification was added.

	Document Tag
	The content of the added document tag.

	Document Classification
	The added document classification.

	File Name
	The name of the file.

	Path
	The location of the file.

	File Size
	The size of the file.

	Document ID
	A unique identifier automatically assigned when a document tag or classification is added.


By default, the system displays all document tag logs. Administrators can also apply various filters for targeted queries.
	Query Criteria
	Description

	Time and Range
	Standard query filters.

	Operation Type
	By default, all types are included. You can select one or more types from the dropdown, including creation, modification, or manual setting.

	Document Tag
	The content of the document tag.

	Document Classification
	The classification range of the file.

	Path
	The file’s location.

	Size
	The file size range.

	Document Name
	The name of the file.

	Document ID
	A unique identifier automatically assigned when a document tag is added. You can use this ID to retrieve all logs related to the document.


10.8 Sensitive Information Scanning Tools
10.8.1 Local Sensitive Content Scanner
Select Sensitive Information → Local Sensitive Content Scanner to scan files on the console’s computer. The tool identifies files containing sensitive content and allows actions such as encrypting, decrypting, or modifying document properties on the identified files.
10.8.2 Remote Sensitive Information Scanning
In the computer tree, select a computer and choose Right-Click → Sensitive Content Management → Remote Sensitive Content Scan to scan files on the selected client. The tool identifies files containing sensitive content and allows remote encryption, decryption, or modification of document properties on these files.
[image: image193.bmp] Note 
Remote scanning can only be performed on online clients.
10.9 Full-Disk Sensitive Information Scan Tasks
Administrators can configure full-disk scan tasks for multiple clients simultaneously. These tasks scan local disks on target clients, identify and log files containing sensitive information, and optionally encrypt the identified files.
Administrators with the permission Function Permissions → Sensitive Information → Configure Full-Disk Sensitive Information Scan Tasks can access the full-disk scan task settings via Sensitive Information → Full-Disk Scan Tasks in the menu.
10.9.1 Set Task
Steps to set up a full-disk sensitive information scan task:
1) Click the Add button [image: image194.jpg]T



 in the top-right corner to open the Create Scan Task dialog.
2) In the General tab, configure the basic settings.
3) Switch to the Advanced tab to configure advanced settings.
4) After finishing the configuration, click OK to create the scan task successfully.
General Settings Explanation：

	Setting Option
	Description

	Task Name
	The name of the current task. The system provides a default name, which can be modified.

	Select Target
	Choose the target computers for the task. Click the button [image: image195.png]


 at the top of the selection window and enter keywords in the dialog to quickly locate and select targets.

	Sensitive Information
	Configure the sensitive information to scan for.

	Sensitive Content
	Check this option and specify the information classification. Files containing the specified sensitive content classification will be considered a match.

	Document Classification
	Check this option and set the classification range. Files within this classification range will be considered a match.

	Match Any Condition
	By default, all selected sensitive information criteria must be met for a file to be considered a match. Checking this option allows a file to be considered a match if it meets any one of the selected criteria.

	Scan Path
	Specify the paths to scan. By default, all local drives are included. You can set local paths, network paths, or mapped drive paths, using commas or semicolons to separate multiple paths.
Example: C:\;D:\ — only scans drives C and D.
You can also use predefined identifiers to scan specific types of drives:

· Local Drives: _local — scans all local drives on the client machine.

· Removable Drives: _portable — scans connected removable devices, including USB drives, secure USB drives, encrypted drives, and external hard drives. (Encrypted workspaces, mobile phones, and optical drives are not supported.)

· Mapped Drives: _map — scans all local mapped drives on the client machine.



	Included Files
	Files within this scope will be scanned. You can select from the predefined file types or click the [image: image196.png]


button to manually enter file paths, supporting wildcards. Examples: *.doc, C:\*, D:\test\*.txt.

	Search Files in Archives
	Check this option to identify documents containing sensitive content within compressed archives.

	Excluded Files
	Files within this scope will not be scanned. You can select from the predefined file types or click the [image: image197.png]


 button to manually enter paths using wildcards. Examples: *.doc, C:\*, D:\test\*.txt.


[image: image198.bmp] Note 
The exclusion scope takes priority over the inclusion scope.
Advanced Settings Explanation：

	Setting Option
	Description

	Task Options
	Configure the specific actions the task will perform.

	Scan Mode
	Select the scanning mode from the dropdown:
Scan All Files — Scans all files on the client, including encrypted and unencrypted files.

Scan Encrypted Files — Scans only encrypted files on the client.

Scan Regular Files — Scans only unencrypted files on the client



	Backup Copies
	Scan documents on the client, back up files that match the specified information classifications, and record them. Logs with a pin icon in the sensitive information logs allow viewing and downloading of the backup documents.

	Encrypt Plaintext to Ciphertext
	Scan documents on the client; any plaintext matching the specified information classifications will be encrypted. The operation is recorded in the Encrypted Document Operation Log as “Encrypted – Sensitive Content Scan Task.” The encrypted file’s attributes are set according to the File Attributes specified below.

	Modify Security Attributes of Encrypted Files
	Scan documents on the client. Encrypted files matching the specified information classifications will have their security attributes modified. The operation is recorded in the Encrypted Document Operation Log as “Modify Document Attributes – Scan Task.”
There are three modes for changing security attributes:
Public – Standard Attribute Change
Only modifies encrypted files whose access permission is set to Public – Standard.

Upgrade Lower-Level Attributes
Compares the file’s current permissions with the new settings. If the current permission is lower than the new permission, it will be updated.
Security Attribute Comparison Rules:
· If in the same security zone, compare security levels.

· If in different zones, the public security zone is considered lower than other zones.

· If in different zones and neither is public, no comparison is made and no change occurs.

Force Attribute Change
Modifies all selected files to the new security attributes, regardless of their original attributes.

The new security attributes are defined under File Attributes below.



	Set Document Classification
	Scan documents on the client. Files matching the specified information classifications will have a document classification added, defaulting to “Unclassified” (no classification).
You can modify this under Set Document Classification below, with options for Specified Classification, Automatic Classification, and whether to allow Downgrading.
Specified Classification
Enable this option to activate the Select Classification dropdown, where you can choose a specific classification. Options include:

· Unclassified — the triggered file is set as unclassified.

· Other classifications, ranked from low to high: Public, Internal, Confidential, Secret, Top Secret..
Automatic Classification
The system sets the document classification based on the classification level associated with the triggered sensitive content.

· If a file matches multiple sensitive content classifications with different levels, the highest classification is applied.

Allow Downgrade (default unchecked)

· If unchecked, only files with an existing classification lower than the task-specified classification will be updated. Files with the same or higher classification remain unchanged.

· If checked, all matched files will be set to the task-specified classification, regardless of their current level.



	Scan Settings
	Configure the scanning task.

	Scan Schedule
	Set the task start time by selecting the appropriate category from the dropdown, which aligns with the categories in Time Type Management.

	Scan Frequency
	Set the scan frequency:
One-time Scan: The task starts immediately after being issued and ends once the scan is complete.

Recurring Scan: Specify dates for regular scans. Tasks unfinished within a cycle will resume at the start of the next cycle.

	Performance Settings
	Configure system performance during the scanning task.

	Scan Speed Priority
	Scanning is faster but may impact system performance. Recommended for non-working hours.

	System Performance Priority
	Scanning is slower to minimize resource usage and maintain system performance. Recommended for working hours.

	Scan Only When Idle
	Scans specified files only when the client is idle. Idle status is shown as “Running (Idle)” on the console.

	File Size
	Only files within the specified size range will be scanned.

	File Security Attributes
	When scanning and encrypting, defines the security attributes of sensitive files after encryption, including permissions and access rights. Encrypted files inherit these settings.


[image: image199.bmp] Note 
1. The “Encrypt” option will not appear if the encryption module is not purchased.
2. A scan task cannot be created if any of the selected computer objects, included files, sensitive content, or document classification fields are empty.
3. When an administrator creates a full-disk sensitive information scan and selects “Encrypt,” the document security attributes are subject to the security zones and levels of the files themselves.
4. Once a full-disk sensitive information scan task is created, its settings cannot be modified. Ensure all configurations are correct before creating the task.
10.9.2 View Task Information
Current Task Information
In the upper section of the full-disk scan interface, you can view the task’s basic information.
	Item
	Description

	Task Name
	The name of the scan task.

	Computer
	The client computer’s name.

	Group
	The group to which the client belongs.

	Status
	The current running status of the client.

	Start Time
	The time the task started.

	End Time
	The time the task ended.

	Task State
	The current state of the task:

1. “Started” when scanning is enabled and the task is running.

2. “Paused” when scanning is disabled.

3. “Starting” / “Pausing” during transitions.

4. “Completed” when the task finishes.

	Progress
	Shows the task completion progress, updated automatically.


Other Task Information
By selecting a client in the lower view under the “Task Information” tab, you can view detailed settings for that client’s scan task, including all configurations set when the encryption task was created.
[image: image200.bmp] Note 
Full-disk sensitive information scan tasks run only once and cannot be repeated.
10.9.3 View Task Logs
In the full-disk sensitive information scan interface, select a client and go to the “Task Logs” tab in the lower view to see the task execution logs for that client. Use the refresh button on the toolbar to update the log.
	Item
	Description

	Time
	The time when the log entry was generated.

	Task Name
	The name of the task being executed.

	Content
	Includes the task’s completion percentage, the directory currently being scanned, and key details such as the number of documents scanned and the number of sensitive items matched.


10.9.4 Enable/Disable Scan Function
Disable
By default, the scan function on a computer is enabled. In the full-disk scan interface, select one or more tasks and click the “Disable” button [image: image201.jpg]


 , or choose “Disable Scan Function” from the right-click menu. The selected tasks will be paused.
Enable
Select one or more paused tasks and click the “Enable” button[image: image202.jpg]


 , or choose “Enable Scan Function” from the right-click menu. The selected tasks will resume execution.
10.9.5 Delete Task
Select one or more tasks and click the “Delete” button[image: image203.jpg]


 , or choose “Delete Computer Task” from the right-click menu. The selected tasks will be removed.
10.9.6 Search Computer Tasks
Click the “Search” button
Click the “Search” button [image: image204.jpg]


 to open the query selection dialog. Choose the specific computer or computer group and click “OK.” The computer list will then display only the computers that match the query criteria for focused viewing.
Mode
Click the “Mode” toggle button[image: image205.jpg]


 to switch between displaying all computers or only those with assigned tasks.
Chapter 11: Visual Perception
The Visual Perception feature uses the computer’s camera to detect abnormal user behaviors, such as unauthorized photos or camera obstruction. When such behavior is detected, the system automatically locks the computer, triggers an alert, and logs the event, helping prevent data leaks.
11.1 Enable/Disable Visual Perception Authorization
By default, Visual Perception authorization is not enabled on the client and must be activated by an administrator. In the console, select the target computer or group (applying to all computers in the group), right-click, and choose “Visual Perception Management → Enable Visual Perception Authorization” to activate it. Selecting “Visual Perception Management → Disable Visual Perception Authorization” will revoke the authorization for the target computer.

After selecting a computer, the “Visual Perception Authorization” property in the Basic Information panel indicates its status:

· Unauthorized — Visual Perception authorization is not enabled.

· Visual Perception Authorized — Visual Perception authorization is enabled.
In the console under Entire Network → Display, if “Show Visual Authorization” is checked, an [image: image206.png]


 next to a computer indicates that Visual Perception authorization is active.
11.2 Visual Perception Settings
Visual Perception settings define permissions for clients with Visual Perception authorization enabled.
	Icon
	Description

	[image: image207.jpg]



	Modify Visual Perception permissions for the selected computer or user.
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	Delete Visual Perception permissions for the selected computer or user.
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	Export or import policy files, or copy the current policy to other clients.


Permissions can be assigned to individual computers and domain users. If a computer or domain user has its own permissions, a small red flag appears at the top right of the icon.
Administrators can configure Visual Perception permissions across the network, computer groups/computers, user groups/users, and policy sets. The priority of permission matching (from highest to lowest) is as follows:
User Policy > User Role Policy > User Group Policy > User Group Role Policy > Computer Policy > Computer Role Policy > Computer Group Policy > Computer Group Role Policy.
Lower-priority policies act as parent group policies for higher-priority ones. For example, for a computer policy, all lower-priority policies—including computer role policies, computer group policies, and computer group role policies—serve as its parent group policies.

Visual Perception permissions can inherit parent group policies.

· Inheritance disabled: Only the object’s own policy applies.

· Inheritance enabled: The object’s policy is combined with parent group policies. If the parent group also has inheritance enabled, the policy continues to propagate upward. If a parent group disables inheritance, only that parent group’s policy is inherited.

After setting permissions, administrators can preview the effective permissions for an object. The preview shows the final combined permissions and indicates the source of each permission.
Visual Perception Settings
	Setting
	Description

	Policy Inheritance
	Use the dropdown to choose Inherit Parent Policy or Do Not Inherit Parent Policy. Default: Inherit Parent Policy + Visual Perception settings disabled. Enabling inheritance combines policies from different objects, while disabling inheritance applies only the object’s own policy.

	Enable Visual Perception Settings
	Check this option to activate the related Visual Perception permissions below.

	Feature Activation Settings
	Configure the settings for enabling Visual Perception functionality.

	Enable Visual Perception Function
	Specifies whether to enable Visual Perception functionality. Default: Not Set.
Not Set: The function follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.

Enable: Activates Visual Perception functionality.

Disable: Deactivates Visual Perception functionality.



	Function Activation for Devices Without a Camera
	This setting must be configured; otherwise, the settings cannot be saved.
Do Not Force Enable: Visual Perception is enabled only if the client has an available camera; otherwise, it remains disabled.

Force Enable for Laptops Only: Visual Perception is forcibly enabled on laptop clients, but not on other types of computers.

Force Enable: Visual Perception is enabled unconditionally, regardless of whether a camera is present.



	Camera Activation Settings
	For clients with Visual Perception enabled, the camera must be activated for the feature to function properly. Camera activation settings include:
User Consent on First Use: The first time Visual Perception activates the camera, a prompt appears requiring the user to click “Agree” to enable it. Once consented, subsequent activations do not prompt the user.

Daily First Use Requires Consent: Each day, the first activation of the camera prompts the user to click “Agree.” After consent, no further prompts appear that day. The prompt appears again on the first activation the next day.

Direct Activation: The camera is enabled automatically without any user prompt.



	Detection Interval
	The time interval for detecting abnormal behavior, in seconds. Default is 1 second. Must be set as a positive integer.

	Activation Condition
	Sets the conditions under which the camera is enabled. This must be configured; otherwise, settings cannot be saved. Options include:
Unconditional Enable: The camera is enabled automatically when the client program starts.

Enable When Using Specified Application: The camera is enabled only when the specified application is launched.

	Application
	This setting is applicable only when the activation condition is “Enable When Using Specified Application.”
Administrators can manually specify applications or select categories from the application classification. Wildcards are supported. If multiple applications are set, activating any one of them will enable the camera.

	Show “Close Sensitive Program Notificatio”
	This setting is effective only when the activation condition is “Enable When Using Specified Application.”
When the specified applications are running, the camera is activated. These applications are considered sensitive programs. You can choose whether to display a menu for quickly closing sensitive programs:

· Show: The client’s system tray right-click menu displays “Close Sensitive Program.” Clicking it opens a window listing all currently running sensitive programs. Selecting “Close Sensitive Program” will automatically terminate all sensitive programs and stop camera usage.

· Do Not Show: The system tray menu does not display “Close Sensitive Program.”


	User Consent Prompt at Startup
	Editable when Enable Visual Perception is set to Enable and Activation Condition is Unconditional Enable. You can choose Default or Custom text. For custom prompts, both the title and content can be specified.

	User Consent Prompt When Launching Application
	Editable when Enable Visual Perception is set to Enable and Activation Condition is Enable When Using Specified Application. You can choose Default or Custom text. For custom prompts, both the title and content can be specified.

	Anti-Photography Detection Settings
	Settings related to preventing unauthorized photos using mobile devices.

	Enable Anti-Photography Detection
	Specifies whether to enable anti-photography detection. Default: Not Set.
Not Set: Follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.

Enable: Activates anti-photography detection.

Disable: Deactivates anti-photography detection.

	Time Threshold
	The duration in seconds that consecutive photography behavior must be detected. Default is 1 second.

	Alarm
	Check this option to trigger an alert when photography is detected within the time threshold.

	Alarm Level
	Three levels are available: Low, Important, Severe.

	Lock Screen
	Check this option to lock the screen when photography behavior is detected.

	Trigger Duration for Lock
	The consecutive duration in seconds of detected photography required to lock the screen. Default is 1 second.

	Anti-Photography Whitelist
	In certain scenarios, users may need to use their phones for scanning. To prevent these actions from being detected as photography, scanning application windows can be added to the anti-photography whitelist. When a whitelisted window is in the foreground, any detected photography behavior is ignored.

Whitelist settings can include the application, window title, and window type.

	Camera Obstruction Detection Settings
	Settings related to preventing unauthorized camera obstruction.

	Enable Camera Obstruction Detection
	Specifies whether to enable camera obstruction detection. Default: Not Set.
Not Set: Follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.

Enable: Activates camera obstruction detection.

Disable: Deactivates camera obstruction detection.



	Time Threshold
	The duration in seconds that consecutive camera obstruction behavior must be detected. Default is 1 second.

	Alarm
	Check this option to trigger an alert when camera obstruction is detected within the time threshold.

	Alarm Level
	Three levels are available: Low, Important, Severe.

	Lock Screen
	Check this option to lock the screen when camera obstruction is detected.

	Trigger Duration for Lock
	The consecutive duration in seconds of detected obstruction required to lock the screen. Default is 1 second.

	External Monitor Detection Settings
	Settings related to preventing the use of external monitors to bypass camera monitoring.

	Enable External Monitor Detection
	Specifies whether to enable detection of external monitors. Default: Not Set.
Not Set: Follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.
Enable: Activates external monitor detection.
Disable: Deactivates external monitor detection.

	Action
	Default: Allow
Allow: External monitors are permitted.

Disable: External monitors are prohibited.

	Alarm
	Check this option to trigger an alert when an external monitor is detected.

	Alarm Level
	Three levels are available: Low, Important, Severe.

	Display Prompt for External Monitor
	Check this option to show a bubble notification on the client when an external monitor is detected.

	Desktop Notification Watermark Settings
	Configurations related to the system desktop watermark notification box.

	Enable Desktop Notification Watermark
	Specifies whether to enable the desktop notification watermark. Default: Not Set.
Not Set: Follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.

Enable: Activates the desktop notification watermark.

Disable: Deactivates the desktop notification watermark.



	Watermark Content
	Set the content of the desktop notification watermark. You can choose the default content or customize it.

When selecting custom content for the first time, all fields provide default values that can be adjusted as needed. Customizable items include:
· Watermark title content

· Watermark title background width

· Watermark title font size

· Watermark title font color

· Watermark body content

· Watermark body background width

· Watermark body font size

· Watermark body font color



	Screen and Capture History Settings
	When the client detects a violation, it saves a record of the current screen and captures an image of the scene in front of the client’s camera at the time of the incident. Relevant settings for these recordings can be configured.

	Record Screen and Capture Images on Abnormal Behavior
	Specifies whether to record the screen and capture images when abnormal or violating behavior is detected. Default: Not Set.
Currently supported behaviors: mobile photography, camera obstruction.
Not Set: Follows the parent group’s inherited setting. If the parent is enabled, it is enabled; if the parent is disabled, it is disabled.

Enable: Activates screen recording and image capture on abnormal behavior. Once enabled, in the Capture Logs, right-clicking an abnormal behavior entry (e.g., “Mobile Photography”) allows viewing the recorded screen and captured images.



Note: Screen recording requires the Screen Monitoring module.
Disable: Deactivates screen recording and image capture on abnormal behavior.

	Record Count
	The number of times the client records the screen and captures images when abnormal behavior is detected. Default is 10 times.

	Record Interval
	The time interval in seconds between consecutive screen and image recordings. Default is 1 second.

	System Unlock Settings
	Configurations for unlocking the client after a Visual Perception-related lock is triggered.

	Unlock Mode
	Specifies the method for unlocking the client. Default: Not Set.
Not Set: Functions the same as Face Unlock; if inheriting a parent group policy, it follows the parent policy.

Face Unlock: On the lock screen, click “Unlock” and position the face in the camera view. Once the face is detected, the system unlocks automatically.

Unlock by Clicking Button: Click the “Unlock” button on the lock screen to unlock automatically.

Automatic Unlock Without Photography/Camera Obstruction: No buttons appear on the lock screen. The system unlocks automatically once no photography or camera obstruction behavior is detected.


When Inherit Parent Group Policy is selected, the object’s own policy is combined with the parent group policy. The resulting effect is detailed as follows:
Visual Perception Sub-Functions
Includes: Enable Visual Perception, Enable Anti-Photography Detection, Enable Camera Obstruction Detection, Enable External Monitor Detection, Enable Desktop Notification Watermark, and Record Screen and Capture Images on Abnormal Behavior.
If the object’s own policy is “Not Set”:
· Follows the parent group policy.

· If the parent policy is Enable, the final effect is Enable, and all specific settings are inherited from the parent.

· If the parent policy is Disable, the final effect is Disable.

· If the parent policy is Not Set, the final effect is Disabled.
If the object’s own policy is “Enable” or “Disable”:
The parent group policy is ignored, and the final effect follows the object’s own policy.
Unlock Mode
1. If the object’s own policy is “Not Set”, it follows the parent group policy. If the parent policy is also “Not Set”, the final effect defaults to Face Unlock.
2. If the object’s own policy is anything other than “Not Set”, the parent group policy is ignored, and the final effect follows the object’s own policy.
[image: image210.bmp] Note 
Object’s own policy refers to the highest-priority policy based on the policy matching hierarchy.
11.3 Capture Logs
Capture logs record activities such as mobile photography and camera obstruction. Administrators can review these logs to detect abnormal user behavior. Access the logs via Visual Perception → Capture Logs. Log details include:
	Attribute
	Description

	Type
	The type of operation, including: Start Capture, Unlock, Camera Obstruction, Mobile Photography, Enter Desktop, View Privacy Policy.

	Status / Level
	The log’s status and severity level. 
Level: Applies to Camera Obstruction and Mobile Photography logs. If Enable Anti-Photography Detection or Enable Camera Obstruction Detection is enabled and an alarm is selected with a severity level, the log level matches the specified alarm level (Low, Important, Severe). If no alarm is selected, the log level is Information. 
Status: For other log types, indicates whether the operation was successful.

	Description
	Detailed explanation of the log entry.


11.4 Client Usage
11.4.1 Camera Consent
When Visual Perception Settings → Feature Activation → Camera Activation is set to require user consent, the consent prompt appears under the conditions specified by the administrator (at startup or when launching a specified application according to the Activation Condition). The screen displays a blue background with white text, including prompts and action buttons.
View Privacy Policy

Clicking View Privacy Policy opens a window showing the product manufacturer’s privacy policy, which can be scrolled and reviewed.
Agree
Clicking Agree indicates acknowledgment of camera activation and acceptance of the privacy policy. Afterwards, position the face in the camera view area; once successfully recognized, the system becomes accessible.
Log Out / Close Relevant Applications
Startup Prompt: Clicking Log Out will log out the current user.
Specified Application Prompt: Clicking Close Relevant Applications will close all applications that trigger the Visual Perception camera activation condition, allowing access to the system afterward.
Request Temporary Access
Clicking Request Temporary Access opens the Verify Operation Code window. The user must report the original code to the administrator. In the console, the administrator uses Tools → Client Tools → Confirmation Code Generator to input the client’s operation code, which decodes the client’s actions and relevant information. The administrator clicks Generate Confirmation Code and provides it to the client. After entering the correct code, the user gains temporary system access.
11.4.2 Unlocking
When the client is locked due to behaviors such as mobile photography or camera obstruction, users can unlock the system according to the administrator-defined unlock mode.
Face Unlock
On the lock screen, position the face in the camera view area. Once recognized, the system grants access to the desktop.
If the face remains centered but unlocking fails, the program may have encountered an error. To continue, the user can click Return → Request Unlock, then provide the original operation code from the Verify Operation Code window to the administrator. After the administrator generates a confirmation code and the user enters it correctly, access to the desktop is granted.
Unlock by Clicking Button
On the lock screen, click Unlock to enter the system desktop.
Automatic Unlock Without Photography / Camera Obstruction
If no abnormal behavior (mobile photography or camera obstruction) is detected, recognition completes successfully, and the system unlocks automatically to the desktop.
Administrator Unlock
If the above methods fail, the administrator can unlock the client via the console. In the computer tree, select the target machine, right-click → Control → Unlock.
Chapter 12: Watermarks
12.1 Watermark Policies
12.1.1 Screen Watermark Policy
Access Watermark → Screen Watermark Policy. Administrators can apply a watermark template to client machines’ screens to display custom watermarks, preventing sensitive information leakage via screenshots or photography.
Screen Watermark Policy Attributes:
	Attribute
	Description

	Watermark Template
	Select a watermark template to define watermark content. Templates are managed under Category Management → Watermark Templates → Screen Watermark Template.

	Display Mode
	Choose Full-Screen Watermark or Application Window Watermark. Full-screen displays the watermark across the entire screen; window watermark applies only to specified program windows.

	Application
	Select programs that trigger the screen watermark when running.

	Authorized Software
	Select licensed software that triggers the watermark when running.

	Website
	Specify websites where the watermark appears in the browser window. This works only when Display Mode is set to Application Window Watermark. Website addresses can be full URLs or include wildcards.

	Window Class Name
	Specify window class names to control full-screen watermark application. This works only when Display Mode is set to Full-Screen Watermark. Multiple class names can be separated by semicolons. Names can be exact or use wildcards. Only foreground windows match the policy; closed or minimized windows do not.
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The Authorized Software option appears only when a valid encryption license is registered.
12.1.2 Print Watermark Policy
Access Watermark → Print Watermark Policy. Administrators can apply watermark templates to printed documents, adding custom images or text to protect document copyrights.
Print Watermark Policy Attributes:
	Attribute
	Description

	Printer Type
	Options include Shared, Network, Local, and Virtual printers. If none are selected, all types are considered selected by default. After saving, all four types will be checked.

	Printer Description
	Specify printer names. You can target a printer on a networked computer, e.g., \\server\* for all printers on \\server, or SomePrinter for a specific printer named SomePrinter.

	Print Job
	Specify print job names, supporting wildcards.

	Watermark Template
	Select a watermark template to define watermark content. Templates are managed under Category Management → Watermark Templates → Print Watermark Template.

	Application
	Specify the application used for printing.

	Authorized Software
	Specify licensed software for printing.
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The Authorized Software option appears only when a valid encryption license is registered.
12.1.3 Document Watermark Policy
Access Watermark → Document Watermark Policy. Administrators can apply watermark templates to documents, ensuring that files carry custom watermarks when shared or saved externally. This provides a deterrent effect for users and enables traceability of potential data leaks.
Document Watermark Policy Attributes:
	Attribute
	Description

	Action
	Options: Add Watermark or Do Not Add Watermark. Default is Add Watermark.

	Watermark Template
	Select a document watermark template to define watermark content. Templates are managed under Category Management → Watermark Templates → Document Watermark Template.

	Backup Copy
	When checked, files triggered by the policy are backed up and can be viewed under Watermark → Document Watermark Logs.

	Minimum Backup File Size
	Specify the minimum file size for backup in KB.

	Maximum Backup File Size
	Specify the maximum file size for backup in KB.

	External Sharing
	Apply watermarks when files are sent through external sharing channels.

	File Name
	Specify file paths or names, supporting wildcards. Default is empty, meaning all files are included.

	Copy to Removable Drive
	Apply or skip watermarks on files copied to removable drives.

	Copy to Network Drive
	Apply watermarks to files copied to network shared paths. By default, all network paths are controlled; custom paths are supported.

	Include Scope
	Specify network paths to include, e.g., \\server\temp or \\server\temp\*. Only files sent to these paths are processed.

	Exclude Scope
	Specify network paths to exclude. Files sent to these paths are not processed.

	IM File Transfer
	Apply watermarks to files sent via IM tools. Requires the Instant Messaging module.

	Chat Tools
	Supported chat platforms include: QQ, ICQ, MSN Messenger, Yahoo, TM, Lanxin, Skype, RTX, LSC, ALI, Fetion, Google Talk, Baidu Hi, 263EM, FeiQ, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, Enterprise WeChat, Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	IM Image Transfer
	Apply watermarks to images sent via IM tools. Requires the Instant Messaging module.

	Chat Tools
	Supported chat platforms include: QQ, ICQ, MSN Messenger, Yahoo, TM, Lanxin, Skype, RTX, LSC, ALI, Fetion, Google Talk, Baidu Hi, 263EM, FeiQ, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, Enterprise WeChat, Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	IM Screenshot
	Apply watermarks to screenshots captured from IM tools. Requires the Instant Messaging module.

	Chat Tools
	Supported chat platforms include: QQ, ICQ, MSN Messenger, Yahoo, TM, Lanxin, Skype, RTX, LSC, ALI, Fetion, Google Talk, Baidu Hi, 263EM, FeiQ, MSNLite, Marketing QQ, Enterprise QQ, Lianwo LINE, Qunying CC, LYNC, Enterprise WeChat, Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	Send Email
	Adds a watermark to attachments in sent emails; requires the Email Control module.

	Sender
	Adds a watermark to email attachments sent by specified senders; can select from the email address library or enter manually. If left blank, applies to all senders.

	Recipient
	Adds a watermark to email attachments received by specified recipients; can select from the email address library or enter manually. If left blank, applies to all recipients.

	Upload Document
	Adds a watermark to files uploaded via browsers, Baidu Netdisk client, or Weiyun client; requires the Web Browsing Control module.

	Website or Network Address
	Specifies browser upload addresses; files uploaded to these addresses will have watermarks applied. Supports wildcards *, e.g., *baidu.com*, and multiple addresses separated by commas.

	Decrypt File
	Adds a watermark to files that are decrypted; requires the Encryption module.

	File Landing Operations
	Adds a watermark to files that are newly created, modified, or renamed locally.

	Document Type
	

	Included Range
	Sets local included paths and file types. Multiple paths can be configured; files within this range will be processed during creation, modification, or renaming.

	Excluded Range
	Sets local excluded paths and file types. Multiple paths can be configured; files within this range will not be processed.


[image: image213.bmp] Note
1. User-level policies do not support local file operations (landing operations) control.
2. Policies by default support penetrating compressed files to identify files within. If a file inside a compressed archive matches the policy, it will be watermarked; other files that do not match the policy remain unaffected.
12.1.4 Circulation Traceability Policy
Select Watermark -> Circulation Traceability Policy. By configuring this policy, administrators can embed invisible traceable information into files when they are sent externally or saved locally, enabling effective file tracking.
The properties of the circulation traceability policy include:
	Policy Attribute
	Description

	Action
	Options: Add traceability information / Do not add traceability information. Default is to add traceability information.

	Traceability Information
	Specify the traceable information to be embedded.

	Backup Copy
	When checked, backups of files triggering the policy are saved and can be viewed under Watermark -> Document Circulation Log.

	Minimum Backup File Size
	Specify the minimum file size in KB.

	Maximum Backup File Size
	Specify the maximum file size in KB.

	External Operation
	Adds traceability information when the file is sent via external channels.

	File Name
	Specify the files that trigger the policy, supporting file paths, names, and wildcards. Default is empty, meaning all files.

	Copy to Removable Drive
	Adds traceability information to files copied to removable drives. Requires the Document Operation Control module.

	Copy to Network Drive
	Adds traceability information to files copied to network shared paths. Requires the Document Operation Control module. Default applies to all network paths but can be customized.

	Include Scope
	Specify network paths to include. Only files transferred to these paths will be processed. Format: \\server\temp or \\server\temp\*. Multiple paths can be set.

	Exclude Scope
	Specify network paths to exclude. Files transferred to these paths will not be processed. Multiple paths can be set.

	IM File Transfer
	Adds traceability information to files sent via IM tools. Requires the Instant Messaging module.

	Chat Tools
	Supported chat tools include QQ, ICQ, MSN Messenger, YAHOO, TM, Lanxin, SKYPE, RTX, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, FeiQiu, MSNLite, Marketing QQ, Enterprise QQ, LINE, Qunying CC, LYNC, WeCom (Enterprise WeChat), Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	IM Image Transfer
	Adds tracking information to images sent via IM tools; requires the Instant Messaging module.

	Chat Tools
	Supported chat tools include QQ, ICQ, MSN Messenger, YAHOO, TM, Lanxin, SKYPE, RTX, LSC, ALI, FETION, Google Talk, Baidu Hi, 263EM, FeiQiu, MSNLite, Marketing QQ, Enterprise QQ, LINE, Qunying CC, LYNC, WeCom (Enterprise WeChat), Activity Message, KK, IMO Class Chat, DingTalk, Feishu, Zalo, WhatsApp, Microsoft Teams.

	Send Email
	Adds tracking information to attachments sent via email; requires the Email Control module.

	Sender
	Specifies the sender whose email attachments will have tracking information added. You can select addresses from the email classification library or enter manually. Leave empty to apply to all senders.

	Recipient
	Specifies the recipient whose received email attachments will have tracking information added. You can select addresses from the email classification library or enter manually. Leave empty to apply to all recipients.

	Match Single Recipient Only
	When checked, the policy applies as long as at least one recipient matches the configured recipients.

	Upload Control
	Adds tracking information to files uploaded via browsers, Baidu Netdisk client, or Weiyun client; requires the Web Browsing Control module.

	Website or Network Address
	Specifies the upload address in the browser. Files uploaded to this address will have tracking information added. Supports wildcards (*), e.g., baidu.com, and multiple addresses separated by commas.

	Decrypt File
	Adds tracking information to files that are decrypted; requires the Encryption module.

	Local Operations
	Adds tracking information to files created, modified, or renamed locally.

	Include Scope
	Sets local paths and file types to include. Multiple paths can be set. Only files in the included scope are processed during creation, modification, or renaming.

	Exclude Scope
	Sets local paths and file types to exclude. Multiple paths can be set. Files in the excluded scope are not processed.


[image: image214.bmp] Note
User-level policies do not support controlling local (on-device) operations.
12.1.5 Document Watermark Permissions
By default, clients cannot manually add or remove document watermarks. Administrators can log in to the console, select Watermark → Document Watermark Permissions, and configure permissions for manual watermark management on the client side.
Add Watermark
Settings are as follows:
	Option
	Description

	Allow Manual Document Watermarking
	A feature toggle. When enabled, the client can right-click a document and see the “Add Document Watermark” option to manually add a watermark.
When manually adding a watermark on the client, users can choose from administrator-defined watermark templates or create and select a local custom watermark template. Custom templates are stored only on the current client machine.

	File Type
	Select the types of documents to which the watermark will be applied.

	Watermark Template
	Choose a watermark template to define the watermark content. Templates can be managed under “Category Management → Watermark Templates → Document Watermark Templates.”

	Allow Custom Watermark
	If checked, users can create and select custom watermark templates locally when manually adding watermarks. If unchecked, users can only choose from predefined templates set by the administrator in the console.

	Backup Files
	If checked, files that trigger the watermark policy will be backed up and can be viewed under “Watermark → Document Watermark Log.”

	Backup Range
	Specify the file size range for backups. Only files within this range will be backed up.


Remove Watermark
The configuration options are as follows:
	Option
	Description

	Allow manual removal of document watermark
	If checked, the client’s right-click menu on a document will show “Document Watermark → Remove Document Watermark”, allowing manual removal of watermarks.

	File Type
	Select the types of documents from which watermarks can be removed.

	File Name
	Specify the included and excluded files for watermark removal.

	Include Files
	Remove watermarks from files that meet the inclusion criteria; supports wildcards.

	Exclude Files
	Do not remove watermarks from files that meet the exclusion criteria; supports wildcards.

	Backup Files
	If checked, files that trigger the policy will be backed up and can be viewed under “Watermark → Document Watermark Log.”

	Backup Range
	Specify the file size range for backup. Only files within this range will be backed up.


[image: image215.bmp] Note
Only explicit watermarks can be removed. Document IDs, implicit universal watermarks, implicit image number watermarks, and tracking information will not be removed.
12.2 Watermark Logs
12.2.1 Document Watermark Logs
Document watermark logs record client operations for adding or removing watermarks on documents. By reviewing these logs, administrators can track user actions such as document sharing or local storage, providing reliable evidence for investigating potential data leaks and enhancing document security.
To view the logs, go to Menu → Watermark → Document Watermark Logs. The logged attributes include:
	Attribute Name
	Description

	Type
	The type of operation that triggered the policy; includes copying to removable drives, copying to network drives, IM file transfer, IM image transfer, IM screenshot, sending emails, uploading, creating, modifying, decrypting, manual watermark addition, manual watermark removal, external removal of watermarks, copying to local drives.

	Watermark ID
	The ID of the applied watermark.

	Document ID
	A unique identifier automatically added when a watermark is applied to a document.

	File Name
	The name of the file.

	File Extension
	The file’s extension.

	File Size
	The size of the file.

	Path
	Source and target paths of the file.

	Watermark Template
	The watermark template used when adding a watermark; empty if a watermark was removed.

	Description
	Detailed information about the operation or failure, such as the IM tool used for sharing or the sender/recipient info for email transmission.


Document watermark logs can be queried using the following criteria:
	Query Criteria
	Description

	ID
	The watermark ID of the document.

	Watermark Template
	The watermark template used when adding the watermark; default is all.

	Operation Type
	The type of operation that triggered the policy; includes: copy to removable drive, copy to network drive, IM file transfer, IM image transfer, IM screenshot, send email, upload, create, modify, decrypt, manual add watermark, manual remove watermark, external remove watermark, copy to local drive, save as.

	Document ID
	A unique document identifier added when the watermark is applied; can be used to query all logs for that document.

	Size
	File size range.

	Source
	

	File
	The type of the source document. When searching by type, you can select from the default types or manually add a type name.

	Path
	The path where the source file is located.

	Target
	

	File
	The type of the target document. When searching by type, you can select from the default list or manually add a type name.

	Path
	The location of the target file.

	Description
	Detailed information about the operation.

	Has Backup File
	By default, this is unchecked. Queries all logs (including those with or without backup files). Check this box to query only logs that have backup files.


12.2.2 Document Tracking Log
The document tracking log records the tracking information added to documents by the client. By reviewing these logs, administrators can identify user actions such as external transfers or local storage of documents. This provides reliable evidence for investigating data leaks and enhances overall document security management.
Select the menu “Watermark -> Document Tracking Log” to view the document tracking logs. The log records include the following information:
	Attribute Name
	Description

	Operation Type
	Type of operation that triggered the policy; includes copy to removable drive, copy to network drive, IM file transfer, IM image transfer, send email, upload, create, modify, decrypt, manual watermark add, manual watermark remove, scan, copy to local drive, Save As.

	Document ID
	Unique identifier of the document.

	Tracking ID
	Identifier for each tracking action.

	File Name
	Name of the file.

	File Extension
	File extension.

	File Size
	Size of the file.

	Path
	Source and destination paths of the file.

	Tracking Information
	Information added to the document during this operation.

	Previous Tracking Info
	Information added to the document in the previous operation.

	Description
	Detailed information about the operation or failure, such as the IM tool used for transfer or the sender/recipient details when sending emails.


The document circulation log can be queried using the following criteria:
	Query Criteria
	Description

	ID
	Circulation log ID of the document

	Circulation Information
	The added circulation information

	Previous Circulation Info
	The circulation information added in the previous operation

	Operation Type
	Type of action that triggered the policy; includes copying to removable drives, copying to network drives, IM file transfer, IM image transfer, sending emails, uploads, creation, modification, decryption, manual watermark addition, manual watermark removal, scanning, copying to local drives, Save As

	Document ID
	Unique identifier assigned to the document when circulation information is added; querying by this ID retrieves all logs of the document

	Size
	File size range

	Source
	

	File
	Type of the source document; when searching by type, you can choose from the default types or manually add a type name.

	Path
	Path of the source file.

	Target
	

	File
	Type of the target document; when searching by type, you can choose from the default types or manually add a type name.

	Path
	Path of the target file.

	Description
	Detailed information about the operation.

	Has Backup File
	By default, unchecked. When checked, only logs with backup files are queried; if unchecked, all logs are queried.


12.3 Watermark Code Query
Select “Watermark -> Watermark Code Query” to retrieve the corresponding computer information based on captured dot matrix watermarks or hidden print markers.
12.3.1 Dot Matrix Watermark
Dot Matrix Meaning
A dot matrix watermark overlays a pattern of dots containing computer information onto printed documents or the computer screen. The dots are arranged in groups of nine (3×3 grid) and repeated across the surface.

Both screen and print watermarks can display dot matrices:

· Screen dot matrix: includes computer name, user name, IP, and date.

· Print dot matrix: includes computer name, user name, IP, date, print job, printer description, page number, and application.

A single dot matrix group is illustrated as follows:
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[image: image217.bmp] Note
1. The first dot matrix pattern is the starting bitmap and does not contain any information.
2. For printed watermarks, each distinct print job generates a unique dot matrix pattern.
3. For screen watermarks, the dot matrix changes according to the computer’s information (computer name, IP, date). If this information remains unchanged (daily cycle) and software window watermarking is enabled, the same dot matrix pattern will appear on all software windows.
Dot Matrix Watermark Code Lookup
Lookup Steps:
1) Locate the starting bitmap pattern in the corresponding watermark. Using this starting pattern as a reference, move three positions to the right and three positions down to obtain a 3×3 dot matrix pattern.
2) Excluding the starting pattern, read each pattern from left to right, top to bottom. Match each pattern against the code table to obtain the corresponding letters or numbers, forming a complete code string.
3) Select the watermark type for this lookup. The supported dot matrix watermark types are print watermark and screen watermark. Enter the obtained code string and click [Search] to retrieve the computer information represented by this dot matrix pattern.
12.3.2 Hidden Print Watermark
Steps to query a hidden print watermark:
1) In Watermark Type, select Hidden Print Watermark.
2) In the printed document, locate the marked point. Enter the corresponding character in Marked Character, and provide the surrounding text in Context. There is no limit on context length—it only needs to include actual text adjacent to the marked character, either before or after.

Example: If the sentence is “This hidden watermark test passed successfully” and the mark is placed under the character W, enter W in Marked Character. For Context, you may enter “Hidden Watermark”, “Hidden Wat”, “Test”, or “Test Passed Successfully”.
3) Click Query to retrieve the corresponding print document information.
12.3.3 Document Watermark
Steps to query a document watermark:
1) In Watermark Type, select Document Watermark.
2) In the file containing the document watermark, enter the watermark ID into Input Code String.
3) Click Query to retrieve the corresponding document watermark information.
[image: image218.bmp] Notes
1. The watermark template must include an ID in its content; only then will the watermark carry an ID.
2. Visible watermarks display the ID directly. For invisible watermarks, the ID must be extracted using the Document Watermark Tool.
12.3.4 Circulation Information
Steps to query circulation information:
1) In Watermark Type, select Circulation Information.
2) Use the Document Watermark Extraction Tool on the file containing circulation information. The extracted data includes the circulation ID. Enter this ID into Input Code String.
3) Click Query to retrieve the corresponding circulation information.
12.4 Document Watermark Extraction
Steps to extract a document watermark:
1) In the console, go to Watermark → Document Watermark Extraction to open the extraction tool interface.
2) Click the “[image: image219.png]


” button and select the file to be processed.
3) When the Circulation Information & Implicit Document Watermark Extraction box displays “File parsing completed, please proceed with extraction”, click Extract.
4) Once extraction is complete, you can view the document ID, implicit document watermark, and circulation information. Use the Copy icon[image: image220.png]


 to copy this information or the Export icon [image: image221.png]


 to save it as a file.
5) If an image file is selected, you can also view the implicit digital watermark and screen watermark under Sample Image & Implicit Watermark Extraction. Use the New Window icon [image: image222.png]


 to display the sample and extracted images in a new window, or the Save Image icon [image: image223.png]


 to export both images as a compressed package.
[image: image224.bmp] Notes
1. Only one document’s watermark information can be extracted at a time.
2. If the selected file is not an image, the Sample Image & Implicit Watermark Extraction section will not be displayed.
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12.5 Document ID Scanning Task
Administrators can configure document ID scanning tasks on multiple clients simultaneously. This enables scanning of local or network paths on the target clients, with the option to assign document IDs to the scanned files.
Administrators with the permission Function Permissions → Watermark → Configure Document ID Scanning Task can access the Watermark → Document ID Scanning Task menu to open the configuration dialog and set up scanning tasks.

Administrators with the permission Function Permissions → Watermark → View Document ID Scanning Tasks and Logs can view task details and related logs.
12.5.1 Configure Task
Steps to configure a Document ID scanning task:
1) Click the Add icon [image: image226.jpg]T



 in the upper-right corner to open the Create Scanning Task dialog.
2) In the General tab, configure the general settings.
3) Switch to the Advanced tab to configure advanced settings.；

4) When all settings are complete, click OK to create the scanning task.
General Settings：

	Setting
	Description

	Task Name
	The name of the current task. Default format: Document ID Scanning Task + Date.

	Target Object
	Select the target computers on which the task will run.

	Scan Path
	Specify the directories to scan. By default, all hard drives are included. Supports local paths, network paths, and mapped drives. Multiple paths can be separated by commas or semicolons.

	Include Files
	Files within this scope will be scanned. You may choose from predefined file types or manually enter patterns using the [image: image227.png]


 button. Wildcards are supported, e.g., *.doc, C:\*, D:\test\*.txt.

	Search Inside Archives
	When checked, documents inside compressed files will also be identified.

	Exclude Files
	Files within this scope will not be scanned. You may choose from predefined file types or manually enter patterns using the [image: image228.png]


 button. Wildcards are supported, e.g., *.doc, C:\*, D:\test\*.txt.


[image: image229.bmp] Note
Exclusion rules take precedence over inclusion rules.
Advanced Settings：

	Setting
	Description

	Task Options
	Configure what the task will perform.

	Scan Files with Document IDs
	Scan only files on the client that already have a document ID, and record them in Watermark → Document Circulation Log.

	Add Document ID
	Scan client files, assign document IDs to files without one, and record them in Watermark → Document Circulation Log.

	Scan Settings
	Configure the scanning parameters.

	Scan Schedule
	Set the time for the task to begin. Select a category from the dropdown menu; the available options correspond to the classifications in Time Type Management.

	Scan Cycle
	Configure how frequently the task will run. Options: 
- One-Time Scan: Runs immediately after deployment and ends once complete. 
- Scheduled Scan: Runs on specified dates; if a scan is not finished within a cycle, it will continue in the next cycle.

	Performance Settings
	Control task performance during scanning.

	Priority: Scan Speed
	Faster scanning speed but with higher impact on system performance. Recommended for non-working hours.

	Priority: System Performance
	Slower scanning speed with lower resource usage. Recommended during working hours.

	Scan Only When Idle
	Files are scanned only when the client is idle. A client is considered idle when the console shows its status as Running (Idle).

	File Size
	Only files within this size range will be scanned.


[image: image230.bmp] Notes 
1. If no target computer is selected or the Include Files field is left empty, the scan task cannot be created.
2. Once a Document ID scanning task is created, its settings cannot be modified. Please confirm all configurations carefully before creation.

12.5.2 Viewing Task Information
Current Task Information
In the upper section of the Document ID Scanning Task interface, you can view the basic details of the current task.
	Field
	Description

	Task Name
	The name of the scanning task.

	Computer
	The name of the client computer.

	Computer Group
	The group to which the client computer belongs.

	User
	The user logged in on the client.

	User Group
	The user group to which the client belongs.

	Computer Status
	The current running status of the client.

	Start Time
	The time when the task started.

	End Time
	The time when the task ended.

	Task Status
	The current status of the task. 
1. If scanning is enabled, the task runs and the status is Started. 
2. If scanning is disabled, the task is paused and the status is Paused. 
3. During transitions, statuses are shown as Starting or Pausing. 
4. When the task finishes, the status changes to Completed.

	File Count
	The number of files scanned and assigned a document ID.

	File Size
	The total size of files scanned and assigned a document ID.

	Progress
	The completion progress of the task, updated automatically.


Additional Task Information
When you select a client, the lower section of the Document ID Scanning Task interface (in the Task Information tab) displays task details for that client. These details include the settings applied when the task was created, such as:

· Scan paths

· Included files

· Excluded files

· Performance settings

· Execution schedule

· Execution cycle

· File size range
[image: image231.bmp] Note 
A Document ID scanning task is executed only once. Once completed, it cannot be rerun.
12.5.3 Viewing Task Logs
In the Document ID Scanning Task interface, select a client. In the lower section, under the Task Logs tab, you can view the logs of tasks executed by that client. Use the Refresh button on the toolbar to update the log view.
	Field
	Description

	Time
	The timestamp when the log entry was generated.

	Task Name
	The name of the task being executed.

	Content
	Includes: 
- Percentage of task completion 
- Directory currently being scanned 
- Key task information (total number of scanned files, number of files assigned document IDs, inclusion conditions, exclusion conditions, etc.).


12.5.4 Enable / Disable Scanning
Disable
By default, the scanning function on a computer is enabled. In the Document ID Scanning Task interface, select one or more tasks and click the Disable icon [image: image232.jpg]


，or right-click and choose Disable Scanning Task. The selected tasks will be paused.
Enable
Select one or more paused tasks and click the Enable icon [image: image233.jpg]


，or right-click and choose Enable Scanning Task. The selected tasks will resume execution.
12.5.5 Delete Task
Select one or more tasks, then click the Delete icon [image: image234.jpg]


 or right-click and choose Delete Scanning Task. The selected tasks will be removed.
12.5.6 Query Computer Tasks
Click the Query icon [image: image235.jpg]


 to open the Select Query Object dialog. Choose a specific computer or computer group, then click OK. The computer list will display only those that match the query criteria, allowing for targeted viewing.
Chapter 13: Asset Management
13.1 Asset Management
The Asset Management feature collects both hardware and software asset information from all client machines. This allows administrators to easily maintain and review the organization’s IT assets, while offering multiple query options for efficient asset statistics and analysis.

From the menu, select Asset Management → Asset Management to open the main window.

The Asset Management window consists of the following sections:

· Title Bar
· Menu Bar
· Toolbar
· Task Navigation Pane
· Data Display Area
· Status Bar
13.1.1 Asset Categories and Attribute Description
Asset Categories
The asset categories include: 
	Category
	Description

	Computer
	Provides a summary description of the client computer, such as logged-in user, domain, and machine name.

	Hardware
	Includes all hardware devices on the client machine, such as CPU, memory, hard drive, motherboard, network card, etc.

	Software
	Includes software on the client machine, such as the operating system, applications, antivirus programs, Windows system software, and Microsoft product patches.

	Custom
	User-defined assets that cannot be automatically detected (e.g., switches, routers, desks, etc.).


Asset Attributes
Each asset may have multiple attributes to describe it. For example:

· Memory may have attributes such as name, slot, capacity, maximum capacity, and type (e.g., DDR, SDRAM).

· Hard drives may have attributes such as name, serial number, and capacity.
Attributes are divided into category attributes and instance attributes:
	Attribute Type
	Description

	Category Attribute
	Statistical attributes of the asset class. For example, for memory, category attributes include total memory, maximum capacity, and number of memory modules.

	Instance Attribute
	Attributes of a specific instance of an asset class. For example, a memory class may have multiple modules, each with instance attributes such as slot, capacity, and type.


Computer assets only have category attributes (since there is always only one computer per client).
Hardware and software assets have both category and instance attributes.
Custom assets only have instance attributes (as they are user-defined).
13.1.2 Asset Category Management
The Asset Category Management feature lists all asset categories along with their respective attributes. Administrators can use this feature to view all attributes of a specific asset type or manually add new asset attributes.

From the menu, select Asset Management → Asset Category Management to open the Asset Category Management window.

· The left pane displays all assets in a tree structure, showing the category hierarchy.

· The right pane displays the attribute list for the selected asset.

· Attributes in black font are category attributes.

· Attributes in blue font are instance attributes.
Attribute Types
There are five types of attributes, each represented by a different icon:。 
	Icon
	Type
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	Text
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	Integer
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	Decimal
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	Date
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	Yes/No


Custom Attributes
In addition to system-defined attributes for each asset, administrators can manually create custom attributes.

Example: To add a new instance attribute for a CPU, such as Warranty Period:

1. In the CPU’s attribute list, select Action → New Attribute to open the Asset Attribute Edit dialog.

2. Choose Attribute Type: Instance Attribute, enter the attribute name Warranty Period, and set the Value Type to Date.

3. Click OK to save.

Custom attributes are marked with an asterisk (*) after the attribute name.

· Custom attributes can be renamed or deleted via Action → Rename or Action → Delete.

· System-defined attributes cannot be renamed or deleted.
Custom Assets
Administrators can also define custom assets to record other enterprise assets for easy viewing and reporting.

Example: If the company has three printers, an administrator can define a custom asset named Printer and add its attribute values.

1. Select Action → New Asset and enter the asset name Printer.

2. Add instance attributes such as Model, Department, Purchase Date, Price, etc.

For custom assets, administrators must manually enter these attribute values. Values can be added under Asset Management → Other Assets.
13.1.3 Hardware Asset Query
Select Asset Management → Hardware Assets to view all hardware assets of client machines, or to query and analyze specific types of assets as needed.
Viewing Asset Information
By default, the system collects summary information for all client machines’ CPU, memory, hard drives, and network cards. To view the hardware assets of a specific computer, select the computer and either right-click → Properties or double-click.
The Asset Information window, by default, displays computer and hardware asset data in a layout similar to File Explorer:

· Left pane: Tree structure showing asset categories.

· Right pane: List view displaying attribute details.

You can also view other asset categories by selecting View → All Category Information or View → Software Category Information.
Within asset instance attributes, there is a default attribute “Summary”, which provides a summary of the specific asset instance and is also used as the name displayed in the asset category tree. Among all category attributes, there is a default attribute “Overview”, which aggregates summaries across all instances.
[image: image241.bmp] Tip
When viewing asset information, you can directly add values to custom asset attributes. Locate the custom attribute, select Action → Properties to open the Asset Attribute Edit dialog, and enter the desired value.
Query Assets
Administrators can set one or more query conditions to filter and view the desired results. Click the Query icon “[image: image242.png]


” in the upper-right corner of the asset result list to open the query condition settings dialog.
	Condition
	Description

	Scope
	By default, all client machines within the entire network are included. Click the … button to select a specific computer group.
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	Click this button to open the condition setup dialog. Each condition consists of an asset attribute, an operator, and a value. Example: Memory - Quantity == 2 or CPU - Name contains "AMD".
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	Remove an existing query condition.
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	View or modify an existing query condition.

	Match Any
	If checked, records that satisfy any of the conditions will be returned. If unchecked, only records that satisfy all conditions will be returned.


[image: image246.bmp] Note  
When setting query conditions, you can query instance attributes from multiple different asset types simultaneously.。
After setting query conditions, you can add attributes to the result list by selecting the asset attributes you want to display.
	Icon/Button
	Description

	=>
	Select an attribute from the asset category tree on the left and double-click or click this button to move it to the result list.

	<=
	Remove an attribute from the result list. Multiple attributes can be removed at once.


[image: image247.bmp] Note  
Similar to query conditions, if an instance attribute from Asset A is already in the result list, you cannot add an instance attribute from Asset B.
After configuring query conditions and the result list, you can save the current settings for future use, set them as default, or delete unnecessary query settings.
	Operation
	Description

	Save
	Enter a name for the query and click Save. Next time, you can select the name from the dropdown menu to recall the saved settings.

	Delete
	Select a saved query and click Delete to remove it.

	Set as Default
	Administrators can modify a query and click Set as Default. The next time the Asset Management window is opened, the default query results will be displayed automatically.


Editing Custom Attribute Values
Using the previously mentioned custom attribute “CPU – Warranty Period” as an example:

1. Set the query condition: CPU – Warranty Period = Not Exists.

2. Configure the result list to include: Computer – Overview, CPU – Summary, CPU – Warranty Period.

3. The query results will show the CPU – Warranty Period* column as empty.

4. Select a row, click on the CPU – Warranty Period* cell, which becomes editable. Enter the attribute value, which will be saved to the database.

5. You can continue adding values for other rows in the same way.
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The result list must include the CPU – Warranty Period column.Since CPU – Warranty Period is a custom instance attribute, the result list must also include at least one other CPU instance attribute. Otherwise, the attribute value cannot be edited.
13.1.4 Hardware Asset Changes
Hardware Asset Changes records all changes to hardware assets on client machines, including additions, deletions, and modifications. To view hardware asset change records, select Asset Changes → Hardware Asset Changes from the menu.
Viewing Asset Change Details
Hardware asset change records include the following information:
	Field Name
	Description

	Change Type
	Type of asset change: Addition, Deletion, or Modification.

	Asset Category
	The category of the asset that changed.

	Description
	A description of the change. Right-click a record and select Properties to view detailed information, including changes to all attributes of the asset.


Querying Hardware Asset Changes
Select File → New Query to open the query panel for hardware assets. Administrators can set various query conditions to filter and view specific change records:
	uery Condition
	Description

	Time and Scope
	General query condition for specifying the time range and target scope.

	Type
	Hardware asset category. Default is All, but a specific asset type can be selected from the dropdown menu.

	Content
	Search by description. Supports fuzzy matching for partial text.


13.1.5 Software Asset Query
Select Asset Management → Software Assets to switch to the software asset query. By default, the system queries computers and their operating systems. Administrators can set additional query conditions to retrieve the desired results.

The software asset query functions similarly to the hardware asset query. Please refer to the Hardware Asset Query section for detailed instructions.
13.1.6 Software Asset Changes
Software Asset Changes records all changes to software on client machines, including additions, deletions, and modifications. To view software asset change records, select Asset Management → Software Asset Changes from the menu.

The content of software asset change records is similar to hardware asset changes. Query conditions include: 
	Query Condition
	Description

	Time and Scope
	General condition to specify the time range and target scope.

	Type
	Software asset category, including: Operating System, Application Software, Antivirus, Windows System Software, and Microsoft Product Patches.

	Content
	Search by description. Supports fuzzy matching for partial text.


13.1.7 Other Assets
After administrators define asset categories and attributes in Asset Category Management, they need to add attribute values in Asset Management → Other Assets.
Adding Custom Assets
Using the previously defined “Printer” as an example:
1、Select File → New Query to open the query condition dialog. Leave the query condition blank.

2、Configure the result list to include: Printer – Model, Printer – Department, Printer – Purchase Date, Printer – Price, which will display all printer attributes.
3、Click the Add icon “[image: image249.png]


”in the upper-right corner of the query result list to enter attribute values for the first printer. Repeat the process to add records for the second and third printers.

4、The printer attribute records are saved for future queries.

Querying Custom Assets
After saving attribute values for custom assets, you can also create query conditions. Select File → New Query and set the conditions, for example: Printer – Price ≥ 1000.Configure the result list to include: Printer – Model, Printer – Department, Printer – Purchase Date, Printer – Price— showing only printers with a price equal to or greater than 1000.
13.2 Software Version Management
If an organization has purchased software with a limited number of installations, Software Version Management helps manage the licensing and installation status of these applications.
13.2.1 Software Category Management
Select Software License Management → Software Category Management to open the Software Category Management window.

· Left pane: Displays all software categories.

· Right pane: Displays the list of software within the selected category.

Software categories collect information about the software itself as well as the operating system. Administrators classify software based on the organization’s purchases, creating one category per software title.

Operations for managing software categories include:
	Operation
	Description

	Create Category
	In the root directory of application categories, select Action → New or Right-click → New to add a new category and enter its name.

	Move Application
	After creating a category, move relevant applications to it. Right-click the application and select Move To the target category, or drag it with the mouse. Multiple applications can be selected simultaneously using Ctrl or Shift.

	Search
	Select File → Find to locate a specific application and its category. The search function can also be used for quick categorization. For example, to move all QQ programs to the QQ category, search for “qq,” then drag all the search results to the QQ category. This greatly simplifies category management for administrators.


13.2.2 Software License Procurement
Select Software License Management → License Procurement to view all software purchased by the organization. You can also filter and query specific software information as needed.
Adding New Software Procurement Information
Whenever the organization purchases a new software title, a corresponding procurement record can be added in License Procurement.
Click the New icon “[image: image250.png]


” in the upper-right corner and fill in the software procurement information. The fields include:
	Field
	Description

	Purchase Date
	Date the software was purchased.

	Software Category
	Select an already defined software category. (Required)

	Name
	Custom description for this purchase. (Required)

	Quantity
	Number of licenses purchased, indicating how many computers the software can be installed on. (Required)

	Expiration Date
	Validity period of the software license.

	Status
	Current status of the software, e.g., Active or Inactive.

	Version
	Software version number.

	Manufacturer
	Software manufacturer.

	Contract Number
	Contract number associated with the purchase.

	Contract Amount
	Amount of the purchase contract.

	Contact Person
	Person responsible for the purchase.

	Contact Information
	Contact details of the responsible person.

	Serial Number
	Software serial number.

	Remarks
	Any additional notes or information.


13.2.3 Software Category Query
Select Software License Management → Software Category Query to view all software installed on client machines. You can also filter and query specific software information as needed.

Using the right-click menu, administrators can set the license status of each software on a client machine, such as Licensed, Unlicensed, Trial, or Free.
For example, if the organization purchased 10 licenses of Office and installed one on a client machine, locate the Office software on that client and mark it as Licensed.
13.2.4 Software Category Statistics
Select Software License Management → Software Category Statistics to generate statistics on the license status of a specific software category within the organization.

For example:

· Count the total number of Office installations across the organization.

· Count the number of Office installations marked as Licensed or Unlicensed.
13.2.5 Software License Statistics
Select Software License Management → Software License Statistics to generate statistics on the license usage of purchased software within the organization.

For example, you can view the total number of Office licenses purchased, the number of licenses already assigned, the number of licenses still available, the number of unlicensed installations, and the number of trial installations.
13.3 Patch Management
The Patch Management feature allows scanning of all client machines to determine their patch installation status. It can also automatically deploy patches to client machines as needed, enhancing system security, reducing download costs, and improving network administrators’ efficiency.
Patch Scanning, Download, and Installation
The patch downloader runs on the server machine, automatically downloading and updating the patch detection file (wsusscan.cab). After the client is first installed, it automatically downloads the patch detection file from the server. Typically, patch detection on the client occurs about 30 minutes after startup.
If there are no special requirements for patch installation and all clients should automatically install patches, administrators can enable one or both of the following options when first starting the console:

· Automatically install for newly discovered clients
· Automatically install newly discovered patches
Note: If these options are set after the client has already completed a patch scan, they will only apply to patches detected in future scans or to newly added clients.
Administrators can view patch installation status on client machines by selecting Asset Management → Patch Management in the console.

If the options above are not configured, administrators must set an automatic installation policy for patches and specify the target client machines. The client machines will then automatically download the patch installation files from the server and install them according to the policy.
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When setting patch installation policies or assigning target computers, you can use CTRL and SHIFT to select multiple patches or machines simultaneously.
Control Functions
Administrators can issue patch scan commands directly from the console. In the list view, the Command button “[image: image252.png]


” and the Scope button “[image: image253.png]


”。 are located at the top-right corner. Clicking the Command button allows selection of actions such as Download Detection File, Refresh Patch Download Status, and Scan Entire Network for Patches.
	Control Function
	Description

	Download Detection File
	Select this to have the server immediately download the latest version of the patch detection file.

	Refresh Patch Download Status
	Select this to have the server immediately download patches that are set with a download policy.

	Scan Entire Network for Patches
	Select this to immediately scan all client machines for patches.

	Scan System Patches
	To scan patches on a single client immediately, right-click the client and select Scan System Patches. Only the selected client will be scanned.

	Select Computer Scope
	Click the Scope button to view patch installation status for a specific computer group or a single client machine.


13.3.1 Patch Mode View
Patch Log Details
Viewing in Patch Mode allows administrators to see a complete list of patches scanned on client machines. Each patch record includes the following attributes:
	Attribute Name
	Description

	Severity
	The severity level of the patch, including: Low, Moderate, Important, Critical, and Unknown.

	Bulletin ID
	Microsoft’s bulletin number for the patch.

	Patch ID
	Unique identifier of the patch.

	Release Date
	The date the patch was released.

	Name
	Name of the patch, usually including the Patch ID.

	Automatic Installation
	Select the patch and right-click to set whether it should be automatically installed.
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 indicates that automatic installation is enabled, while an empty field means it is not set.

	Forced Installation
	Select the patch and right-click to set whether it should be forced to install.
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 indicates that forced installation is enabled, while an empty field means it is not set.

	Download Status
	The download status of the patch: Not Downloaded, Downloading, or Downloaded. Hovering over a patch shows its download progress; 100% indicates completion.
A patch will be downloaded if any of the following conditions are met:

1. The patch has an automatic installation policy set.

2. The patch has a forced installation policy set.

3. The patch is selected for installation on a specified client machine.

	Not Installed Count
	Number of client machines requiring the patch but not yet installed. Selecting the patch in the list shows installed and not-installed machines below.

	Installed Count
	Number of client machines requiring the patch and already installed.

	Total Machines
	Total number of client machines that require the patch, i.e., the sum of installed and not-installed counts.

	Installation Success Rate
	The success rate of patch installation, calculated as Installed Count ÷ Total Machines.

	Details
	Double-click or right-click a patch and select Details to view additional information, including download path, patch size, and description.


Patch Automatic Installation Policy
For newly released patches, you can configure whether they should be automatically installed. This is done in the console under Tools → Options → Server Settings → Patch Options by enabling “Automatically install newly discovered patches by default”.
For patches that were previously not set to auto-install, administrators must manually configure the automatic installation policy. Right-click the patch and choose Auto Install / Do Not Set.

· Auto Install: The patch will be automatically installed on client machines that have an automatic installation policy enabled (in Computer Mode, select the target computer, right-click, and choose Auto Install).

· Do Not Set: The patch will not have an automatic installation policy.
Patch Forced Installation Policy
Right-click the patch and select Force Install / Do Not Set.
If Force Install is selected, the patch will be installed on all client machines, including those that come online after the setting is applied, regardless of existing installation policies.
If Do Not Set is selected, the patch will not have a forced installation policy.
Patch Query
In Patch Mode, click the Query button [image: image256.png]


 at the top-right of the list view to search for specific patches. Query conditions include Severity, Bulletin ID, Patch ID, and Name.
Severity Levels: All, Unknown, Low, Moderate, Important, Critical.

Bulletin ID, Patch ID, Name: Supports wildcards and partial matches.

13.3.2 Viewing by Computer Mode
Computer Log Information
Viewing in Computer Mode allows you to see all client machines and their patch installation status. Computer information includes:
	Attribute
	Description

	Computer
	The group and name of the client machine.

	Network Address
	The IP address of the computer.

	Operating System
	The operating system of the computer.

	Last Scan Time
	The last time the computer’s patches were scanned.

	Auto Install
	Indicates whether patches are set for automatic installation.
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 means enabled; blank means not set.

	Not Installed Count
	Number of patches required but not yet installed on this computer. Selecting the computer displays installed and uninstalled patches in the patch list below.

	Installed Count
	Number of required patches that have already been installed on this computer.

	Total Patches
	Total number of patches required for this computer, i.e., the sum of installed and not installed patches.


Computer Auto-Installation Policy
In Patch Management → Computer Mode, the client machine list and patch installation details are displayed. For newly added client machines, you can set whether patches are automatically installed. This can be configured in the console under Tools → Options → Server Settings → Patch Options → Set New Clients to Auto Install by Default.
If this option was not set previously, the administrator must configure it manually.
Manual Auto-Install Setting: Right-click the computer entry and select Auto Install / Do Not Set. Computers set to Auto Install will automatically install patches that have an auto-install policy (in Patch Mode, right-click a patch and select Auto Install). If Do Not Set is selected, the computer will not have an auto-install policy.
Assigning Patch Installation Policy to Specific Computers
Administrators can also assign installation policies for specific patches on individual computers. In the patch detail list for a selected computer, right-click a patch and choose Install / Do Not Install to apply the policy.
13.3.3 Viewing Patch Installation Policies for Computers
The following three policies can cause a patch to be installed on a computer:
1. Auto-Install Policy (requires both the patch auto-install policy and the computer auto-install policy)
2. Patch Force-Install Policy
3. Computer-Specific Patch Installation Policy
When multiple policies apply simultaneously, the priority is as follows:
Computer-Specific Patch Installation Policy > Patch Force-Install Policy > Auto-Install Policy
In Patch Mode, when a patch is selected, the computer list below, or in Computer Mode, when a computer is selected, the patch list below, the Install column in these views shows the currently active installation policy for that patch on the selected computer.
	Icon
	Active Installation Policy
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	Patch Auto-Install Policy
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	Patch Force-Install Policy
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	Computer-Specific Patch Installation Policy — Install
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	Computer-Specific Patch Installation Policy — Do Not Install

	empty
	No Installation Policy


13.4 Vulnerability Assessment
The Vulnerability Assessment feature automatically scans all computers within the network for vulnerabilities and compiles statistics, enabling network administrators to monitor and evaluate security risks. It also helps take timely actions to remediate vulnerabilities, thereby enhancing overall system security.
Clients with the software installed will automatically scan for vulnerabilities. Administrators can also initiate scans directly from the console. Click the Command button “[image: image262.png]


” to start a vulnerability scan immediately, or click the Scope button “[image: image263.png]


” to select a specific computer group or individual computer to view vulnerability information.
13.4.1 View by Vulnerability Mode
Under Vulnerability Assessment → Vulnerability Mode, you can view the list of vulnerabilities and which computers are affected. The vulnerability list includes the following information: 
	Attribute
	Description

	Severity Level
	The risk level of the vulnerability: Information, Medium, or Critical.

	Name
	A brief summary of the vulnerability.

	Affected Count
	Number of client machines that have this vulnerability.

	Unaffected Count
	Number of client machines not affected by this vulnerability.

	Additional Details
	Right-click a vulnerability and select Details to view a detailed description and recommended remediation steps. Administrators can manually fix vulnerabilities based on these solutions.


13.4.2 View by Computer Mode
In Vulnerability Assessment → Computer Mode, you can view computer information along with detailed vulnerability records.

Computer information includes: computer name, computer group, network address, and operating system.

Vulnerability details include: severity level, name, and whether the vulnerability exists.
Double-click a vulnerability to view its detailed information and recommended remediation steps.
13.5 Software Distribution
Through the AnySecura console, administrators can automatically distribute and install software on client machines, or copy specific files or applications to clients. Using the software distribution feature, administrators can quickly deploy software and business applications across the entire network, significantly reducing their workload.
To create a distribution task, go to Assets Management → Software Distribution. The distribution process involves two steps: creating a distribution package and creating a distribution task. The task will then deploy the prepared package to the specified client machines.
13.5.1 Distribution Package
Administrators must first create a distribution package. The package defines the parameters required for distribution, is stored on the server, and can be reused multiple times.
Click the New button “[image: image264.png]


” to create a distribution package. The information required when creating a package includes: General Information, File Information, Detection Conditions, and Prerequisites.
Set General Information
First, configure the general information, including: 
	Field Name
	Description

	Package Name
	Default is “New Package.” Administrators can modify the name, but it cannot be empty.

	Creation Time / Modification Time
	Automatically generated by the system; cannot be edited. Initially empty when creating a new package. After creation or later editing, the creation time and administrator name are displayed. Modification time updates whenever the package is modified.

	Operating System
	Select the OS versions applicable for this package. Multiple selections are allowed; all are selected by default.

	System Language
	Select the system language applicable for this package. Default is “All.”


Set File Information
Switch to the File Information tab on the left to configure the package’s files, including: 
	Field Name
	Description

	General
	Includes package size, computer name, and original path.

	Package Size
	Size of the package after creation (read-only).

	Computer Name
	Name of the computer where the console is running when creating the package (read-only).

	Original Path
	Original path of the package file (read-only).

	Distribution Mode
	Three options: Install Software, Execute Program, and Distribute File.

	Install Software
	Distribute an application installer to the client and install it.

	Execute Program
	Execute a specified program on the client only once.

	Distribute File
	Distribute specified files to the client.

	Command Line
	Required when Install Software or Execute Program is selected. Typically the core installer or program file name. Can be entered manually or extracted from the file list by right-clicking and selecting Use File Name as Command Line.

	Target Path
	Required when Distribute File is selected. Specifies the path on the client machine. Default: {desktop}\deploy files.

	Run Mode
	Run as current logged-in user uses the client’s logged-in user permissions. If unchecked, the program runs under the system (SYSTEM) account.

	File List
	Displays all files and directories in the package. Columns include File Name, Size, Modified Time, and Version. Use the Add button “[image: image265.png]


”to select files/folders. Multiple files/folders can be added simultaneously but must be under the same parent folder. Each time you click Add, a new file list is created, automatically replacing the previous list.


Set Detection Conditions and Prerequisites
Detection Conditions: These define the criteria for determining whether the software has been successfully installed. The client automatically checks these conditions; if met, the installation is considered successful. If not, the client will continue attempting installation. Detection conditions are mandatory for “Install Software” mode, but not required for other distribution modes.
Prerequisite Conditions: These specify the conditions that must be satisfied for the package to be executed. Before distributing the package, the client checks these conditions: if satisfied, the package is deployed; otherwise, deployment is skipped. Prerequisites are optional.
For different system and software environments, detection and prerequisite conditions can be set in five types:
	Detection Condition
	Description

	File
	Checks whether a specific file exists; requires full file path input.

	File Version
	Checks a file along with its version; requires full file path input.

	Registry Key
	Checks whether a specific registry key exists.

	Registry Value
	Checks a specific registry key and its value for more precise validation.

	Installed Software
	Generally refers to programs listed in “Control Panel → Add/Remove Programs.”


Example of Detection Conditions：
The following are the detection conditions for creating a Microsoft Office 2003 installation package.
	Condition Type
	Logic
	Content

	File
	Exists
	{pf}\Microsoft Office\OFFICE11\EXCEL.EXE

	File Version
	>=
	11.0.5612.0

	Registry Key
	Exists
	SOFTWARE\Microsoft\Office\11.0\Access\InstallRoot

	Registry Value
	Exists
	SOFTWARE\Microsoft\Office\11.0\Access\InstallRoot – Path

	Installed Software
	Contains
	Microsoft Office Professional Edition 2003


[image: image266.bmp] Tip  
The specified file path in a condition can include predefined macros, such as:
"tmp" 
temp folder(c:\windows\temp)
"win" 
windows directory(c:\windows)
"sys"
     system directory(c:\windows\system32)
"sys32"
system directory (32-bit: c:\windows\system32; 64-bit: C:\Windows\Syswow64)
"pf"
     program files(c:\program files)
"pf32"
Program Files (32-bit: c:\program files; 64-bit: C:\Program Files (x86))
"sd"

system drive(c:\)
"cf"

common files(c:\program files\common files)
"cf32"
common Files (32-bit: c:\program files\common files; 64-bit: C:\Program Files (x86)\common files)
Package Deletion and Modification
Deletion removes the package, while editing allows modification of its parameters, conditions, and other settings. A package can only be deleted or edited when its status is “Ready”. A package is considered Ready if no distribution tasks are currently using it.
13.5.2 Distribution Tasks
After creating a distribution package, you need to create a distribution task to assign it to target computers. In the Distribution Task view, click the New button “[image: image267.png]


” in the top-right corner to create a task.
Settings for a distribution task include: 
	Field Name
	Description

	Task Name
	Default name is “New Task”; administrators can modify it. The name cannot be empty.

	Package Name
	Click the “…” button to select the distribution package to use.

	Maximum Retry Attempts
	Specifies how many times the task will retry if distribution fails. Default is 10; can be changed to any other integer. Entering 0 means the task will keep retrying indefinitely until successful, unless manually stopped.

	Status
	Displays the current status of the task. Click the Settings button to configure execution mode and schedule.

	Execution Mode
	Continuous Execution: The task will run repeatedly according to the specified schedule. If “Stop execution after successful distribution” is checked, the task will cease on the client once the distribution succeeds.

Execute Once: The task will run only a single time. Regardless of success or failure, it will not run again after completion.



	Execution Schedule:
	Execute immediately: The distribution task runs as soon as it is created. If the client is offline, it will execute the next time the client starts.

Execute at computer startup: The task runs when the client computer starts. If the client is online, a restart is required for execution.

Execute at a specified time: The task runs at the set time according to the schedule.



	Target Computers:
	Click the “[image: image268.png]


” button to select the client computers that will receive the distribution task.


After configuring the task properties, click OK to start the distribution task immediately. You can monitor the task status in the task list.
The available information includes:
	Field Name
	Description

	Task Name
	The name assigned when the task was created.

	Package Name
	The name of the distribution package selected at creation.

	Task Status
	The current status of the task.

	Successful Count
	Number of target computers where the task was successfully distributed.

	Failed Count
	Number of target computers where the task distribution failed.

	In Progress Count
	Number of target computers where the task is still in progress.

	Other Count
	Number of tasks in other statuses, calculated as total tasks minus the sum of successful, failed, and in-progress counts.

	Planned Install Count
	Number of installations planned for this task, i.e., the number of target computers selected at creation.

	Total Tasks
	Total number of tasks; each selected target computer counts as one task.

	Installation Success Rate
	The success rate of task distribution, calculated as the ratio of successful count to planned install count.


Distribution tasks can also be deleted or edited. During the task distribution process, deletion and editing are not allowed. You must first stop the task (by right-clicking the task and selecting Stop) before performing delete or edit operations.
Copying a Distribution Task
In the distribution task list, right-click the selected task and choose Copy this Distribution Task. A new task creation dialog will appear, allowing you to create a new task based on the selected one. In the new dialog, the Package Name is empty, while all other settings are carried over from the original task.
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If the package used by a task in the distribution list is marked as Package in Use, it cannot be deleted or modified. Only after deleting the distribution task will the corresponding package status return to Ready.
13.6 Software Uninstallation
Through the AnySecura console, administrators can set software uninstallation tasks on client machines, enabling rapid bulk removal of software. The console also allows monitoring of client software installations to prevent reinstallation of specified applications.
Select Asset Management -> Software Uninstallation to create an uninstallation task. Tasks can be created in two modes: Software Mode and Computer Mode.
In both modes, you must configure the task mode and execution schedule. The settings are described as follows:
	Field Name
	Description

	Task Mode
	Select the mode in which the uninstallation task will run.

	Continuous Execution
	Continuously monitors the software; if detected, it will be uninstalled during the specified execution period.

	Execute Once
	The uninstallation task runs only once; after execution, whether successful or not, it will not run again.

	Execution Schedule
	Select the time period when the task should execute.

	Immediate Execution
	If the software is detected as installed, it is uninstalled immediately.

	Execute When Idle
	If the software is detected, uninstallation begins when the client is idle (no keyboard or mouse activity for over 3 minutes) and the console shows the client status as idle.

	Execute at Specified Time
	If the software is detected, uninstallation occurs at the specified time, which refers to a set time each day.


13.6.1 Software Mode Task Setup
In Software Mode, uninstallation tasks are defined around selected software, targeting client machines where the software is installed or may be installed. This allows multiple software applications to be uninstalled across multiple computers simultaneously.
Installed Software List
Under Software Uninstall → Software Mode, you can view a list of all installed software detected across client machines. The list includes the following information:
	Field Name
	Description

	Software Name
	Name of the software.

	Company Name
	Name of the software vendor.

	Installed Count
	Number of client machines where the software is installed.

	Task Count
	Number of client machines that have received the uninstallation task for this software.


Selecting a software allows you to view detailed information about the client machines where it is installed, as well as the client machines executing the uninstallation task.

Both installed computers and computers executing the uninstall task include the following information:
	ield Name
	Description

	Computer
	Name of the client machine.

	Computer Group
	The group to which the client machine belongs.

	User
	The currently logged-in user on the client machine.

	Network Address
	The IP address of the client machine.

	Operating System
	The operating system of the client machine.

	Status
	The runtime status of the client, consistent with the basic client information, including: Running, Offline, Client Uninstalled.

	Software Version
	When installing or uninstalling the selected software, the version number of that software on the client machine.

	Software Status
	Indicates whether the software is In Use or Being Uninstalled. If no uninstall task is set, it shows In Use. If an uninstall task is set, even if it hasn't started due to scheduling, it shows Being Uninstalled.

	Size
	The installation size of the software.

	Installation Time
	The date and time the software was installed on the client.

	Installation Path
	The path where the software is installed on the client.

	Task Mode
	Continuous execution or Single execution. This column appears only in the list of client machines executing uninstall tasks.


Setting Software Uninstall Tasks
Steps to set a task:
1) In the installed software list, select one or more software items, right-click and choose Uninstall; or select a software item, then in the client machine list below, select one or more computers, right-click and choose Uninstall. This opens the software uninstall task dialog.
2) The left panel displays the client machines; select the machines on which the task should be executed.
3) The upper-right panel shows the selected software to be uninstalled.
4) In the task settings, choose the Task Mode and Execution Time.
5) Click OK to finalize the task setup.
13.6.2 Setting Tasks in Computer Mode
In Computer Mode, uninstall tasks are set based on selected client machines, targeting the software installed on them. This allows multiple software items to be uninstalled from a single machine.
Client Machine List
Under Software Uninstall → Computer Mode, you can view client machine information along with detailed software installation and uninstall data.

· By selecting a client machine from the list, you can see all software installed on that machine, including:

· Software Name

· Vendor/Company

· Software Version

· Size

· Installation Path

· You can also view all software uninstall tasks that have been assigned to the selected client machine.
Setting Software Uninstall Tasks
Steps to configure a task:
1) In the client machine list, select a client. In the Installed Software section below, choose one or more software items, right-click, and select Uninstall to open the software uninstall task settings dialog.
2) On the left, the client machine list allows you to select which machines will execute the task.
3) On the upper-right section, the software list displays the selected software.
4) In the task settings, choose the Task Mode and Execution Schedule.
5) Click OK to complete the task configuration.
13.6.3 Software Uninstall Task Management
Viewing Tasks
In Computer Mode, select a client and choose Uninstall Tasks to view the uninstall task information for that machine. The details include:
	Field Name
	Description

	Uninstall Task
	Name of the software to be uninstalled.

	Task Mode
	The task mode selected when configuring the task.

	Last Completion Time
	The last time the task was completed on the client.
-For Execute Once tasks, this time remains fixed after
 the single execution.

- For Continuous tasks, this time updates after each
 execution of the task.



	Task Status
	The current status of the task: Not Started / In Progress / Success / Failure.
- For Continuous tasks, after each execution, the status resets to Not Started, followed by the result of the last run (Success / Failure).


Deleting Tasks
Delete Tasks for a Client
In Computer Mode, select a client, go to the Uninstall Tasks tab, choose one or more software uninstall tasks, right-click and select Delete Task. The selected tasks will be removed.
Delete Tasks for a Software
In Software Mode, select a software, go to the Target Computers for Uninstall Tasks tab, select one or more clients, right-click and choose Cancel Uninstall Task. The selected tasks will be canceled.
[image: image270.bmp] Notes 
1. For tasks set to “Execute Once” that have already been completed, deleting the task removes it from the list.
2. For “Execute Once” tasks that have not yet run (scheduled time not reached), deleting the task removes it from the list, and it will not execute when the scheduled time arrives.
3. For “Continuous Execution” tasks, selecting Delete Task from the right-click menu removes the task from the list, and the task will not execute even if the specified software is installed later.
Uninstall Task Overview
Click the [image: image271.jpg]


 in the Software Uninstall interface to open the Uninstall Task dialog, where you can set query conditions to search for specific uninstall tasks. Query results can be printed or exported via the right-click menu.
	Query Condition
	Description

	Scope
	The range of client machines; a specific group can be selected.

	Uninstall Software Name
	Name of the software to uninstall; supports fuzzy search.

	Uninstall Task Mode
	Mode of the uninstall task: All / Execute Once / Continuous Execution.

	Uninstall Task Status
	Status of the uninstall task: All / Not Started / In Progress / Success / Failed.


Chapter 14: Category Management
To facilitate queries, reporting, and policy configuration, administrators can predefine categories in the system. Category management includes: application categories, website categories, removable storage categories, software installation package categories, software uninstall categories, time type categories, network address categories, network port categories, email categories, watermark template categories, and sensitive information category libraries.
14.1 Application Categories
Select Category Management → Applications to open the application category window. By default, the system defines two categories: System Applications and Uncategorized.
System Applications refers to programs related to the operating system. To prevent critical issues, these system programs are separated into this category. Administrators may also move other programs into this category as needed.
All applications are collected from client machines. If an application does not match any existing category, it is classified as Uncategorized. Administrators can create new categories and move relevant programs from Uncategorized into the new category, but applications cannot be manually added. 
Applications can also be categorized using Application Identification Rules. These rules act like tags: any application that matches a rule is automatically assigned to the category associated with that rule.
Administrators organize applications with similar types into a single category. Available operations for managing categories include:
	Operation
	Description

	Create Category
	In the root directory of application categories, select Action → New or right-click New to add a new category and enter its name. Subcategories can also be added: select an existing category, right-click New, and a subcategory will be created under it.

	Move Applications
	After creating a category, relevant applications need to be moved into it. Locate the applications, right-click Set Application Category or choose Action → Move To to transfer them to the target category, or drag them with the mouse to the desired category. A Set Identification Rule window will appear, allowing you to specify the target category and the type of identification rule. Multiple applications can be selected simultaneously by holding Ctrl or Shift.

	Search
	Click the “[image: image272.bmp]” on the toolbar or select “Action -> Search” to open the search window, which allows you to locate specific applications, their categories, or application recognition rules.
The application library search has two modes: Search by Recognition Rule and Search by Application Record:
1. If the “Application Recognition Rules” column is displayed in the application library, the search box is in Recognition Rule Search mode. Enter your criteria and click search to find the corresponding recognition rules.
2. If the “Application Recognition Rules” column is not displayed, the search box is in Application Record Search mode. Enter your criteria and click search to find the corresponding application records.
The search function can also speed up classification. For example, to move all QQ programs to the QQ category, enter “qq” in the search; all matching programs will appear and can be dragged to the QQ category, greatly simplifying the classification process.

	Export Applications
	Select an application or an application category, then choose “Action -> Export” or right-click and select “Export” to export the selected applications.

	Show Recognition Rules
	Click the Show Recognition Rules icon“[image: image273.bmp]” on the toolbar to toggle the display of the application recognition rules panel. When enabled, the application classification view splits into two sections: recognition rules appear in the upper pane, and applications appear in the lower pane.

	Create a New Recognition Rule:
	Click the New Recognition Rule icon “[image: image274.bmp]” on the toolbar, select Action → New Recognition Rule, or create it directly from an application record. The Set Recognition Rule window opens, allowing you to define a new rule based on Name, File Name, Company Name, Icon, or Application Category. Once the rule is selected, the applications that match it will appear in the application panel.

	Import Recognition Rule Library
	Select Action → Import Recognition Rule Library to import a recognition rule library file. The file must be in .csv format.

	Export Recognition Rule Library
	Select Action → Export Recognition Rule Library to export the recognition rules from the application library to a local file in .csv format.

	Delete Recognition Rule
	Select a rule and choose Right-click → Delete to remove the recognition rule. The associated application records will not be deleted; they will attempt to match other recognition rules. If no match is found, they will automatically revert to the Unclassified category.


[image: image275.bmp] Note
The Unclassified and System Applications categories cannot be deleted and cannot have subcategories created under them.
Creating Identification Rules
The currently supported identification rules are as follows:
	Identification Rule
	Description

	File Name Recognition
	Identifies programs solely by their file name; programs with the same file name are classified together.

	File Name + Company Name Recognition
	Identifies programs by both file name and company name; programs matching both are classified together.

	Class Feature Recognition
	Uses an internal hash value of the program to identify it. This hash, calculated via a custom algorithm, ensures that different versions of the same software from the same company (e.g., Sohu News 1.6.0 and 1.7.3) are recognized as the same class. It also prevents evasion via simple file name changes.

	Specific Program Feature Recognition
	Uses a unique program identifier for recognition. Only the selected program will match; other programs will not.


[image: image276.bmp] Note
The priority for applying identification rules is: Specific Program Feature Recognition > File Name + Company Name Recognition > File Name Recognition > Class Feature Recognition.
There are two ways to create identification rules: manual creation and creation via application records.
Steps for manual creation:
1）Click the Show Identification Rules icon “[image: image277.bmp]” on the toolbar to display the application identification rules pane.
2）Select an application category group, then click the New Identification Rule icon “[image: image278.bmp]” on the toolbar or choose Action → New Identification Rule to open the identification rule settings window.
3）In the settings window, enter the Name and File Name, optionally select Company Name, choose the target category, add any remarks, and click OK.
4）The newly created rule will appear under the selected application category group. Selecting this rule will display all applications that match it in the application pane.
[image: image279.bmp]Note
1. Manual creation can only produce File Name rules or File Name + Company Name rules.
2. Selecting the Company Name option during creation will generate a File Name + Company Name rule.
3. Leaving the Company Name option unchecked will generate a File Name rule.
Steps to Create an Identification Rule via an Application Record:
1）In the Applications panel, select an application record, then either right-click → Set Program Category or drag the record to a group in the left-hand category tree. The Set Identification Rule window will appear.
2）In the window, click the icon [image: image280.png]


 button to select the target application group. If using drag-and-drop, the group defaults to the one where the record was dropped. 
3）Choose the type of identification rule to create: File Name, File Name + Company Name, Feature of This Type of Application, or Feature of This Application.
4）Click OK. The new identification rule will appear under the selected group. Selecting this rule will show all applications in the panel that match it.
[image: image281.bmp] Note
Creating identification rules via application records does not require manually entering names or other details; all information is automatically extracted from the application record.
14.2 Website Classification
Administrators can categorize websites according to enterprise needs, making it easier to monitor and control employee browsing by category.
Click Classification Management → Website to open the website category window. By default, no categories exist, so administrators must manually add website categories and website identifiers. Website identifiers support wildcards.
	Operation
	Description

	Create Category
	In the left website category view, select Action → New → Website Category to create and name a new category. Subcategories can also be created under an existing category.

	Create Website Identifier
	After creating a category, right-click in the right website view and select New → Website Identifier to add a website record. Enter a name and URL. URLs can be full addresses or use wildcards such as * and ? (e.g., *sina*, *game*).

	Import Website Identifiers
	Select a category, right-click in the website view, and choose Import Website Identifiers to batch import multiple website records.

	Search
	Select Action → Search or click the search icon in the toolbar to locate a specific website and determine its category. Fuzzy search is supported.

	Export Website Library
	In the left category view, select Action → Export Website Library or right-click and choose Export Website Library to export the entire library, including all hierarchical structures and identifiers.

	Import Website Library
	In the left category view, select Action → Import Website Library or right-click and choose Import Website Library to import a previously exported library under the Website Category node.


Additionally, in the web browsing logs and statistics, you can right-click a record and select “Add to Website Category” to assign its URL to an existing category.
14.3 Time Type Categories
To facilitate queries and reporting, administrators can predefine time categories. By navigating to Category Management → Time Type, administrators can view existing time categories. The system provides four default types: All Day, Working Hours, Break Time, and Weekend.
Administrators can adjust these categories according to the company’s working schedule. Clicking a time type allows viewing and editing its time range. Beyond the system-defined categories, administrators can create additional time types.
	Operation
	Description

	Add Time Type
	Click the add button “[image: image282.png]


” to create a new category and enter its name. The default time range is All Day and must be manually adjusted.

	Delete Time Type
	Select the time type to remove and click the delete button “[image: image283.png]


”.The four default system time types cannot be deleted.


14.4 Removable Storage Categories
To effectively manage the use of removable storage within the organization, all removable drives must first be categorized in the storage repository. Administrators can group drives by department or individual use and assign different permissions to each category to prevent data leaks.
Removable drives are classified as encrypted or unencrypted (standard). Encrypted drives are secured by our product and can only be used on client machines with the client installed. Machines without the client cannot access these drives. Encrypted drives can only be created via the console.
Removable drives can be registered and managed. By navigating to Category Management → Removable Storage, administrators can open the removable storage window. The system provides two default categories: Registered and Unregistered. All newly acquired drives are placed under Unregistered. Once registered, drives move to the Registered category. Administrators can manually create new categories under Registered, but not under Unregistered.
Methods for acquiring removable storage information:
	Method
	Description

	Client Acquisition
	All drives used on client machines are initially placed under Unclassified. Administrators can move them into custom categories.

	Console Acquisition
	Administrators can insert removable drives directly into the console machine to add their information. Navigate to Operation → Local Removable Storage Info to view inserted drives. Drives marked with “[image: image284.bmp] ” indicate they have not yet been saved in the storage repository.


Local Removable Storage Operations
	Icon
	Description

	[image: image285.png]=Y




	Manually refresh the local removable storage list.

	[image: image286.png]



	Newly inserted drives are initially placed under Unclassified. Click this button to assign the drive to another category.

	
[image: image287.png]



	Safely eject locally inserted encrypted drives..

	[image: image288.jpg]



	Modify the volume serial number of the local removable storage device.

	[image: image289.png]



	Save the removable storage information to the category repository.

	[image: image290.png]



	Click to access related operations for the removable device.

	Set Storage Category
	Newly inserted drives are initially placed under Unclassified. Click this button to assign the drive to another category.

	Format as Unencrypted
	Convert an encrypted drive into an unencrypted (standard) drive.

	Format as Encrypted
	Convert an unencrypted drive into an encrypted drive.

	Initialize Secure USB
	Initialize the secure USB interaction area. You will be prompted to reset the password, and all existing files in the interaction area will be erased.

	Safely Eject
	Safely eject a locally inserted encrypted drive.

	Set Volume Serial Number
	Modify the volume serial number of the local removable storage device.

	View Interaction Logs
	View interaction area logs on the secure USB that have not yet been uploaded.

	[image: image291.jpg]



	Removable Storage Registration and Management Operations

	Register
	Register a removable drive.

	Unregister
	Unregister a previously registered removable drive.

	Cancel Loss Report
	Cancel the loss report for a drive that was marked as missing.

	Modify Registration Info
	Edit the registration information of a removable drive.


Creating an Encrypted Drive
Administrators can create encrypted drives by inserting the drives sequentially into the console machine. To do this, navigate to Category Management → Removable Storage to open the storage repository, then go to Operation → Local Removable Storage Info to view the list of local drives.
Click the “[image: image292.png]


” button to format a standard removable drive into an encrypted drive. During formatting, you can choose the file system for the encrypted drive (FAT32/NTFS). All existing files on the drive will be deleted, and the drive can only be used on machines with the AnySecura client installed. Administrators should confirm before proceeding with the format.
After successful formatting, the icon changes to “[image: image293.bmp]” , indicating the drive is now encrypted but not yet saved. Clicking the Save button updates the icon to “[image: image294.png]


” , confirming it is saved in the repository.
[image: image295.bmp] Note
By default, encrypted drives cannot be used on clients. A removable storage permission policy with Read and Write enabled must be configured on the client for the drive to be accessible.
Formatting an Encrypted Drive to Unencrypted
Administrators can convert an encrypted drive back to a standard (unencrypted) drive using two methods:
Manual formatting on a machine without the client installed
1. An encrypted drive works normally on client machines, but when inserted into a machine without the AnySecura client, it will prompt for formatting. Selecting Yes will manually format the drive to unencrypted, deleting all files.
2. For organizations with strict policies, employees should be warned that manual formatting will permanently remove encryption.
Formatting via the console
Insert the encrypted drive into the console machine, open the removable storage repository, and view Local Removable Storage Info to locate the drive.
Select the encrypted drive and click the “[image: image296.png]


” button to format it as unencrypted. After successful formatting, the drive’s icon reverts to “[image: image297.bmp]” , and its serial number changes, requiring a save.
Encrypted drives cannot be safely ejected via standard Windows plug-and-play. To safely remove, click the Eject button in the interface.
[image: image298.bmp] Notes
1. On client machines, right-click the encrypted drive and select Eject device to safely remove it.
2. Mobile phone storage cannot be formatted as an encrypted drive.
Registration Control
By default, mobile storage registration control is disabled. To enable it:

1. Go to Category Management > Mobile Storage to open the mobile storage window.

2. Select Operation > Registration Control, check Enable, and configure the inclusion/exclusion scope and whether to display warning messages.
Once enabled, only registered mobile storage devices with a "Normal" status can be used on clients within the configured scope. Unregistered, lost, expired, or deactivated devices will be blocked.
During registration, you can enter relevant device details and assign it to a category (default: "Registered").
There are two ways to register a mobile storage device:
Local Registration
Insert the mobile storage device into the console computer.
Open the Mobile Storage Repository and select Operation > Local Mobile Storage Information to view the device details.
Select the mobile storage device, click the "Register" icon “[image: image299.jpg]


”  button to register it, then click the "Save" icon “[image: image300.png]


” button to save.
Remote Registration
Insert the mobile storage device into the remote client computer.
Through the console, open the Mobile Storage Repository and select Operation > Remote Mobile Storage Information.
Select the remote client where the device is inserted to view its details.
Select the mobile storage device, click the "Register" icon “[image: image301.jpg]


” button to register it, then click the "Save" icon “[image: image302.png]


” button to save.
Additional operations for the icon button”[image: image303.jpg]


”：

	Operation Name
	Description

	Deregister
	For registered mobile storage devices that are no longer in use. Deregistered devices will become unavailable on clients and will be automatically moved to the "Unregistered" category.

	Report Loss
	For registered mobile storage devices that have been lost. Reported devices will become unavailable on clients while remaining in their original group.

	Cancel Loss Report
	For lost devices that have been recovered. This operation restores normal functionality to the device on clients.

	Modify Registration
	Allows editing of device information such as device name and serial number that was entered during registration.


Removable Storage Attributes
Removable storage devices include USB drives, external hard drives, memory sticks, smart cards, and other portable devices. The attributes of a removable storage device are as follows:
	Attribute
	Description

	UDiskID
	A unique identifier for each removable device. This ID does not change after formatting.

	Volume Serial Number
	The serial number of the device. It may change after formatting.

	Device Description
	Descriptive information about the device.

	Remarks
	Notes for easy identification, such as user or asset number. Default is empty. Right-click Modify Remarks to add.

	Capacity
	The total storage capacity of the device.

	Partition Format
	The file system format, typically FAT, FAT32, or NTFS.

	Type
	Indicates whether the device is encrypted. Empty means unencrypted.

	Volume Label
	The drive’s volume label.

	First Registration Time
	The first time the device was registered.

	Expiration Time
	The expiration time set during registration.

	Status


	The registration status of the device: 
1. Normal – Registered drive
2. Unregistered – Unregistered via operation
3. Lost – Reported lost
4. Expired – Passed the set validity period
5. Not registered: a mobile storage device that has not been registered before.

	Last Operation Time
	The last time the device was used (inserted or removed).

	Last Used Computer
	The client machine that last used the device.

	Count
	The number of identification entries recognized as this device under the current rules. Right-click Properties to view detailed identification info.

	Device Name
	Name of the removable storage device.

	Device Number
	Identifier number of the device.

	Department
	Department that owns the device.

	User
	Name of the device’s user.

	Position
	Job position of the user.

	Contact
	Contact information of the user.

	Employee ID
	Employee number of the user.

	Last Modified Time
	The last time the device registration information was updated.

	Usage Details
	Double-click a device to view detailed attributes. Click View Usage or right-click a record and select View Usage to check the usage scope of the device.


Identification Rules
Navigate to Category Management → Removable Storage to open the storage repository, then go to Operation → Identification Rules to configure removable storage identification rules. Currently, two methods are supported: UDiskID and Volume Serial Number.

By default, UDiskID is used as the matching rule. If multiple devices share the same UDiskID, those UDiskIDs can be designated as invalid UDiskIDs in the identification rules. Devices with invalid UDiskIDs will then use the Volume Serial Number for identification.

Administrators can specify one or more UDiskIDs as invalid by entering their full values, using “;” or “,” as separators. Alternatively, all UDiskIDs can be set as invalid, forcing all devices to be identified solely by their Volume Serial Number.

Search
The removable storage repository offers multiple search criteria to help administrators quickly locate the required device information. Open the search dialog by selecting File → Search or clicking the Search button “[image: image304.png]


” on the toolbar.
	Search Criteria
	Description

	UDiskID
	Search by UDiskID. Enter a specific UDiskID; partial matches are supported.

	Volume Serial Number
	Search by volume serial number. Must enter the full serial number; partial matches are not supported.

	Category
	Default is All Categories, but specific categories can be selected for the search.

	Description
	Search by device description. Partial matches are supported (e.g., entering “usb” will return devices whose description contains “usb”).

	Volume Label
	If left empty, all labels are included. Enter a label (e.g., “h”) to filter by that label.

	Encryption Type
	Default is All Types. Can filter by encrypted or unencrypted drives.

	Partition Format
	Search by partition format (e.g., enter NTFS to find all drives with NTFS format).

	Remarks
	Search by remarks. Partial matches are supported.

	Capacity
	Set a capacity range to search by the drive’s storage size.

	Last Used Time
	Set a time range to search by the drive’s last usage.

	Registration Validity
	Set a time range to search by the drive’s registration validity period.

	Registration Status
	Default is All Statuses, but specific statuses can be selected.

	Keyword
	Search in registration info and remarks. Supports partial matches.


Administrators can combine multiple search criteria for more precise results. The search results display the category of each removable drive, and administrators can drag and drop drives into the desired category.
Status Statistics
In the removable storage repository, navigate to Operation → Status Statistics to view the registration and usage status of all drives.。
Importing and Exporting the Removable Storage Repository
To export the entire repository, select Operation → Export Removable Storage Repository.

To import a previously exported repository, select Operation → Import Removable Storage Repository.
[image: image305.bmp] Note
1. During export, invalid UDiskID entries and all registered information are included, but unregistered devices are not exported.
2. If the identification rules are set to “Use Volume Serial Number Only”, import and export operations are disabled.
14.5 Network Address Categories
Go to Category Management → Network Address to define network address categories. The system provides the following defaults: All, Enterprise Network, Internet, LAN, and External Network. Since LAN and External Network cannot be modified, they are not displayed in Category Management.
The system automatically generates the Enterprise Network range based on the server’s IP address. Administrators can adjust this range to match the organization’s internal network. The Internet range is generated automatically, covering all IP addresses outside the Enterprise Network range. In addition to the system-defined categories, administrators can manually add new categories by specifying IP address segments.
[image: image306.bmp] Note 
LAN and External Network categories cannot be viewed in Category Management, but they are visible in Network Traffic Statistics, Traffic Control Policies, and Network Control Policies. A LAN refers to the subnet of a specific computer, while an External Network is any network outside that LAN.
14.6 Network Port Categories
Go to Category Management → Network Port to define port categories. The system provides the following defaults: All, ICMP, TCP, UDP, Email, Web, and Network Sharing.

· All, ICMP, TCP, and UDP cannot be modified or extended.

· Email, Web, and Network Sharing allow administrators to add or adjust port ranges.
In addition to these system-defined categories, administrators can manually create new port categories with custom port ranges. System-defined categories cannot be deleted or renamed, while manually created categories can be both deleted and renamed.
14.7 Software Installation Package Rule Repository
Administrators can predefine rules for software installation packages, specifying criteria such as installation package hash or installation package information. Both the rule repository and software installation packages must be manually added by the administrator.
Navigate to Category Management → Software Installation Package to open the rule repository window. By default, the repository is empty, and administrators need to manually create rule categories and rules.
Installation Package Rules
	Operation
	Description

	Create Category
	In the repository view, select Operation → Create Category to add a new rule category. Subcategories can also be created under an existing category.

	Add Rule
	Supported rule identification methods fall into two categories:
1. By hash value
2. By installation package information – including product name/subject, file description/title, company name, digital signature, etc.
When creating a new identification rule, only one method can be selected.
Once a category has been created, right-click the category and select Add Rule. You can choose either Direct Creation or Extract from Installation Package.
Extract from Installation Package:
Select a local installation package (currently supports .exe and .msi formats). A new rule dialog will appear, automatically populated with the package’s extracted details. By default, Product Name/Subject is selected for identification. Additional fields may be checked or adjusted as needed. The selected package will also be uploaded to the installation package repository once the rule is created.
Direct Creation:
Opens a blank rule creation dialog where all fields are empty. Administrators can fill in the required details manually.
Click OK to complete the creation of the new rule.

	Search
	Select Operations → Search or click the search button in the toolbar to locate specific installation package rules. Supports fuzzy search.

	Copy To
	In the list view, select one or more installation package rules. From the right-click menu, choose Copy To to duplicate the selected rules into another group. A single rule can exist in multiple groups simultaneously. Drag-and-drop provides the same effect as Copy To.

	Move To
	In the list view, select one or more installation package rules. From the right-click menu, choose Move To to cut and transfer the selected rules into another group. The original group will no longer contain them.

	Export Rule Library
	Select Operations → Export Rule Library to export all installation package rules (partial export is not supported). The exported file format is CSV.

	Import Rule Library
	Select Operations → Import Rule Library, then choose a previously exported local rule library file. Duplicate entries will not be imported.


Installation Package Information Library
When a rule is added using the “Retrieve from Installation Package” option, the selected package information will appear in the Installation Package Information Library. Administrators may also manually add installation package information.
	Operation
	Description

	Add Installation Package Information
	In the right-hand Installation Package Rules view, select the Installation Package Information Library node and right-click Add Installation Package Information. You can add a single installation package or import all packages from a folder.

Within the Information Library, right-click an installation package and select Create Rule to generate an installation package rule based on that package. This works the same way as the Retrieve from Installation Package method.



	Search
	Select Operations → Search or click the Search button on the toolbar to look up a specific installation package. Fuzzy search is supported.


Additionally, in the policy log, you can select a software installation control record, right-click, and choose Add to Category Library → Software Installation Library to add the corresponding installation package as an installation rule.
14.8 Software Uninstallation Categories
Administrators can categorize software based on business needs, making it easier to manage and control employee uninstallation by category.
By selecting “Category Management -> Software Uninstallation”, they can open the uninstallation category library. The system has no default categories, so administrators must manually create the uninstallation categories and add software to them.
	Operation
	Description

	Create Category
	In the uninstallation category library view, select “Action -> Create Category” to create and name a new software uninstallation category. You can also create a subcategory under an existing category.

	Add New Software Uninstallation Rule
	After creating a category, select it and right-click in the software view on the right, then choose “Add Rule.” A dialog box will appear for adding new settings:
Add Software
There are two ways to add software:
Method 1: Click the Add button [image: image307.png]


 and manually enter the software name, company name, and notes. Wildcards are not supported in the software name, and the entered name must match exactly what appears in Control Panel → Programs and Features.
Method 2: Click the Import button[image: image308.png]


 and select the desired software from the list. The list contains software details collected by the server from client devices.
Method 2 is recommended.
Select Category
In the category view, choose the category to which the software will be added.
When Adding Duplicate Entries
Allow adding to multiple categories: If the software already exists in another category, it can also be added to the new one.

Only add new software, skip existing: Existing software in the library will be ignored; only new entries will be added.

Move software to the new category: If the software already exists in another category, it will be moved from the old category to the new one.



	Search
	Select “Action -> Search” or click the Search button[image: image309.png]


on the toolbar to find specific software. Fuzzy search is supported.

	Properties
	In the right-hand list view, select a software entry and choose “Action -> Properties” or click the Properties button[image: image310.png]


to view its details.

	Copy To
	In the right-hand list view, select one or more software entries and choose “Copy To” from the right-click menu. The selected software will be copied to another group. A single software can exist in multiple groups. Drag-and-drop has the same effect as “Copy To.”

	Move To
	In the right-hand list view, select one or more software entries and choose “Move To” from the right-click menu. The selected software will be moved to another group, and it will no longer exist in the original group.


You can also select a software uninstallation control record in the policy log, right-click, and choose “Add to Category Library -> Software Uninstallation Category Library.” This adds the software package from the record to a specified existing category library.
14.9 Email Categories
Administrators can categorize email accounts based on business needs, making it easier to manage and control them by category.
Select “Category Management -> Email Categories” to open the email category window. The system has no default categories, so administrators must manually create the email category library and define email identifiers. Wildcards are supported in email identifiers.
	Operation
	Description

	Create Category
	In the left-hand email category view, select “Action -> New -> Email Category” to create and name a new email category. You can also create a subcategory under an existing category.

	Create Email Identifier
	After creating a category, right-click in the right-hand view, choose “New -> Email Identifier”, and enter the name, email address, organization, and notes. The email field is required and supports wildcards. You can enter a full email address (e.g., “123@outlook.com”) or use a wildcard for a range of addresses (e.g., “*@gmail.com”).

	Import Email Identifiers
	Select a category, right-click in the right-hand view, and choose “Import Email Identifiers” to add multiple email identifiers at once. 

	Search
	Select “Action -> Search” or click the Search button[image: image311.png]


on the toolbar to locate which category an email belongs to or check if it exists. Fuzzy search is supported.

	Export Email Categories
	In the left-hand email category view, select “Action -> Export Email Categories” or choose the same option from the right-click menu. This exports the entire email category structure, including all levels and email identifiers.；

	Import Email Categories
	In the left-hand email category view, select “Action -> Import Email Categories” or choose the same option from the right-click menu. This imports previously exported email categories under the “Email Categories” node.


14.10 Sensitive Information Classification Library
To help administrators manage internal documents, they first need to define text-based rules in the Sensitive Information Classification Library. The system uses these rules to automatically match internal documents and classify them. Combined with permissions set by the administrator for different document categories, the system can control and log the sharing and usage of documents based on their classification.
When setting text-based rules, administrators need to configure two types of categories: Feature Rules and Information Categories. Feature Rules define specific document-matching criteria, while Information Categories group different Feature Rules together to identify and classify documents.
Select “Category Management -> Sensitive Information Classification Library” to open the library window.
	Operation
	Description

	New
	Select the root node of Information Categories / Feature Rules, then choose “Action -> New” or click the New button on the toolbar to create a new Information Category or Feature Rule.

	Search
	Select “Action -> Search” or click the Search button[image: image312.png]


 on the toolbar to locate specific Feature Rules or Information Categories. Fuzzy search is supported.

	Show Hidden Feature Rules
	Feature Rules imported from the Keyword Extraction Tool are hidden by default. Select “Action -> Show Hidden Feature Rules” to view them.

	Import
	Select “Action -> Import” and choose a classification library file to import previously exported Information Categories or Feature Rules.

	Export
	Select “Action -> Export” to export specific Information Categories or Feature Rules. Export options include:
Export All: Exports the entire Information Classification and Feature Rules library.

Export Information Categories: Exports specified Information Categories along with the Feature Rules applied to them. Feature Rules not linked to these categories will not be exported.

Export Feature Rules: Exports only the specified Feature Rules.


Information Category Settings
	Operation
	Description

	Information Category Name
	Administrators can define a custom name for the information category. Names must be unique.

	Category Level
	This defines the classification level of the information category, corresponding to the sensitivity level used by the Document Label feature. This option appears only if the Document Label module is installed.

By default, the level is unset, meaning no document label is applied. Administrators can select an appropriate level as needed, allowing management policies to link sensitive information categories with document label levels.

In the left-hand view of the Sensitive Information Classification Library, you can switch between Category View and Level View. In Level View, right-click an information category and select “Set Category Level” to modify its level.

	Notes
	Optional notes or description for the information category.

	Rule Group
	Feature Rules included in the information category; multiple rules can be selected.

	Rule Weight
	Default weight is 100. Administrators can adjust it to any integer between 0–100. A document matches the information category only when the sum of matched Feature Rule weights reaches or exceeds 100.


Feature Rule Settings
	Operation
	Description

	Feature Rule Name
	Administrators can define a custom name for the feature rule. Names cannot start with “@” and must be unique.

	Type
	Specifies the type of content the feature rule will identify, including File Name, File Type, File Size, File Content, and File Properties:
File Name: Supports keyword or regular expression patterns. Uses the Include Content field (excluding Exclude Content values) to match the target file’s name or storage path.

File Type: Uses the Include Content field (excluding Exclude Content values) to perform a fuzzy match on the file header content.

File Size: Specifies the file size in the Include Content field to match target files of that size.

File Content: Supports keyword or regular expression patterns. Uses the Include Content field (excluding Exclude Content values) to match text within the document.

File Properties: Applicable only to Office documents. Set the property name, data type, and property value to match document attributes such as creation time, modification time, author, etc.



	Content Scope
	For certain supported file types, you can refine the part of the file to be scanned. The default is Entire Content, but you can also choose Header/Footer Only or Body Only.
Currently, header/footer and body-level scanning is supported for the following file types: doc, docx, xls, xlsx, ppt, pptx, wps, et, dps.
If a rule is set to scan only the header/footer or only the body, files of unsupported types will be considered non-matching.

	Deduplication
	When enabled, if the same text appears multiple times in a document during matching with this feature rule, it is counted only once.
If disabled, each occurrence is counted separately.

	Case Sensitivity
	When enabled, matching English text in the Include Content field is case-sensitive.

	Hit Count
	Specifies the minimum total number of occurrences of the text in Include Content required for a document to match this feature rule. Valid values are integers from 1 to 10,000. A document matches the rule only if the total occurrences meet or exceed this value.

	Content Classification
	Specifies the type of information in Include Content and Exclude Content. Options include Keyword and Regular Expression:
Keyword: Matches text literally as entered in Include Content or Exclude Content.

Regular Expression: Matches text in Include Content or Exclude Content using regular expressions.

	Include Content
	Defines the content used to match documents. Multiple entries are supported, separated by commas or line breaks.

· Supports plain text or regular expressions.

· For keywords, entries can be separated by commas or semicolons.

· For regular expressions, entries must be separated by semicolons.

The format varies depending on the selected content recognition type.



	File Name
	Content set here is used to match the target document’s file name and storage path.
Keyword:
Supports wildcards.

Use \ as the path separator.

If the content does not include \, only the file name is matched, not the path.

If the content includes \, both the file name and path are matched.

Regular Expression：
Use \\ as the path separator.

If the content does not include \\, only the file name is matched.

If the content includes \\, both the file name and path are matched.


Example:
For a document located at D:\Company Confidential\Contract Documents\1025415\Sales Contract 2019.docx, only the following Include Content settings will match:

1. Contract Documents → No match

2. Company Confidential\ → Match

3. Sales Contract → Match

4. \d{7} → No match

5. \\\d{7}
6. \d{4} → Match



	File Type
	Content set here is used to match the target document’s file type.

If the predefined file types in the current feature rule library do not meet your needs, you can specify a custom file type using the following format:

Offset | File Header Signature, For example: 10|87828101

Both the offset and file header signature are expressed in hexadecimal.
A positive offset indicates the position from the start of the file, while a negative offset indicates the position from the end of the file.
If the offset is 0, it can be omitted, and only the file header signature needs to be set (e.g., FFD8FF).

How to obtain offset and file header:
Install and open UltraEdit.exe.Drag the target file into the software.From the menu, select Edit -> Hex Functions -> Hex Edit.
In general, it is recommended to open multiple files of the same type, compare their hex content, and select the portion that consistently appears as the file header signature, along with its corresponding offset, to improve file type matching accuracy. 

	File Content
	Content set here is used to match the target document’s text. Support for Keyword and Regular Expression is the same as for File Name.

	Exclude Content
	Specifies content that should be ignored during matching. The rules follow the same format as Include Content, and Exclude Content takes priority over Include Content.


The feature rule library already includes predefined rules for commonly used file types based on File Type. These predefined rules are displayed in blue and cannot be deleted or modified.
The predefined library includes the following file types:

Adobe Illustrator files, Altium Protel files, AutoCAD files, AnySecura encrypted files, Office files, PDF files, Photoshop files, Pro/ENGINEER files, SOLIDWORKS files, Visual Studio files, video files, image files, compressed files, and audio files.
Some types have hidden subtypes by default. To view them, select “Action -> Show Hidden Feature Rules.”
When setting up an information category, users can either use existing predefined feature rules or right-click a feature rule and select “New Feature Identification” to create custom feature rules.
14.11 Watermark Templates
Select “Category Management -> Watermark Templates” to allow administrators to predefine watermark templates. In the watermark template window, you can add Print Watermark Templates, Screen Watermark Templates, and Document Watermark Templates.
Function / Button Description
	Function / Button
	Description
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	Adds a template based on the selected node: if Print Watermark Templates is selected, a print watermark template is added; if Screen Watermark Templates is selected, a screen watermark template is added; if Document Watermark Templates is selected, a document watermark template is added.
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	Modifies the selected watermark template.
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	Deletes the selected watermark template.
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	Finds watermark templates containing specified text in their names.

	Export
	Select “Action -> Export” or right-click Export to export the entire watermark template library, including print, screen, and document watermark templates.

	Import
	Select “Action -> Import” or right-click Import to import a previously exported watermark template file. Templates with duplicate names will not be imported.


14.11.1 Creating Watermark Templates
Watermark templates can be created in two ways: Create Blank Template or Copy from Existing Template.
Create Blank Template
Example: Creating a Print Watermark Template：
1) Select the Print Watermark Templates root node, click the Add button[image: image317.png]T



，choose Create Blank Template, and click OK.
2) Configure watermark objects, which include:1. Dot matrix，2. Specified position，3. Tiled，4. Marker points；
3) Select the Dot Matrix node and configure the dot matrix parameters in the right-hand view.；
4) Select Specified Position or Tiled, click the Add button to add a watermark object. Choose Create Blank Object and specify the watermark style and type, or select an existing watermark object to copy. Click OK.
5) If the watermark style selected is Specified Position, the new object will be placed under the Specified Position node. If the style is Tiled, it will be placed under the Tiled node.
6) Select the specific watermark object and configure its properties in the right-hand view.
7) Once all settings are complete, click OK.
Copy from Existing Template
When copying from an existing template, you can select a template during creation. The new template will inherit the watermark objects from the selected template, which can be adjusted as needed after creation.。

14.11.2 Watermark Object Description
Creating a watermark template primarily involves adding watermark objects and configuring their properties.
The supported watermark objects are as follows:
	Watermark Object
	Description

	General Watermark Object
	A general watermark object consists of a watermark style (Tiled or Specified Position) and a watermark type (Image, QR Code, or Text).
Multiple combinations of different watermark styles and types can be added. Objects with the same watermark style will be placed under the corresponding style node after creation.
For example:
If the watermark style selected during creation is Specified Position, the new watermark object will be placed under the Specified Position node.

If the style is Tiled, the new object will be placed under the Tiled node.

Watermark objects can be configured for Print, Screen, and Document Watermark Templates.

For document watermark templates, these objects are considered explicit objects.

	Dot Matrix
	A dot matrix watermark consists of a group of circular patterns containing computer information, arranged in a 3×3 grid and repeated. 
Each watermark template can have only one dot matrix setting.
Supported for Print, Screen, and Document watermark templates. For document templates, considered an explicit object.

	Marker Point
	Exclusive to Print Watermark Templates. When added, marker points mark specific text in the printed document according to a defined algorithm. Each watermark template can have only one marker point setting.

	Implicit Watermark Object
	Exclusive to Document Watermark Templates, including Implicit – General Document and Implicit – Image/Number. Each watermark template can have only one setting for each implicit object type.


14.11.3 General Watermark Objects
The settings for a general watermark object include Watermark Style and Watermark Type.
	Property
	Description

	Watermark Style
	

	Tiled
	The watermark is repeated across the entire display area according to the configured horizontal and vertical spacing.

	Specified Position
	The watermark is placed at a specific position and is not repeated.

	Watermark Type
	

	Text Watermark
	The watermark content is text.

	Image Watermark
	The watermark content is an image.

	QR Code Watermark
	The watermark content is a QR code.


When a watermark object is selected, its properties can be configured in the right-hand view as follows:
	Property
	Description

	Object Name
	The name of the watermark object.

	Watermark Content
	The specific content of the watermark. The content differs depending on the watermark type (details provided later).

	Parameter Settings
	Specific parameter settings for the watermark. Available parameters vary by watermark type (details provided later).

	Watermark Position / Watermark Spacing
	For Specified Position style, set the exact watermark position (details in Specified Position common properties). For Tiled style, set the watermark spacing (details in Tiled common properties).


Specified Position – Common Properties
For watermark objects with the Specified Position style, the common property is Watermark Position.
	Property
	Description

	Watermark Position
	

	Position
	The location where the watermark appears on the page (Top, Bottom, Left, Right, Center, Top-Left, Top-Right, Bottom-Left, Bottom-Right).

	Horizontal Offset
	The horizontal distance from the specified position. Positive values move the watermark to the right, negative values to the left.

	Vertical Offset
	The vertical distance from the specified position. Positive values move the watermark upward, negative values downward.


Tiled – Common Properties
When the Tiled node is selected, common properties can be set for all tiled watermark objects.
	Property
	Description

	Rotation Angle
	Adjusts the tilt of the tiled watermark. Options include Left, Center, and Right tilt. The angle can be specified. (Applies only to text watermarks.)

	Page Margins
	Sets the fill area for the tiled watermark on the page. Margins can be specified individually for Left, Right, Top, and Bottom.


[image: image318.bmp] Note
The rotation angle applies only to text watermarks.
Common Properties for Tiled Watermarks (All Types)
	Property
	Description

	Watermark Spacing
	

	Horizontal Distance from Previous Object
	The horizontal distance to the previous watermark of the same type (text or image).

	Vertical Distance from Previous Object
	The vertical distance to the previous watermark of the same type (text or image).

	Same Row as Previous Object
	If checked, the watermark aligns on the same row as the previous watermark of the same type; if unchecked, it does not. Default is unchecked.


Text Watermark Settings
The watermark content and parameters for text watermarks are as follows:
	Property
	Description

	Watermark Content
	Can display IP address, MAC address, computer name, computer alias, computer group, user, user alias, full user, user group, date, time, serial number, print job name, etc., or custom content can be added.

	Parameters
	

	Font
	The font used for the watermark text.

	Size
	The font size of the watermark text.

	Fill Color
	The fill color of the text watermark. Print watermarks default to gray but can be customized. Screen watermark templates include an option Auto Adjust to Screen, which dynamically adjusts color based on the client system's screen.

	Border Color
	For text watermarks, the border color defaults to none for both print and screen watermarks, but can be customized as needed.

For screen watermark templates, there is an additional Auto Adjust to Screen option. When selected, the border color dynamically adjusts based on the client machine’s current screen color.

	Rotation Angle
	The tilt of the watermark text.

	Hollow Font
	If checked, the watermark text will appear hollow.


Image Watermark Settings
The watermark content and parameters for image watermarks are as follows:
	Property
	Description

	Watermark Content
	

	Image Content
	Select an image to use as the watermark. Currently, only .jpg and .bmp formats are supported.

	Parameters
	

	Image Height
	Adjusts the height of the imported image.

	Image Width
	Adjusts the width of the imported image.


QR Code Watermark Settings
The watermark content and parameters for QR code watermarks are as follows:
	Property
	Description

	Watermark Content
	Can display IP address, MAC address, computer name, computer alias, computer group, user, user alias, full user, user group, date, time, serial number, print job name, etc., or custom content can be added. The selected content will be encoded as the QR code.

	Parameters
	

	Size
	The display size of the QR code watermark.

	Color
	The color of the QR code watermark.
For print and document watermark templates, only a custom color can be set.

For screen watermark templates, the color can be set manually or dynamically adjusted with the Auto Adjust to Screen option, which adapts the QR code color based on the client screen background.




14.11.4 Dot-Matrix Watermark Object
A dot-matrix watermark consists of computer information represented as a group of nine dots (in a 3×3 grid), repeated across the area.
The parameters for a dot-matrix watermark are as follows:
	Property
	Description

	Parameters
	

	Dot Diameter
	Size of each dot in the matrix.

	Dot Color
	Color of the dots. For screen watermark templates, an Auto Adjust to Screen option is available, which automatically adjusts dot color based on the current screen background at a default interval of two minutes.

	Transparency
	Opacity of the dot-matrix watermark.

	Watermark Spacing
	

	Dot-Matrix Side Length
	The side length of a single dot-matrix pattern (9-dot grid).

	Dot-Matrix Spacing
	Distance between two adjacent dot-matrix patterns.

	Block Spacing
	Distance between two groups of dot-matrix blocks (each block contains 9 dot-matrix patterns).


14.11.5 Mark Point Watermark Object
Mark points are used in print watermarks as hidden identifiers. Based on the configured parameters, a specific algorithm selects corresponding text in the printed document and places a mark point beneath it. These mark points can be detected in the printed output.
The parameters for mark points are as follows:
	Property
	Description

	Mark Point Size
	Default is Medium. Can be adjusted to Small, Medium, or Large as needed.

	Number of Mark Points per Page
	Specifies how many mark points are printed on each page. Default is 3; can be set to 1, 2, 3, 4, or 5.

	Marked Character Type
	Determines which character types receive mark points beneath them. Default is Chinese only. If set to All Characters Except Punctuation, mark points can appear under Chinese, English, numbers, etc., excluding only punctuation marks.


14.11.6 Explicit / Implicit Watermark Objects
Explicit and implicit watermark objects are used in document watermark templates.
Explicit watermarks include Explicit Dot-Matrix, Explicit Specified Position, and Explicit Tiled, corresponding to the common watermark objects described earlier (specified position, tiled, and dot-matrix).
Implicit watermarks include Implicit General Document and Implicit Image & Number.
Implicit General Document Watermark Settings
The parameter settings for the Implicit General Document watermark are as follows:
	Property
	Description

	Watermark Content
	Can display IP address, MAC address, computer ID, computer alias, computer group, user, user alias, full user name, user group, date, time, document number, or custom information. Custom content can also be added.


[image: image319.bmp] Note
Implicit general watermarks do not provide a preview.
Implicit Image & Number Watermark Settings
The parameter settings for the Implicit Image & Number watermark are as follows:
	Property
	Description

	Watermark Content
	Fixed as Number


[image: image320.bmp]Note
Implicit Image & Number watermarks apply only to image files and do not provide a preview.
14.11.7 Effect Preview
After configuring the watermark object properties, you can preview the watermark effect in the rightmost panel.
	Icon/Button
	Description
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	Open a new window to display the watermark at its original full size; press ESC to return.
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	Display the watermark at its original size within the preview window.
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	Display the watermark scaled to fit the preview window.
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	Change the preview window orientation to landscape; the watermark adjusts accordingly (applicable to print watermarks only).

	Size
	Displays the watermark effect size.


14.12 User Permission Template Categories
To standardize how users are granted document-related permissions, administrators can predefine document permission templates. When assigning document permission policies to users, these predefined templates can be directly selected. Users can only use the templates set by the administrator to configure their permissions.
Administrators with the “View User Permission Template Library” and “Set User Permission Template Library” permissions can view and manage the permission template library.Navigate to “Category Management → User Permission Template” to open the User Permission Template window.
Function / Button Description
	Icon / Button
	Description
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	Import a user permission template file.
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	Export the user permission template to a file.
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	Click to create a new template.
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	Click to delete the selected template.
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	Click to copy the selected template.
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	Cancel the creation or modification of a template.
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	Save the template after setting or modifying it; changes take effect only after saving.


Template Permission Settings
The permissions in a template can be configured as follows, with their respective default settings:
	Property Name
	Description

	Read
	Can be set to Prohibit / Allow; default is Allow.

	Modify
	Can be set to Prohibit / Allow; default is Allow.

	Copy
	Can be set to Prohibit / Allow / Not Set; default is Not Set.

	Print
	Can be set to Prohibit / Allow / Not Set; default is Not Set.

	Screenshot
	Can be set to Prohibit / Allow / Not Set; default is Not Set.

	Validity Period
	Can set the number of valid days; default is Unlimited.

	Decrypt
	Can be set to Prohibit / Not Set; default is Prohibit.

	Set
	Can be set to Prohibit / Allow; default is Prohibit.


14.13 Condition Library
Administrators can predefine a library of conditions, which can be directly selected when configuring advanced conditions for various management policies.
	Operation
	Description

	New Condition
	Click the add button “[image: image332.png]


” to create a new condition. Set the condition name, content, and remarks.

	Delete Condition


	Select the condition to delete, then click the delete button “[image: image333.png]


” to remove it.

	Edit Condition


	Select the condition to edit, then click the edit button “[image: image334.png]


” to modify it.


The currently supported conditions (parameters) include the following:
OSType: Operation type
OSVer: Operating system version
OSName: Operating system name
Devtype: Device type, currently supports two types — Notebook (laptop) and Desktop (non-laptop)
DevName: Device name
Ver: Client version
IP: Device IP address
Brief instructions for condition settings are as follows:
1.Format: [Parameter] [Operator] [Value]. Examples:
DevType = Notebook, DevType in (Notebook, Desktop), OSName like "*Windows*"

2.Multiple parameters can be combined using logical operators (AND, OR, NOT). Example:
OSType = Mac and DevType = Notebook

3.Parentheses can be used to define nested conditions. Example:
(DevType = Notebook and OSType = Mac) or (not OSType = Mac)

4.Supported operators:
>, >=, <, <=, =, ==, <>, !=, like, not like, in, not in, exist
Chapter 15: Request Management
15.1 Desktop Request Management
For operational needs, companies often implement desktop request management policies—such as device control or print control—to regulate and restrict employee access to corporate resources. If an employee needs to temporarily bypass these restrictions for work purposes, they can submit a request explaining the reason. Once approved by an administrator, the relevant desktop management restrictions can be temporarily lifted under specified conditions.
15.1.1 Request Management
By default, desktop request management allows viewing all requests and supports multiple query methods.
Online Approval:
When the client is online, the steps for submitting and approving desktop requests are as follows:
1) The client with “Allow” request permission submits a request.
2) A notification appears on the console, and the request record can be viewed under Request Management → Desktop Request Management → Request Management, with the status shown as Pending Approval.

3) Double-click the request record to view its details and any attached files. If the administrator finds the requested temporary access or duration inappropriate, they can adjust the request content.
4) To approve, click Approve; to reject, click Reject.
5) Once approved, the request takes effect when the client executes the Enable action in the desktop request management request window.
Offline Approval:
When the client is offline, the steps for desktop request submission and approval are as follows:
1) The client with “Allow” request permission submits a request and clicks Offline Request in the desktop request management window to generate an offline request file.
2) The administrator receives the request file, right-clicks Import Request File in the desktop request management interface, and imports the file.
3) A notification appears on the console, and the request record can be viewed in desktop request management with the status Pending Approval.
4) Double-click the request record to review the request details and any attached files.
5) To approve, click Approve; to reject, click Reject.
6) Select the approved request record, right-click Export Approval Result, and save the file.
7) Send the exported approval result file to the client, who imports it in the request management window and activates the request.
Rejecting a Request
Select one or more requests, then right-click and choose Reject, or click the icon [image: image335.png]


 button，and enter the rejection reason to deny the request. 
Any administrator with “Reject Approval” permission in the workflow can reject a request. Once rejected, the request is considered denied.
Requests with the status Pending Approval can be rejected. Requests that have been Approved but not yet executed can also be rejected. Even requests currently in execution can be rejected.
Quick Approval
Select multiple requests simultaneously, then click the icon [image: image336.png]


 button or choose Quick Approval from the right-click menu. To approve, click Approve; to deny, click Reject.
Delete Requests
Administrators with delete permissions can remove requests from Desktop Request Management. In the management view, select one or more requests and choose a deletion mode: Delete Selected Records, Delete Current Page Records, or Delete All Matching Records.
[image: image337.bmp] Note 
Requests in any status can be deleted. If an approved request has not yet been distributed, deleting it will prevent the approval result from being delivered to the client.
15.1.2 Delegation of Approval Rights
When an administrator is away, they can temporarily delegate their desktop application approval rights to a trusted administrator. System administrators can also assist other administrators in delegating their rights to designated personnel. During delegation, both the authorization period and the scope of approval rights can be defined. Once the set period expires, the delegated rights are automatically revoked.
Only administrators with the permission path “Application Management -> Desktop Application Management -> Approval Rights Delegation” can delegate their rights. Only administrators with Encryption Management Rights are eligible to receive such delegation. System administrators can view all active delegations.
	Icon Buttons
	Description
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	An administrator can serve as both a delegator and a delegate, with the option to switch views between rights they have delegated and those they have received. System administrators can also switch to view all administrators’ delegations.
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	Set up approval rights delegation. 
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	Revoke a delegation, i.e., withdraw the delegated rights.


Delegating Approval Rights
To delegate approval rights to another administrator, follow these steps:
1) From the menu bar, go to Application Management -> Desktop Application Management -> Approval Rights Delegation to open the delegation window.
2) Click the button[image: image341.jpg]


 to switch to the Delegation Settings view, then click the button [image: image342.jpg]


 to open the Approval Rights Delegation Settings window.
3) In the General tab, check Enable Delegation, select the delegate administrator, specify the start and end time of the delegation, and enter any remarks.
4) Switch to the Functional Permissions tab, select the rights to delegate (either all or specific permissions), and then click OK to confirm.
5) You can then view the details of the delegation under Application Management -> Desktop Application Management -> Approval Rights Delegation -> Delegation Settings.
Sub-delegation of Approval Rights
1) With system administrator privileges, click the[image: image343.jpg]


 button in the Desktop Application Approval Delegation interface to switch to View All Delegations, then click the [image: image344.jpg]


 button to open the Sub-delegation Settings window.
2) In the General tab, check Enable Delegation, select the delegate administrator, specify the start and end time of the delegation, and enter any remarks.
3) Switch to the Functional Permissions tab, select the rights to delegate (either all or specific permissions), and then click OK to confirm.
4) You can then view the details of the sub-delegated rights under Application Management -> Desktop Application Management -> Approval Rights Delegation -> View All Delegations.
Automatic Suspension of Delegation
In both delegation and sub-delegation, the General tab provides an option: Automatically suspend delegation when the delegator is online.
If selected, the delegate is granted the assigned rights only when the delegator is not logged into the console. Once the delegator logs in, the delegation is suspended and the delegate’s rights are withdrawn.
This setting only withdraws the rights temporarily while the delegator is logged into the console. Once the delegator logs out, the delegate automatically regains the delegated rights. To revoke the rights permanently, the delegation must be deleted in the Approval Rights Delegation interface.
[image: image345.bmp] Note 
Delegated rights cannot be further delegated or sub-delegated to other administrators.
15.1.3 Approval Workflow Management
Desktop Application Management supports workflow configuration with multi-level approvals, ensuring each request is reviewed and verified at the appropriate management levels.
Administrators with the permissions “View Desktop Applications and Approvals” and “Configure Desktop Approval Workflows” can log into the console and navigate to Application Management -> Desktop Application Management -> Approval Workflow Management to access the workflow interface and manage approval processes.
Function Button Descriptions
	Icon Button
	Description
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	Search,Search approval workflows based on specified criteria. 
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	New,Create a new workflow.
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	Edit,Edit the selected workflow.
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	Delete,Remove the selected workflow.
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	Copy,Duplicate the selected workflow.
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	Export,Export the full list of approval workflows in HTML, XLSX, or CSV format.

	[image: image352.png]



	Move Up,Move the selected workflow one position up.
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	Move Down,Move the selected workflow one position down.
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	Replace,After selecting a workflow, replace the current approver with a new one.
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	Cancel,Cancel a new entry or modification.
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	Save,Save changes to apply the new or modified workflow.


Search Workflow
Click the Search icon “[image: image357.bmp]” to open the search dialog. Enter search criteria such as Name, Application Type, Application Object, or Approver. Fuzzy search is supported. Clicking Search will highlight the first matching result; clicking again will move to the next matching entry.
Create Workflow
Click the New icon “[image: image358.png]


” to create a workflow. Each new workflow includes Basic Settings and Workflow Steps. By default, a newly created workflow is not active. To enable it, select the checkbox in front of the workflow name.
Basic Settings include:
	Field
	Description

	Workflow Name
	The name of the new workflow. Duplicate names are not allowed. If left blank, the default name is “Approval Workflow”. Subsequent workflows will be named “Approval Workflow_1”, “Approval Workflow_2”, and so on.

	Application Type
	The application types to which this workflow applies. You can select All or specific types.

	Application Object
	The application objects to which this workflow applies. Options include Computer, User, or Role.


Click the Add icon[image: image359.jpg]


 to create workflow steps. Multiple steps can be added, and each step can be modified, deleted, or moved up and down. At least one step is required to complete the workflow setup.
Workflow step settings include:
	Field
	Description

	Step Name
	The name of the new step. Required field; format is unrestricted, but duplicate names are not allowed.

	Approvers
	The approvers assigned to this step. Multiple approvers can be selected. This field is required.
Two modes are available:
1. Manager Approval
Approval follows the predefined approval hierarchy, with managers at each level reviewing sequentially.
2. Specified Approvers
One or more designated approvers can be selected to handle the approval.

	Approval Conditions
	You can set the condition to either “All approvers must approve” or “A specified number of approvers must approve.” The specified number cannot exceed the total number of approvers.
If Manager Approval is selected, the condition applies at each level of the approval chain. The request moves to the next level only after the current level meets the approval requirement. If any approver at a level rejects the request, approval at that level fails. The step completes only after all required levels in the chain have been approved.
If Specified Approvers is selected, the step is completed once the required number of approvals is reached. However, if any approver rejects the request, the step fails.

	Allow Approvers to Modify Request Content at This Step
	If selected, approvers at this step can adjust the request content as needed. Once approved, the modified version of the request will be executed.


[image: image360.bmp] Note       Manager Approval is a multi-level approval process based on predefined approval relationships. The number of levels and the approvers at each level vary depending on the applicant, as determined by the configured approval hierarchy. For details on Manager Approval, see the “Manager Approval” section.
Edit Workflow
Click the Edit button to open the workflow editing page, where you can modify the selected workflow’s conditions and environment settings. 
[image: image361.bmp] Note        After a workflow is edited, any pending requests associated with the original version of that workflow will become invalid.
Copy Workflow
Click the Copy button to duplicate the selected workflow. The copied workflow appears at the top of the list, with its name set to the original workflow name plus _N, where N indicates the copy number relative to the original workflow.

All settings of the copied workflow, including its enabled/disabled status, are identical to the original.
Delete Workflow
Click the Delete button to remove the selected workflow. If there are ongoing requests within the workflow at the time of deletion, those requests will be terminated, and the applicants will receive a corresponding notification.
Automatic Approval
Select a workflow, then click the icon “[image: image362.png]


” and choose Set Automatic Approval to configure automatic approval settings:
	Setting
	Description

	Condition
	By default, this option is unchecked, meaning all requests are automatically approved immediately upon submission. If checked, you can set a timeout period. When a request remains unapproved after the specified duration, the workflow continues with automatic approval.

	Approval Action
	The outcome of automatic approval. The default is Auto-Approve, but you can choose Auto-Reject.

	Approval Comment
	The comment recorded during automatic approval. Default is blank. If Auto-Reject is selected, a comment is required.


Select a workflow with automatic approval enabled, click the icon “[image: image363.png]


” , and choose Cancel Automatic Approval to disable it. Enabling or disabling automatic approval does not alter the original workflow, and requests already in progress remain valid.
Replace Workflow Approvers
Select one or more workflows and click the Replace icon “[image: image364.bmp]” to open the Replace Approver dialog. In the dialog, choose the original approver and the new approver. Click OK and save to update the selected workflows with the new approver.
[image: image365.bmp] Note       The original approver can only be selected from approvers included in the selected workflows, while the new approver can be chosen from all users. After replacing the approver, any pending requests associated with the original workflow will become invalid.
Workflow Matching Rules
Requests are matched to workflows in the order they appear in the approval workflow list, from top to bottom. Once a request matches a workflow, no further matching occurs. If a request does not match any custom workflow, it defaults to the Admin workflow for approval.

Once a request is matched to a workflow, it progresses sequentially through each step. Each step must meet its specified approval criteria before moving to the next step. Only the approvers assigned to the current step can approve; approvers from other steps cannot. A request is considered approved only after all steps have been successfully completed.

If a request is at step N and the required number of approvers approve, it moves to step N+1. If the required number of approvals is not met and any approver rejects, the request reverts to step N-1. Approvers at N-1 do not need to re-approve; if any approver clicks Reject, the request moves back to step N-2. If any approver clicks Comment and provides an explanation that satisfies approval criteria, the request returns to step N.

Desktop Application Management also supports veto operations. Any administrator with Veto Approval rights can reject a request at any stage. Once vetoed, the request is marked as rejected and does not return to a previous step. Requests that have been approved but not yet executed cannot proceed if vetoed.
15.1.4 Automatic Approval Settings
Administrators can grant approvers the permission for automatic approval. Once enabled, requests submitted to the designated approvers will be automatically approved.

Approvers must have the “Allow Automatic Approval” permission to enable this feature. Administrators can assign this permission via the console at Tools -> Account Management -> Functional Permissions -> Desktop Application Management, by checking “Allow Automatic Approval”.
Enable Automatic Approval
Approvers can log into the console at Application Management -> Desktop Application Management -> Automatic Approval Settings. Click the Edit icon[image: image366.bmp] , check Enable Automatic Approval, and set the active time. By default, it applies all day. You can select a predefined time type from Classification Management -> Time Types, or choose Custom to set a specific time range in the pop-up time selector. Click OK to activate automatic approval.
View Request Details
When a request is automatically approved, the approval action is displayed as “Approved (Automatic)” in the console under Desktop Application Management -> Request Management and on the client under View Desktop Requests -> View Request Details.
15.2 Encryption Request Management
15.2.1 Decryption Request Management
By default, Decryption Request Management displays all decryption requests, including both approved and pending requests. Requests can be searched and filtered using various criteria.
Online Approval
When the client is online, the decryption request and approval process proceeds as follows:
1) The client submits a decryption request via the right-click menu or scanning tool.
2) A notification appears on the console, and the request is listed in Decryption Request Management with the status Pending Approval.

3) Double-click the request to view request details and file content.

4) To approve, click Approve; to reject, click Reject.

5) Once approved, the client can decrypt the file in the request details window.
Offline Approval
When the client is offline, the decryption request and approval process is as follows:
1) The client submits a decryption request via the right-click menu or scanning tool, which generates a request file in the request information menu.

2) The administrator imports the request file in Decryption Request Management by right-clicking and selecting Import Request File.

3) A notification appears on the console, and the request is listed in Decryption Request Management with the status Pending Approval.

4) Double-click the request to view its details and file content.

5) To approve, click Approve; to reject, click Reject.

6) In Decryption Request Management, select the request, right-click, and choose Export Approval Result to save the approval outcome to a file.

7) Send the exported approval result file to the client. The client imports this file in the request information menu to complete decryption.
Quick Approval
Select multiple decryption requests, right-click, and choose Quick Approval. Click Approve to approve all selected requests, or Reject to deny them.
Delete Requests
Administrators with permission to delete decryption requests can remove requests from the system. In the decryption request view, select one or more requests and choose a deletion mode: Delete Selected, Delete Current Page, or Delete All Matching Records.
[image: image367.bmp] Note 
Decryption requests in any status can be deleted. If an approved request that has not yet been distributed is deleted, the approval result will not be sent to the client.
15.2.2 External Transfer Request Management
External Transfer Request Management functions similarly to Decryption Request Management.
Online Approval：

When the client is online, the external transfer request and approval process is as follows:
1) The client submits an external transfer request via the right-click menu or scanning tool.
2) A notification appears on the console, and the request is listed in External Transfer Request Management with the status Pending Approval.
3) Double-click the request to view details and file content. For multi-level directories, double-click a folder to view subfolders. Click the icon[image: image368.jpg]


 or icon[image: image369.jpg]


 to return to the parent directory.
4) To approve, click Approve; to reject, click Reject.
5) Once approved, the client generates the external transfer files in the request information window.
Offline Approval：

When the client is offline, the external transfer request and approval process proceeds as follows:
1) The client submits an external transfer request via the right-click menu or scanning tool, generating a request file in the request information window.
2) The administrator imports the request file in External Transfer Request Management by right-clicking and selecting Import Request File.
3) A notification appears on the console, and the request is listed in External Transfer Request Management with the status Pending Approval.
4) Double-click the request to view details and file content.
5) To approve, click Approve; to reject, click Reject.
6) In External Transfer Request Management, select the request, right-click, and choose Export Approval Result to save the approval outcome.
7) Send the exported approval result file to the client. The client imports this file in the request information window to generate the external transfer files.
Quick Approval
Select multiple external transfer requests, right-click, and choose Quick Approval. Click Approve to approve all selected requests, or Reject to deny them.
Delete Requests
Administrators with permission to delete external transfer requests can remove them. In the external transfer request view, select one or more requests and choose a deletion mode as needed: Delete Selected Records, Delete Current Page Records, or Delete All Matching Records.
[image: image370.bmp] Note
External transfer requests can be deleted in any state. If an approved request has not yet been delivered, deleting it will prevent the approval result from being sent to the client.
15.2.3 Temporary Offline Request Management
When a client needs to travel for a short period, such as completing a business trip within a few days, it is recommended to use the Temporary Offline function. By default, the Temporary Offline Request Management view displays all temporary offline requests.
Online Approval：

When the client is online, the approval process for a temporary offline request is as follows:
1) The client submits a temporary offline request.
2) A pop-up notification appears on the console, and the request is listed in the Temporary Offline Request Management view with the status Pending Approval.
3) Double-click the request record to open the approval window, where you can review the client’s reason for the request and the requested offline expiration time. If necessary, the administrator can adjust the expiration time.
4) To approve, click Approve; an authorization code is generated in the approval window. To reject, click Reject and provide a reason for the rejection.
5) Once approved, the client goes offline. From that moment until the expiration time, the client operates in fallback mode, following online encryption and decryption policies.
6) The client can view the approval result in the request information window.
Offline Approval
When the client is offline, it cannot submit a temporary offline request. In this case, the administrator must create the request from the console. The steps are as follows:
1) On the Temporary Offline Approval page, click the Create Request button[image: image371.bmp].
2) Select the target offline computer or computer group, then click OK.
3) Specify the expiration time and click Approve.
4) The offline request dialog closes, and an approved record is automatically added to the Temporary Offline Request Management window.

5) The administrator double-clicks the record to reopen the offline request dialog and retrieve the authorization code. This code is then communicated to the offline client (e.g., by phone or other means). After the client imports the authorization code, it enters temporary offline mode and follows online encryption/decryption policies until the administrator-defined expiration time.
Delete Request
Administrators with permission to delete temporary offline requests can delete them. In the Temporary Offline Request view, select one or more requests, and choose a deletion mode as needed: delete selected records, delete current page records, or delete all matching records.
[image: image372.bmp] Note 
Any temporary offline request can be deleted, regardless of its status. If an approved but undistributed request is deleted, the approval result will no longer be delivered to the client.
15.2.4 Document Property Change Request Management
Document property change requests are managed in a manner similar to decryption requests.
Online Approval：

When the client is online, the steps for submitting and approving a document property change request are as follows:
1) The client submits a document property change request via the right-click menu or the scanning tool.
2) A notification bubble appears on the console, and the request record (with status Pending Approval) can be viewed under Document Property Change Request Management.

3) Double-click the request record to view the request details and file content.

4) To approve, click Approve; to reject, click Reject.

5) Once approved, the client can modify the document properties in the request information window.
Offline Approval：

When the client is offline, the steps for submitting and approving a document property change request are as follows:
1) The client uses the right-click menu or scanning tool to request a document property change, which generates a request file in the request information window.
2) The administrator obtains the request file, then in the Document Property Change Request Management interface, right-clicks and selects Import Request File, and imports the file.
3) A notification bubble appears on the console, and the request record (with status Pending Approval) can be viewed under Document Property Change Request Management.
4) Double-click the request record to view the request details and file content.
5) To approve, click Approve; to reject, click Reject.
6) In the Document Property Change Request Management interface, select the request record, right-click, and choose Export Approval Result, then save the file.
7) Send the exported approval result file to the client. The client imports the result file in the request information window and then modifies the document properties.
Quick Approval
Select multiple document property change requests at the same time, right-click and choose Quick Approval. To approve, click Approve; to reject, click Reject.
Delete Request
Administrators with permission to delete document property change requests can remove them. In the document property change request view, select one or more requests and choose a deletion mode as needed: delete selected records, delete all records on the current page, or delete all records that meet the conditions.
[image: image373.bmp] Note 
Requests in any status can be deleted. If an approved request has not yet been distributed, once deleted, the approval result will no longer be delivered to the client.
15.2.5 Delegation of Approval Authority
When an administrator is away, they can temporarily delegate their approval authority to a trusted administrator to handle approval tasks. System administrators can also assist other administrators by delegating their authority to someone else. During delegation, the authorization time frame and scope of approval authority can be defined. Once the set period expires, the delegated authority is automatically revoked.
Only administrators with the “Workflow Management – Approval Authority Delegation” permission can delegate authority to others. Only administrators with “Encryption Function Management Authority” can accept delegation. System administrators can view all delegation records.
	Icon Button
	Description

	[image: image374.jpg]



	An administrator can act as both a delegator and a delegate. You can switch views between delegated and received authorizations. System administrators can also switch to view delegation records of all administrators.

	[image: image375.jpg]



	Configure approval authority delegation. 

	[image: image376.jpg]€y




	Delete a delegation, i.e., revoke the delegated authority.


Delegating Approval Authority
The steps to delegate approval authority to another administrator are as follows:
1) From the menu bar, select “Application Management” to open the main management window, then go to “Application Management -> Encryption Application Management -> Approval Authority Delegation.”
2) Click the[image: image377.jpg]


 button to switch to the authority delegation settings interface, then click the [image: image378.jpg]


 button to open the Approval Authority Delegation Settings window.
3) In the General tab, check “Enable Delegation,” select the entrusted administrator, set the delegation start and end time, and enter remarks.
4) Switch to the Functional Permissions tab to select the permissions to delegate. You may choose to delegate all permissions or only specific ones. After configuration, click [OK].
5) Go to “Application Management -> Encryption Application Management -> Approval Authority Delegation -> Delegation Settings” to view the details of the delegated authority.
Delegated Authority Reassignment
1) Log in with System Administrator privileges. In the Approval Authority Delegation interface, click the[image: image379.jpg]


 button to switch to the “View All Delegations” interface, then click the [image: image380.jpg]


 button to open the Delegated Authority Reassignment Settings window.
2) In the General tab, check “Enable Delegation,” select the entrusted administrator, set the start and end time of the delegation, and enter remarks.
3) Switch to the Functional Permissions tab to select the permissions to delegate. You may choose to delegate all permissions or only specific ones. After configuration, click [OK].
4) Navigate to “Application Management -> Encryption Application Management -> Approval Authority Delegation -> View All Delegations” to review the details of the reassigned authority.。

Automatic Delegation Suspension
When configuring Delegation or Delegated Reassignment, the General tab includes the option “Automatically suspend delegation when the delegator is online.” If this option is selected, the delegatee will only hold the delegated authority when the delegator is not logged into the console. Once the delegator logs into the console, the delegation is suspended and the delegatee’s authority is revoked.

This setting only provides a temporary suspension while the delegator is online. After the delegator logs out, the delegatee will automatically regain the delegated authority. To permanently revoke delegated authority, the delegator must delete the delegation in the Approval Authority Delegation interface.

[image: image381.bmp] Note 
Delegated authority cannot be further delegated or reassigned to other administrators.
15.2.6 Approval Workflow Management
The multi-level approval feature supports complex organizational approval processes, ensuring that requests are reviewed and verified by managers at each level. In a multi-level approval workflow, the roles responsible for each level are referred to as Encryption Approvers. Encryption Approvers are administrators with encryption management permissions.
Administrators with “View Encryption Approval Workflow” and “Configure Encryption Approval Workflow” permissions can log in to the console, navigate to “Application Management -> Encryption Application Management -> Approval Workflow Management”, and perform all workflow management operations.
Function Button Description
	Icon Button
	Description

	[image: image382.bmp]
	Search – Click to query approval workflows based on specified criteria.
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	New – Click to create a new workflow.

	[image: image384.jpg]



	Edit – Click to edit the selected workflow.

	[image: image385.png]



	Delete – Click to delete the selected workflow.

	[image: image386.jpg]



	Copy – Click to duplicate the selected workflow.

	[image: image387.bmp]
	Export – Click to export all workflows; supported formats: HTML, XLSX, CSV.

	[image: image388.png]



	Move Up – Move the selected workflow up by one position.

	[image: image389.png]



	Move Down – Move the selected workflow down by one position.

	[image: image390.bmp]
	Replace–After selecting a specific process, click this button to assign a new approver.

	[image: image391.png]



	Restore – Click this button to cancel a new or modified workflow. 

	[image: image392.png]



	Save – Click this button to save the workflow settings or modifications for them to take effect.


Search Workflow
Click the “[image: image393.bmp]” button to open the search dialog. Enter the search criteria, which can include Name, Request Type, Request Target, and Approver, with support for fuzzy search. Clicking the Search button will locate the first matching record; clicking it again will move to the next matching record.
Create Workflow
Click the “[image: image394.png]


” button to create a new workflow. The new workflow includes workflow conditions and workflow stages. By default, the newly created workflow is disabled. Check the box before the workflow name to enable it.
Workflow Conditions Include the Following:
	Field Name
	Description

	Basic Settings
	Configure the basic information of the workflow.

	Workflow Name
	Name of the new workflow. Cannot duplicate an existing workflow name. If left blank, it defaults to “Approval Workflow”, with subsequent workflows named “Approval Workflow_1,” “Approval Workflow_2,” and so on.

	Request Type
	Select the request types that this workflow can match. You may choose all or one/multiple specific types.

	Request Target
	Select the targets this workflow can match, such as computers, users, or roles.

	File Settings
	Configure file attributes. Leaving this blank means no restrictions.

	File Count
	Only requests with a number of files within the specified range will match this workflow. Range: [0, 100,000].

	Total File Size
	Only requests with total file size within the specified range will match this workflow. 
Range: [0, 100,000,000].

	File Path / File Type
	Only requests whose file paths or file types match the configured settings will match this workflow. You can specify file paths, file types, or a combination of both. Separate multiple conditions with commas (,) or semicolons (;). Wildcards are supported, e.g., *.doc, *.txt, C:\test\*. Conditions are evaluated using an OR logic.

	Document Attributes
	Click the button[image: image395.jpg]


 to open the condition settings dialog, where you can configure the file’s “Set Permissions” and “Access Permissions.”
If “Match any of the above conditions” is checked, the workflow will match if any single condition is met. If unchecked, all conditions must be exactly met for the workflow to match.
Leaving this blank means there are no restrictions.

	External Recipients
	Select the External Recipients.
If “Match any of the above conditions” is checked, the workflow will match if any one condition is met. If unchecked, all conditions must be fully satisfied for the workflow to match.
Leaving this blank means there are no restrictions.

	External Distribution Settings
	Click the button[image: image396.jpg]


 to open the condition settings dialog, where you can configure external distribution properties (Print, Virtual Print, Clipboard, Screenshot, Edit/Modify) and their corresponding conditions (Allow/Block).
If “Match any of the above conditions” is checked, the workflow will match if any single condition is met. If unchecked, all conditions must be fully satisfied for the workflow to match.
Leaving this blank means there are no restrictions.

	Temporary Offline
	Select the duration range, with units available in minutes, hours, or days, up to a maximum of 1,000 days.
If “Temporary Offline” is not checked, there are no restrictions.


Click the “icon” button [image: image397.jpg]


 to add workflow stages. You can create multiple stages, and each stage can be edited, deleted, or moved up and down. At least one stage is required to complete the workflow setup. Workflow stage settings include the following:
	Field Name
	Description

	Stage Name
	Name of the new stage. Format is flexible, required, and must be unique.

	Approvers
	All approvers for this stage. Multiple approvers can be selected; selection is required. There are two approval modes:
1. Hierarchical Approval
Approvals are carried out level by level according to the predefined approval hierarchy.
2. Designated Approvers
One or more specific approvers can be selected to handle the approval for this stage.

	Approval Conditions
	The stage can be set to pass if “All approvers must approve” or “A specified number of approvers must approve.” The specified number cannot exceed the total number of approvers.

If Hierarchical Approval is selected, the approval condition applies to each level in the approval chain. The stage only advances to the next level when the current level meets the approval condition. If any approver at a level rejects, the stage cannot pass.

The stage concludes only after all multi-level approval conditions are fulfilled.


[image: image398.bmp] Note 
1. When creating a new workflow, some pages are only applicable to specific application types (these pages include prompts). If the selected application types do not include a certain type, the pages relevant only to that type will not be displayed.
2. Hierarchical Approval is a multi-level approval based on predefined approval relationships. The number of approval levels and approvers at each level vary depending on the applicant, according to the preset approval hierarchy. For detailed usage, refer to the “Hierarchical Approval” section.
Edit Workflow
Click the Edit button to enter the workflow editing page, where you can modify the selected workflow, including all workflow conditions and settings.
[image: image399.bmp] Note       Editing a workflow will invalidate any pending applications that belong to this workflow.
Copy Workflow
Click the Copy Workflow button to duplicate the selected workflow. The copied workflow is placed at the top of the workflow list by default, with its name appended by _N, where N indicates the copy version number of the original workflow in the list. All settings of the copied workflow, including its enabled status, are identical to the original.
Delete Workflow
Click the Delete Workflow button to remove the selected workflow. If there are pending applications in the workflow being deleted, those applications will be terminated, and the applicants will receive a corresponding notification.
Automatic Approval
Select a workflow, click the icon button “[image: image400.png]


”, and choose Set Automatic Approval to configure automatic approval settings:
	Settings
	Description

	Conditions Met
	By default, this option is unchecked. All submitted applications will enter automatic approval immediately. If checked and a timeout is set, the workflow will automatically approve the application if it remains unapproved after the specified duration from submission.

	Approval Action
	The result of automatic approval. Default is Auto Approve; can also be set to Auto Reject.

	Approval Comments
	Comments filled in during automatic approval. Default is empty; can be added as needed. If the action is set to Auto Reject, comments must be provided.


Select a workflow with automatic approval enabled, click the “icon” button “[image: image401.png]


”,and choose Cancel Automatic Approval to disable automatic approval for that workflow. Setting or canceling automatic approval does not alter the original workflow, and ongoing applications under automatic approval will remain valid.
Replace Workflow
Select one or more workflows, click the Replace button “[image: image402.bmp]”, and open the Replace Approver dialog. In the dialog, choose the original approver(s) and the new approver(s). After confirming and saving, the approvers in the selected workflows will be replaced with the new approvers.
[image: image403.bmp] Note 
The original approver can only be selected from the approvers included in the selected workflow(s), while the new approver can be chosen from all users. After replacing approvers, any pending requests under this workflow will become invalid.
Workflow Matching Principles
Requests are matched against the approval workflows in the list from top to bottom. Once a request matches a workflow, no further workflows are checked. If a request does not match any custom workflow, it will default to the system workflow, which is approved by administrators with the corresponding approval permissions or system administrators. The default workflow cannot be modified, moved, or deleted.

After a request matches a workflow, it proceeds sequentially through each workflow stage. Only when the approval conditions for the current stage are met can the request move to the next stage. Only approvers assigned to the current stage can approve; approvers of other stages cannot. A request is considered approved only after passing all stages.

If a request is at stage N and the required number of approvers approve, it proceeds to stage N+1. If the required number of approvals is not reached and an approver rejects, the request reverts to stage N−1. Approvers at stage N−1 do not need to reapprove; if any approver clicks Reject, the request will move back to stage N−2. If any approver clicks Explain and provides a justification for approval, the workflow returns to stage N.
[image: image404.bmp] Note 
Approver accounts included in a workflow may experience permission changes or be deleted. In an active workflow, if any stage has fewer approvers with encryption management permissions than the required number for approval, that workflow becomes invalid.
For approvers who lose their encryption management permissions, restoring their permissions will not reactivate the invalidated workflow.
15.2.7 Automatic Approval Settings
Administrators can grant specific approvers the permission to perform automatic approvals. Once enabled, applications submitted by clients to these approvers will be approved automatically.
Approvers must have the “Allow Automatic Approval” permission to enable this feature. Administrators can grant this permission via the console under Tools → Account Management → Encryption Features → Workflow Management, by selecting Allow Automatic Approval.
Enable Automatic Approval
The approver logs into the console and navigates to Workflow Management → Automatic Approval Settings. Click the [image: image405.bmp] Edit button, check Enable Automatic Approval, and select the active time. By default, this is set to all day. You can choose a predefined time type (set under Classification Management → Time Types) or select Custom to define a specific time range in the pop-up time selection window. Click OK to activate automatic approval. Applications submitted by clients during the specified time will be automatically approved when routed to the corresponding approver.
View Application Details
When an application is approved via automatic approval, the approval action is displayed as “Approve Application (Automatic)” both in the console under Encryption Application Management and on the client side under View Encryption Application Status → View Application Details.
15.3 Superior Approval
The approval process supports stepwise approvals based on hierarchical relationships. Each applicant’s request flows through the hierarchy according to the established superior-subordinate structure, making the approval process more flexible and adaptable.
15.3.1 Configuring Approval Relationships
“Application Management → Approval Manager → Approval Relationships” allows you to configure approval relationships by assigning an approval manager, effectively designating the “superior.”
Function Button Guide
	Icon/Button
	Description

	[image: image406.bmp]
	Search——Click to query approval relationships based on specified criteria. 

	[image: image407.jpg]



	New——Click to create a new approver or a new approval relationship.

	[image: image408.jpg]



	Edit——Click to edit the selected approval relationship.

	[image: image409.png]



	Delete——Click to remove the selected approval relationship.

	[image: image410.png]



	Clear All——Remove all custom approval relationships.


Successfully created approval relationships will appear in the “Approval Relationships” view. There are two ways to create an approval relationship:
Create a New Approver
Click the New button[image: image411.jpg]T



 or right-click on an empty area in the view and select “Create New Approver”. The dialog that appears displays the current console’s user tree. Checking a user sets them as the approver for their group, including all subgroups.
Create a New Approval Relationship
Click the New button[image: image412.jpg]T



 or right-click on an empty area in the view and select “Create New Approval Relationship”. In the dialog that appears, choose the requestor and the approver.
or right-click on an empty area in the view and select “Create New Approval Relationship”. In the dialog that appears, choose the requestor and the approver.
When setting an approval relationship, if the requestor is a computer or user group, the selected approver will act as the approver for all objects in that group, including subgroups, at the organizational level. If the requestor is a specific computer or user, the approver will be responsible for that individual computer or user at the user level.
[image: image413.bmp] Note       1. An approver at the organizational level is matched to the closest relevant group approver.
2. If both organizational-level and user-level approvers exist, the user-level approver takes precedence.
3. A requestor may have multiple supervisors, i.e., multiple approvers. The first listed approver is considered the primary approver. For user-level matching, once the user’s supervisor approves, the request flows to the primary approver’s supervisor. For organizational-level matching, once the highest-level group approver approves, the request also flows to the primary approver’s supervisor.
4. If a requestor is the primary approver for their own group and has no designated user-level approver, their submitted request will flow directly to the nearest parent group approver.
15.3.2 Assigning Positions
In “Request Management → Approver Management → Positions”, you can view approvers and the requestors they oversee. By default, approvers have no assigned positions. Setting positions helps streamline management and can also be used in workflows, allowing a request to advance automatically once approved by an approver holding the designated position.
Function Button Guide
	Icon/Button
	Description
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	Search: Click to query approvers based on specified criteria.
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	Set Position: Click to assign a position to the selected approver.

	[image: image416.png]



	Delete Position: Click to remove the position of the selected approver.
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	Clear All: Remove all custom positions for all approvers.


[image: image418.bmp] Note        Positions can be assigned only to approvers who are users. Approvers who are administrators cannot be assigned a position.
15.3.3 Approval Relationship Chain
Once an approval relationship is established, a chain is formed between requestors and approvers, applicable to both desktop requests and encrypted requests.

For a requestor, their approver is considered the “superior”, who may also have their own approver, i.e., the superior’s superior, and so on. This creates a hierarchical approval chain from the bottom up. The chain ends when the highest-level approver has no further superior.

When a workflow step is set to “Superior Approval”, the request flows upward along the approval chain: first to the immediate superior, then to the superior’s superior, and so on. At each level, once the approver completes their review, the request continues to the next level until the chain ends or the step’s completion criteria are met.
Requestor Matching
When setting an approval relationship, both users and computers can be assigned a superior, meaning each has its own approval chain. When matching a requestor, the user’s approval chain takes priority.

For example, if User A logs in on Computer B:

· If User A has an approval chain, it will be used.

· If User A has no approval chain (no superior), Computer B’s approval chain will be used.

· If neither the user nor the computer has an approval chain, the requestor is considered to have no superior.

The following explanation uses a user as the requestor example; the process is the same for a computer requestor.
Example:
The user hierarchy is as follows (group names are enclosed in < >, approvers in ( ); approvers listed on a group represent organizational-level approvers, while approvers listed on a computer represent user-level approvers).
Entire Network Structure:
——<R&D Department> (Approvers: User A, User B)

——User A

——User B

——User C

——<R&D Team 1> (Approver: User D)


——User D


——User F

——<R&D Team 2> (Approvers: User G, User A)


——User G


——User M 



——User H（Approver: User A）


——User P（Approver: User C）
User G has no user-level approver assigned. Therefore, their organizational-level approvers—User G and User A—would normally be considered their superiors. However, since User G is the primary approver for their current group, R&D Team 2, this level is skipped. The request then moves directly to the parent group’s approvers, User A and User B. At the organizational level, the primary approver, User A, has no further superior, so the approval chain ends.
Therefore, User G’s approval chain is:
User G (Requestor) → User A, User B (Level 1)
User M has no user-level approver assigned. Therefore, their first-level superiors at the organizational level are User G and User A. The second-level superiors are User A and User B. Since the primary approver at the organizational level, User A, has no further superior, the approval chain ends.
Therefore, User M’s approval chain is:
User M (Requestor) → User G, User A (Level 1) → User A, User B (Level 2)
User H has organizational-level approvers User G and User A, as well as a user-level approver User A. Since user-level approvers take precedence, User H’s superior is User A. At the organizational level, the primary approver User A has no further superior, so the approval chain ends.
Therefore, User H’s approval chain is:：

User H (Requestor) → User A (Level 1)
User P has organizational-level approvers User G and User A, but also a user-level approver User C. Since user-level approvers take priority, User P’s superior is User C.User C does not have a user-level approver, so their organizational-level approvers are User A and User B. At this level, the primary approver User A has no superior, so the approval chain ends.
Therefore, User P’s approval chain is:
User P (Requestor) → User C (Level 1) → User A, User B (Level 2)
15.3.4 Configure Approval Workflows
In “Request Management → Desktop Request Management → Workflow Management”, you can configure approval workflows. At each workflow step, you may enable the Superior Approval mode. In this mode, there is no need to manually assign approvers—the request will follow the existing approval chain and move upward step by step.
Superior Escalation Within a Step
When a request enters a step in Superior Approval mode, the following applies:

· At approval level N, once the required number of approvers approve, the request advances to level N+1.

· If the required number of approvals is not met and any approver rejects, the request moves back to level N-1.

· Approvers at level N-1 do not need to review again:

· If any approver clicks Reject, the request returns to level N-2.

· If any approver clicks Comment and provides an approval explanation, the request returns to level N.
If a request is rejected at level 1:

· When the current step is not the first step, the request returns to the previous step. If that step is also in Superior Approval mode, the request flows to the last approver in that step’s approval chain.

· When the current step is the first step, the same applies: the request returns to the previous step, and if it is in Superior Approval mode, it flows to the last approver in that step’s approval chain.

Once the approval chain for a step is fully completed, the request proceeds to the next step. If it was the final step, the request is closed.

For any request under approval, an administrator with Rejection Authority can deny the request at any point. Once rejected, the request is immediately marked as Denied and will not return to any previous step. For requests that have been approved but not yet executed, a rejection prevents execution.
Superior Approval Settings
Consecutive Approval Levels
This option is enabled by default with a level of 1 and supports integers from 1 to 10. The request follows the approver chain and stops once the specified level is reached, completing the current step.
Example:
If a requestor’s approval chain has 3 levels:
If the level is set to 2, once level 2 approves, the request does not proceed to level 3 and the current step ends, moving to the next step.
If the level is set to 5, the request continues until level 3 approves (the last level in the chain), and then moves to the next step.
Multi-Level Approval Until Specified Group Level
Enable this option to stop the request once it reaches or exceeds the specified group level. The default level is 1, supporting integers from 1 to 10.

The level refers to the hierarchy in the organizational tree: the top-level group is level 1, its subgroups are level 2, and so on.
Example:
A requestor’s approval chain has 4 levels:

· Level 2 approver manages a group at level 4.

· Level 3 approver manages a group at level 2.

· Level 4 approver manages a group at level 1.
If the level is set to 4, once level 2 approves, the chain has reached the 4th-level group. The request stops and moves to the next step.
If the level is set to 3, after level 2 approves, the chain has not yet reached the 3rd-level group, so it continues to level 3. Once level 3 approves, the chain reaches the 2nd-level group, exceeding the specified level, and the request ends, moving to the next step.
Multi-Level Approval Until Specified Position
Enable this option and enter one or more position names, separated by commas (,) or semicolons (;). Multiple positions are treated as alternatives. Once a request is approved by an approver holding any of the specified positions, the current step ends.
Example:
A requestor’s approval chain has 4 levels:

· Level 2 approver holds the position Supervisor.

· Level 3 approver holds the position Director.
If the specified positions are “Supervisor, Director”, the request stops after level 2 (Supervisor) approves, ending the current step and moving to the next.
[image: image419.bmp] Note       Once a request is matched to a workflow, its approval chain is fixed. If the workflow is still in progress and approvers change, the request remains valid and continues along the originally assigned approval chain.
15.3.5 Workflow Fault Tolerance
During workflow execution, the following situations may prevent a step from completing:
1.The requestor has no superior.
2.Consecutive Approval Levels is selected, but the approval chain has fewer levels than specified.
3.Multi-Level Approval Until Specified Group Level is selected, but the chain does not reach the specified group level.
> The specified group level has no approver;
> The request flows to the end of the approval chain without reaching or exceeding the specified group level.
4. Multi-Level Approval Until Specified Position is selected, but:
> None of the approvers in the chain have an assigned position;
> The assigned positions do not match the specified positions;
> There are approvers with matching positions, but the approval condition “All approvers must approve” is not selected, and none of the eligible approvers have approved.
When configuring a workflow step, you can set fault tolerance for scenarios where the step cannot complete.
	Setting
	Description

	Auto-Approve Step
	If the current step is not the last, the request moves to the next step after the last approver approves. If it is the last step, the request is automatically rejected, and the approval result is Denied.

	Designated Approver
	Assign a specific approver. If the request reaches the last level in the approval chain and the step cannot complete, it flows to the designated approver. If approved, the request proceeds to the next step; if denied, it returns to the previous level in the approval chain.


15.4 Permission Viewing
15.4.1 View Request Permissions
In “Request Management → View Request Permissions”, you can see the approval and self-recording permissions for all computers/computer groups and users/user groups.
15.4.2 Search Request Permissions
In “Request Management → Search Request Permissions”, you can set query criteria in the right-hand panel, including request type, status, object type, object scope, and object name. After clicking Search, the information list displays all matching approval and self-recording permissions.
In “Request Management → View Request Permissions”, you can view the approval and self-recording permissions for all computers/computer groups and users/user groups.
15.5 Request Approval Permission Settings
By default, computers and users have no request permissions. Administrators can manage desktop request permissions for computers/users in “Request Management → Request Approval Permission Settings.”

After selecting the target object, set permissions for each request type in the right-hand Request Approval Permission Settings view.
Setting Method:

1. Use the dropdown under Request Status to set permissions:

· Empty or Disabled: the client cannot submit this request type.

· Allowed: the client can submit this request type, with specific scope restricted by advanced settings.
2. After setting the request status, click the [image: image420.bmp] Edit button to configure advanced settings.
Advanced Settings:
Device Usage
	Advanced Setting
	Description

	Device Type
	Select the device types that clients are allowed to request. All types are selected by default.

	Device Description
	Enter allowed device descriptions. Wildcards are supported. By default, there is no restriction.


Removable Storage Usage
	Advanced Setting
	Description

	Read/Write Permission
	Select the allowed read/write permissions for removable storage devices. The default setting is Read-Only.


Printing / Printing Without Watermark
	Advanced Setting
	Description

	Print Job Name
	Set allowed print job names for clients. Supports wildcards. No restriction by default.

	Printer Type
	Select allowed printer types: local, shared, network, or virtual. Multiple selections supported. All types selected by default.

	Printer Description
	Enter allowed printer descriptions. Supports wildcards. No restriction by default.

	Application
	Add allowed application names for printing. Defaults to all applications.

	Backup File
	Enable to back up files submitted for printing. Backup files can be viewed in the document print log.
Requests to print without a watermark cannot be backed up.


Email Sending
	Advanced Setting
	Description

	Recipient
	Enter allowed recipient email addresses. Supports wildcards.

	File Name
	Specify allowed file types for sending. Exclusion rules take priority over inclusion. Defaults to all files.


File Transfer via Chat Tools
	Advanced Setting
	Description

	File Name
	Specify allowed file types for transfer. Exclusion rules take priority over inclusion. Defaults to all files.

	Chat Tool
	Select allowed chat tools. Multiple selections supported. All tools selected by default.

	Backup File
	Enable to back up files sent via chat tools. Backup files can be viewed in the document operation log.


File and Data Upload
	Advanced Setting
	Description

	Website or Network Address
	Enter allowed websites or network addresses. Supports wildcards. Separate multiple entries with a semicolon (;).

	Port Range
	Specify allowed port ranges for uploads. Separate multiple ports with a semicolon (;).


Copy to Removable Drive / Network Drive / Burn to Disc
	Advanced Setting
	Description

	File Name
	Specify allowed file types for copying or burning. Exclusion rules take priority over inclusion. Defaults to all files.

	Backup File
	Enable to back up files copied to removable drives, network drives, or burned to discs. Backup files can be viewed in the document operation log.


Remove Document Watermark
	Advanced Setting
	Description

	File Type
	Specify allowed file types for watermark removal.

	File Name
	Specify allowed file names and paths. Exclusion rules take priority over inclusion. Defaults to all files.

	Backup File
	Enable to back up files from which watermarks are removed. Backup files can be viewed in Watermark → Document Watermark Log and Watermark → Document Flow Log.


[image: image421.bmp] Note
Removing document watermarks only supports explicit watermarks. It does not remove document numbers, implicit generic watermarks, flow information, or hidden image-based numeric watermarks.
External Transmission of Sensitive Files
	Advanced Setting
	Description

	File Name
	Specify allowed file names. By default, all files are allowed. Select “Only the following file types” and define inclusion/exclusion lists to restrict requests. Exclusion rules take priority. Wildcards are supported.

	Sensitive Content
	

	Allow Files Containing
	Select sensitive information categories. Files matching these categories are allowed. Default is all categories.

	Disallow Files Containing
	Select sensitive information categories. Files matching these categories are blocked. Disallowed categories take priority over allowed ones.

	Transmission Method
	Choose allowed transmission methods. All are selected by default.

	Copy to Removable Drive
	Enable to allow requests to copy files to removable drives.

	Copy to Network Drive
	Enable to allow requests to copy files to network drives.

	File Transfer via Chat Tools
	Enable and specify chat tools. Requests to send files via these tools are allowed.

	Send Email
	Enable and specify recipient emails. Requests to send attachments to these recipients are allowed. By default, all recipients are allowed. Multiple recipients are separated by ; or ,.

	Upload Files
	Enable to allow requests to upload files.

	Print
	Enable and specify print job names. Requests to print files matching these jobs are allowed.

	External Transmission Action
	Specify allowed external actions.

	Skip Watermark
	Requests to externally transmit Office, PDF, or image files can skip watermarking.

	Skip Encryption
	Requests to externally transmit files can skip encryption.

	Backup File
	Enable to back up files when the requested action is executed. Backups can be viewed in the Sensitive Information Log.


External Transmission Without Document Watermark
	Advanced Setting
	Description

	File Type
	Specify allowed file types for external transmission.

	File Name
	Specify allowed file names and paths. By default, all files are allowed. Select “Only the following file types” and define inclusion/exclusion lists. Exclusion rules take priority. Wildcards are supported.

	Watermark Handling
	

	Allow Client to Choose
	The client can decide whether to keep or remove the original watermark on the transmitted file.

	Keep Original Watermark
	The client can only retain the original watermark; removing it is not allowed.

	Remove Watermark (except images)
	The client can only remove the watermark (except for images); keeping the original watermark is not allowed.

	Transmission Method
	Select allowed external transmission methods. All are selected by default.

	Copy to Removable Drive
	Enable to allow requests to copy files to removable drives.

	Copy to Network Drive
	Enable to allow requests to copy files to network drives.

	File Transfer via Chat Tools
	Enable and specify transmission types (file, image, screenshot) and chat tools. Requests using these tools for external transmission are allowed.

	Send Email
	Enable and specify recipient emails. Requests to send attachments to these recipients are allowed. By default, all recipients are allowed. Multiple recipients are separated by “;” or “,”.

	Upload Files
	Enable to allow requests to upload files.

	Backup File
	Enable to back up files when the request is executed. Backups can be viewed in Watermark → Document Watermark Log.


[image: image422.bmp] Note
In External Transmission Without Document Watermark, if the Remove Watermark option is applied, only explicit document watermarks can be removed. Document numbers, implicit generic watermarks, flow information, and hidden image-based numeric watermarks are not supported.
Policy Priority
All computers (and groups) inherit the policy from the Computer node by default. Individual computers inherit the policy from their parent computer group. Computer group policies override the Computer node policy, and individual computer policies override the computer group policy.
All users (and groups) inherit the policy from the User node by default. Individual users inherit the policy from their parent user group. User group policies override the User node policy, and individual user policies override the user group policy. 

User policies take precedence over computer policies.
15.6 Self-Record Permission Settings
To reduce the administrative overhead of frequent external file requests, administrators can grant clients self-record permissions, allowing them to approve external file requests within the allowed scope, with corresponding log records.
In “Request Management → Self-Record Permission Settings”, set self-record permissions for computers/users. Use the dropdown under Request Status to configure permissions:

· Empty or Disabled: the client cannot submit this type of request.

· Allowed: the client can submit this type of request.

Click the [image: image423.bmp] Edit button to access advanced settings. The advanced settings are the same as those in Request Approval Permission Settings.
15.7 Self-Record Logs
Requests submitted via client self-recording generate corresponding logs. Administrators can view these logs in “Request Management → Self-Record Logs”.Double-click a log entry to see detailed information, including: request type, time, file name, file path, valid period, request reason, and description.
15.8 Desktop Request Document Upload Settings
Settings for desktop request documents allow files that meet the specified conditions to be uploaded to the Request Document Storage Server. This requires integration with the storage server.
	Icon Button
	Description
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	Edit the document upload settings for the selected computer or user. 
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	Delete the document upload settings for the selected computer or user.
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	Export policy files, import policy files, or copy the current policy to other clients.


Desktop Request Document Upload Settings: Options
	Setting Option
	Description

	Enable Setting
	Enable or disable uploading request documents to the document storage server.

	Document Storage Server Address
	Enter the address of the document storage server (HTTPS only; use the corresponding HTTPS port).

	Include Files
	Files within this scope will be uploaded to the storage server. Choose from predefined file types or manually enter paths using the button. Supports wildcards, e.g., *.doc, C:\*, D:\test\*.txt.

	Exclude Files
	Files within this scope will not be uploaded. Choose from predefined file types or manually enter paths using the button. Supports wildcards, e.g., *.doc, C:\*, D:\test\*.txt.

	File Size
	Set the size range for files to be uploaded. Custom sizes are allowed, within 0–2,000,000 KB.


[image: image427.bmp] Note 
Supported requests include: External Transmission of Sensitive Files, External Transmission Without Document Watermark, and Copy to Removable Drive.
15.9 Client Requests
Computers or users subject to restrictions from printing policies, device control policies, removable media policies, email control policies, IM file transfer control policies, upload control policies, document control policies, sensitive information external transmission policies, or document watermark policies can submit requests to lift these restrictions if they have “Allow Request” permission.
When the client is online: Requests are immediately sent to the console for approval. Once approved, the restriction can be lifted via View Request Information.
When the client is offline: Requests must be exported from View Request Information and sent to the administrator. The administrator imports the request into the console for approval. Once approved, the client imports the authorization file from the administrator and activates it via View Request Information.
General Request Settings Explanation
The time settings for requests have the same meaning across all types of requests.
	Setting Name
	Description

	Valid Time Period
	The restrictions are lifted within the specified time period.

	Effective Time After Approval
	Starts counting from the moment approval is granted; restrictions are lifted within the specified duration.

	Activatable Time Within Valid Period
	An additional restriction within the valid time range. Click “?” for detailed explanation.


15.9.1 Print Requests
When a computer or user is restricted from printing, they can request to temporarily lift the restrictions for specific printers and applications.
Computers or users with “Allow Request” permission can right-click the client icon, select Request → Print, choose the printer and application to lift restrictions, set the time, provide a reason, and click Apply to submit the request.
15.9.2 Request to Print Without Watermark
When a computer or user is restricted by a policy that adds watermarks during printing, they can submit a request to temporarily print to specific printers and applications without adding a watermark.
The steps for submitting a request to print without a watermark are the same as those for a regular print request.
15.9.3 Device Usage Requests
When a computer or user is restricted from using certain devices, they can request temporary access to specific devices.
Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Request → Use Device.

2. View all disabled devices and predefined device categories in the current client environment (matching the console Device Control settings).

3. Select the devices to lift restrictions for, set the time period, provide a reason, and click Apply to submit the request.
15.9.4 Removable Media Requests
When a computer or user is restricted from using removable storage devices, they can request temporary access to specific devices.
Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → Use Removable Media.

2. View all removable storage devices in the current client environment.

3. Select the devices to lift restrictions for and set read/write permissions.

4. Set the time period, provide a reason, and click Apply to submit the request.
15.9.5 Send Email Requests
When a computer or user is restricted by an email control policy, they can request temporary permission to send emails with attachments.
Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → Send Email.

2. Set the recipients and attach the files.

3. Set the time period, provide a reason, and click Apply to submit the request.
15.9.6 IM File Transfer Requests
When a computer or user is restricted by an IM file transfer control policy, they can request temporary permission to send files via chat tools.
Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → IM File Transfer.

2. Set the file details and select the chat tool.

3. Specify the time period, provide a reason, and click Apply to submit the request.
15.9.7 File and Data Upload Requests
When a computer or user is restricted by an upload control policy, they can submit a request to temporarily upload files to specified websites.
Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → Upload Files and Data.

2. Set the file details and target website.

3. Specify the time period, provide a reason, and click Apply to submit the request.
15.9.8 Copy to Removable Drive, Network Drive, or Burn to Disc Requests
When a computer or user is restricted by a document control policy from modifying or deleting content on removable drives, network drives, or discs, they can submit a request to temporarily perform these actions.

Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → Copy to Removable/Network Drive or Burn to Disc.

2. Specify the files or folders for the request.

3. Set the time period, provide a reason, and click Apply to submit the request.
15.9.9 Remove Document Watermark Requests
When a computer or user is restricted by a document watermark policy or watermark permissions, they can request to remove watermarks from marked files.

Computers or users with “Allow Request” permission can:

1. Right-click the file and select Document Watermark → Request Removal, or right-click the client icon and select Desktop Request → Remove Document Watermark.

2. Specify the file details, provide a reason, and click Apply to submit the request.
[image: image428.bmp] Note
1. Removing document watermarks only supports explicit watermarks; it does not remove document numbers, implicit generic watermarks, circulation information, or implicit image-based numeric watermarks.
2. For compressed files, all watermark-removable file types within the archive must meet the request permissions for the submission to succeed.
15.9.10 Sensitive File Transfer Requests
When a computer or user is restricted by a sensitive information transfer policy from sending files containing sensitive data, they can request temporary permission to transfer specific files by designated methods.

Computers or users with “Allow Request” permission can:

1. Right-click the client icon and select Desktop Request → Transfer Sensitive Files.

2. Specify the files and transfer method, set the time period, provide a reason, and click Apply to submit the request.
15.9.11 Transfer Files Without Watermarks
When a computer or user is restricted by a document watermark policy for external transfer, they can request temporary permission to transfer files either removing the watermark or retaining the original watermark.

Computers or users with “Allow Request” permission can:

1. Right-click a file and select Document Watermark → Request Transfer Without Watermark, or

2. Right-click the client icon and select Desktop Request → Transfer Without Watermark.
Then set the file details, transfer options, time period, provide a reason, and click Apply to submit the request.
[image: image429.bmp] Note
1. Removing watermarks only supports explicit document watermarks; it does not remove document numbers, implicit general watermarks, circulation information, or hidden image-based numeric watermarks.
2. For compressed files, if the archive contains files with removable watermarks, all such files must meet the request permissions for the application to be successfully submitted.
15.9.12 View Application Status
On the client desktop, right-click the AnySecura tray icon and select “View Desktop Applications” to see application and approval statuses.
Double-click a record to view detailed information, including application details, requested items, approval status, workflow, approval history, and effective time.
	Button
	Description

	Enable
	After approval, click to lift the restrictions specified in the application.

	Reapply
	Resubmit applications that were rejected, denied, canceled, expired, completed, or deleted.

	Delete
	Delete applications that are canceled, expired, completed, deleted, rejected, or denied. Cannot delete applications pending approval, approved, or in progress.

	View
	View detailed information of the application.

	Import Approval
	For offline cases, import the approval file from the console to obtain the result.

	Offline Application
	Generate an offline application file to send to the console for approval.

	Cancel Application
	Cancel the application.


15.10 Client Self-Approval
Computers or users restricted by printing, device control, removable media, email, IM file transfer, upload, document control, sensitive information transfer, or document watermark policies can self-approve requests within their allowed scope if they have the “Allow Application” self-approval permission.
Client self-approval operates similarly to regular client requests. Right-click the client tray icon, select “Desktop Application Request” to open the request wizard, choose the appropriate request type, then click the “Self-Approval” button in the wizard. Once completed, the requested action can be executed immediately.
15.11 Proxy Administrator
When an administrator grants a client Proxy Administrator access, the client can log into the proxy console on that machine to approve desktop security management requests.
15.11.1 Login
If a computer or user has any application item set to Allowed in the console under Desktop Application → Application Approval Permission Settings or Desktop Application → Self-Approval Permission Settings, they can log into the proxy console. Right-click the client icon in the system tray, select Approval Management Platform, and enter an administrator account and password. The proxy console supports automatic startup.
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When logging into the proxy console, selecting Auto Start will make the proxy console launch automatically and display the login dialog the next time the client starts and connects to the server. This setting can also be configured via Application Management → Options in the proxy console, under Basic Settings → Login Settings by checking Auto Start.
If both Auto Start and Auto Login are selected and a valid administrator account and password are entered, the proxy console will automatically log in in the background the next time the client starts and connects to the server. The main console interface will not appear, but the user can access it from the client’s system tray icon menu.
15.11.2 Approval Management
The proxy console’s approval management functions are the same as the main console: it allows viewing desktop security management requests, approving applications, importing and exporting approval files, and managing delegated approval permissions.
15.11.3 Locking
To prevent others from approving requests via the proxy console, administrators can lock it when stepping away. While locked, the proxy console will still receive notifications for decryption and outbound requests, but a password is required to approve them. There are three locking methods: immediate lock, lock upon leaving, and lock when minimized.
Immediate Lock:
Select Operations → Lock from the menu to lock the console instantly.
Lock on Away:
Go to Request Management → Options, check Automatically lock when user is away, and set the delay in minutes before locking. The default is 15 minutes.
Lock on Minimize:
Go to Request Management → Options, and check Lock when minimized to tray.
Chapter 16: Network Access Detection
The Network Access Detection feature identifies unauthorized computers attempting to access the network and blocks them, effectively protecting confidential files, preventing data theft, and reducing the risk of virus intrusion, thereby enhancing overall network security.
Open the Network Access Detection window by selecting Tools → Network Access Detection from the menu.
16.1 Starting Network Access Detection
Starting Network Access Detection
By default, Network Access Detection is not enabled, so the detection window will initially be empty. To start detection, go to System → Settings to configure the detection policy.

In the settings dialog, check Enable Network Access Detection. This will activate the detection feature, and all online computers within the subnet of installed clients will be scanned. In each subnet, one client machine acts as the detection agent, marked with a small red flag. This agent scans all computers within its subnet.

If Detect IP Address Range is set when enabling detection, only network devices within the specified IP range will be scanned, provided there are client-installed machines within that range.

Check Alert for New Machines by MAC Address to trigger alerts when a newly scanned MAC address is not listed in the existing computer list, indicating a new device. If this option is not checked, the system uses an IP+MAC combination management mode: if both IP and MAC match an existing entry, no alert is issued; if either IP or MAC is unmatched, the device is considered new and an alert is generated.
Computer List
Scanned computers are categorized as Client or Non-Client and displayed under the Client section in the computer list.
	Client Type
	Description

	Client
	Indicates a computer with the client module installed.

	Unknown
	Indicates a computer without the client module installed. If Block all non-client computers from network access is checked in System → Settings, these computers will be blocked from communicating with protected machines.


You can choose to view the computer list in either IP+MAC Mode or MAC Mode.
	View Mode
	Description

	IP+MAC Mode
	A computer is uniquely identified by its IP and MAC address.

	MAC Mode
	A computer is identified solely by its MAC address.


If a computer uses dynamically assigned IP addresses that change frequently, viewing in IP+MAC Mode may show multiple entries with the same MAC but different IPs. In MAC Mode, these entries are merged into a single computer, with the IP displayed as the most recent one.
Access Rule Settings
Administrators can configure access rules for computers based on IP, MAC, or IP+MAC, including the following types: Authorized, Protected, Blocked, and Normal.

	Rule Type
	Description

	IP/MAC Rule
	Sets a rule based on a specific IP and MAC address. The IP+MAC combination uniquely identifies a computer. If the computer is later detected, this rule will apply.

	IP Rule
	An IP Rule sets a rule based solely on the IP address. If a detected computer matches this IP and has no existing rule, it will automatically inherit this IP-based rule.
For example, if IP 192.168.1.1 is authorized, any scanned computer with this IP—regardless of its MAC—will automatically be treated as IP Authorized.

	MAC Rule
	A MAC Rule applies a rule based solely on the MAC address. If a detected computer has this MAC and no existing rule, it will automatically adopt the MAC-based rule.

For example, if MAC 6C-F0-49-64-FA-00 is set as authorized, any scanned computer with this MAC—regardless of its IP—will automatically be assigned MAC Authorized.

	Authorized
	Authorized computers are never blocked. Use this for administrator machines or critical network devices to prevent accidental blocking due to missing client installation.

	Protected
	Typically applied to important computers to block unauthorized access and prevent confidential data theft.

	Blocked
	Blocked computers are restricted from communicating with protected machines once network access control is enabled.

	Normal
	Normal indicates no access rule is set. Use this to clear any previous Authorized, Protected, or Blocked rules.
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Setting an IP or MAC rule adds a custom record. For unrestricted MACs or IPs, the value will display as <Any>. When assigning a computer type, you can select multiple computers and apply the setting to all of them at once.
16.2 Enabling Access Control
Enabling the Access Control Feature
After configuring computer types, you can enable the access control feature. Open the policy settings dialog by selecting Operations → Settings.
1) Enable Access Control
Checking this option activates access control on the agent computer, preventing Blocked computers from accessing Protected computers. 
Administrators can set all computers not allowed to access protected machines as Blocked.
2) Block All Non-Client Computers from Network Access
If this option is checked, computers without the client installed—and not marked as Authorized or Protected—cannot access Protected computers. Ensure that any non-client computers that should not be blocked are manually set as Authorized or Protected.
Typically, external computers without the client cannot access protected machines, effectively safeguarding confidential data.
3) Restrict by IP Address Range
If no IP range is specified, the agent computer will block all computers marked for blocking within the subnet. If an IP range is specified, only computers within that range will be blocked.
16.3 Other Settings
Configuring Detection Agents
Computers marked with a small red flag icon “[image: image432.png]


” are detection agents. A detection agent scans all online computers within its subnet and enforces control functions, blocking unauthorized computers.
To facilitate network management, administrators can designate one or more stable client machines—such as those without personal firewalls and rarely shut down—to have priority as detection agents. As long as these machines are running, one of them can act as the detection agent.
To set priority, select a computer and use the right-click menu Agent Level → Priority. The computer will display a blue flag icon. Only computers with the Normal type can be set as detection agents, and setting priority ensures it becomes the agent first.
To prevent a computer from becoming a detection agent, use the right-click menu Agent Level → Prohibit.
Predefined Computer Types
In addition to computers detected by the detection agent, administrators can manually add computers and assign their types for proactive management. Select Control → Add to add a computer. Administrators can set the type based on IP+MAC, or just IP or MAC, and configure the corresponding access rules.
	Type Setting
	Description

	IP-MAC
	Assign a type based on both IP and MAC addresses. The IP+MAC combination uniquely identifies a computer, and if this computer is later detected, its type will automatically update to the predefined type.

	IP
	Assign a type based solely on the IP address. If a detected computer matches this IP and has no assigned type, it will automatically adopt this IP-based type.

For example, if IP 192.168.1.1 is authorized, any scanned computer with this IP—regardless of its MAC—will automatically be IP Authorized.

	MAC
	Assign a type based solely on the MAC address. If a detected computer matches this MAC and has no assigned type, it will automatically adopt this MAC-based type.

For example, if MAC 00-F0-4C-8C-DE-6A is set as illegal, any scanned computer with this MAC will automatically be MAC Illegal.

	Rule
	Administrators can assign a computer as Authorized, Illegal, Protected, or Normal.


Once added successfully, any computer that meets the specified criteria will automatically adopt the predefined type. The detection agent will then enforce access control based on this type.
Searching, Modifying, and Deleting Computers
When the computer list becomes large, administrators can use the search bar to filter computers by last online time, IP address range, name, access rule, or client status.

Double-click any record in the computer list, or select Control → Properties, to open the properties dialog. This dialog displays all identification information for the computer and allows administrators to modify its name, access rule, or agent level.

For computers that have not been used for a long time, administrators can delete them. If the computer reappears on the network, it will be displayed again in the list.
Chapter 17: Data Backup
17.1 Database Backup
Backing Up the Primary Database
To prevent database file corruption or other incidents that may prevent the server from starting normally, it is recommended that administrators back up the database after configuring classifications and policies.

The main steps for backing up the primary database are:
1) First, stop the AnySecura Server and any other programs using the SECURE database.
2) Open SQL Server 2000 Enterprise Manager or SQL Server 2005 Management Studio.
3) Right-click the SECURE database and select All Tasks → Detach Database.
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4) After successfully detaching the database, administrators can copy the primary database files—SECURE.mdf and SECURE_Log.LDF—to the backup directory.
5) Once detached, the SECURE entry will be removed from the Enterprise Manager. To restore the database, administrators need to select All Tasks → Attach Database and reattach the primary database in the Server installation directory.
The method above backs up the database by detaching it first and then copying the database files. Alternatively, you can stop the MSSQLSERVER service, copy the database files to the backup directory, and then restart the MSSQLSERVER service and the AnySecura Server. This achieves the same backup result.
Log Database Backup
Log data is stored daily in the DATA directory, which by default is located in the installation folder. Files are named by date. For example, for June 20, 2009, the files might include:
SECURE _DATA.20090622.MDF
SECURE _DATA.20090622_Log.LDF
SECURE _DATA.20090622.X.MDF
SECURE _DATA.20090622.X_Log
There are typically 2 to 10 files per day.
The main steps for backing up the log database are:
1) Stop the AnySecura Server and MSSQLSERVER services.
2) Copy the .MDF and .LDF database files to the backup directory.
3) Restart the MSSQLSERVER service and the AnySecura Server.
17.2 Console Backup Management
17.2.1 Backing Up Data
Administrators can use the console’s Backup Data feature to regularly back up client data, storing it on another drive or removable storage device. This helps prevent issues caused by large data volumes or insufficient disk space.
Open the backup and view window by selecting Tools → Server Management → Database Backup Management.
	Icon Status
	Description
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	Create a new backup task.
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	Cancel a backup task.
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	Set up a scheduled backup plan.


Creating a Backup Task
Click the New Task icon on the toolbar to create a backup task. The steps are as follows:
1) Select the types of data to back up, including basic event logs, document operation logs, document operation copies, web browsing logs, print logs, email and screen history, and other available data types.
2) Choose the date range for the data to be backed up, specifying the start and end dates.
3) Select the destination path to save the backup data.
Check Store backup data on the SQL Server machine and select a path; the backup will be saved to the corresponding path on the SQL Server machine.
Check Store backup data to a network path and enter the full network path, e.g., \\192.168.1.1\backupdata. Domain names are supported. You must also provide a username and password with read/write permissions for this network path. Click Test Connection to verify access; once successful, the backup data will be saved to the specified network location.
4) To free up database space, administrators can check Delete Original Data to automatically remove backed-up data; otherwise, the data will remain in the database.
5) Click OK to start the backup task.
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When storing backup data to a network path, keep the following points in mind:
1. If the server and database are on different machines, storing backup data to a network path is not supported.
2. During Test Connection, ensure the server and console machines are not using a different username than the one provided for the network path, as this may cause the connection test to fail.
3. When loading backups, data from a network path cannot be loaded directly. You must first copy the data from the network path to the server machine before loading.
Adding a Backup Schedule
Click the Backup Schedule icon on the toolbar to open the Backup Schedule Management window. Then click New to create a backup schedule. The steps are as follows:
1) Click the Backup Schedule icon on the toolbar to open the Backup Schedule Management window. Then click New to create a backup schedule. The steps are as follows:
2) Select the First Backup Time.
3) Define the Backup Date Range: Enter the start and end dates. The end date is required, and the unit will match the selected backup frequency. Backups will occur within this range relative to the start time.
4) Select Data Types to Back Up: Choose from basic event logs, document operation logs, document operation copies, web browsing logs, print logs, email and screen history, and other available data types.
5) Delete Original Data (Optional): Check this option to automatically remove data that has been backed up.
6) Select the Backup Destination Path.
7) Click OK to save the schedule. The new backup plan will appear in the backup schedule list.
At the scheduled execution time, the system will create a new backup task based on the plan and start it automatically.
Backup Schedule List
The backup schedule list displays the basic attributes of each backup task, including creation time, next execution time, data range, delete original data, and backup path. Tasks can be edited or deleted.
	Field Name
	Description

	Creation Time
	The time when the backup task was created.

	Next Execution
	The next scheduled start time for the task. If the task has never run, this shows the first execution time.

	Data Range
	The types of data included in the backup task.

	Delete Original Data
	Indicates whether the backed-up data will be deleted from the database after backup.


Backup Task List
The backup task list shows the basic properties of each backup task, including start date, end date, backup path, delete original data, backup time, and status. The detailed task list provides information on when each database was backed up.
	Field Name
	Description

	Start Date / End Date
	Specifies the date range of the data to be backed up.

	Backup To
	The directory where the backup files are stored.

	Delete Original Data
	Indicates whether the backed-up data will be removed from the database after backup.

	Start Time / End Time
	The start and completion times of the backup task, which indicate how long the task took.

	Status
	The status of a running backup task updates in real time, showing which database is currently being backed up. Other statuses include Task Canceled, Task Completed Successfully, and Task Failed.


In the backup task list, the right-click menu also provides the following options:
	Menu Item
	Action

	Cancel Task
	Stops the currently selected backup task.

	Delete Log
	Deletes the log of the selected task. Incomplete tasks cannot be deleted.

	Properties
	View the conditions and detailed settings of the selected backup task.

	Refresh
	Refreshes the backup task list.
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Only one backup task can run at a time. If a backup task is already in progress, new backup tasks cannot be started.
17.2.2 Loading and Unloading Backup Data
Administrators can load backup data from versions 3.0 and 3.1 into the database for viewing. Loading backup data restores it to the server without affecting the existing server data.
Open the backup management window by selecting Tools → Server Management → Database Backup Management. Here, you can view the list of already loaded backup data, as well as load or unload backup data.
Loading Backup Data
Select Backup Management → Load, or click the Load Backup button on the toolbar. Choose the directory containing the backup files, check the data you want to load, and click Load followed by OK to load the selected backup data.
Both local directories and network drives are supported. To load data from a network drive, click Browse Network Location at the bottom of the window, enter the network path (e.g., \\192.168.1.1\backupdata ), which supports domain names, and click OK to confirm the network path.
The backup data list displays the backup date, file path, and file size. For backups from the same day, up to 10 files can be loaded simultaneously.

Loaded backup data can be viewed and queried directly through the console without affecting the existing data on the server.
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When loading data from a network path, keep the following points in mind:
1. The database must be SQL Server 2012 or later.
2. Both the SQL Server machine and the specified network path must be in the same domain, and the SQL Server service account must be a domain account with full control over the specified network path.
Unloading Backup Data
If a backup is no longer needed for viewing, it can be unloaded from the server. Select one or more backup data entries, then click the Unload Backup button icon “[image: image440.png]
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”. A list of backups to be unloaded will appear. Click OK to remove them; the corresponding backup data will be deleted, and they will no longer be visible in the console.
Chapter 18: Tools
18.1 Account Management
The system administrator has the highest level of privileges and can access all system functions. By creating additional administrator accounts, the system administrator can delegate certain management tasks to other administrators.  

Select Tools → Accounts to view administrator information. Here, administrators can add or delete accounts, enable or disable accounts, and change administrator passwords. When creating a new administrator account, clicking Save allows you to continue adding passwords and accounts directly on the Accounts page.
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	Action
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	Add an administrator account and optionally enter a description.
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	Delete an administrator account. The system administrator Admin cannot be deleted.
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	Change the login password for an administrator account. The default password is blank.
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	Expand additional function options.

	Enable
	Enable a disabled administrator account.

	Disable
	Disable an administrator account. The system administrator Admin cannot be disabled.

	Move to
	Moving administrators can be done in three ways:
1. If a regular administrator A has no sub-administrators, moving A under administrator B will make A a sub-administrator of B.
2. If administrator A has a sub-administrator C, moving C under administrator B will remove C from A’s hierarchy and make C a sub-administrator of B.
3. If a regular administrator A has a sub-administrator C, moving C to the entire network will make C a regular administrator, no longer under A.

	Importing Accounts
	Using a CSV file exported via the Export Account Permissions feature, administrators can import accounts. The import only updates the administrator name, email, and notes; other permissions remain unchanged.
Import Options：
Update Only Existing Accounts
Unchecked (default): Updates email and notes for existing accounts. New accounts are also imported, but all permissions except email and notes are unchecked.
Checked: Updates only email and notes for existing accounts. New accounts are not imported.
This option is not selected by default.
Add Encryption Approver Permissions
Unchecked (default): Imported accounts will not change the permissions “Has Encryption Management Rights” or “Login Only as Proxy Administrator.”
Checked: Imported accounts will have “Has Encryption Management Rights” and “Login Only as Proxy Administrator” enabled during import.
The default setting is unchecked.

	Copy Permissions To
	Select an administrator A and copy their permissions to another administrator B. Administrator B will retain their original permissions while gaining all of administrator A’s permissions.

	Export Account Permissions
	Export the permissions of all current administrators for review. In the exported file, a checked permission is marked with “√”, and an unchecked permission is marked with “×”.
The export also includes notes and email information.


[image: image447.bmp] Note
Notes on “Copy Permissions To”:
1. System administrator permissions cannot be copied to a non-system administrator who already has sub-administrators, nor to any sub-administrator.
2. To copy permissions from a non-system administrator A to a sub-administrator (whose parent is B), there are two scenarios:
  a. If A’s permissions are within B’s permission scope, A must have no sub-administrators for the copy to succeed. If A has sub-administrators, the copy will fail.
  b. If A’s permissions exceed B’s permission scope, the copy will fail.
18.1.1 Administrator Password Security Verification
Administrator password security verification enforces password complexity and limits on incorrect attempts to enhance protection against malicious password-cracking attempts. By default, this feature is disabled. The system administrator can enable and configure it by clicking Administrator Password Security Verification in the lower-left corner of the Account Management interface.
	Setting
	Description

	Enable Administrator Password Security Verification
	Check this option to activate password security verification; the settings below will take effect only when enabled.

	Password Complexity
	Configure rules for administrator password complexity.

	Password Cannot Be Empty
	When checked, administrators with empty passwords will be required to set a non-empty password; otherwise, they cannot log in.

	Minimum Password Length
	When checked, set the minimum password length. Administrators whose passwords are shorter than this length will be forced to update their password to meet the requirement; otherwise, they cannot log in.

	Password Complexity Verification
	Check this option to enforce password complexity. If an administrator’s password does not meet the complexity requirements when logging in, they will be forced to change it; otherwise, the account cannot access the console.
Click the icon [image: image448.jpg]


 to view the detailed complexity requirements.

	Incorrect Password Attempts Verification
	This setting defines rules for handling the number of incorrect administrator password attempts.

	Enable Incorrect Password Attempts Verification
	Check this option and configure the time window, maximum allowed incorrect attempts, and account lock duration. If an administrator exceeds the specified number of incorrect password attempts within the set time, the account will be locked. During the lock period, the account cannot log in—even with the correct password.

	Timeout Lock
	Settings related to automatically locking the administrator console after a period of inactivity.

	Lock Console After Inactivity
	Check this option and set the idle time limit. Once the console remains idle for the specified duration, it will automatically lock, requiring the administrator password to log back in.
This setting also applies when an administrator logs into a proxy console. The console’s timeout lock takes precedence over the proxy console lock settings.

	Periodic Password Change
	Settings for enforcing a maximum usage period for administrator passwords.

	Maximum Password Age (Days)
	Check this option and set the maximum number of days a password can be used, defaulting to 30 days. Starting from the configuration date, once the password reaches the specified duration, the administrator must change it.

	Password Expiration Reminder (Days)
	Check this option and set the reminder period in days, defaulting to 3 days. Once the remaining password validity reaches this period, a reminder will appear daily at 10:00.

The reminder period cannot exceed the maximum password age.


When an administrator account is locked after exceeding the allowed number of incorrect password attempts, an audit log is generated and can be viewed in the Audit Console.
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1.The Administrator Password Security Verification settings apply to all administrator accounts.
2. To prevent malicious lockouts of the Admin or Audit accounts, their login attempts on the server machine are not limited.
18.1.2 Administrator Permissions
Administrator permissions are divided into four main modules: General, Functional Permissions, Management Scope & Object Management, and Encryption Features.
	Module
	Description

	General
	Specifies the administrator type and login mode.

	Functional Permissions
	Defines the administrator’s functional privileges, such as managing client logs, setting various policies, performing remote client maintenance, and patch management.

	Management Scope
	Determines the scope of management for non-system administrators. They can manage all computers and users, or select specific computers and users.

	Object Management
	Specifies the range of removable storage groups that non-system administrators can view.

	Encryption Features
	Grants non-system administrator accounts permissions for encryption functions, including management rights and secure areas.


General Permissions:
	Permission
	Description

	Type
	

	System Administrator
	Only system administrators can view and manage authorized software and secure areas. System administrator icons display a five-pointed star; non-system administrators’ icons do not.

	Encryption Management & Approval
	Grants the ability to manage the encryption system, including approving encryption requests.

	Can Manage Other Accounts
	Allows creating and modifying permissions for other non-system administrators (modified permissions can exceed the administrator’s own), but cannot change their own permissions.

	Allowed Policy Level
	Specifies the maximum policy level the administrator can set, including Normal, Priority, and Highest. System administrators have full access by default; other administrators default to Normal level, which can be adjusted here.

	Login
	

	Single Console Login Only
	Prevents simultaneous logins to multiple consoles.

	Login Only on Specified Computers or IPs
	Restricts login to designated computer names or IP addresses.

	Proxy-Only Login
	Allows login only as a proxy administrator on the encryption client; console login is not permitted.

	Login to Encryption Management Only
	Allows login from the console directly to the encryption management system interface, without access to other AnySecura console functions.

	Account Management
	

	Allow Creating Sub-Accounts
	Checking this option grants the administrator permission to create sub-administrators. Administrators with this permission can go to Tools → Accounts in the console to create sub-administrators, whose permissions cannot exceed those of the parent administrator.

Only regular administrators can create sub-administrators; system administrators, as well as the Admin and Audit accounts, cannot enable this option.
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The "Allow Creating Sub-Accounts" option is available only for non-system administrators. System administrators, as well as the Admin and Audit accounts, cannot enable this option.
Administrator Functional Permissions
	Function Permissions
	Description

	Files
	Grants permissions for operations on the computer and user trees, such as creating groups, moving, renaming, deleting, as well as exporting data and printing.

	Control
	Grants permissions to control clients, including lock/unlock, sending notifications, logging off computer accounts, startup/shutdown, remote wake-up, and client uninstallation.

	Statistics
	Grants permissions to query statistical records, including application statistics, web browsing statistics, and network traffic statistics.

	Logs
	Grants permissions to query log records, including basic logs, application logs, web browsing logs, document operation logs, shared document logs, document printing logs, asset change logs, policy logs, system logs, backup document logs, and removable storage logs.

	Policies
	Primarily manages permissions for querying and modifying policies, including: viewing and configuring basic policies, application policies, web browsing controls, device controls, print controls, screen recording, log management, remote control, traffic management, network controls, email controls, instant messaging file controls, upload controls, document controls, system alerts, removable media authorization, custom configurations, software installation management, and cloud document backup policies.

	Monitoring
	Grants permission to query and export records such as screen activity, emails, and instant messages,including viewing live screens, checking email and instant messaging logs, reviewing screen history, and exporting screen history.

	Maintenance
	Primarily refers to permissions for maintaining remote computers,including viewing and managing remote information, performing remote control, and transferring files remotely.

	IT Asset Management
	Primarily refers to permissions for managing assets, including viewing asset information, configuring asset categories and attributes, and editing custom categories and attributes.

	Patch Management
	Primarily refers to permissions for managing system patches, including viewing patch information, configuring patch settings, and installing patches.

	Vulnerability Management
	Primarily refers to permissions for managing system vulnerabilities, including reviewing vulnerability scan results and configuring scan settings.

	Software Distribution
	There are two parts: permissions for managing distribution packages, including viewing and configuring packages; and permissions for managing distribution tasks, including checking task status and installation results, setting up tasks, and executing them.

	Software Uninstallation Management
	Primarily refers to permissions for managing software uninstallation, including viewing and configuring uninstallation tasks.

	Network Access Control
	Primarily refers to permissions for network access control, including viewing access status, configuring access settings, and managing related policies.

	All Category Management
	Primarily refers to permissions for managing various categories, including application categories, website categories, time categories, network address categories, network port categories, removable storage, software distribution package library, software uninstallation library, email categories, watermark template library, and sensitive information library.
Specifically:

Removable Media Library: includes viewing/configuring the library, registration control, managing encrypted drives, formatting as encrypted drives, initializing secure USB drives, secure USB interaction logs, and enabling/disabling registration control.

Watermark Template Library: includes viewing and configuring the library.

Sensitive Information Library: includes viewing and configuring the library.

	Desktop Security Management
	Primarily refers to permissions for managing desktop security functions, including viewing standard and approval requests, deleting requests, rejecting approvals, delegating approval permissions, viewing and configuring standard module approval workflows, and viewing and setting request permissions.

	Deletion
	primarily refers to permissions specifying which records can be deleted, including statistics, logs, emails, and instant messages.

	Data Backup
	Primarily refers to permissions for backing up and viewing data, including backing up logs and accessing data.

	Parameter Settings
	Primarily for configuring the server and mail report server, including server settings and mail report server settings.

	Security Check
	Primarily controls access to security check functions, including security check conditions, settings, logs, and status.

	Relay Server Management
	Primarily manages permissions for relay server functions, including viewing and configuring relay servers.

	Roles
	Primarily manages permissions for policy roles, including viewing, configuring, and assigning roles.

	Document Cloud Backup Server
	Primarily manages permissions for document cloud backup functions, including managing document permissions, configuring settings, viewing scan tasks and logs, and scheduling scan tasks.

	Sensitive Information
	Permissions for querying and modifying policies and logs.

Includes: Granting/revoking sensitive content identification permissions, viewing full-disk scan tasks and logs for sensitive information, configuring full-disk scan tasks for sensitive information, viewing/setting outbound control policies for sensitive information, viewing/setting sensitive information landing control policies for sensitive information, and viewing/deleting logs related to sensitive information.

	Watermark
	Permissions to configure and view screen, print, and document watermarking features.
Includes: Viewing/setting screen watermark policies, viewing/setting print watermark policies, viewing/setting document watermark policies, viewing/setting traceability policies for document circulation, viewing/setting document watermark permissions, viewing/deleting document watermark logs, viewing/deleting document circulation logs, querying watermark codes, using the document watermark extraction tool, viewing document numbering scan tasks and logs, and configuring document numbering scan tasks.

	AI Visual Perception


	ermissions related to visual awareness features.
Includes: Authorizing/revoking visual awareness access, viewing/configuring visual awareness settings, viewing capture logs, deleting capture logs, reviewing capture history, and exporting capture history.

	Application Permissions
	Permissions for the desktop request feature.
Includes: Viewing/setting request approval permissions, viewing/setting self-filing permissions, and viewing/deleting self-filing logs.

	Server Management
	Permissions for configuring server-related functions.
Includes: Managing domain organizational structures, administering distributed servers, performing remote server checks, and managing email reports.

	Client Management
	Permissions for managing client operations.
Includes:

Computer Management: Permissions for computer management. This permission requires the administrator's scope to cover all computers to take effect.

Client Upgrade Management: Permissions for managing client upgrades. This permission requires the administrator's scope to cover all computers and all users to take effect.

	Access Gateway
	Permissions related to connecting the AnySecura server to the access control server.
Includes: Viewing access control devices and configuring access control devices.

	Reporting System
	Permissions to access the reporting system.

	Auxiliary Functions
	Permissions to use auxiliary tools.
Includes: Generating client confirmation codes, creating client offline assistant tools, and generating client offline data collection tools.

	Product Upgrade
	Permissions for product maintenance and upgrade management, including updating maintenance codes, checking and downloading new versions, and receiving maintenance service expiration reminders.

	Software Center Server
	 Permissions to access the Software Center Server.


Object Management：

	Management Permission
	Description

	Removable Media Library
	Permissions to manage the removable media library. During permission assignment, only the "Registered" group is available for selection.
Administrators can only manage removable media classifications within their own object scope. Administrators with full management permissions for the entire removable media library will also have permissions for the "Uncategorized" group.


Encryption Features:
	Management Permission
	Description

	Document Encryption & Sharing
	Permissions for document encryption, decryption, and external sharing.

Includes: Enabling/disabling encryption, remote management of encrypted documents, encrypting/decrypting documents, external document sharing, and configuring document encryption algorithms.

	Authorized Software
	Permissions to manage the authorized software library.

	Security Zones
	Permissions to add, modify, and delete security zones.

	External Sharing Objects
	Permissions to configure external sharing objects and authorized external computers.

	Permission Settings
	Permissions to configure encryption policies on clients.

Includes: Viewing encryption permissions, setting encryption permissions, managing encryption system login/logout, viewing encryption parameters, configuring encryption parameters, viewing document backup policies, setting document backup policies, viewing long-term offline authorization, and setting long-term offline authorization.

	Encrypted Document Operation Logs
	Permissions to manage operation logs for encrypted documents.

Includes: Viewing encrypted document operation logs, viewing backed-up encrypted documents, and deleting encrypted document operation logs.

	Task Management
	Permissions to operate the full-disk scan feature.
Includes: Viewing full-disk scan tasks and logs, configuring encryption tasks, and configuring decryption tasks.

	Workflow Management
	Permissions for managing various types of requests.
Includes: 

· Viewing decryption requests and their approval status; deleting decryption requests; approving/denying decryption requests.

· Viewing external sharing requests and their approval status; deleting external sharing requests; approving/denying external sharing requests.

· Viewing temporary offline access requests and their approval status; deleting temporary offline requests; approving/denying temporary offline access requests.

· Viewing document property modification requests and their approval status; deleting property modification requests; approving/denying document property modification requests.

· Delegating approval permissions to other users.

· Viewing encryption approval workflows; configuring encryption approval workflows; enabling automatic approval rules.

	Standby Server
	Permissions to manage the standby server.

Includes: Viewing standby server details and configuring standby server settings.

	Document Backup Server
	Permissions to manage the document backup server.

Includes: Viewing document backup server details and configuring document backup server settings.

	USB Key Management
	Permissions to manage USB Key functionality.

Includes: Adding/removing USB Key information, modifying USB Key information, viewing USB Key logs, and deleting USB Key logs.

	Smart Device Management
	Permissions to use smart device management features.

Includes: Viewing smart devices, modifying smart device settings, and authorizing smart devices.


	Security Zones
	Description

	All Zones & All Levels
	Allows management of documents across all security zones and all classification levels.

	All Zones, Specified Level
	Allows management of documents in all security zones, but only those at or below a specified classification level.

There are five security levels: Non-sensitive, Internal, Confidential, Secret, and Top Secret.
Example: If the specified level is "Secret", the administrator can manage documents classified as Non-sensitive, Internal, Confidential, and Secret.

	Specified Zones & Levels
	Allows management of documents only within specified security zones and at or below their corresponding classification levels.


Administrators should assign security permissions based on actual needs and avoid granting unnecessary privileges.
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When configuring policies or creating new workflows through the console, administrators are not restricted by their own security zone or clearance level assignments.
18.2 Computer Management
The Computer Management feature allows administrators to manage client-module-equipped computers across entire network segments and enables users to check license usage details—such as the number of licenses currently in use and whether usage exceeds the licensed scope.
Additionally, in environments with large numbers of computers, hardware maintenance (e.g., replacing hard drives or network cards) may require reassigning client IDs to ensure devices are still recognized as the original clients after hardware changes. This reassignment can also be performed within the Computer Management interface.
18.2.1 Overview of the Computer Management Window
To access the Computer Management window, navigate to Tools > Client Management > Computer Management. The interface consists of a query bar, a computer authorization information list, and a computer identification information list.
The Computer Authorization Information List includes the following details:
	Field Name
	Description
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	This icon indicates the computer is within the licensed scope and is authorized. Computers without this icon exceed the license limit. Check the "Authorization Information" to view purchased licenses and current usage counts.

	Name
	The display name of the client computer in the console.

	ID
	The unique ID assigned to the client by the server.

	Network Address
	The IP address used by the client.

	MAC Address
	The MAC address and IP address of the client.

	Group
	The computer group to which the client belongs.

	Status
	The current operational status of the client (e.g., Online, Offline).

	Conflict
	Indicates whether the client has a conflict. Blank means no conflict; "Yes" indicates a conflict exists.

	Last Seen
	The last time the client was active.

	Installation Time
	The installation time of the client.

	Version
	The version information of the client.

	Offline Days
	The number of days the client has been offline.


Click any record in the Computer Authorization Information List to view its associated identification details in the Computer Identification Information List at the bottom of the Computer Management window.

The Computer Identification Information List includes the following fields:
	Field Name
	Description

	[image: image453.png]



	A red checkmark on this icon indicates that the client is currently using this identification record.

	Operating System
	The operating system information of the client.

	Hard Disk ID
	The hard disk ID information of the client.

	MAC Address
	The MAC address of the client.

	Computer Name
	The hostname of the client computer.

	First Seen Time
	The time when the client first connected to the server.


Administrators can quickly locate specific computer information using the following search criteria: 

	Search Criteria
	Description

	All
	Default query for all computers with the client module installed.

	By IP Address
	Search for clients within a specified IP address range.

	By Last Seen Date
	Search for clients whose last active date falls within a specified range. Useful for locating inactive clients.

	By Client ID
	Search for a specific client using its unique Client ID.

	By Name
	Search by the client's display name in the console. Supports fuzzy matching.

	By Offline Days
	Search for clients that have been offline for a specified number of days.

	By Status
	Search based on the client's operational status (e.g., Online/Offline) as shown in the console.

	By MAC Address
	Search by the MAC address of the client as displayed in the console.

	By Hard Disk ID
	Search using the Hard Disk ID shown in the Computer Management > Identification Information section.


In the Computer Authorization Information panel, several auxiliary function buttons are provided with the following descriptions:
	Operation
	Description
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	Export the computer authorization list to an HTML, XLS, or CSV file.
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	Print the computer authorization information list.
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	Preview the computer authorization information list before printing.
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	Delete: Administrators can remove unwanted clients to free up licenses. Deletion uninstalls the client and reduces license count.
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	Uninstall: Uninstalls the client without reducing license count.

	[image: image459.jpg]



	Encryption Management: Enable or revoke encryption authorization for selected clients.
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	Sensitive Information Identification Management: Enable or revoke sensitive data identification authorization for selected clients.
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	Secure Desktop Management: Enable or revoke secure desktop authorization for selected clients.


After performing delete or uninstall actions, administrators must click the 【Confirm】 button to apply the changes. Otherwise, the operations will not take effect. This measure is designed to prevent accidental modifications.
18.2.2 Reassigning a Client ID
Reassigning a client ID is typically required in two scenarios:
1. Resolving conflicts: If two enterprise computers swap hard drives and later connect simultaneously, they may be recognized as the same client. The console will display a conflict warning, and the client entry in the Computer Authorization Information list will appear in red. Clicking the entry will reveal two or more identification records.
2. Hardware replacement: If a computer’s hard drive or network card is replaced due to damage, the device may be detected as a new client. The newly identified client must be reassigned to the original client ID.
Steps：

1）In the Computer Authorization Information list, select the client requiring reassignment and click its identification record.
2）Click the 
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 button in the upper-right corner of the list to open the Computer Identification Settings. Two options are available:
A. Assign a new client to the identification record: Reassign a new ID to the identification record, with an optional custom name. The reassigned client will appear in the "Ungrouped" section of the console's computer tree.
B. Move the identification record to an existing client: Manually enter an existing client ID or use the Select button [image: image463.png]


 to choose an existing client. For example, if assigning record B to existing client A, client A’s name in the console will automatically update to match record B’s name.
18.2.3 Viewing Client Identification Tracking Logs
Due to factors such as operating system updates, hard drive replacements, or network card changes, a client's identification information may be altered. The Client Identification Tracking Log allows administrators to review historical changes to client identification records.
Steps:
1）In the Computer Authorization Information list, select the client for which you want to view the identification tracking log, and click its identification record.
2）Click the [image: image464.png]


 button in the upper-right corner of the list to query the Client Identification Tracking Log. The log includes the following information:
	Field Name
	Description

	Time
	The timestamp when the client logged in or came online.

	Identification Method
	The method used to identify the client.

	Match Result
	The result of the client identification matching process.

	ID
	The unique ID of the client.

	Name
	The name of the client.

	Operating System
	The current operating system of the client.

	OS Directory
	The operating system directory of the client.

	Network Address
	The network address (IP address) of the client.

	MAC Address
	The MAC address of the client.

	Hard Disk ID
	The hard disk ID information of the client.


If identification information changes, corresponding log entries will be generated, and differences between previous and updated values will be highlighted in red.
18.3 USB Encryption Client Management
Navigate to Tools > Client Management > USB Encryption Client Management to centrally manage USB encryption clients. Only authorized USB encryption clients will appear in the list within this window.
The USB encryption client list includes the following attributes:
	Attribute Name
	Description

	UDiskID
	The unique identifier of the USB drive configured as an encryption client. This ID remains unchanged even after formatting.

	Name
	The name assigned during the authorization of the USB encryption client.

	Group
	The computer tree group to which the USB encryption client belongs.

	Authorization Status
	The authorization status of the USB encryption client (e.g., Authorized, Unauthorized).

	Version
	The version of the USB encryption client.

	Expiration Time
	The expiration date set during the authorization of the USB encryption client.

	Installation Time
	The time when the USB drive was configured as an encryption client.

	Last Online Time
	The last time the USB encryption client connected to the server.

	Authentication Interval
	The set authentication interval for the USB encryption client.


Operations for USB Encryption Clients:
	Operation
	Description
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	Grant authorization to a USB encryption client. Authorized clients are marked with an icon[image: image466.png]


；
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	To delete a client, the USB drive must be physically inserted into the console-running machine. After deletion, the USB drive must be fully reconfigured to regain encryption client functionality.
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	Adjust authorization settings for the USB encryption client. Options include Global Settings (default) and Custom Settings.
Custom settings override global settings. Clients with custom password settings are marked with a * prefix before their UDiskID.
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	Export the policy configuration file for the currently selected USB encryption client.
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	Reactivate a previously disabled USB encryption client.
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	Disable the client, revoking its encryption capabilities until re-enabled.
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	Configure password complexity requirements, including Global Settings (default) and Custom Settings.
Custom settings override global settings. Clients with custom password complexity rules are marked with a # prefix before their UDiskID.


When authorizing a USB encryption client, the configuration options are as follows:
	Setting Item
	Description

	Import Removable Disk Info
	Import the authorization file required for setup.

	File Path
	Select the exported USB information file (with .uea extension).

	Removable Disk Authorization Info
	Configure authorization details for the USB drive.

	UDiskID
	The unique identifier of the USB drive, automatically generated by the system and cannot be modified.

	Removable Disk Name
	Assign a name to the USB drive, which will be displayed in the console's computer tree.

	Group
	Specify the group to which the USB client belongs.

	Valid Until
	Set the expiration date for the USB client's authorization. Beyond this date, encryption features will be disabled. If left unchecked, the authorization remains permanent.

	Authentication Interval
	Enable this option and set a number of days. The client must connect to the server at least once within this period; otherwise, it will expire and lose encryption functionality.


USB Encryption Client Password Settings:
	Setting
	Description

	Change Password at First Login
	If enabled, the user must change the password upon first login. The USB client cannot be used until the password is updated.

	Password Complexity
	Settings for password strength requirements.

	Password Cannot Be Empty
	If enabled, an empty password will be rejected. The user must set a non-empty password to log in.

	Minimum Password Length
	If enabled, passwords shorter than the specified length will be rejected. The user must meet the length requirement to log in.

	Password Complexity Validation

	If enabled, passwords failing complexity rules (e.g., lacking uppercase letters, numbers, or symbols) will be rejected. The user must comply with the rules to log in.
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 to view complexity requirements.

	Password Attempt Limit
	Settings for limiting incorrect password attempts.

	Enable Password Attempt Limit
	If enabled, the USB client will be locked after exceeding the specified number of failed attempts. The lock can be temporary (e.g., 30 minutes) or permanent until manually unlocked.


[image: image474.bmp] Note
If a USB encryption client is permanently locked, the lock can be removed by resetting the password.
18.4 Alert Messages
Alert messages record real-time alarm logs, accessible via Tools > Alerts. If the console has enabled "Pop-up Alert Bubbles", notifications will appear as pop-up bubbles on the console machine when alarm conditions are met. Click these bubbles to view all real-time alert records.
Alert messages primarily include: Policy-Triggered Alerts、Server Alerts、Client Exception Alerts
1. Policy-Triggered Alerts
For all AnySecura policies, if the "Alert" option is enabled during policy configuration, triggering the policy will generate a pop-up bubble notification on the console machine and log the event in Tools > Alerts.
2. Server Alerts
These alerts are defined by the AnySecura server's internal mechanisms. Relevant scenarios will trigger pop-up bubble notifications on the console. Key server alerts include:
	Alert Name
	Description

	Client Login Conflict
	Triggered when two clients are identified as the same device, indicating a login conflict.

	Insufficient Space in ZTEMP Directory Partition
	Alert when the disk partition containing the cache directory has less than 512MB of free space.

	Insufficient Space in DATA Directory Partition
	Alert when the disk partition containing the data directory has less than 512MB of free space.

	New Computer Detected
	Alert when a new computer is detected on the network.

	Detect Long-Term Offline Clients
	An alert is triggered when a client remains offline beyond the specified duration.
Enable the client offline alert in the console under Tools > Options > Console Settings > Real-Time Alerts, and set the threshold in days.

	Insufficient Plain Text Backup Server Space
	Alert when the free space on the disk containing the plain text backup path falls below a specified value.

Set the threshold in: Right-click the encrypted document backup server icon → Tools > Options → Space Management Settings → Space Alert Threshold.

	Plain Text Backup Server Stopped Collection
	Alert when backup stops due to insufficient space on the disk containing the plain text backup path.

Set the threshold in: Right-click the encrypted document backup server icon → Tools > Options → Space Management Settings → Stop Backup Threshold.

	Database Access Error
	Alert when an error occurs while accessing the database during a backup task. The alert message includes error details.

	Server Computer Time Trust Status
	Alert when the last recorded time by the server does not match the current system time. The alert prompts whether to trust the current system time.


3. If client exception alerts are enabled in the console under Tools > Options > Console Settings > Real-Time Alerts, an alert is triggered whenever abnormal clients are detected. The alert message displays a list of the affected clients.
Real-time alerts can display up to 500 records by default. Administrators can adjust the maximum number under Tools > Options > Real-Time Alerts > Alert Window.

Alert messages record only real-time alerts. When the console is closed or re-logged in, records are automatically cleared.

· To review policy-triggered alerts, go to Logs > Policy Logs.

· To review server alerts, go to Logs > System Events and search by keyword.

· Client exception alerts cannot be queried; check current abnormal clients under Tools > Network Access Detection.
18.5 Mail Report Settings
Real-time alert information can be sent to designated email addresses via the mail server, allowing administrators to receive and respond to alerts promptly.
Before using the mail report feature, the system administrator must configure the mail report server under Tools > Options > Mail Report Server Settings.
Once the mail report server is configured, proceed to Tools > Mail Report Settings to view, add, or modify mail report configurations.
	Icon Buttons
	Action
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	Add mail configuration
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	Delete mail configuration


The alert notification email requires the following parameters:
	Parameter
	Description

	Name
	A user-defined description for the mail configuration. When adding a configuration, the console provides a default name, but administrators can customize it.

	Mail Subject
	Sets the subject of the mail report.

	Maximum Alerts
	The maximum number of alerts included per email. If exceeded, remaining alerts are sent in the next email. Default is 100.

	Minimum Alert Level
	Default is “All,” sending alerts of all levels. Selecting “Low” sends Low, Important, and Critical alerts; selecting “Important” sends Important and Critical alerts.

	Send Interval
	Specifies the time interval between emails. Default is 30 minutes.

	Recipient Address
	Email address that receives the alert information.

	Send Test Email
	Tests whether the email can be delivered to the recipient.

	Send as Attachment
	If checked, alerts are sent as an attachment. Default is unchecked (sent in email body).

	Attachment Password
	When sending as an attachment, a compressed file is sent, which can be password-protected.

	Alert Type
	Specifies the policy types for which alert emails are sent, e.g., application control policy, web browsing control policy, system alert policy, etc.

	Computer Scope
	Specifies the range of computers included in the mail report.

	User Scope
	Specifies the range of users included in the mail report.


[image: image477.bmp] Note
The computer scope and user scope have an “OR” relationship. An email will be sent if either scope includes the target.
All administrators can view, modify, and delete the mail reports they created. The system administrator (admin) can also view and delete mail reports created by other administrators, but cannot edit them.

Mail sending details, such as send time, sender address, and delivery status, can be viewed under Logs > System Events.
18.6 Network Access Gateway Management
The network access control function based on access devices requires a connection between the server and the access devices. Click Tools > Network Access Gateway Management to add, delete, or modify access devices.
	Icon Buttons
	Description
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	Add an access device
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	Modify access device information, including display name and device IP
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	Delete an access device. After deletion, the connection between the server and the device is disconnected, but the device’s disaster recovery settings remain active. To fully remove them, log in to the access device management interface and delete the corresponding server under Server Management.


A server can connect to multiple access devices. In the access device list, you can view information about each device, including controller IP, connection status, and last connection time.
	Property Name
	Description

	Controller IP
	The IP address of the access device.

	Connection Status
	The current connection status between the access device and the server includes:
Connected: The device and server are connected normally
Disconnected: The device and server failed to connect
Disabled: The server is disabled on the device’s web management interface
Rejected: The server is removed from the device’s web management interface

	Last Connection Time
	Last Connection Time


18.7 Policy Application Query
Click Tools > Policy Application Query to view all configured policies. Through the policy library, administrators can clearly see which policy is applied to which client, as well as the policy details, such as whether it is enabled and whether it applies to computers or users. Administrators can search policies by name.
18.8 Client Tools
Confirmation Code Generator
When a client machine cannot connect to the server—such as when the network card is disabled or the user is traveling—but temporary policy removal or client uninstallation is needed, the console cannot be used to apply the changes.
Users can directly run the client tool on the client machine using the following steps:
1) On the client machine, hold Ctrl + Alt + Shift and type the string secureat to open the client tool.
2) Select Clear All Policies and click Generate Operation Code.
3) A Verify Operation Code dialog will appear. The user must report the original operation code to the administrator.
4) The administrator enters the client’s operation code in the console under Tools > Client Tools > Confirmation Code Generator to parse the operation and client information.
5) After verification, the administrator clicks Generate Confirmation Code.
6) The administrator provides the confirmation code to the client, who enters it to continue the specified operation.
For detailed instructions on uninstalling the client using the client tool, refer to the Installation and Deployment section.
Client Offline Assistant Tool
Temporary policy removal or client uninstallation can also be performed using the Client Offline Assistant Tool. Follow these steps:
1) In the console, go to Tools > Client Tools > Client Offline Assistant Tool to open the tool. You can choose to temporarily clear client policies or permanently uninstall the client.

2) After selecting the desired operation, click Next. Set the number of allowed executions, the validity period, and an optional password required to run the tool.

3) After configuration, choose an export path to generate the temporary policy removal tool. The exported tool is an EXE file; copy it to the offline client and run it to execute the operation.
Client Offline Data Collection Tool
Some clients may remain offline for extended periods, yet administrators still need to monitor their usage regularly. The Client Offline Data Collection Tool allows collecting and uploading data from offline clients. Follow these steps:
1) In the console, go to Tools > Client Tools > Client Offline Data Collection Tool to open the tool.
2) Select the path to store the tool, set an optional password and validity period, and configure data collection and clearing options as needed. Click Create to generate the Client Offline Data Collection Tool, which includes:
Data Collection and Clearing
Collect All Client Data: By default, the tool’s Data Collection and Clearing tab lists the available offline log types and time ranges for selection. If this option is checked, the tab will hide the log selection list and display a One-Click Collect button. Clicking it collects all offline logs from the client.
Exclude Backup Files in Logs: By default, the tool collects both logs and any backup files within them. If this option is checked, only the logs are collected, excluding the backup files.
Allow Data Clearing with Upload Code: This option is enabled by default. Successfully uploaded data files carry a data upload completion code. In the Data Collection and Clearing tab, clicking Clear and entering the corresponding code deletes the related locally stored client data that has already been uploaded.
Data Management Settings
Hide Data Management Page: By default, the tool displays the Data Management tab, which allows uploading offline data. Checking this option hides the Data Management tab.
3) Send the generated offline data collection tool to the offline client and run it there. In the tool’s Data Collection tab, select the time range and data type, then click Backup. After completion, an odtb folder will appear in the same directory as the tool.
If Collect All Client Data was selected during generation, simply click One-Click Collect to gather all data.
4) Send the offline data collection tool along with the odtb folder to an online client and run it there. In the Data Management tab, select the collected offline data and click Upload, then wait for the upload to complete.
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1. Only servers with a valid serial number and registration can use the offline client data collection feature.
2. For offline clients that have never been online, uploading offline data for the first time will create a node for the client under Ungrouped in the computer structure tree.
18.9 Server Time
If the server time is incorrect—for example, if the system time on the server machine is manually set days ahead or behind—it can seriously affect the product’s stability and security. Many functions, such as policy validity, data generation time, and automatic clearing, rely on accurate server time.
When an abnormal server time is detected, a bubble alert appears when the administrator logs into the console and will continue to remind periodically. The administrator must correct the server’s operating system time and re-establish trust in the console.
Go to Tools > Server Management > Server Time to view the current server time. If the administrator confirms that the server time is correct, clicking Trust will stop the console from showing the alert bubble.
18.10 Relay Server Management
When deploying a relay architecture, the server can connect to multiple relays. Go to Tools > Server Management > Relay Server Management to manage the relays connected to the server.
Authorization
After setting the relay’s connection parameters, it must be authorized from the console connected to the corresponding server.

In the console, go to Tools > Server Management > Relay Server Management, select the relay in the structure tree on the left, and choose Authorize from the right-click menu. Once successful, the relay’s status in the display view on the right will change to Authorized. To revoke authorization, select an authorized relay, right-click, and choose Revoke Authorization; the relay will return to the Unauthorized status.
View Basic Information
Select the main server and choose Basic Information to view its details, including:
	Property Name
	Description

	Status Information
	Information about the main server’s status

	Name
	Always displayed as <Main Server>

	Network Address
	The IP address of the main server machine

	Version
	The current version of the main server

	Total Client Connections
	Total number of clients connected to the main server

	Online Clients
	Number of clients currently online and connected to the main server


Select the repeater and choose 'Basic Information' to view the basic information of the repeater, including:
	Property Name
	Description

	Status Information
	Information about the relay’s status

	Name
	The relay name shown in Tools > Server Management > Relay Server Management; defaults to the relay machine’s computer name and can be renamed in the console

	Computer
	The computer name of the relay machine

	Applicant
	The applicant set when configuring the relay’s connection parameters

	Network Address
	The IP address of the relay machine

	Running Status
	Includes: “Unauthorized, disconnected from main server,” “Connected, not authorized,” “Connected, authorized”

	Start Time
	The time the relay was started

	Uptime
	The duration the relay has been running since startup

	Connection Status
	The connection status with the main server. Displays Connected if successful, Failed if there is an issue

	Last Connection Time
	The most recent time the relay connected to the main server

	Authorization Status
	Whether the main server has authorized the relay: Authorized or Unauthorized

	Authorization Update Time
	The last time the main server updated the relay’s authorization

	Total Client Connections
	Total number of clients connected to the relay

	Online Clients
	Number of clients currently online and connected to the relay

	Scope Settings
	Scope configuration information of the relay

	Management Scope
	The management scope assigned to the relay

	Exclusion Scope
	The exclusion scope assigned to the relay


Scope Settings
Select Scope Settings to configure the relay’s management scope, exclusion scope, and other related settings.
	Setting
	Description

	Management Scope
	Sets the range of client IP addresses the relay can manage.

Supports IP range and subnet mask formats:

IP range format: 192.168.0.1-192.168.0.100

Subnet mask format: 192.168.2.1/24
Default is empty, meaning all clients are managed. If set to 192.168.0.1-192.168.0.100, only clients within this IP range will connect to and be managed by the relay.

	Exclusion Scope
	Sets the range of client IP addresses excluded from relay management.

Default is empty, meaning no clients are excluded. If set to 192.168.0.1-192.168.0.100, clients within this IP range will not connect to or be managed by the relay.

	Active Polling
	If checked, the relay server will actively connect to port 8235 of clients within the management scope. If unchecked, the server will not actively connect to clients.

Default is unchecked.


Pre-Forwarding Traffic
Pre-forwarding traffic settings use traffic policies to limit communication between the main server and relays.

Various management operations can be performed on the policies:
	Icon Button
	Description
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	New——Click to create a new policy
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	Modify——Click to create a new policy
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	Delete——Click to delete a selected policy
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	Move Up——Click to delete a selected policy
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	Move Down——Move the selected policy down one position


Click the New button[image: image487.jpg]


 to configure traffic settings and data types, creating a new traffic policy. Multiple traffic policies can be created. After setting or modifying a policy, click the Save button[image: image488.png]o



 to apply the changes.
The parameters for creating a new pre-forwarding traffic policy are as follows:
	Parameter
	Description

	Traffic Settings
	

	Restriction Time
	The time period when the policy is effective, including: All day, Work hours, Rest hours, Weekends, or Custom. Time categories can also be pre-defined in Time Category Management.

	Limit Relay-to-Server Traffic
	Restricts traffic sent from the relay to the main server (KB/s). Enter an integer value. If unchecked, no limit is applied.

	Limit Relay Receive Traffic
	Restricts traffic received by the relay from the main server (KB/s). Enter an integer value. If unchecked, no limit is applied.

	Limit Total Send/Receive Traffic
	Restricts the combined send and receive traffic between the relay and the main server (KB/s). Enter an integer value. If unchecked, no limit is applied.

	Data Types
	

	Prohibited Data Types
	If checked, select the specific data types to block. During the restriction time, the selected data types will be prohibited for sending and receiving. If unchecked, no data type restrictions are applied.


Policy Matching Principle
Policies are matched from top to bottom. Once a valid policy is matched, only that single policy takes effect, and no further policies are evaluated.
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A policy is considered valid when it is checked (enabled).
Post-Forwarding Traffic
Post-forwarding traffic settings use traffic policies to limit communication between a relay and its connected clients.
	Icon Button
	Description
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	New——Click to create a new policy
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	Modify——Click to modify a selected policy
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	Delete——Click to delete a selected policy
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	Move Up——Move the selected policy up one position
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	Move Down——Move the selected policy down one position


Click the New button [image: image495.jpg]


 to set the network address, restriction time, and traffic settings, creating a new traffic policy. Multiple policies can be created. After setting or modifying a policy, click the Save button [image: image496.png]o



 to apply the changes.
The parameters for creating a new policy are as follows:
	Parameter
	Description

	Network Address
	The network address range where the policy applies. Options include: All, LAN, WAN, Enterprise Network, Internet. Custom ranges can also be defined in Category Management.

	Restriction Time
	The time period when the policy is effective, including: All day, Work hours, Rest hours, Weekends, or Custom. Time categories can also be pre-defined in Time Category Management.

	Traffic Settings
	

	Total Traffic
	Limits the total traffic for all IPs within the network address range. You can restrict traffic sent from the relay to clients, received from clients, or the combined send/receive traffic. Each value is an integer; leaving it unset means no limit.

	Per-IP Traffic
	Limits traffic for each individual IP within the network address range. You can restrict traffic sent from the relay to clients, received from clients, or the combined send/receive traffic. Each value is an integer; leaving it unset means no limit.


Policy Matching Principle
Policies are matched from top to bottom. Each IP will match only one Per-IP Traffic limit and one Total Traffic limit.
1、Policies are matched according to priority.
2、Each policy can include both Total Traffic and Per-IP Traffic limits. When a policy is matched, both the total and per-IP traffic restrictions are applied simultaneously.
Advanced Settings
Advanced settings allow configuration of load balancing for relay servers, maximum number of connections, and whether the relay server is designated as a backup.
	Property Name
	Description

	Enable Load Balancing
	Check this option to enable load balancing. 
This function evenly distributes clients across multiple deployed relays, ensuring each relay efficiently utilizes resources.

	Rated Connections
	Default is 1000; can be adjusted. 
Increase the value if the relay machine has high performance, or decrease it if performance is lower.

	Specified Load Rate
	Default is 0; can be set to another value.
If 0: clients on this relay are migrated according to the load balancing algorithm when its load rate (current connections ÷ rated connections) exceeds that of other relays, until overall balance is achieved.
If set to another value: clients are migrated only when the relay’s load rate exceeds the specified value; no migration occurs if the load rate is below the specified threshold.

	Maximum Connections
	The maximum number of clients that can connect to this relay. Default is unchecked; if enabled, the default maximum is 3000, and it can be set to another value.

	Set as Backup Relay
	Check this option to designate the relay as a backup. Clients will connect to it only if all regular relays are unreachable. If the backup relay is also unreachable, clients will connect to the main server. If unchecked, the relay functions as a regular relay. 
Default is unchecked.


[image: image497.bmp] Note 
1. Clients perform load balancing only among relays with the same connection priority level.
2. Load rate is calculated as: current connections ÷ rated connections.
Load Balancing Example 1
Within the company, Relay A and Relay B are deployed, each capable of handling all 1,500 clients. Without load balancing enabled, Relay A connects to 1,000 clients, while Relay B connects to 500 clients.
Scenario 1: Relay A and Relay B Have Similar Performance
Load balancing can be configured as follows:
Enable load balancing on Relay A, set rated connections to 1000, and specified load rate to 0.
Enable load balancing on Relay B, set rated connections to 1000, and specified load rate to 0.
Effect:
Relay A’s load rate is 1000 ÷ 1000 = 100%, and Relay B’s load rate is 500 ÷ 1000 = 50%. Since Relay A’s specified load rate is 0 and its load rate is higher than Relay B’s, some clients on Relay A will migrate to Relay B until the load is balanced.
Scenario 2: Relay A Has Higher Performance than Relay B
In this case, more clients can connect to Relay A.
Policy 1:
Enable load balancing on Relay A, set rated connections to 2000, specified load rate to 0.
Enable load balancing on Relay B, set rated connections to 1000, specified load rate to 0.
Effect:
Relay A’s load rate is 1000 ÷ 2000 = 50%, and Relay B’s load rate is 500 ÷ 1000 = 50%. Both relays have the same load rate, so clients do not switch. The higher-performance Relay A handles more clients than the lower-performance Relay B.
Alternatively, without changing rated connections, adjusting the specified load rate allows Relay A to handle more clients than Relay B.
Policy 2:
Enable load balancing on Relay A, set rated connections to 1000, specified load rate to 120.
Enable load balancing on Relay B, set rated connections to 1000, specified load rate to 0.
Effect:
Relay A’s load rate is 1000 ÷ 1000 = 100%, and Relay B’s load rate is 500 ÷ 1000 = 50%. Although Relay A’s load rate is higher than Relay B’s, it does not exceed its specified load rate of 120%, so clients on Relay A will not migrate.
Client Information
Select Client Information to view details of clients connected to the current server or relay.
	Field Name
	Description

	Name
	The name displayed in the computer tree. Can be renamed for easier management; if not changed, it defaults to the computer name.

	Computer
	The client’s actual computer name.

	Computer Group
	The group to which the client belongs.

	Network Address
	The IP address used for communication between the client and the server/relay.

	Status
	The client’s current status: Running, Offline, or Client Uninstalled.

	Last Online Time
	The last time the client communicated with the server/relay.

	Server Name
	The name of the server or relay the client is connected to.


18.11 Policy and Library Synchronization Management
When library information changes, the server synchronizes the latest policies and library data to client machines.
Select Tools -> Server Management -> Policy and Library Synchronization Management to view the synchronization status of policies and libraries on each client.
By default, online clients with policies or library status marked as Not Synchronized are displayed. Click the Query button[image: image498.jpg]


 to modify search criteria and quickly locate specific results. In the Query Results dropdown menu, you can choose which data columns to display.
If a client’s policy or library synchronization time is earlier than the corresponding modification time, the status shows Not Synchronized, and the synchronization time is displayed in red, indicating the client has not received the latest policies or library updates.
Click the icon button[image: image499.jpg]


 to view the library’s last modification time. Double-click a client in the synchronization view to see detailed synchronization information for that machine’s policies and libraries.
18.12 Organizational Structure Synchronization
The organizational structure synchronization feature allows the AD domain structure to be synced to the AnySecura server. Computers and users in the AD domain that are not yet connected to the server can be pre-assigned to groups. When a client connects to the server, it is automatically placed into its designated group.
Select Tools -> Server Management -> Organizational Structure Synchronization to access the Organizational Structure Synchronization management interface.
18.12.1 Synchronization Configuration
Select Organizational Structure Synchronization -> Synchronization Configuration to add, modify, delete, or execute synchronization for AD or LDAP servers. You can also view the synchronization configuration details.
Icon Button Description
	Icon
	Description
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	Add a synchronization configuration.
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	Modify the selected synchronization configuration.
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	Delete the selected synchronization configuration.
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	Execute the selected synchronization configuration immediately.
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	View the selected synchronization configuration to see its execution results; if none is selected, display results for all configurations.


[image: image505.bmp] Note
When viewing a synchronization configuration:


If the target is set to Users, the synchronization results are immediately visible in the configuration view after execution.


If the target is set to Computers, and no computers have connected to the server yet, only the synchronized computer group structure is visible; individual computers will appear in the corresponding groups only after installing the client and connecting to the server.
Add Configuration
Click the icon [image: image506.png]


 or select Add Configuration from the right-click menu in the Synchronization Configuration interface to create a new synchronization configuration. When adding a configuration, you need to set the AD connection and specify the synchronization targets.
	Parameter
	Description

	Connection Settings
	Enter AD or LDAP server details so the server can connect and retrieve the organizational structure.

	Configuration Name
	Name of the configuration; if left blank, the domain name will be used by default.

	Server Type
	Select the server type: Domain Server or LDAP Server.

	Domain Name
	The domain name of the server to be synchronized.

	Domain Server Address
	The IP address of the server to synchronize.
If LDAP Server is selected, click Advanced to configure the LDAP port, protocol version, SSL usage, and whether to use anonymous connection.
If Anonymous Connection is not checked, manually enter the specified username and password.
Username format: cn=xx,ou=xx,dc=xx,dc=xx
Example: For LDAP domain Dep.com, with user userA in group Sales, to log in as userA, enter:
cn=userA,ou=Sales,dc=Dep,dc=com
Password: Enter the password corresponding to userA.


	Login Account
	If a Domain Server is selected, enter a domain user account authorized to access the AD structure.

	Password
	Password for the AD domain login account.

	Enable Automatic Synchronization
	Default is unchecked. Check this option and set the synchronization interval to enable automatic synchronization according to the specified interval.

	Object Settings
	Specify which domain objects (including domain computers and users) are synchronized to designated locations on the server. A single synchronization configuration can contain multiple object settings, enabling multiple synchronization relationships.
Icons at the top-right of the Object Settings section allow Add, Modify, Delete, and Preview actions. Click the icon[image: image507.png]


 to add an object setting. Detailed parameter explanations are provided below.

	Source Settings
	onfigure the source for the domain synchronization, specifying which organizational units (OUs) in the domain to synchronize.After configuring the connection settings, click Test Connection. Only when the connection succeeds can the source settings be selected.

	Source Selection
	Click the icon button[image: image508.png]


to choose the groups to synchronize. Multiple selections are supported, but cross-level selection is not allowed.

	Exclusion List
	Click the icon button[image: image509.png]


to select objects to exclude from synchronization. Excluded objects will not be synchronized. You can select one or more computers, users, or organizational units, including across levels.

	Target Settings
	Specify where the selected domain organizational units will be synchronized in the console. Supports synchronization to computer groups and user groups.

	Computer Group
	Click the icon button[image: image510.png]


to select the target computer group in the console for synchronization. The selected source structure will sync to this target, and domain computers will be automatically assigned to the corresponding group after installing the client.When setting the computer group, a synchronization mode must be selected. See the Synchronization Mode section for details.

	User Group
	Click the icon button [image: image511.png]


 to select the target user group in the console for synchronization. All users in the selected source structure will be synchronized to this target location.

	Other Settings
	Miscellaneous settings

	Do Not Import Empty OUs
	If checked, OUs with no objects in the source will not be imported; if unchecked, all selected OUs will be imported. Checked by default.

	Sync Disabled Objects
	If checked, disabled objects in the source will be synchronized; if unchecked, disabled objects will not be synchronized. Unchecked by default.


The synchronization modes are explained as follows:
	Mode Name
	Description

	Sync Only Source Computers
	Only clients corresponding to computers in the source domain OUs are synced to the console’s computer groups.

	Sync Only Source Users
	Only clients corresponding to users in the source domain OUs are synced. When a client connects, the logged-in user is matched to the source users; if a match is found, the client is synced to that user’s group. If no match, the client is placed in “Ungrouped.”

	Sync Source Computers and Users (User Priority)
	Synchronize client machines to the console’s computer group based on both computers and users from the source domain organizational units. 
After a client installs the client software and connects to the server, the logged-in user on the client is first matched against the source users. If a match is found, the client is synced to that user’s group in the source; if no user match is found, the client computer is then matched against the source computers. If a computer match is found, the client is synced to that computer’s group in the source.
If neither user nor computer matches, the client is assigned to the ungrouped category.

	Sync Source Computers and Users (Computer Priority)
	Synchronize client machines to the console’s computer group based on both computers and users from the source domain organizational units. 
After a client installs the client software and connects to the server, the client computer is first matched against the source computers. If a match is found, the client is synced to that computer’s group in the source; if no computer match is found, the logged-in user on the client is matched against the source users. If a user match is found, the client is synced to that user’s group in the source.
If neither computer nor user matches, the client is assigned to the ungrouped category.


18.12.2 Synchronization Logs
Select Organization Structure Sync -> Synchronization Logs to view logs of organizational structure synchronization.
The synchronization log contains the following details:
	Attribute Name
	Description

	Operation Type
	Includes: Add, Move, Rename, Failure.

	Object Type
	Type of synchronized object, including Computer, Computer Group, User, User Group.

	Object Name
	Name of the synchronized object.

	Description
	Description of the event corresponding to the object type.


[image: image512.bmp] Note
When organization structure synchronization is abnormal, check the synchronization logs to identify the cause of the error.
Synchronization logs can be queried using the following criteria:
	Query Criteria
	Description

	Time
	General query condition.

	Operation Type
	Defaults to All; you can also select a specific operation type from the dropdown.

	Object Type
	Filter by object type to view synchronization logs for a specific type.

	Object Name
	Search by object name to find logs for a specific object; supports fuzzy search.

	Description
	Search by description; supports fuzzy search.


18.12.3 Exception Objects
For computers or users that need to be assigned to specific groups and should not follow the AD organizational structure, they can be set as exception objects. During manual or automatic synchronization, exception objects will not be synchronized.
Select “Organization Sync -> Exception Objects” to add, modify, or delete exception objects. Once the AD organizational structure has been synchronized to the server, manually moving a computer or user within the synchronized range in the console’s structure tree will trigger a confirmation prompt. Confirming the move will automatically set these objects as exception objects.
18.13 Client Upgrade Management
After the server is upgraded, the client upgrade packages are updated. Once the server distributes the clients and upgrade packages, clients will automatically install the updates. After a restart, the upgrade is complete.
By default, clients do not upgrade automatically, meaning the server will not distribute upgrade packages automatically. Settings for automatic upgrades must be configured through Client Upgrade Management.
Select “Tools -> Server Management -> Client Upgrade Management” to view the current client upgrade package version on the server. Through the upgrade settings, clients can be set to automatically upgrade or downgrade to match the server version.
	Parameter
	Description

	Upgrade Settings
	

	Package Version
	Displays the current upgrade package version. The dropdown menu on the right allows selecting the upgrade setting.

	No Upgrade
	Selecting this option prevents all clients from upgrading.

	Auto Upgrade
	Selecting this option enables all clients to automatically upgrade to the latest version.

	Only Upgrade to XX Version
	This option locks the upgrade version and will display the specific version based on the current upgrade package on the server. Once a specific version is locked, clients will only upgrade to that version. 
If the server's upgrade package matches the locked version (e.g., 3.59.127.0), the dropdown menu will show "Only upgrade to 3.59.127.0." 
If the server's upgrade package is a different version (e.g., 3.59.228.0), the dropdown will display both "Only upgrade to 3.59.127.0" and "Only upgrade to 3.59.228.0." 
Once "Only upgrade to 3.59.228.0" is selected, the next time the dropdown is opened, only that option will appear because the locked version matches the server's upgrade package.

	Distribution Time Range
	Upgrade files will only be distributed to clients during the specified time range.

	Allow Client Downgrade
	If the client version is higher than the server's upgrade package, selecting this option allows the client to downgrade; if unchecked, the client version remains unchanged.

	Search
	Enter Name, Computer, IP, or Last Logged-in User to find clients. Supports keyword search but not wildcards.

	Scope
	Upgrade files are only distributed to clients within the selected scope.

	Status
	Displays the status of clients within the selected scope, including computer name, IP address, current client version, and upgrade status.


18.14 Options
Select "Tools -> Options," where administrators can view and modify the default settings for the current console and server.
18.14.1 Console Settings
The console settings allow configuration of parameters for log viewing, real-time information, and real-time alerts.
	Parameter
	Description

	Basic Settings
	

	Login Settings
	Actions when logging into the console, including options to remember the password, enable auto-login, and prompt when using an admin account with no password.

	Close Settings
	Actions when closing the console, with options to minimize to the system tray or exit the program, and to display a prompt upon closing (default is to show a prompt).

	Upgrade Maintenance
	

	When the product is not under warranty
	Online upgrade function and reminder settings for when the product is not covered by a warranty period.
Reminder on next login: A prompt will appear each time you log into the console, indicating the absence of a warranty code and displaying the window to update the warranty code.

Reminder after a specified date: Set a specific date, and after this date, a reminder will appear each time you log into the console, indicating the absence of a warranty code and displaying the window to update the warranty code.

No reminder: No reminder will appear upon logging into the console, and the window to update the warranty code will not be displayed.



	Automatic Product Upgrade Check
	Online upgrade function, automatic product upgrade check settings.

Automatically check after each login: The system will check for new versions every time you log into the console. If a new version is available, a prompt will appear; if no new version is found, no prompt will be shown.

Check after a specified date: Set a specific date, and before this date, the system will not automatically check for new versions. After the specified date, it will automatically check for new versions upon each login.

No automatic check: Select this option to disable automatic checks for new versions.

	Sound Settings
	

	Enable Sound
	Check this option to receive sound alerts for alarm messages and application notifications in the console.

	Sound Type
	Choose between "Alarm" and "Notification."

	File Path
	Specify the sound file path, which can be selected via browsing. Only .wav files are supported.

	Log Viewing
	

	Log Query
	Set the maximum number of entries displayed per page in the log query. The default is 20 entries per page.
By default, the log displays the name of the object's immediate parent group. If "Show Full Path for Group Fields" is checked, the entire group hierarchy will be displayed.

	Log Query Conditions
	Time range options for log queries:

yy/mm/dd: Query by date

yy/mm/dd hh:mm: Query by minute

	Application Library Query
	The maximum number of applications displayed per page in the application library is set to 50 by default.

	Real-Time Information
	

	Screen Monitoring
	Set the real-time screen tracking interval. The default is 2 seconds.
Set the auto-rotation interval. The default is 2 seconds.
By default, all screens are displayed. You can choose to show only visible screens.

	Real-Time Maintenance
	Set the tracking interval for the application list. Default is 2 seconds.
Set the tracking interval for the process list. Default is 2 seconds.
Set the tracking interval for the performance list. Default is 2 seconds.

	Remote Control
	Set the default actions during remote control. Options include locking the remote computer's mouse and keyboard or viewing only the controlled computer.

	Real-Time Alerts
	

	Alert Window
	Set the number of records to display in the alert window. The default is 500 records.

	Popup Settings
	Check this option to display real-time alerts triggered by policies on this console machine.
Set the minimum alert level for popups: Low, Important, Severe.

	Client Offline Alerts
	Enable client offline alerts and set a specific duration (e.g., 10 days). The console will show an alert with a list of clients that have been offline for 10 days or more.

	Client Abnormal Alerts
	Enable client abnormal alerts. When an abnormal client is detected, an alert will pop up showing the list of abnormal clients.

	Encryption Function
	

	Encryption Serial Number Warning
	Enable a reminder when the encryption serial number is not registered. An alert will pop up when the serial number is unregistered.
Enable a reminder when the encryption serial number expires. An alert will pop up when the serial number expires.

	Encryption Approval Process Reminder
	Enable reminders when saving changes to the approval process. A message will pop up stating, "If there are current requests in approval, modifying the process may invalidate the request and require resubmission." Disable this option to prevent the reminder.

	Encryption Application Notification Reminder
	Enable pop-up notifications for encryption, external sending, document property changes, and temporary offline applications. A bubble alert will appear for these actions. Disable this option to prevent the pop-up alert.


18.14.2 Server Settings
The server settings allow configuration of multiple system parameters:
	Parameter
	Description

	Patch Options
	

	Automatically Install Patches on New Clients
	Check this option to automatically install downloaded patches on newly installed client machines. Otherwise, new clients will not automatically install patches. Administrators can enable this option upon their first login to the console.

	Automatically Download Newly Discovered Patches
	Check this option to automatically download patches discovered during scans. Otherwise, newly discovered patches will not be automatically downloaded. Administrators can enable this option upon their first login to the console.

	Data Clearing
	Default is to not clear data. Check "Enable this feature" to activate data clearing.

	Global Settings
	By default, all data is retained, and the server will not delete any data. You can choose to retain data for a specified number of days. The default is 30 days, and data older than 30 days will be deleted.

	Custom Settings
	You can set retention periods for different types of log data individually. The default retention period is "Global Settings," meaning data will be deleted according to the global configuration. You can also customize and set specific retention days or choose to retain all data.

	Management Scope
	

	Search Range
	You can add an IP address range for the server to search for client machines. This is typically used when clients cannot actively connect to the correct server, and the server should enable active polling.

	Allow Connections Only from Search Range
	Check this option to restrict connections to the server to only those client machines within the specified search range.

	Exclusion Range
	You can add an IP address range to exclude certain client machines from connecting to the server. Clients within the exclusion range will not be able to connect to the server.

	Traffic Settings
	Configure traffic policies to limit the bandwidth for client machines within a specified network range, preventing excessive bandwidth usage that could affect other common communications.
Click the "New" button [image: image513.jpg]


to set the network address, restriction time, and traffic limits, creating a new traffic policy. Multiple traffic policies can be created.

	Connection Settings
	

	Bandwidth Settings Between Server and Client
	The bandwidth range is from 1 to 102400 KB/s. Typically, bandwidth limitation is unnecessary in a local area network (LAN), but may be useful for VPN networks.

	Active Polling
	The server will actively connect to client port 8235 within the licensed client list. This is enabled by default. If unchecked, the server will not actively connect to clients.

	Directory Settings
	

	Data Directory
	Administrators can change the storage paths for various data files, including: data directory, cache directory, software distribution, backup emails, screen history, backup documents, and Microsoft product patches.
The default directory is the AnySecura installation directory. Administrators can modify this, but existing data will not be automatically moved to the new directory. The server must be stopped, and data must be manually moved to the new directory. The new directory settings take effect only after restarting the server.

	Set Directory
	Click the "Set" button “[image: image514.bmp]” to open the directory tree of the server computer and select the new data storage directory. The save directory will only update to the new directory after the server is restarted.

	Restore Initial Directory
	Click the "Restore" button “[image: image515.bmp]” to revert the save directory of the specified data objects to the initial directory, which is the server module's installation directory.

	Remaining Space Management
	

	Minimum Available Storage
	When the available storage (including data and cache directories) falls below this value, data collection will stop, and a popup alert will appear.

	Remaining Storage Alert Value
	When the available storage (including data and cache directories) falls below this value, a popup alert will appear, but data collection will continue.

	Performance Settings
	

	Fixed Mode
	Fixed mode sets the maximum number of clients the server can handle concurrently, with a range of [0-100].

	Dynamic Mode
	In dynamic mode, the server automatically adjusts the number of clients it can handle concurrently based on the load. The "Standard" load level means the server uses 30% of the database process's average CPU. If set to "High," the upper limit is 50%, and if set to "Low," it's 10%.
The server runs in dynamic mode by default, with the processing mode set to "Standard."
Generally, in dynamic mode, the server performs better, and the number of clients it can handle concurrently increases.
Real-time operations, such as viewing real-time screens or remote maintenance, are not affected by this setting and are processed immediately.

	Error Settings
	

	Record Errors During Client Validation
	Check this option to record error messages. Server error logs can be viewed under "Logs -> System Events."

	Minimum Error Level
	Defines the severity of error messages recorded:
All
Reports all errors.
Low
Client’s response during communication is not as expected.
Medium
License authorization exceeded.
Important
Serial number or checksum error.
Severe
Unable to pass server validation due to being in the exclusion range.

	Client Auto-Deletion
	

	Automatically Delete Inactive Clients
	Check this option and set the number of inactive days (default is 30 days). The next time you log into the console, clients that have been inactive for 30 days or more will be automatically deleted.
The auto-delete function will not uninstall the client. When the client reconnects, it will be moved from the "Deleted" group back to its original group, and both the main License and extended function authorizations will be restored.
To automatically uninstall the client during deletion, modify the OServer3.ini file in the server installation directory and add the following configuration: 
[CONFIG] 
AGENT_AUTO_UNINSTALL = 1 
This setting will take effect within one minute without needing to restart the server.


Traffic Settings
The traffic settings in server parameters are managed through traffic policies.
Various management operations can be performed on the policies：

	Icon Button
	Description
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	New，Click this button to create a new policy.
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	Edit，Click this button to modify the selected policy.
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	Delete，Click this button to delete the selected policy.
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	Move Up，Click this button to move the selected policy up by one position.
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	Move Down，Click this button to move the selected policy down by one position.


Click the "New" button[image: image521.jpg]


 to set the network address, restriction time, and traffic settings, creating a new traffic policy. Multiple traffic policies can be created.
The parameters for creating a new policy are explained as follows:
	Parameter
	Description

	Network Address
	The network address range where the policy applies. Options include All, LAN, External Network, Enterprise Network, Internet, or custom settings in Category Management.

	Restriction Time
	The time period during which the policy is active. Options include: All Day, Working Hours, Break Time, Weekend, Custom Time, or pre-set options in Category Management.

	Traffic Settings
	

	Total Traffic
	The total traffic limit for all IPs within the network address range. You can limit the traffic sent from the server to clients, received from clients, or both. Each setting is an integer value, or can be left unset to remove restrictions.

	Individual Traffic
	The traffic limit for each individual IP within the network address range. You can limit the traffic sent from the server to the client, received from the client, or both. Each setting is an integer value, or can be left unset to remove restrictions.


Policy Matching Principle
The policy matching is performed top-down, and each IP can match only one individual traffic limit and one total traffic limit.

1. Policies are matched based on priority.
2. Each policy can include both individual and total traffic limits. When matching a policy, both individual and total traffic must be checked. (The purpose of having both individual and total limits is to allow special IPs and ensure the bandwidth of a specific outbound line is not exceeded.)
Example 1
If you want to limit the traffic between each client and the server within a specific IP range (192.168.2.50-192.168.2.100) to a maximum of 200KB,

you can set the policy as follows:

Network address: 192.168.2.50-192.168.2.100,

Individual traffic limit: "Limit total send and receive traffic to 200KB/S".
Example 2
If you want to limit the total traffic between all clients and the server within a specific IP range (192.168.2.50-192.168.2.100) to a maximum of 2MB,
you can set the policy as follows:
Network address: 192.168.2.50-192.168.2.100,
Total traffic limit: "Limit total send and receive traffic to 2MB/S".
Example 3
The following conditions apply:
1. External client computers connect to the company network via VPN (assigned to the IP range 192.168.10.1-192.168.10.254). Each machine has a bandwidth of 1MB, but the communication traffic with the AnySecura server should not exceed 500KB.
2. The internal bandwidth is also limited to 10MB in total, with the requirement that the bandwidth used by AnySecura should not exceed 5MB. The internal network range is 192.168.9.1-192.168.9.254.
3. A monitoring computer at an important office (192.168.10.10) needs priority control, with a bandwidth limit of 2MB/s.
To set up the policy, follow these steps:
1. Add a network address category named "VPN Access Segment" with the content:
192.168.10.1-192.168.10.254;

2. Add a network address category named "Corporate Intranet" with the content:
192.168.9.1-192.168.9.254;

3. Set the first traffic policy:
For the network address, select the "VPN Access Segment" and "Corporate Intranet" categories.
Total traffic limit: "Limit total send and receive traffic to 5MB/s".
Individual traffic limit: "Limit total send and receive traffic to 500KB/s".

4. Set the second traffic policy:
For the network address, set it to 192.168.10.10.
Individual traffic limit: "Limit total send and receive traffic to 2MB/s".

18.14.3 Email Report Service Settings
Before using the email report feature, the system administrator must configure the email report server in "Tools -> Options -> Email Report Server Settings".
	Parameter
	Description

	Settings List
	Add, modify, or delete email report server settings.


Email Report Server Settings List Button Descriptions:
	Icon Button
	Action
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	Create a new email report server setting, entering the email server setup page.
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	Delete the currently selected email report server setting.
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	Re-edit the currently selected email report server setting.
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	Move the currently selected email report server setting up one position. Default settings are not affected and remain at the bottom.
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	Move the currently selected email report server setting down one position. Default settings are not affected and remain at the bottom.
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	Set the currently selected email report server as the default server.
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	Cancel the current email report server's default status.


Email server settings are matched from top to bottom. If a rule matches, this setting will be used to send emails. If no settings match, no emails will be sent.

When adding or modifying an email alert server, the following items need to be configured:
	Parameter
	Description

	Basic Information
	

	Configuration Name
	A user-defined description for the server. When adding an email server, the console will default to a name, but the administrator can customize it.

	Sending Server Information (SMTP)
	

	Email Server Address
	The address of the email server, which can be either an IP address or a domain name.

	Port
	The SMTP port, default is 25.

	SMTP Account
	The SMTP account.

	Password
	The password associated with the SMTP account.

	Require Secure Connection (SSL)
	Check this option to use a secure connection (SSL) for sending emails.

	Encryption Connection Type
	By default, set to "None," meaning the email server will not use an encryption protocol for sending emails.
If SSL/TLS is checked, emails will be sent using SSL/TLS protocol.
If STARTTLS is checked, emails will be sent using STARTTLS protocol.

	Sender Email Information
	

	Sender Email Address
	The email address used to send alert emails.

	Nickname
	The sender's nickname displayed in the email.

	Matched Email
	

	Email Set
	A collection of email suffixes used to receive alert emails, separated by ";", e.g., @outlook.com; @gmail.com.


Policy Example
If the internal email system of the company cannot send or receive emails from external networks, both internal and external email accounts need to receive alert emails. In this case, two email servers need to be set up: one for internal emails and one for external emails.
①Set up one email server, matching email addresses with: @companyname.com.
② Set up another email server, matching email addresses with: @ outlook.com, and set this server as the default.
Chapter 19: User System Management
If the company already has an AD domain or LDAP, and unified identity authentication and management are required on client machines, the User System Management feature can be used.
To access the User System Management interface, select Tools -> Server Management -> User System Management.
19.1 Server Configuration
Select User System Management -> Server Configuration to add the corresponding AD domain server or LDAP server configuration.
Icon Button Descriptions
	Icon Button
	Description
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	Add a new server configuration.
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	Move the selected server configuration up one position to adjust priority.
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	Move the selected server configuration down one position to adjust priority.
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	Edit the selected server configuration.

	[image: image533.bmp]
	Delete the selected server configuration.


Click the “[image: image534.bmp]” to open the server settings interface. Select the server type, and input the domain name and IP address of the domain server.The server type can be either "LDAP Server" or "Domain Server."If LDAP Server is selected, click the "Advanced Settings" button to enter the LDAP server's advanced settings interface, where you can configure the LDAP server’s port, protocol version, SSL usage, and whether to use anonymous connections.
After configuring the server parameters, click the "Test Login" button to open the connection test window. Enter the username and password for the configured server. Finally, click "OK" to add a new server configuration.
19.2 Login Authentication
19.2.1 Console Settings Policy
Select Tools -> Server Management -> User System Management -> Login Authentication to access the login authentication interface, where you can configure whether to enable login authentication.
Click the icon [image: image535.bmp] to open the login authentication configuration interface and set the corresponding parameters:
	Parameter
	Description

	Enforce Authentication
	Check this option to enable forced login authentication.

	Included Range
	Set the client range that will perform forced authentication.

	Excluded Range
	Set the client range that will not perform forced authentication.

	Non-Forced Authentication
	Check this option to enable non-forced login authentication.

	Included Range
	Set the client range that will perform non-forced authentication.

	Excluded Range
	Set the client range that will not perform non-forced authentication.


[image: image536.bmp] Note
If both forced login authentication and non-forced login authentication are set for a client, the forced login authentication will take precedence over the non-forced login authentication.
19.2.2 Client Login Authentication
Login Authentication
Forced Authentication
For clients with forced authentication enabled:
If the Windows system login account does not exist on the domain server specified in "Server Configuration", a user system login dialog will pop up after logging into Windows. The dialog cannot be closed unless the username and correct password of an existing domain server user are entered. Only then can the computer be used normally.
If the Windows system login account exists on the domain server specified in "Server Configuration", the user system login dialog will not pop up after logging into Windows. The current logged-in user will automatically log into the user system, and the computer can be used normally.
Non-Forced Authentication
For clients with non-forced authentication enabled:
Regardless of whether the Windows system login account exists on the domain server specified in "Server Configuration", the user system login dialog will not pop up after logging into Windows. The current logged-in user will automatically log into the user system, and the computer can be used normally.If the login dialog is manually triggered, it can be closed directly.
[image: image537.bmp] Note
In the client tray menu, select "Login User" or "Logout" to manually log in or log out of the user system.
Request to Cancel Forced Login
Under the forced login authentication policy, if the client forgets their domain account or is offline, they can request to cancel forced login authentication temporarily until the computer is restarted.

After the first failed login attempt, the client will see a "Request to Cancel Forced Login" button on the interface. Clicking this button will open the "Verify Operation Code" window.

In the console, go to Tools -> Client Tools -> Confirmation Code Generator. Copy the original operation code from the client’s "Verification Operation Code" field into the Client Operation Code field of the Confirmation Code Generator, then click "Parse" and click "Generate Confirmation Code". Enter the confirmation code generated by the console into the "Verification Operation Code" field on the client to cancel the forced login authentication.
Switch User
For clients with forced login authentication or non-forced login authentication enabled, if a domain account is used to log into the operating system, the user system will automatically log in using this domain account. Right-clicking the client tray will display a "Switch User" option. Clicking this will open the user system login window, where you can enter another user's login credentials to switch to a different user.

After successfully switching to another user, right-clicking the client tray will change the "Switch User" option to "Logout". Selecting "Logout" will automatically log the user back into the original domain account used to log into the operating system.
19.3 Associated Authentication
19.3.1 Console Settings Policy
Select User System Management -> Associated Authentication to enter the associated authentication settings interface, where you can choose whether to enable associated authentication and configure the corresponding parameters.
Click the icon [image: image538.bmp] to open the associated authentication configuration interface and set the parameters as needed.
	Parameter
	Description

	Enforce Authentication
	Check this option to enable forced user association authentication.

	Included Range
	Set the client range that will perform forced authentication.

	Excluded Range
	Set the client range that will not perform forced authentication.

	Non-Forced Authentication
	Check this option to enable non-forced user association.

	Included Range
	Set the client range that will perform non-forced authentication.

	Excluded Range
	Set the client range that will not perform non-forced authentication.

	Do Not Associate User
	After successful login with the user account from this setting, the user can log in and use the computer normally, but the username will not be associated with the local machine. Supports input in username and domain\username format.

	Prohibit User Association
	After logging in or authenticating with the user account from this setting, the authentication will fail, and the computer will remain locked. Supports input in username and domain\username format.


19.3.2 Client Associated Authentication
Forced Associated Authentication
For clients with forced associated authentication enabled:
If the machine already has an associated user and the associated user exists on the domain server specified in "Server Configuration", the "User Association Authentication" window will not pop up, and the computer can be used normally.
If the machine does not have an associated user, or the associated user is not the one specified in "Server Configuration" on the domain server, the "User Association Authentication" window will pop up. The window cannot be closed, and the user must enter the username and correct password of an existing domain server user. Only after successful verification can the computer be used normally. The newly entered user will automatically become the local machine's associated user.
Non-Forced Association
For clients with non-forced associated authentication enabled:
If the machine already has an associated user and the associated user exists on the domain server specified in "Server Configuration", the "User Association Authentication" window will not pop up, and the computer can be used normally.
If the machine does not have an associated user, or the associated user is not the one specified in "Server Configuration" on the domain server, the "User Association Authentication" window will pop up. You can either enter the username and correct password of an existing domain server user (which will automatically set this user as the local machine’s associated user), or directly close the dialog, and the computer can still be used normally. If a new user is entered, that user will be set as the local machine’s associated user.
19.4 Associated Information
When setting synchronization configurations, if the source is a user and the target is a computer, the system will match the user based on the first login. If the match is successful, the computer will be synchronized to the group where the source user belongs. This user is referred to as the "Computer's Associated User."
Select User System Management -> Associated Information to view which user is associated with the computer.
Associated Information includes:
	Attribute Name
	Description

	Computer
	The name of the computer with an associated user.

	Computer Group
	The group name that the computer belongs to.

	Computer Associated User
	The name of the user associated with the computer.

	Associated User Status
	The status of the associated user on the domain server.

	Last Login User
	The name of the last user who logged into the computer.

	Association Time
	The time when the computer was associated with the user.


Icon Button Descriptions
	Icon Button
	Description
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	Query the associated user of the computer to quickly locate and view the specified associated information.
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	The associated information list will display computers based on the selected display mode and filter criteria. 

	[image: image541.bmp]
	Select a computer and perform this operation to synchronize the computer based on the last logged-in user. The "Computer Associated User" will be updated to the last logged-in user.

	[image: image542.png]



	Select a computer and perform this operation to choose a user for synchronization. The computer will be synchronized to the selected user, and the "Computer Associated User" will be updated to the selected user.
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	Automatic Reassociation Settings.
Scope Settings
Included Range:
Select the range of computers that will enable automatic reassociation.
Excluded Range:
Select the range of computers that will not enable automatic reassociation. The excluded range takes priority over the included range.
Automatic Reassociation
Associated User Inactivity Days
Check this option and set the number of days. When the current associated user has been inactive for the specified number of days, the next login or an already logged-in non-associated user will be automatically associated with the computer as the new associated user.
Non-Associated User Exclusive Usage Days
Check this option and set the number of days. When a non-associated user exclusively uses the computer for the specified number of consecutive days (with only this non-associated user logging in and using the computer), this non-associated user will be automatically associated with the computer as the new associated user.
These two settings work independently. When both are enabled simultaneously:
1. If the current associated user test has not exceeded the specified inactivity days, but the non-associated user test2 has exclusively used the computer for more than the specified consecutive days, test2 will automatically become the new associated user for the computer.
2. If the current associated user test has exceeded the specified inactivity days, and test2 is already logged in and using the computer, test2 will immediately become the new associated user for the computer, even if test2 has not yet exceeded the required consecutive usage days.

	[image: image544.bmp]
	Do Not Associate Any User. Select a computer and perform this action, the computer will be synchronized based solely on the computer, not the user. A "*" symbol will appear before the computer's name.

	[image: image545.bmp]
	Edit Remarks. Select a computer and perform this action to update the remarks for that computer in the list.


Chapter 20: Audit Console
The Audit Console primarily records logs of administrative actions on the console, making it easier to track and query what operations the administrator has performed.
20.1 Login to Audit Console
Click SConsole.exe in the installation directory or navigate to Start -> All Programs -> AnySecura -> AnySecura Console to launch the console module.
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Enter the server IP address or the server machine name, and use the system auditor account "audit". The initial password is empty. Then, log in to the Audit Console.
20.2 Audit Console Interface Overview
The Audit Console includes the following components: Title Bar、Menu Bar、Toolbar、Administrator Bar、Data View、Query Bar、Status Bar
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The Administrator Bar displays a list of all administrators and auditors. By selecting a specific administrator, the audit logs will show all the operation logs for that administrator.

The Audit Log View provides features for printing and exporting useful audit logs, as well as a delete function to remove unnecessary audit logs.
	Field Name
	Description

	Print/Print Preview
	Select File -> Print/Print Preview to print the current audit log.

	Export
	Select File -> Export to export the audit log. There are two methods: right-click Export -> Current Page Records, or Export -> All Matching Records.

	Delete
	Select File -> Delete to delete audit logs. There are three methods: right-click Delete -> Selected Records, Delete -> Current Page Records, or Delete -> All Matching Records.


20.3 Using the Audit Console
Audit Console Settings
Select Tools -> Options to configure the audit console settings.
Check the option "Display Administrator Description After Admin Name". After restarting the console, the administrator description will appear next to the administrator's name in the administrator structure tree view.
Audit Log Content
Audit logs include console login status, administrator operation logs, policy modification/deletion, real-time screen viewing, remote control, and administrator account/permission settings.

The content recorded in the audit logs includes:
	Field Name
	Description

	Time
	The exact time of the administrator's action on the console.

	Computer
	The name of the computer from which the administrator logged into the console.

	Network Address
	The IP address of the computer from which the administrator logged into the console.

	Administrator
	The administrator's account name.

	Administrator Description
	A description of the administrator's account.

	Description
	A description of the administrator's actions on the console.


Audit Log Query
Audit administrators can query the required log information using time range, administrator name, or operation description.
	Query Condition
	Description

	Time Range
	Set a time range to query audit logs within that period.

	Administrator Name
	Query the audit logs of a specific administrator. The administrator list can be viewed in the administrator bar.

	Operation Description
	Query the audit logs based on the description of specific operations.


Set Auditor Account
Select Tools -> Accounts. The system auditor can view and add new auditor accounts and set their functional permissions.
	Field Name
	Description

	General
	Specify the type of auditor and the login mode for the auditor. This is similar to the settings for the console administrator account.

	Functional Permissions
	Includes permissions for saving and deleting audit logs.

	File
	Includes permissions for exporting data and printing.

	Delete
	Refers to the permission to delete log data.

	Document Cloud Backup Server
	Permission to log in to the cloud backup server's web audit interface.

	Managed Objects
	Select which administrators the auditor can audit. This grants the auditor permission to view the operation logs of the selected administrators. Multiple administrators can be selected. The system auditor can audit all administrators.


[image: image548.bmp] Note
Due to the sensitivity of the administrator audit logs, by default, the delete operation menu will not appear even if the delete permission is granted. It needs to be specifically enabled.

For the specific method to enable this, please contact online technical support.
Chapter 21: Document Security Management
21.1 Terminology Overview
Authorized Software
Authorized software refers to software used for editing important documents, such as Microsoft Word, AutoCAD, Photoshop, Visual Studio, etc.

In an encryption system, documents created using authorized software are automatically encrypted, and when opened using authorized software, the encrypted documents are automatically decrypted. Unauthorized software cannot view encrypted files, and computers with encryption functionality disabled cannot view encrypted files.
Security Area and Level
Security area and level are used to distinguish the access permissions for encrypted documents across different clients within the organization.
By default, there is a public security area, and custom areas such as Marketing and Finance departments can be added.
There are five security levels: Ordinary, Internal, Confidential, Secret, and Top Secret. The security level increases from Ordinary to Top Secret.

In the console's encryption authorization settings, you can configure which clients can access specific security areas and levels. In the document properties of encrypted files, you can set the security area and level required to access the document. For example, if a client has access to the Ordinary level in the Marketing department, they can access encrypted documents with the Ordinary level in the Marketing department but cannot access documents with the Ordinary level in the Finance department.
Document Permissions
Document permissions are used to distinguish the access rights of different users within the organization for encrypted documents.

The entities in encrypted documents include the creator and the reader. The creator is the user who encrypts the document, while readers are the users who can access the document. A single encrypted document can only have one creator, but multiple readers.
The user permissions for an encrypted document include: read, modify, copy, print, screenshot, decrypt, set permissions, and validity date.

In the console's encryption authorization settings, you can configure the document permissions for newly created encrypted documents. In the encrypted document properties, you can specify the users who can access the document and their permissions.
For example, if an encrypted document has Zhang San as the reader, with permissions to read and modify, but copy, print, screenshot, decrypt, and set permissions are prohibited, then:

· Zhang San can read and modify the document but cannot copy, print, screenshot, decrypt, or set permissions for the document.

· Li Si cannot read the document at all.

Since document permissions are user-specific, the encryption document permission feature must be used in conjunction with User System Management, otherwise, the feature will not be effective.
Online and Offline
When the client can connect to the server, it is considered online; when the client cannot connect to the server, it is considered offline. For example:

· A laptop connected to the company's local network can access the server, so it is online.

· The same laptop taken home, unable to connect to the server, is offline.

Generally, when the client leaves the corporate environment, file encryption and decryption are not allowed. However, if access to encrypted files is necessary, offline permissions can be set.

In the console’s Encryption Permission Settings interface, you can configure the permissions for the client when it is online. In the Offline Permission Settings interface, you can configure the permissions for the client when it is offline.
Backup Mode
When the main server encounters issues, such as stopping or crashing, the backup server will be activated and enter Backup Mode. This indicates that the current AnySecura encryption system is operating in backup mode. The client will then connect to the backup server and transition to backup mode, retaining the encryption and decryption permissions as if it were online.
Decryption
Encrypted documents within the enterprise sometimes need to be sent to external personnel. In such cases, the document must be manually decrypted into a standard document for external parties to view.

Employees with decryption permissions can directly decrypt documents. Employees without decryption permissions can apply to the administrator for decryption. Once the administrator approves the request, decryption will be permitted.
Outbound (External Sending)
Sometimes, encrypted documents within the enterprise need to be sent to specific external personnel for viewing, and to prevent secondary leaks, the document can be generated as an outbound document.

Employees with outbound permissions can directly generate outbound documents. Employees without outbound permissions can apply to the administrator for outbound authorization. Once the administrator approves the request, the employee will be allowed to generate the outbound document.

External personnel need to install the Outbound Document Viewer in order to view the outbound documents.
21.2 Operation Workflow
Enable Encryption
1) Install the client
2) Enable encryption authorization in the console
3) Configure encryption permissions in the console, including licensed software, secure areas, and levels
Request & Approval
1) Client submits decryption/external release request
2) Console reviews and approves
3) Client performs decryption/external release
External Release Viewer
1) Install the External Release Viewer
2) Authorize the Viewer in the console
3) Import authorization into the Viewer
4) Client generates external release documents
5) Viewer opens external release documents
21.3 Enable/Disable Encryption Authorization
For Windows clients, encryption authorization supports two modes: Transparent Encryption and Read-Only Encryption. Both modes cannot be enabled simultaneously.
	Encryption Mode
	Description

	Transparent Encryption
	Files open decrypted automatically and are saved encrypted automatically.

	Read-Only Encryption
	Encrypted files can only be opened in read-only mode and cannot be modified. Non-encrypted files remain unencrypted after being modified and saved.


By default, clients are not authorized for encryption. In the computer’s basic information, the encryption status is shown as “Unauthorized.” Administrators can enable or disable encryption authorization as needed through the computer list, basic information, or computer management in the console.

For clients with Transparent Encryption enabled, a small lock icon appears at the bottom left of the computer tree icon. The basic information shows the encryption status as “Transparent Encryption Authorized.”

For clients with Read-Only Encryption enabled, a green dot icon appears at the bottom left of the computer tree icon. The basic information shows the encryption status as “Read-Only Encryption Authorized.”

Mac and Linux clients only support Transparent Encryption mode.
Computer List:
In the AnySecura console’s computer list, select the target computer or group (if a group is selected, the action applies to all computers in the group). Right-click and choose Encryption Management → Enable Transparent Encryption or Enable Read-Only Authorization to activate the corresponding encryption mode. To remove encryption authorization, select Encryption Management → Disable Encryption Authorization.
Basic Information:
In the AnySecura console’s basic information section, select a computer group to view details of all computers within it. Select one or more computers, right-click, and choose Encryption Management → Enable Transparent Encryption or Enable Read-Only Authorization to activate the corresponding encryption mode. To remove encryption authorization, select Encryption Management → Disable Encryption Authorization.
Computer Management:
In the AnySecura console, go to Tools → Client Management → Computer Management to open the computer management view.
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	Enable Transparent Encryption Authorization
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	Enable Read-Only Encryption Authorization
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	Disable Encryption Authorization for the computer


[image: image552.bmp] Note 
Once encryption authorization is disabled on a client, encrypted documents on that computer will no longer be accessible. Before disabling authorization, decrypt all encrypted documents on the computer.
[image: image553.bmp] Info 
Unless otherwise specified, the following instructions assume Transparent Encryption mode is enabled.
21.4 Authorized Software Management
From the menu bar, select Document Security Management to open the encryption management main window. Then choose Management → Authorized Software to view the currently supported authorized software for Windows, Mac, and Linux.
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	Action
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	Import authorized software library
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	Export authorized software library
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	Add custom authorized software
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	Edit custom authorized software settings
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	Delete custom authorized software
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	Restore custom authorized software settings
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	Save changes


If the required authorized software is not in the software library, you can add it as custom authorized software.
	Field
	Description

	Name
	Custom software name (editable, cannot be empty).

	Icon
	Click “…” to select an icon for the custom software.

	Description
	Description of the custom software.

	Associated Processes
	Processes linked to the software. One software can match multiple processes, separated by “;”. Example: winword.exe; excel.exe.

[Advanced Use] To match version information, use the following format:

Key1=Value1|Key2=Value2|Key3=Value3|Key4=Value4 (multiple entries separated by “;”).

If “=” is omitted, it refers to the process name.
Example:
ProcessName=Winword.exe| InnerName=WinWord| OriginalName=WinWord.exe;

	Encrypted Files
	Files that open decrypted automatically and are saved encrypted; multiple entries separated by “;”

	Decryption-Only Files
	Files that open decrypted automatically but are not encrypted when saved; multiple entries separated by “;”


21.5 Secure Zone Management

Before configuring encryption permissions for clients, define secure zones according to the organization’s department structure.
In the Document Security Management window, secure zones can be viewed and modified.
	Icon Button
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	Add a secure zone and enter a description
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	Edit the secure zone name and description
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	Delete a secure zone


By default, there is a Public Secure Zone that cannot be modified or deleted. Files automatically encrypted by authorized software are assigned to the Public Secure Zone at the standard level. To facilitate information sharing, all clients with encryption enabled have access to the Public Secure Zone at the standard level.
21.6 External Release Object Management
External release objects are entities that can open external release documents outside the encryption system environment.
In the Document Security Management window, external release objects can be viewed and modified.
	Icon Button
	Action
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	Import external release object information. Existing objects and authorization info are ignored; imported authorizations are set as unverified.
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	Export current external release object information, including authorization details.
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	Add an external release object and optionally enter a description.
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	Edit the name and description of an external release object.
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	Delete an external release object.
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	Import external computer IDs to bind external release documents to specific machines.
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	Import external USBKey IDs to bind external release documents to specific USBKeys; only machines with the USBKey inserted can open the external release documents.
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	Manage external USBKeys.


By toggling the selected and unselected states in the status bar, you can enable or disable the corresponding external release object.
Authorization Types
Currently, three authorization methods are supported for external release objects.
	Authorization Method
	Description

	General Authorization
	Computer-based authorization. No machine binding is required; any computer importing the general authorization certificate generated under the external release object can open the external release files.

	Bound Computer Authorization
	Computer-based authorization. Requires binding the computer via its ID. Only machines with the bound ID can access the external release files.

	Bound External USBKey Authorization
	USBKey-based authorization. Requires binding the external USBKey via its ID. Only machines with the bound USBKey inserted can open the external release files.


General Authorization
Steps:
1) Add an external release object; it is enabled by default.
2) In the Authorization section, right-click and select Create General ID. Once created, the general ID is set as verified. (This step can be skipped; authorizing the external release object directly will automatically generate a general ID.)
3) Select the external release object and right-click to choose Authorize.
4) In the authorization window, configure settings such as expiration date and password protection, then click Generate Authorization File to create the general authorization file.
5) Import the authorization file into the External Release Viewer. When the general ID is enabled, the viewer can open all external release files sent to this external release object.
Bound Computer Authorization
Step:
1) Add an external release object; it is enabled by default.
2) In the Authorization section, right-click and select Import External Computer ID.
3) In the import window, enter the computer’s ID, name, and description, then click OK to generate a bound ID, initially unverified.
4) Select the bound ID and right-click to choose Verify.
5) Select the external release object and right-click to choose Authorize.
6) In the authorization window, configure settings such as expiration date and password protection, then click Generate Authorization File to create the bound authorization file.
7) Import the authorization file into the External Release Viewer to access all external release files sent to this external release object.
8) Bound authorization can be done by first importing a general authorization certificate and then binding the ID, or by binding the ID first and then importing the generated bound authorization certificate.
[image: image572.bmp] Note 
For details on obtaining external computer IDs, refer to the Authorization → Obtain ID subsection in the External Release Viewer chapter.
Bound External USBKey Authorization
Steps:
1) Insert the external USBKey into the machine logged into the console.
2) Add an external release object; it is enabled by default.
3) In the Authorization section, right-click and select Import External USBKey ID.
4) In the import window, the USBKey ID is loaded automatically. If multiple USBKeys are inserted, select the one to authorize, enter a name and description, then click OK to generate the bound USBKey ID.
5) Select the generated USBKey ID and right-click to choose Verify.
6) Select the external release object and right-click to choose Authorize.
7) In the authorization window, configure settings such as expiration date and password protection, then click Authorize USBKey. The USBKey is now authorized, and any machine with this USBKey inserted can access all external release files sent to the external release object.
[image: image573.bmp] Note 
1. If no external USBKey is inserted on the console machine during authorization, click Generate Authorization File and import the file on a machine with the USBKey inserted to complete the authorization.
2. For details on obtaining external USBKey IDs, refer to the Authorization → Obtain ID subsection in the External Release Viewer chapter.
Switching Between General and Bound Authorization
General and bound authorizations cannot coexist. Enabling general authorization disables bound authorizations, and enabling one or more bound authorizations disables general authorization.

If general authorization is initially used and stricter control is required, import computer IDs, generate bound authorizations, and enable them. Only machines with bound IDs can then access external release files sent to this external release object.

If bound authorization is currently used and control needs to be relaxed, generate and enable general authorization (or enable an existing one). Any machine importing the general authorization certificate can access external release files sent to this external release object. Previously bound machines do not need to import any additional authorization files to view these files.
21.7 External Release Configuration Template Management
In the console, go to Document Security Management → External Release Configuration Template Management. Administrators can create and manage templates for external release configurations, enabling easy reuse of common settings.
Icon Button Description
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	Import—Import an external release configuration template file
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	Export—Export the selected template as a file
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	New – add a new template
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	Delete – remove the selected template
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	Copy – duplicate the selected template
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	Restore – cancel creation or modification of a template
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	Save – save changes for the template to take effect


Each administrator can only use and manage templates they created and cannot view templates created by others. Templates exported by other administrators can be imported.
21.8 Encryption Permission Settings
Encryption permission settings define the permissions for clients with encryption authorization when connected to the server. Permissions can be configured for Windows, Mac, and Linux clients.
	Icon Button
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	Edit encryption permissions for the selected computer or user
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	Delete encryption permissions for the selected computer or user
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	Export policy file, import policy file, or copy the current policy to other clients


Encryption can be configured for computers and domain users. If a computer or user has custom permissions, a small red flag appears at the top-right corner of its icon.

Administrators can set encryption permissions at multiple levels: entire network, computer groups → computers, user groups → users, and policy collections. Permission priority (from highest to lowest) is:

User Policy > User Role Policy > User Group Policy > User Group Role Policy > Computer Policy > Computer Role Policy > Computer Group Policy > Computer Group Role Policy
Lower-priority policies act as parent group policies for higher-priority ones. For example, for a computer policy, all lower-priority policies—including computer role, computer group, and computer group role policies—serve as its parent group policies.

When setting encryption permissions, General, Authorized Software, and Secure Zone can be configured to inherit parent group policies:

· If inheritance is disabled, only the object’s own policies apply.

· If inheritance is enabled, the object’s policies are combined with parent policies. Inheritance continues up the hierarchy if parent groups also have inheritance enabled; it stops if a parent group disables inheritance, inheriting only that level’s policy.

· Inheritance is independent for General, Authorized Software, and Secure Zone settings.

After configuring encryption policies, administrators can preview the policy effect for a selected object. In the preview, General, Authorized Software, and Secure Zone are displayed in two sections: policy settings and policy execution effect. The execution effect shows the object’s final combined policy and the source of each policy.
General
	General Permissions
	Description

	Policy Inheritance
	Dropdown to select Do Not Inherit Parent Policy or Inherit Parent Policy. New policies default to Inherit Parent Policy + Authorization Disabled. Inheriting parent policies combines policies across objects; not inheriting applies only the object’s own policy.

	Enable Authorization Settings
	When checked, settings below (e.g., allow decryption requests) become active.

	Allow Decryption Requests
	Default encryption permission; users can request document decryption from administrators.

	Advanced Settings
	Restrict which files can be requested for decryption by clients.

	File Name
	Defaults to all files. Specific file types (e.g., *.dwg, *.dxf) can be set, with separate inclusion and exclusion lists; exclusions take precedence over inclusions.

	Security Attributes
	Defaults to all attributes and levels. Specific secure objects and levels can be set with inclusion and exclusion ranges; exclusions take precedence.

	Allow Direct Decryption
	Permission to decrypt encrypted files directly without administrator approval.

	Advanced Configuration
	Limits the number or total size of files that clients can decrypt directly.

Enable Settings must be checked for the following options to take effect.

	Time
	Cycle for quota calculation; choose Daily or Hourly.

	Quantity Quota
	When checked, set the maximum number of files that can be decrypted within the cycle.

	Size Quota
	When checked, set the maximum total file size (in MB) that can be decrypted within the cycle.

	Action
	Determines behavior when quota is exceeded: Deny prevents further decryption; Allow permits continued decryption.

	Alarm
	When checked, exceeding the quota triggers an alert in the console; alert levels can be adjusted.

	Warning
	When checked, set a warning message to display on the client when the quota is exceeded.

	Backup Decrypted Documents
	Back up decrypted files; the backup is the original encrypted file before decryption

	Backup Range
	Only documents within this size range will be backed up

	Allow External Release Requests
	Users can request external release of documents from the administrator

	Advanced Settings
	When requesting external release, restrict the selectable external release objects and configuration; external release configuration can be chosen from existing templates via the[image: image584.jpg]


button or set manually. Click the[image: image585.jpg]


button to save the current settings as a new external release template

	External 

Recipients
	When a client requests file export, it can only be sent to designated recipients. It can also be configured to require at least one recipient for each export request.

	File

Configuration
	When a client requests file export, each permission can only be set as specified.
Printing, Virtual Printing, Clipboard, Screenshot, Editing, Auto-Delete, Hide:
Unlimited: The client can freely select or deselect 
this permission when requesting file export.

Prohibited: The client cannot select this permission, 
and it cannot be changed.

Allowed: The client must select this permission, and 
it cannot be changed.
Maximum Open Count & Validity Period:
Unlimited: The client can choose whether to set a 
maximum open count or validity period.

Input Value:
· Open Count: Enter a positive integer from 1–99; the client can only set this value as the maximum open count, which cannot be changed.

· Validity Period: Enter a positive integer from 1–1000; the client cannot set a validity period longer than the specified number of days.
Decrypt-Only Files:
· Prohibited: The client cannot enable file decryption.

· Input Value: Enter file types separated by commas (e.g., *.dwg,*.dxf). The client can select “Allow File Decryption,” and only files of the specified types will be decrypted. Files generated via “Save As” from the exported file will be decrypted if they match the specified types; all others remain encrypted.


	
	Password Authentication:
· Unlimited: The client may set a password or leave it unset; there is no restriction on the password.

· Password Required: The client must set a password when requesting file export.

· Password Complexity Required: The client must set a password that meets complexity requirements.

	Allow Direct Export of Documents
	Generate exported documents directly without administrator approval

	Advanced Settings
	Restrict recipient selection and export configuration when the client exports files directly. See Advanced Settings for Export Request Permissions for details; settings are similar

	Backup Exported Documents
	Backup exported documents

	Backup Range
	Only exported documents within this size range will be backed up

	Allow Extraction of Documents Within Client Permissions
	Clients can extract exported documents with access rights within their own permissions

	Allow Extraction of Higher-Permission Documents
	Clients can extract exported documents with access rights higher than their own

	Allow Request to Modify Encrypted Document Properties
	Clients can request administrators to modify encrypted document properties

	Additional Advanced Settings
	When set for domain users or groups, further advanced options can be configured per user. When clients request document property changes, restrictions can be applied to searchable/viewable audiences and user permissions

	Reading Audience

	Settings below take effect only when “Enable User Permission Control” is checked;
Users and roles that the client can find under the “Search” tab when modifying document properties. Users and roles outside this scope cannot be searched. Default is the entire network (all users and roles)
Users and roles that the client can view when modifying document properties. Default is empty; the “User Structure” tab will not appear. Once a browsable audience is selected, the “User Structure” tab appears showing the selected audience

	User Permissions


	When the client modifies document user permissions, each file permission can only be set as specified.
Read, Modify, Set Permissions: Can be set to Prohibited or Allowed + Prohibited

Copy, Print, Screenshot: Can be set to Prohibited, Not Set + Prohibited, or Allowed + Not Set + Prohibited

Decryption Permission: Can be set to Prohibited or Not Set + Prohibited;
Permission Effects:
Allowed + Not Set + Prohibited: The client can 
set the reader’s permission to Allowed, Not Set, or 
Prohibited.

Not Set + Prohibited: The client can set the 
reader’s permission to Not Set or Prohibited.

Allowed + Prohibited: The client can set the 
reader’s permission to Allowed or Prohibited.

Prohibited: The client can only set the reader’s 
permission to Prohibited.



	
	When a permission is set to Not Set, its effect depends on the authorized software used to open the file. For example, if a DOCX file’s “Print” permission is set to Not Set, printing is blocked if the Office Word software used to open the encrypted file prohibits printing. If the software allows printing, the encrypted document can be printed.
Validity Period:
Unlimited: The client can choose whether to set a 
document validity period.

Input Value: Enter a positive integer 1–1000; the 
document validity cannot exceed this number of 
days.



	Template Settings
	When modifying document user permissions, the client can only select from templates set by the administrator.

Allow Template Selection: Enables the user permission template feature; check to turn it on.
Selected Template: Default is empty. Click[image: image586.png]


to 
open the template selection window and choose from
available templates.

	
	Allow Modifying Permissions in Template: 
Default is unchecked. If unchecked, the client cannot 
change permission states after selecting a template. 
If checked, the client can modify permission states 
within the template’s allowed range.

	Allow Direct Modification of Encrypted Document Properties
	Modify encrypted document properties directly without administrator approval.

	Advanced Settings
	When setting for domain users or groups, additional per-user advanced options can be configured.

When the client directly modifies encrypted document properties, restrictions apply to searchable or browsable audiences and user permissions. See Advanced Settings for Modification Request Permissions for details; the settings are similar.

	Allow Proxy Admin Login
	Allows administrator accounts to log in as a proxy admin on the client for decryption and export approvals

	Allow Client to Logout of Encryption System
	The client can log out of the encryption system while online. All encryption functions are disabled upon logout and restored after logging back in

	Encryption Login Method
	If Allow Client to Logout of Encryption System is checked, the client can log out of the encryption system.
Allow Client to Set Login：The client can configure 
online and offline login preferences under 
“Encryption Icon → Right-Click → Options → 
Encryption System Login Settings.”
Force Manual Login: Online and offline login are 
set to “Force Manual Login” and cannot be changed.
Automatic Login: Online and offline login are 
set to “Automatic Login” and cannot be changed.


When the “Inherit Parent Group Policy” option is selected, the client policy is combined with the parent group policy. The combination rules are as follows:
1.Checked-Type Settings (e.g., “Allow Decryption Request,” “Allow Direct Decryption”): If any combined policy has the option checked, the final effect is Checked.

2.Advanced Settings (e.g., “Advanced Settings” for “Allow Decryption Request” or “Allow Export Request”): The final effect follows the highest-priority policy based on policy matching.

3.Backup Range Settings (e.g., “Backup Range” for “Backup Decrypted Documents” or “Backup Exported Documents”): The final effect follows the highest-priority policy based on policy matching.

4.Encryption Function Activation Method: Priority is as follows: Force Manual Login > Force Automatic Login > Automatic Login (retain previous state) > Allow Client to Set. The highest-priority setting present in the combined policies becomes the final effect.

[image: image587.bmp] Note 
For Linux and Mac clients, only “Allow Decryption Request” and “Allow Direct Decryption” take effect when configuring general encryption permissions. Other settings are currently not supported.
Authorized Software
For transparent encryption, authorized software must be selected manually. For read-only encryption, when a client opens an encrypted document in read-only mode, the software used automatically becomes the authorized software.
	Authorized Software Permission
	Description

	Policy Inheritance
	Dropdown to choose Do Not Inherit Parent Policy or Inherit Parent Policy. New policies default to Inherit Parent Policy + Disable Authorized Software Settings. Inherited policies combine across objects; non-inherited policies apply only to the object itself.

	Enable Authorized Software Settings
	Check to activate the authorized software settings below.

	Name
	Name of the authorized software. Settings can be configured under the Windows, Linux, or Mac tabs.

	Encryption Mode
	Four modes are available for authorized software:

	Automatic Encryption/Decryption
	Can view encrypted files, and files created or modified with this software are automatically encrypted.

	Smart Encryption/Decryption
	Can view encrypted files. Modifying encrypted files preserves encryption; modifying non-encrypted files preserves non-encrypted status.

	Read-Only Encryption
	Can view encrypted files but cannot modify and save them with this software.

	Decrypt-Only
	Can view encrypted files, and any files modified and saved with this software become non-encrypted documents.


Additionally, you can configure whether printing, virtual printing, screenshots, and clipboard usage are allowed for each authorized software. This setting applies to both transparent encryption and read-only encryption.

If Inherit Parent Group Policy is selected, the client policy is combined with the parent policy. The combination rules are:

1. Enable Authorized Software: If any combined policy enables the software, the final effect is Enabled.

2. Authorized Software Permissions: The final effect follows the settings in the highest-priority policy based on policy matching.
[image: image588.bmp] Note 
1. For Linux clients, only Automatic Encryption/Decryption and Decrypt-Only take effect when setting the authorized software encryption mode. Other modes are treated as Automatic Encryption/Decryption.
2. For read-only encryption, if the program used to open an encrypted file is not set as authorized software, printing, virtual printing, screenshots, and clipboard operations are all prohibited.
Security Zone
Specifies the security zones and levels of documents that a client can open. For example, a client with Marketing Confidential permission can open documents at the Marketing Confidential level or lower, but cannot access any documents in the Finance department.
	Security Zone Permission
	Description

	Policy Inheritance
	Dropdown to choose Do Not Inherit Parent Policy or Inherit Parent Policy. New policies default to Inherit Parent Policy + Disable Security Zone Settings. Inherited policies combine across objects; non-inherited policies apply only to the object itself.

	Enable Security Zone Settings
	Check to activate the security zone settings below


When Inherit Parent Group Policy is selected, the client policy is combined with the parent policy. The combination rules are:

1. Security Zones and Levels: Priority is as follows: All Zones & Levels > All Zones with Specified Levels > Specified Zones & Corresponding Levels. The highest-priority setting determines the final effect.

2. Within the Same Zone: Security level priority is Top Secret > Confidential > Secret > Internal > General. The highest-priority level takes effect.
Default Document Properties
By default, encrypted documents are set to Public Zone – General Level with no user permissions. You can configure all documents or specific documents with designated security zones, levels, and user permissions.
	Options
	Description

	Set Default Properties for New Encrypted Documents
File Scope
	Check to activate the settings below

	Include Files
	Files in this scope will use the configured default security properties. Enter file names or paths; wildcards are allowed (e.g., *.doc, c:\*)

	Exclude Files
	Files in this scope will not use the configured default security properties. Enter file names or paths; wildcards are allowed (e.g., *.txt, c:\*)

	Document Properties
Set Permissions
Access Permissions            
	Configure default permissions for encrypted files
Configure default access rights for encrypted files

	User Permission Control
Target Objects
User Permissions            
	Settings below take effect only when Enable User Permission Control is checked;
Set the default target objects for encrypted files;
Set the default user permissions for encrypted files;


[image: image589.bmp] Note
This setting applies only to newly created encrypted files. Existing encrypted files will not have their security properties changed.
21.9 Encryption Parameter Settings
In the Encryption Parameter Settings interface, you can configure the disaster recovery time and whether to hide encryption marks on encrypted documents in File Explorer for the entire network, specific groups, or specific clients.
All encryption parameter settings must be saved to take effect.
	Icon Button
	Description
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	Modify the encryption parameter settings of selected computers or users 
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	Delete the encryption parameter settings of selected computers or users
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	Export policy file, import policy file, or copy the current policy to other clients


[image: image593.bmp]Note 
Unless otherwise specified, all encryption parameter settings apply only to Windows clients and do not take effect for Linux or Mac clients.
Emergency Settings
Disaster Recovery Time
Disaster recovery time is set for emergencies. If a client with a configured disaster recovery time cannot connect to the server due to network or server failures, and no long-term offline authorization policy is in place, the client can enter backup mode within the disaster recovery time and perform encryption and decryption operations according to its online permissions.
[image: image594.bmp] Note
This setting also applies to Mac and Linux clients.
Allow Copying Small Amounts of Text
For authorized software with clipboard restrictions, content cannot be copied to non-authorized software. However, for business needs, a small portion of text may need to be copied from such documents. In this case, you can enable Allow Copying Small Amounts of Text.

Enter the number of characters allowed for copying. For example, entering 5 allows copying up to 5 characters.
Display Settings
Hide Encryption Marks
On clients with Hide Encryption Marks enabled, encrypted documents no longer show the small lock icon. Users cannot visually distinguish between encrypted and non-encrypted documents.

Hide Encryption Client Interface
On clients with Hide Encryption Client Interface enabled, the encryption system icon in the system tray (bottom-right corner) is hidden. Users cannot access functions through the encryption icon menu.
[image: image595.bmp] Note 
This setting also applies to Mac clients.
Security Password Settings
Require Security Password
On clients with Require Security Password enabled, the security password cannot be empty and must be set.
Password Must Meet Complexity Requirements
On clients with Password Must Meet Complexity Requirements enabled, the security password must satisfy all of the following:
1、At least six characters in length.
2、Include characters from at least three of the following four categories:
   Uppercase letters (A–Z)

Lowercase letters (a–z)

Digits (0–9)

Non-alphabetic characters (e.g., !, $, #, %)
3、Password strength must be medium or higher.
Security Password Input Settings
Administrators can restrict how clients enter security passwords. The settings are as follows:
	Setting
	Description

	Allow Client to Set
	Default option. Clients can configure security password input settings at their discretion.

	Require Password for Every Operation
	When selected, the client’s security password input setting is set to Require Password for Every Operation and cannot be changed.

	Enter Once After Logging Into Secure Object
	When selected, the client’s security password input setting is set to Enter Once After Logging Into Secure Object and cannot be changed.

	No Password Required for Login Operations
	When selected, the client’s security password input setting is set to No Password Required for Login Operations and cannot be changed.


Password Error Attempt Verification
When enabled, the client validates the number of incorrect security password entries for operations requiring a password.
	Setting
	Description

	Within Time Limit
	Specify a time period in minutes. Default is 20 minutes. 0 means no time limit.

	Max Incorrect Attempts
	The number of incorrect password entries allowed. Default is 5.

	Password Lock Duration
	After reaching the maximum incorrect attempts, the security password input is disabled for the specified duration. Default is 10 minutes; 0 means no lock.

	Password Lock Alert
	When the maximum incorrect attempts are reached, the console generates an alert. Alert level is lowest; enabled by default.


After configuration, if the number of incorrect password attempts reaches the specified limit within the set time, the password input field will be locked for the specified duration.
Maximum Password Usage Period
Administrators can specify the number of days a security password is valid. For example, if set to 30 days, the password can be used normally for 30 days from the time it is set. After 30 days, the client will be prompted that the password has expired and must be changed. If the client already has a security password when configured from the console, the period starts from the time the console setting is applied.
Encrypted Document Thumbnail Settings
Configure encrypted document thumbnails to display them and their previews in File Explorer.
	Setting
	Description

	Show Thumbnails
	Enable or disable display of encrypted document thumbnails.

	File Types
to Show
	Select the types of encrypted documents for which thumbnails are displayed.

	File Types to Exclude
	Select the types of encrypted documents for which thumbnails are not displayed.

	Show Previews
	Enable or disable display of encrypted document preview images.

	File Types to Show
	Select the types of encrypted documents for which previews are displayed.

	File Types to Exclude
	Select the types of encrypted documents for which previews are not displayed.


[image: image596.bmp] Note 
Encrypted files with the following types—*.jpg, *.jpeg, *.jpe, *.bmp, *.gif, *.png, *.tif, *.tiff—display thumbnails and previews by default.
Email Whitelist
Clients with an email whitelist automatically decrypt encrypted attachments into regular files when sending specified emails. Currently, only SMTP emails without SSL are supported.
Click the [image: image597.png]


 at the end of the Email Whitelist cell to configure email address rules, attachment file names, and whether to back up decrypted attachments.
	Setting
	Description

	Email Address Rules
	Configure whitelist email address rules; multiple rules can be set.

	Attachment File Name
	Control specific attachment names. You can specify included or excluded file names. Supports wildcards and multiple entries separated by “,” or” ;”.

	Backup Decrypted Attachments
	If enabled, displays Yes; otherwise, No.

	Backup Range
	Set the size limit for backing up encrypted attachments. Default is 0–100,000 KB; attachments exceeding this range will not be backed up.


Email Address Rules
Click the [image: image598.png]


 at the end of the Email Whitelist cell, then click the [image: image599.png]


 again to add email address rules.
	Setting
	Description

	Rule Name
	Set the name of the email rule.

	Mode
	Select the mode: Decrypt Attachments or Do Not Decrypt Attachments. 
Decrypt Attachments: Encrypted attachments in emails matching this rule will be decrypted. 
Do Not Decrypt Attachments: Encrypted attachments in emails matching this rule will not be decrypted. 
Default is Decrypt Attachments.

	Recipient Email
	Set the recipient email addresses, including To, CC, and BCC fields. You can specify included and excluded emails, with excluded emails taking priority over included ones. Emails in the exclusion list do not match this rule and will continue to the next policy.
Supports direct email input or selecting email categories for control:
Click the [image: image600.png]


 to add email addresses. You can enter a full email address (e.g., 123@gmail.com) or use wildcards for a range of addresses (e.g., *@outlook.com). Separate multiple entries with commas. After setting, click the [image: image601.png]


 to modify.
Click the [image: image602.png]


 to add an email category.

	Allow Recipients Outside the Exclusion List to Decrypt
	Control decryption for recipients outside the exclusion list.
For emails with multiple recipients:
1. If none of the recipients are within the inclusion list, their attachments will not be decrypted.
2. If at least one recipient is within the inclusion list (and not in the exclusion list):
>> Recipients in the inclusion list: attachments will be decrypted.
>> Recipients in the exclusion list: attachments will not be decrypted.
>> Recipients neither in the inclusion nor exclusion list:
If this option is checked, their attachments will be decrypted.
If unchecked, their attachments will not be decrypted.


	Sender Email
	Set the sender email addresses. You can specify included and excluded emails, with excluded emails taking priority over included ones. Emails in the exclusion list do not match this rule and will continue to the next policy.
Supports direct email input or selecting email categories for control:
Click the [image: image603.png]


 to add email addresses. You can enter a full email address (e.g., 123@outlook.com) or use wildcards for a range of addresses (e.g., *@gmail.com). Separate multiple entries with commas. After setting, click the [image: image604.png]


 to modify.
Click the [image: image605.png]


 to add an email category.


Multiple email address rules can be set, and the order of the rules can be adjusted using the [image: image606.png]
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.
Email Address Rule Matching Principle
Rules are matched from top to bottom. Once an email matches a valid rule, subsequent rules are not evaluated. If no rules match, the email's encrypted attachments will not be decrypted.
Email Whitelist Rule Example 1
Company Scenario:
1. The company has established a Document Control Department (DCD), which acts as the plaintext gateway. For emails sent to external networks, after internal approval, the DCD sends them using external email accounts.
2. All external emails use the domain @outerdept.com.
Requirement:
When the DCD sends emails externally, encrypted attachments must be decrypted , but only if the email CCs the DCD supervisor (chen@outerdept.com).
To meet the above requirement, configure an email whitelist rule as follows:
Mode: Decrypt Attachments

Recipient Email: Include chen@outerdept.com; Exclude none; check Allow Recipients Outside Exclusion List to Decrypt
Sender Email: Include *@outerdept.com; Exclude none

Email Whitelist Rule Example 2
Company Scenario:
1.Internal work uses the company’s internal email system. Employee communications and workflow files are all exchanged via internal emails.

2.All internal emails use the domain @innerdept.com.

Requirement:
For internal employee emails, only emails sent to specific leaders (li@innerdept.com, zhang@innerdept.com) should have attachments decrypted. All other emails should not decrypt attachments.
To meet the above requirement, configure an email whitelist rule as follows:
Mode: Decrypt Attachments

Recipient Email: Include li@innerdept.com, zhang@innerdept.com; Exclude none; do not check Allow Recipients Outside Exclusion List to Decrypt
Sender Email: Include *@innerdept.com; Exclude none
Log Policy
By default, clients record all encrypted document operation logs. In some cases, not all logs need to be recorded. A log policy can control which encrypted document operations are logged.
	Setting
	Description

	Record Logs
	Enabled by default. Uncheck to stop logging. Only when checked can operation types and file ranges be configured.

	Operation Types to Log
	Default is to log all operation types. Can be customized as needed.

	File Range to Log
	

	Included Files
	Files within this range will have their encrypted operations logged. Enter file names or paths, supports wildcards (e.g., *.doc, c:\*).

	Excluded Files
	Files within this range will not have their encrypted operations logged. Enter file names or paths, supports wildcards (e.g., *.doc, c:\*).


[image: image608.bmp] Note
This setting also applies to Mac and Linux clients.
Extended Features
Encrypt New Files
The Encrypt New Files feature automatically encrypts newly created or modified files in specified directories. After encryption, files are assigned the security attributes: Public Security Area – Normal level.
	Setting
	Description

	Encrypt New Files
	Enable or disable the Encrypt New Files feature.

	Exclusion Range
	Specify directories and file types that will not be automatically encrypted. Multiple entries are supported. By default, all files in local hard drive directories are included.

	Encryption Range
	Specify directories and file types that will be automatically encrypted. Multiple entries are supported. By default, all files in local hard drive directories are included.


Currently supports local drives and network drives. Directories must be valid client local disk paths and support wildcards * and the general path {sd}. For example: {sd}users\*\Documents. {sd} represents the system drive root (e.g., C:\) and must be lowercase. Folder names follow {sd} directly, without an additional \.

File types support wildcards” * ” and “?”.

If a Document Backup Server is deployed, clients with the Encrypt Document Auto Backup Task enabled will automatically back up files encrypted via the Encrypt New Files policy.

Encrypting Authorized Software – Decrypt Only
Administrators can configure authorized software to decrypt only files without re-encrypting them.
	Setting
	Description

	Process
	Specify the process name of the authorized software. Supports wildcards. Multiple processes are separated by commas (,).

	File
	Add filter files to apply settings. Supports full paths and extensions (e.g., E:\work\*.dat). Wildcards and general paths are supported. Multiple entries separated by commas (,).


[image: image609.bmp] Note 
1. Only applies to files modified during the use of authorized processes. It does not apply to files encrypted manually, via Encrypt New Files, or through full-disk scan encryption.
2. Files set as "Do Not Encrypt" in this setting take precedence over files in the authorized software library.
Watermark Settings for External Documents
External Document Window and Print Watermarks
Clients can configure external documents to display watermark information when opened or printed. This includes custom text, the creator of the external document, and the reader of the external document. Watermarks appear in the visible window when opening the document or on printed external files.
	Setting
	Description

	Enable Policy
	Enable or disable the external document window and print watermark policy. Detailed settings require this option to be checked.

	Watermark Type
	Select the watermark type for the policy: Window Watermark, Print Watermark, or Both. Default is Both.

	Text Content
	Specify the text for the watermark.

	Font
	Set the font type for the watermark text.

	Custom Text Size
	Set the font size for the watermark text. Default is 48.

	Creator & Reader Info Size
	The font size for creator and reader info is automatically adjusted based on the custom text size. Default is 28.

	Color
	Set the font color of the watermark text.

	Transparency
	Set the transparency of the watermark text. Default is 80%.

	Creator Info
	Select which creator information to display in the watermark: computer name, IP address, username, creation time.

	Reader Info
	Select which reader information to display in the watermark: computer name, IP address, username, reading time.


External Document Floating Window Title
Enables a floating window when an external document is opened, with customizable title text. The window can be freely moved within the file viewing area.
	Setting
	Description

	External Document Floating Window Title
	Enable or disable the floating window title for external documents.

	Text Content
	Set the text displayed in the floating window title.

	Font Color
	Set the font color of the floating window title.

	Background Color
	Set the background color of the floating window title area.

	Show Close Button
	If checked, a close button appears on the floating window, allowing the user to manually close it; if unchecked, the window cannot be manually closed until the external document is closed.

	Show Process Type Icon
	If checked, the floating window displays the external document’s process type icon; if unchecked, it does not display.

	Show Permissions
	If checked, moving the mouse over the floating window shows the current permissions of the external document; if unchecked, permissions are not displayed.


External Document Border
You can set external documents generated by the client to display a border when opened, helping users distinguish between regular files and external files. Both the border color and size can be configured.
	Setting Option
	Explanation

	External Document Border
	Set whether to enable the external document border;

	Border Color
	Set the border color;

	Border Size
	Set the border size (1–10); higher values make the border thicker.


External Document Network Settings
By default, external documents are blocked from accessing the network. If certain external documents require network access to function properly, administrators can allow specific processes to access designated networks.
	Settings Options
	Description

	Allow External Document Network
	Enable or disable the policy that permits network access for external documents.

	Allowed Network
	Specify the process and its permitted network(s). Multiple policies can be set, each containing a process name and a set of network addresses. Network addresses must be in the format IP or IP:Port. Multiple IPs are separated by commas (,); IP ranges and port ranges are not supported.
Example: If the process is set to CATIA.exe and the allowed network is 192.168.7.230:8090, CATIA.exe will be allowed to access 192.168.7.230:8090 when viewing external documents. 


Document Upload Request Settings
Enable Settings
Turn on document upload request settings. When enabled, documents that meet the criteria will be uploaded to the request document storage server.
	Settings Options
	Description

	Enable Settings
	Enable or disable uploading request documents to the document storage server.

	Document Storage Server Address
	Enter the address of the document storage server (HTTPS protocol only; use the corresponding HTTPS port).

	Include Files
	Files within this scope will be uploaded to the storage server. Select from predefined file types or manually enter using the button; wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).

	Exclude Files
	Files within this scope will not be uploaded to the storage server. Select from predefined file types or manually enter using the button; wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).

	File Size
	Set the file size range for uploads. Custom values are allowed, limited to 0–2,000,000 KB.


[image: image610.bmp] Note 
Supports the following requests: decryption requests, external document requests, and document attribute change requests.
21.10 Long-Term Offline Authorization Settings
Long-term offline authorization defines the permissions for clients with encryption enabled when they cannot connect to the server. For example, if company executives frequently work offsite, long-term offline authorization ensures they can still view and edit encrypted documents.
	Icon Button
	Description
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	Modify long-term offline permissions.
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	Delete long-term offline permissions.
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	Export offline authorization files.
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	You can choose to export policy files, import policy files, or copy the current policy to other clients.


Long-term offline permissions allow specifying a time range during which encrypted documents can be accessed offline. These permissions can also include decryption, external document access, authorized software, and secure zone rights, configured similarly to encryption permissions.

When Windows, Mac, or Linux clients are online, long-term offline permissions take effect immediately.
When Windows clients are offline, you can export an offline authorization file and send it to the client, where it can be imported to apply the permissions.
[image: image615.bmp] Note
Currently, offline authorization import is not supported on Mac and Linux clients.
21.11 Secure Communication Settings
Secure communication settings work with the hardware security gateway. This policy must be configured only after the security gateway is deployed; otherwise, issues such as inability to access the internet may occur.
	Icon Button
	Description
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	Modify secure communication settings.
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	Delete secure communication settings.
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	Options include exporting policy files, importing policy files, or copying the current policy to other clients.


When configuring secure communication settings, the “Application System Protection” and “Network Shared Document Protection” options support inheritance from parent group policies.

· If inheritance from the parent policy is disabled, only the object’s own policy applies.

· If inheritance is enabled, the object’s policy is combined with the parent’s policy.

· If the parent also has inheritance enabled, the policy continues to inherit from higher-level parent groups.

· If a parent disables inheritance, the policy stops inheriting beyond that level, applying only the parent’s policy.

Inheritance between “Application System Protection” and “Network Shared Document Protection” is independent.
Detailed setting descriptions:
Application System Protection
	Settings Option
	Description

	Policy Inheritance
	Choose from the dropdown: “Do not inherit parent policy” or “Inherit parent policy.” By default, new policies are set to “Inherit parent policy + Application System Protection disabled.” Inheriting the parent policy combines policies across objects; disabling inheritance applies only the object’s own policy.

	Enable Application System Protection
	Check this option to enable protection for the client’s application system.

	Secure Process Window Label
	Enter specific text (e.g., “Secure Process”) to display on the process window when the secure process is opened.

	Exception Network Range
	For secure processes in forced mode, only protected application system servers can be accessed; other network addresses are blocked. To allow access to additional networks, define them as exception ranges. Supports IP ranges, domain names, and multiple entries separated by commas (e.g., 192.168.1.1-192.168.1.100,192.168.2.102,development.tec).

	Secure Process
	To configure a secure process, click the [image: image619.png]


 to add it, and enter the process name and encryption mode.
Process Name: Enter the name(s) of the process(es) to be set as secure. Multiple process names can be entered in one configuration, separated by commas (e.g., iexplore.exe, TortoiseProc.exe). When saved, multiple entries will automatically be split into separate configurations.
Encryption Mode: Divided into Forced Mode, Smart Mode, and Smart Browser Mode.
Forced Mode: The secure process can only access protected application servers and servers within the exception network range; all other addresses are blocked. Files uploaded to protected servers or exception network servers are decrypted, and files downloaded are encrypted.
Smart Mode: The secure process can access both protected servers and exception network servers, as well as other non-protected servers.

· If the process has not accessed a protected server since startup, files uploaded or downloaded to non-protected servers or exception network servers are transferred without encryption/decryption.

· If the process has accessed a protected server, subsequent uploads to non-protected or exception servers are decrypted, and downloads are encrypted.
Smart Browser Mode: The secure process can access protected servers, exception addresses, and other non-protected addresses.

· Regardless of whether it has accessed a protected server, files uploaded or downloaded to non-protected or exception servers are transferred without encryption/decryption.
If Smart Mode is selected, the related Smart Mode Settings must be configured.

	Smart Mode Settings
	This setting applies only to secure processes configured in Smart Mode.

	Protected Servers
	Enter the protected application system servers. Multiple servers can be added, separated by semicolons, commas, or line breaks. Supported formats include:
IP:Port (e.g., 192.168.2.104:8080)

IP:Port Range (e.g., 192.168.2.104:8080-8079)

IP Range:Port (e.g., 192.168.2.1-192.168.2.255:8080)

IP Range:Port Range (e.g., 192.168.2.1-192.168.2.255:1000-8079)

Domain name (e.g., jira5.development.tec)

Note: Protected servers set here must match the protected application system servers configured in the security gateway. Otherwise, smart mode secure processes cannot access the protected servers.

	Upload Control
	Check this option to control file uploads.

	Upload Size Limit
	Set the maximum file size allowed for upload. Files exceeding this size will be blocked.

	Upload Control Whitelist
	Specify whitelist addresses; files uploaded to these addresses are not restricted when upload control is enabled.
Multiple entries are supported, separated by semicolons, commas, or line breaks. Supported formats include:
IP:Port (e.g., 192.168.2.104:8080)
IP:Port Range (e.g., 192.168.2.104:8080-8079)
IP Range:Port (e.g., 192.168.2.1-192.168.2.255:8080)
IP Range:Port Range (e.g., 192.168.2.1-192.168.2.255:1000-8079)
Domain name (e.g., jira5.development.tec)


[image: image620.bmp] Note
In Smart Browser Mode:Windows supports only IE, Google Chrome, 360 Secure Browser, 360 Extreme Browser, Firefox, and Edge.Mac supports only Google Chrome and Safari.Linux does not support Smart Browser Mode.
After configuring secure communication settings, you can preview the policy effects for a selected object. In the preview page, Application System Protection is divided into two sections: Policy Settings and Policy Execution Effect. The execution effect shows the object’s final combined policy and its source.

If inheritance from the parent group policy is enabled, the object’s policy is combined with the parent’s policy. The combination rules are as follows:

1. For check-type settings (e.g., “Enable Application System Protection,” “Upload Control” in Smart Mode), if any inherited policy is checked, the final combined effect is checked.

2. For other input-type settings (e.g., “Secure Process Window Label,” “Exception Network Range,” “Secure Processes,” “Smart Mode Settings”), non-conflicting entries are combined, while conflicting entries are resolved according to policy priority; the setting from the highest-priority policy becomes the final combined effect.
Network Shared Document Protection
	Settings Option
	Description

	Policy Inheritance
	Choose from the dropdown: “Do not inherit parent policy” or “Inherit parent policy.” By default, new policies are set to “Inherit parent policy + Network Shared Document Protection disabled.” Inheriting the parent policy combines policies across objects; disabling inheritance applies only the object’s own policy.

	Enable Network Shared Document Directory Protection
	Check this option to enable protection for network shared document directories on the client.

	Security Gateway Address
	Set the IP address of the security gateway. Click the[image: image621.png]


to add.

	Protected Shared Document Directory
	Set the protected shared document directories. Click the [image: image622.png]


to add and enter the exact directory path (e.g., \\192.168.1.1\release\).Wildcards are not supported.

	File Whitelist Settings
	Files added to the file whitelist can be copied from protected network shared document directories without encryption.

· Check PE Files to include executable files (e.g., .exe, .dll) in the whitelist.

· Check Specified File Types and enter file types. Multiple types can be entered, separated by commas (e.g., *.txt, *.png). These file types will be added to the whitelist.

	Process Whitelist Settings
	Only authorized processes can directly open files in protected network shared document directories. To allow non-authorized processes to open files, configure the process whitelist.

· Enter process names, supporting wildcards and multiple entries separated by commas (e.g., notepad.exe, *word.exe).


[image: image623.bmp] Note
If a protected shared document directory can be accessed via both domain name and IP, both addresses must be added (e.g.,\\192.168.1.1\release\ and \\server\release\ ). Otherwise, access through an address not added will not be controlled.
After configuring secure communication settings, you can preview the policy effects for a selected object. In the preview page, Network Shared Document Protection is divided into two sections: Policy Settings and Policy Execution Effect. The execution effect shows the object’s final combined policy and its source.

If inheritance from the parent group policy is enabled, the object’s policy is combined with the parent’s policy. The combination rules are as follows:

1. For check-type settings (e.g., “Enable Network Shared Document Directory Protection,” checked options in File Whitelist), if any inherited policy is checked, the final combined effect is checked.

2. For other input-type settings (e.g., Security Gateway Address, Protected Shared Document Directory, Process Whitelist Settings), non-conflicting entries are combined. Conflicting entries are resolved according to policy priority; the setting from the highest-priority policy becomes the final combined effect.
21.12 Encrypted Document Operation Logs
Encrypted document operation logs can record:

1. On Windows clients: encryption, decryption, external document generation, document attribute changes, decryption requests, external document requests, and document attribute change requests.

2. On Mac and Linux clients: encryption and decryption operations.

By default, all logs are displayed. Administrators can apply various query filters. Double-click a log to view details. If backup logs are available, document copies can be viewed in the details. Backup documents also support bulk export:

· Use the right-click menu “Export Backup Documents” to export selected or all backup records.

· Use “Export Logs and Backup Documents” to export both selected or all logs and backup files simultaneously.
21.13 Full-Disk Scan
Users can set scan tasks on multiple clients simultaneously to scan local disks and encrypt/decrypt specified files. A single client can have multiple encrypt/decrypt tasks, which are executed in the order they were created.
Administrators with Encryption Function – Task Management permission can access the encryption management main window via the Document Security Management menu, then select Full-Disk Scan to configure full-disk scan and encryption/decryption tasks.
[image: image624.bmp]Note
Full-disk scan is also supported on Mac and Linux clients.
21.13.1 Disk Scan Task Settings
Full-Disk Scan Encryption Task
Steps to set up a full-disk scan encryption task:
1) Select one or more client machines, click the Add button [image: image625.jpg]T



 , and choose Create Encryption Task from the menu to open the task creation dialog.
2) In the General tab, configure the general settings.
3) Switch to the Advanced tab to configure advanced settings.
4) After completing the settings, click OK to create the scan encryption task successfully.
General Settings Description:
	Settings Option
	Description

	Task Name
	The name of the current task. A default value is automatically provided and can be modified.

	Select Targets
	Choose the target computers. Previously selected clients are pre-checked, and you can add or remove selections.

	Scan Path
	Specify the scan paths. By default, all local drives are included. You can set local paths, network paths, or mapped drive paths. Multiple paths can be separated by commas or semicolons. You can use specific drive letters (e.g., C:\;D:\) or predefined identifiers to scan corresponding drive types. Currently, three identifiers are supported:
Local Drives: _local — scans all local drives on the client.

Portable Drives: _portable — scans all connected portable devices, including USB drives, secure USB drives, encrypted drives, and external hard drives. Does not support encrypted workspaces, mobile phones, or optical drives.
Mapped Drives: _map — scans all locally mapped drives on the client.

	Include Files
	Files within this scope will be scanned and encrypted. You can select from predefined file types or click the[image: image626.png]


to manually enter file types. Wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).

	Exclude Files
	Files within this scope will not be scanned or encrypted. You can select from predefined file types or click the[image: image627.png]


to manually enter file types. Wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).

	Filter Files
	By default, some system files are excluded. Click the[image: image628.png]


to view the specific filtered files. To include these files in the scan, add them to the Include Files list.


[image: image629.bmp] Note 
The priority among Include Files, Exclude Files, and Filter Files is: Exclude > Include > Filter.
Advanced Settings Description:
	Settings Option
	Description

	Task Options
	Configure the actions to be performed during the task.

	Encrypt Plaintext to Ciphertext
	Plain files detected during the scan will be encrypted.

	Change Document Properties for Ciphertext
	Encrypted files detected during the scan will have their document properties modified. Three options are available:
Public–Normal Change: Only changes the access permissions of encrypted files with the “Public–Normal” attribute.
Change Lower-Level to Higher-Level: Compares the original and new permissions of encrypted documents. If the original permission level is lower than the new one, it will be updated.
Comparison rules:
1. Within the same security zone, compare security levels.

2. Across different security zones, the public zone is lower than other zones.

3. Between non-public zones, there is no hierarchy. 

Force Change: Overrides the original security attributes, applying the new settings regardless of the original attributes.

	Document Properties
	Configure the properties applied to files after encryption, including permissions, access rights, and user rights.

	Document Settings
	Set the document’s permissions and access rights. Default is Public–Normal.

	User Rights
	When enabled, specify creator identity, target users, and permissions. Encrypted files will carry these user rights.

	
	Creator Identity:Choose from Machine-Associated User, Last Logged-In User, or Specified User. Selecting Specified User opens the user organizational tree via the [image: image630.png]


 button to select the desired user.

	
	Document Targets & Permission: By default, includes <Creator>, which cannot be deleted. To add reader objects, click the [image: image631.png]


 to open the organizational tree and select users or roles as document readers.
Associated Permission: Document permissions include Read, Modify, Copy, Print, Screenshot, Decrypt, and Set Permissions.

	Performance Settings
	Configure system performance during task execution.

	Scan Speed Priority
	Scanning is faster but may impact system performance. Recommended for non-working hours.

	System Performance Priority
	Scanning is slower, minimizing resource usage and preserving system performance. Recommended for working hours.

	Scan Only When Idle
	Scanning and encryption occur only when the client is idle. The client is considered idle when its status in the console shows Running (Idle).

	Scan Time Period
	Set the start time for the scan and encryption task. Select the desired time category from the dropdown menu, which corresponds to the categories defined in Time Type Management.

	File Size
	Only files within this size range will be encrypted.


[image: image632.bmp] Note 
1. If Include Files is empty or no target computers are selected, the scan and encryption task cannot be created.
2. When an administrator creates an encryption task and sets document security properties, it is subject to their own security zone and level restrictions.
3. Once a full-disk scan encryption task is created, its settings cannot be modified. Ensure all settings are confirmed before creating the task.
Full-Disk Scan Decryption Task
Steps to set up a full-disk scan decryption task:
1) Select one or more client machines, click the Add button [image: image633.jpg]T



 , and choose Create Decryption Task from the menu to open the task creation dialog.
2) In the General tab, configure the general settings.

3) Switch to the Advanced tab to configure advanced settings.

4) After completing the settings, click OK to create the scan decryption task successfully.
General Settings Description:
	Settings Option
	Description

	Task Name
	The name of the current task. A default value is automatically provided and can be modified.

	Select Targets
	Choose target computers. Previously selected clients are pre-checked, and you can add more. Use the search bar to enter a target name for fuzzy matching; clicking search once locates the next matching object.

	Scan Path
	Specify the scan paths. By default, all local drives are included. You can set local paths, network paths, or mapped drive paths. Multiple paths can be separated by commas or semicolons. You can use specific drive letters (e.g., C:\;D:\) or predefined identifiers to scan corresponding drive types. Currently, three identifiers are supported:
Local Drives: _local — scans all local drives on the client.

Portable Drives: _portable — scans all connected portable devices, including USB drives, secure USB drives, encrypted drives, and external hard drives. Does not support encrypted workspaces, mobile phones, or optical drives.
Mapped Drives: _map — scans all locally mapped drives on the client.

	Include Files
	Files within this scope will be scanned and decrypted. By default, all files are decrypted. You can select from predefined file types or click the[image: image634.png]


to manually enter file types. Wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).

	Exclude Files
	Files within this scope will not be scanned or decrypted. You can select from predefined file types or click the[image: image635.png]


to manually enter file types. Wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).


Advanced Settings Description
	Settings
	Description

	File Security Attributes
	Specify which encrypted files will be decrypted based on access permissions and security attributes.

	All Zones, All Levels
	Select to decrypt encrypted files in all zones and levels.

	All Zones, Specific Level
	Select this option and specify a level to decrypt encrypted files in all zones at that level.

	Specific Zone, Specific Level
	Select this option and specify a zone and level. Encrypted files with access permissions equal to or lower than this setting will be decrypted.

	Performance Settings
	Configure system performance during task execution.

	Scan Speed Priority
	Scanning is faster but may impact system performance. Recommended for non-working hours.

	System Performance Priority
	Scanning is slower, reducing resource usage and preserving system performance. Recommended for working hours.

	Scan Only When Idle
	Scanning and decryption occur only when the client is idle. The client is considered idle when its status in the console shows Running (Idle).

	Scan Time Period
	Set the start time for the scan and decryption task. Select the desired time category from the dropdown menu, corresponding to Time Type Management categories.

	File Size
	Only files within this size range will be decrypted.


[image: image636.bmp] Note 
1. If no target computers are selected, the scan and decryption task cannot be created.
2. When an administrator creates a decryption task and sets document security properties, it is restricted by their own security zone and level.
3. Once a full-disk scan decryption task is created, its settings cannot be modified. Ensure all settings are confirmed before creating the task.                      4. Encrypted files without user rights will be decrypted according to the specified security attributes.                                                       5. For encrypted files with user rights:                   If File Security Attributes is set to All Zones, All Levels, user rights are ignored and all documents are decrypted.        If set to All Zones, Specific Level or Specific Zone, Specific Level, only documents readable by all users will be decrypted. Documents with restricted user access will not be decrypted.
21.13.2 View Task Information
Multiple encrypt/decrypt tasks can be set for a single client. Tasks are executed in the order they were created. The task currently being executed is the Current Task, while tasks waiting to be executed are Pending Tasks. Once the current task is completed, the next pending task automatically becomes the current task.
Current Task Information
In the upper view of the full-disk scan interface, you can view the basic information of the task currently being executed on each client.
	Item
	Description

	Computer
	The name of the client computer.

	Group
	The name of the group the client belongs to.

	Scan Function
	Status of the scan function: Enabled or Disabled. When enabled, full-disk tasks can be executed; when disabled, full-disk tasks are paused. The default status is Enabled.

	Current Task
	The name of the full-disk task currently being executed on the client.

	Current Task Status
	Status of the full-disk task currently being executed on the client:
1. Enabled: Task is running; status shows Started.
2. Disabled: Task is paused; status shows Paused.
3. During starting or pausing, the status shows Starting or Pausing.
4. pon completion, status shows Completed.

	Start Time
	The start time of the full-disk task currently being executed on the client.

	Progress
	The completion progress of the current full-disk task, automatically updated in real time.


Other Task Information
Select a client, and in the Task Information tab in the lower view of the full-disk scan interface, you can view not only the current task but also the pending tasks for that client. The details include all settings configured when each encryption or decryption task was created.
[image: image637.bmp] Note 
Full-disk scan tasks are executed only once and are not retained after completion. Subsequent tasks will then be executed.

Special Case:
If the last task for a client (with no pending tasks) is completed, its information remains in the Current Task section of the full-disk scan interface. Performing Disable Scan Function → Enable Scan Function on that client will re-execute the task, which is useful for scenarios requiring the same task to be run periodically.
21.13.3 View Task Logs
In the full-disk scan interface, select a client and open the Task Logs tab in the lower view to view the logs of tasks executed on that client. Use the Refresh button on the toolbar to update the log view.
	Item
	Description

	Time
	The timestamp when the log entry was generated.

	Task Name
	The name of the task currently being executed.

	Content
	Includes the task’s completion percentage, the directory currently being scanned, and key information about the task (including include and exclude conditions).


21.13.4 Enable/Disable Scan Function
Disable
The scan function on a client is enabled by default. In the full-disk scan interface, select one or more clients and click the Disable button [image: image638.jpg]


 or choose Disable Scan Function from the right-click menu. The scan function on the selected clients will be disabled, and any running tasks will be paused
Enable
Select one or more clients with the scan function disabled, then click the Enable button [image: image639.jpg]


 or choose Enable Scan Function from the right-click menu. The scan function on the selected clients will be enabled. Any paused tasks will resume, and subsequent tasks will execute in order.
21.13.5 Delete Task
Select one or more clients, then click the Delete button[image: image640.jpg]


 or choose Delete Client Task from the right-click menu. All tasks for the selected clients, including the current and pending tasks, will be deleted.
21.13.6 Search Client Tasks
Search
Click the Search button [image: image641.jpg]


 to open the Select Query Object dialog. Choose the desired client or client group and click OK. The client list will then display only the clients matching the search criteria for targeted viewing.
Mode
Click the Mode Switch button[image: image642.jpg]


 to choose between displaying All Clients or only Clients with Tasks.
21.14 Document Management
Local Scan on Console
In the Document Security Management window, select Tools → Local Scan Tool to scan encrypted files on the console’s local computer. You can perform encryption, decryption, generate external files, and modify document properties.
Remote Document Management
In the AnySecura console main window, select a client in the Computers panel, then right-click and choose Encryption Management → Remote Encrypted Document Management. This allows scanning of encrypted files on the specified client and performing encryption, decryption, external file generation, and document property modifications remotely. Operations can only be performed on online clients.
[image: image643.bmp] Note 
Mac and Linux clients do not currently support remote document management.
21.15 Intelligent Terminal Management
Select Document Security Management → Intelligent Terminal Management. Administrators can view smart terminal devices with the security viewer installed and manage these devices.。
21.15.1 Basic Operations
View Basic Information
Select a smart device in the left-hand view, then click the Basic tab on the right. The data displayed shows the basic information of the selected smart device.
1） Intelligent Terminal Basic Information
	Field
	Description

	Summary Information
	

	Name
	Name of the smart terminal, default matches the user entered during authorization request; can be renamed in the console.

	User
	Name of the user who applied for terminal authorization.

	Group
	Group to which the smart terminal belongs.

	Last Online Time
	Last time the smart terminal communicated with the server.

	Authorization Status
	Status of the terminal’s authorization: Pending Approval, Authorized, Authorization Denied, Authorization Cancelled, Universal Authorization, Expired, Deleted.

	Application Information
	Reason provided when requesting authorization for the terminal.

	Authorization Validity
	Validity period set during terminal authorization.

	Authorization Authentication Interval
	Interval for authorization authentication set during terminal authorization.

	Device Information
	

	App Information
	Information about AnySecura-related apps installed on the terminal.

	Terminal Name
	Name of the smart terminal.

	Status
	Current status of the terminal: Online or Offline.

	Offline Days
	Number of days the terminal has been offline.

	Network Address
	IP address of the terminal.

	Operating System
	Terminal’s operating system.

	Device Model
	Model name of the terminal.

	Device Manufacturer
	Manufacturer of the terminal.


2） Intelligent Terminal Group Basic Information
In the Intelligent Terminals panel, select a group and click the Basic tab on the right. The displayed data shows the basic information of the selected terminal group.
If Entire Network is selected, all terminal groups will be displayed. Click the Expand button “[image: image644.png]


” in the top-right corner of the display area to view the list of all smart terminals within these groups.
Group Operations
In the intelligent terminal hierarchy, there is initially only the Ungrouped category. When a smart terminal requests authorization, the Pending Approval and Unauthorized groups are automatically created, and the requesting terminal appears under both groups.

After an administrator processes the authorization:

· The terminal is removed from Pending Approval.

· If authorization is denied, the terminal remains in Unauthorized.

· If authorization is approved, the terminal moves from Unauthorized to Ungrouped.

Once a smart terminal is successfully authorized for the first time, it is placed in Ungrouped by default. To facilitate management, administrators can create additional groups to logically organize terminals.
Create a New Group
In the intelligent terminal hierarchy, select the root node Intelligent Terminals or an existing group. Then choose File → New Group from the menu. A new group node will appear in the hierarchy in editable mode. Enter the group name and assign authorized smart terminals to this group. Administrators can use the same method to create multi-level group structures.
[image: image645.bmp]Note
By default, there is an Ungrouped category. Newly authorized smart terminals are automatically assigned to this group. The Ungrouped group cannot be deleted, renamed, or used to create subgroups.
Assign or Change Group
To assign a smart terminal to a logical group or change its group, select the terminal(s), then choose File → Move To from the menu and select the target group. The selected terminals will be moved to the designated group.

Alternatively, you can use drag-and-drop: select the terminals, hold down the left mouse button, and drag them to the desired group. The selected terminals or groups will then belong to the target group.

Search
The search function allows administrators to quickly locate a specific smart terminal and view its related information.

In the intelligent terminal hierarchy, select File → Search to open the search dialog. Enter your search criteria, which can include Name (as shown in the hierarchy), Network Address, Operating System, Authorization Status, or Status. Fuzzy matching is supported.The search results will be displayed in a list below. Double-clicking a terminal in the list will take you directly to its detailed information page.
Rename
To facilitate management, administrators can rename a smart terminal to a more convenient and recognizable name. Select the terminal, then choose File → Rename from the menu. The updated name will be displayed in the console.
Delete
For smart terminals that no longer need to be managed, administrators can delete them from the console. Select File → Delete to remove the selected terminal. If a terminal group is deleted, all its subgroups and terminals will also be removed.

Deleting a terminal will revoke its authorization. The AnySecura Viewer on that device will stop functioning, displaying the message: “Your authorization has been deleted. Please contact the administrator.”
Restore
For smart terminals previously deleted from a group, administrators can restore them from the console. Select File → Restore to return the terminal to its original group. The authorization status will also revert to the state it was in before deletion.
21.15.2 Authorization Management
Enable Authorization
After a smart terminal applies for authorization using the security viewer, it will appear in the “Waiting for Approval” group. To authorize a terminal: select a terminal with the status Waiting for Approval, right-click and choose Authorization Management → Enable Authorization, configure the authorization settings, and click OK. 
The authorization settings include:
	Setting
	Description

	Authorization Time Settings
	Configuration for the smart terminal’s authorization duration.

	Authentication Interval
	If checked, specify the number of days within which the security viewer on the terminal must connect to the server at least once. If the terminal does not connect within the specified days, the authorized security viewer will become unusable and display “Authorization expired, please contact administrator.” If unchecked, the terminal can use the security viewer indefinitely without connecting to the server. Default: checked, 7 days.

	Authorization Validity Date
	If checked, select a date before which the terminal’s authorization is valid. After this date, the authorization expires and the security viewer cannot be used. If unchecked, the terminal’s authorization has no time limit. Default: unchecked.

	Group Settings
	Assign the terminal to a group after authorization.

	Select Group
	Choose the target group; after enabling authorization, the terminal will be placed in this group.


Reject Authorization
Select a smart terminal with the status Waiting for Approval, right-click and choose Authorization Management → Reject, enter the reason for rejection, and click OK. After rejection, the terminal’s authorization status will change to Rejected, and the rejection reason will be displayed on the security viewer’s authorization status page.
Pause Authorization
For smart terminals with the status Authorized, the administrator can right-click and select Authorization Management → Pause Authorization to suspend the terminal’s authorization.
Once paused, the security viewer on the terminal will not function properly, and the authorization page will display: “Your authorization has been paused, please contact the administrator.”
Cancel Authorization
For smart terminals with the status Authorized, Paused, or Expired, the administrator can right-click and select Authorization Management → Cancel Authorization to revoke the terminal’s authorization.
After cancellation, the terminal’s authorization status will change to Canceled, and the security viewer will no longer function. The authorization page will display: “Your authorization has been canceled, please contact the administrator.”
Modify Authorization Information
For smart terminals with the authorization status of "Authorized," "Paused," or "Expired," the administrator can right-click and select "Authorization Management -> Modify Authorization Info" to update the terminal's authorization details. The modifiable settings are the same as those available when enabling authorization.
21.15.3 Encryption Settings
Encryption Settings
The encryption settings for a smart terminal primarily define its security zones. They specify which security zones and levels of encrypted documents the terminal can access. Documents outside the permitted security zones or levels cannot be opened on this device.
For example, if a smart terminal is granted access only to the Marketing Department’s confidential level, the AnySecura viewer on this terminal can open documents at the Marketing confidential level and below, but cannot open any documents from the Finance Department regardless of their security level.
Watermark Settings
Administrators can configure watermark types and content to have the AnySecura viewer display custom text or QR codes when viewing files, effectively protecting document copyright.
The watermark settings include:
	Setting Name
	Description

	Enable Watermark Policy
	Check this option to activate the AnySecura viewer watermark policy.

	Watermark Content
	Set the watermark content. Options include text watermark and QR code watermark.

	Text Watermark
	Check this option to add text as a watermark. Requires setting text content, font size, font color, and transparency. Text content options include user, current date, and custom content.

	QR Code Watermark
	Check this option to add QR code information as a watermark. Requires setting QR code content and transparency. QR code content options include current date, user, and custom content.

	Parameter Settings
	Configure related parameters.

	Watermark Style
	Set the watermark style. Three styles are available; preview can be viewed on the left.

	Documents
	Set which documents the watermark applies to. By default, all documents are enabled. Optionally, apply watermark only when viewing encrypted documents.


21.16 USBKey Management
Encrypted USBKeys serve as tools to elevate user encryption permissions. Inserting an encrypted USBKey into a client machine enables changes to encryption permissions.
Navigate to Document Security Management → USBKey Management to save USBKey information and manage these USBKeys.
[image: image646.bmp] Note 
USBKey functionality is supported only on Windows clients. Mac and Linux clients are currently not supported.
21.16.1 Registration
An encrypted USBKey must be registered before it can be used. There are two registration methods:
Local Registration
Insert the encrypted USBKey into the console machine. Navigate to Document Security Management → USBKey Management to open the USBKey library. Select Operation → Local USBKey Information to view the USBKey details. Select the USBKey, click the “[image: image647.jpg]


” button，choose Register, enter the registration information, and then click the “[image: image648.png]


” button to save.
Remote Registration
Insert the encrypted USBKey into a remote client machine. From the console, open the USBKey library and select Operation → Remote USBKey Information. In Remote Client, choose the client with the inserted USBKey to view its details. Select the USBKey, click the “[image: image649.jpg]


” button, choose Register, enter the registration information, and then click the “[image: image650.png]


” button to save.
The information required for registration includes:
	Option
	Description

	General
	Optional general record information.

	Device ID
	Displays the device ID; cannot be modified.

	Valid Until
	By default unchecked, meaning no expiration. If checked and a date is specified, the USBKey will expire after this date and become unusable.

	USBKey Category
	The category under which the USBKey is registered.

	Remarks
	Records information about the USBKey user, including device number, department, user, position, contact info, and additional notes.

	Function Permissions
	Permissions granted by this USBKey; when used, the client’s current permissions are combined with the USBKey permissions.

	Online Encryption Permission
	If the client is offline, it still inherits the online encryption permissions from the USBKey.

	Direct Decryption Permission
	Permission to directly decrypt documents.

	Direct External Sharing Permission
	Permission to directly share documents externally.

	All Security Areas and Levels
	Grants permission for all security areas and levels.

	Usage Scope
	Specifies the computers and users allowed to use this USBKey.


21.16.2 Basic Operations
Descriptions of operations for local USBKey information:
	Icon Button
	Description
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	Refresh the local USBKey list.
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	Save USBKey information to the classification library.
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	Operations related to USBKey data and password.

	Reset Password
	Reset the USBKey’s usage password to the initial password, which is set under “Operations -> USBKey Password Settings.” For locked USBKeys, resetting the password also unlocks the device.

	Reset Data
	To prevent USBKey forgery, each registered USBKey has a unique random number. Unauthorized operations may cause a mismatch with the server, making the USBKey unusable. Reset Data restores the registered random number.

	Restore Factory Settings
	Restore the USBKey to its original factory settings. A USBKey restored to factory settings can be registered on another server.
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	AnySecura USBKey Registration Operations

	Register
	Register the USBKey.

	Disable
	After successful registration, the USBKey is enabled by default. Disabling it will make the USBKey unusable.

	Enable
	Re-enable a disabled USBKey to restore normal use.

	Modify Registration Info
	Modify general information, permissions, and usage scope entered during registration.

	Delete
	Delete the USBKey from the library. The next time it is inserted, it will be treated as unregistered.

	Auto Update ID
	When checked, a USBKey using an old ID will update automatically. If unchecked, a prompt will appear to choose whether to update. Default is unchecked.


[image: image655.bmp] Note
The operations for remote USBKey information are similar.
[image: image656.bmp] Note
Restoring factory settings can only be performed on local USBKey information.
USBKey Properties
The properties of a USBKey include:
	Property Name
	Description

	Device ID
	The ID information of the USBKey.

	Registration Status
	Status options:
Unregistered: The USBKey is not registered and cannot be used.


Authorized: The USBKey is registered and can be used.

Disabled: The USBKey is disabled and cannot be used.

Expired: The USBKey has expired and cannot be used.

	Usage Scope
	Computers and users authorized to use the USBKey at registration.

	Permissions
	Functional permissions assigned to the USBKey during registration.

	Expiration Date
	The expiration date set for the USBKey at registration.

	First Registration Time
	The first time the USBKey was registered.

	Last Modification Time
	The last time the USBKey’s registration information was modified.

	Last Operation Time
	The last time the USBKey was used.

	Last Operating Computer
	The computer that last used the USBKey.

	Remarks
	Notes set for the USBKey during registration.

	Device Name
	The name assigned to the USBKey at registration.

	Device Number
	The number assigned to the USBKey at registration.

	Department
	The department the USBKey belongs to, set during registration.

	Device User
	The name of the user assigned to the USBKey.

	Position
	The position of the USBKey’s assigned user.

	Contact Information
	Contact details of the USBKey’s assigned user.

	View Usage
	Right-click a USBKey entry and select “View Usage” to see its usage details.


21.16.3 Security Settings
USBKey Password Settings
Open the USBKey library and select “Operations -> USBKey Password Settings” to manage USBKey passwords.
The settings are described as follows:
	Setting
	Description

	Initial Login Password
	When resetting the password, it will revert to the initial login password, which is 123456 by default.

	Require Password Change on First Login
	If checked, the user must change the password on the first login with this USBKey.

	Password Error Limit
	If checked and a maximum error count is specified, the USBKey will be locked after reaching the limit of incorrect password attempts. Locked USBKeys cannot be used and require a password reset to unlock.


USBKey ID Settings
The ID acts as a usage credential for the USBKey. Each USBKey comes with a default ID from the factory, which the server also distributes to clients. The USBKey can only be used on a client if its ID matches the client’s stored ID; otherwise, it cannot be used.

On the server machine, log in to the console, open the USBKey library, and select “Operations -> USBKey ID Settings” to manage USBKey ID usage.

The functions of the buttons are as follows:
	Button
	Description

	Modify
	Modify the USBKey ID. In the settings interface, you can choose to use the default ID or a custom ID, which can be either manually entered or randomly generated.

	Backup
	Backup the custom ID.

	Import
	Import a previously backed-up ID.


If you do not want to use the default USBKey ID, you can change it to a custom ID. After modification, the USBKey will use the new ID, and the server will synchronize it to the client to ensure the client always has the latest ID.

After changing the ID, other USBKeys that have not been updated cannot be used on clients with the latest ID. You can update USBKey IDs in the console under either local or remote USBKey information.
[image: image657.bmp]Note
The ID Settings menu is not available when logging into the console from machines other than the server.
21.16.4 Log Viewing
In the USBKey library, select a USBKey, right-click, and choose “View Usage” to see its operation logs, including USBKey registration, modification of registration information, deletion, insertion, and removal.
To view logs for all USBKeys, go to the USBKey library and select “Operations -> USBKey Operation Logs.”
21.16.5 Offline Use
For offline client machines, only the USBKey authorization information saved before going offline can be used. Any USBKey registered or with modified permissions after the client goes offline cannot be used on that client.
In this case, the administrator can select “Operations -> Export USBKey Authorization File” in the USBKey library to export the authorization file and send it to the client for import.
21.17 Backup Server Settings
The console menu “Document Security Management -> Backup Server Management” includes two options: “Settings” and “Change Connection Password.”
Settings
Click “Settings” to open the Backup Server Settings dialog and configure the access range for backup servers. Steps are as follows:
1) Go to the console menu: “Document Security Management -> Backup Server Management -> Settings” to open the Backup Server Settings window.
2) Set the allowed IP range for backup servers and click Submit. For example, if the allowed IP range is 192.168.0.1–192.168.0.100, any backup server outside this range cannot connect to the main server.
The Backup Server Settings dialog also displays a list of all backup servers currently registered on the main server.
Change Password
Click “Change Connection Password” to set the connection password between the backup server and the main server. Steps:
1. Go to the console menu: Document Security Management -> Backup Server Management -> Change Connection Password.

2. After setting the connection password, the backup server can successfully connect to the main server, authenticate through it, and obtain its authorization.

[image: image658.bmp] Note 
Windows, Mac, and Linux clients can all be taken over by the backup server if the main server fails.
21.18 Custom Keys
Users can select the encryption algorithm for client-side file encryption and set custom keys while backing up key information.
Encryption Algorithm Settings
Log in to the console and go to Document Security Management -> Document Encryption Algorithm Settings to open the settings dialog. Click Modify in the “Encryption Algorithm” group box.
You can use the default encryption algorithm or choose a custom algorithm. Currently, four algorithms are available: DES, 3DES, AES128, and AES256.
Encryption Key Settings
In Document Security Management -> Document Encryption Algorithm Settings, click Modify in the “Encryption Key” group box.
You can use the default encryption key or define a custom key.
When using a custom key:

· If Generate New Custom Key is checked, you can randomly generate or manually enter a new key as the custom key.

· If Generate New Custom Key is unchecked, the latest key from the existing custom keys will be used.

· Notes are required for all custom keys.

All keys are saved. The latest key is used for encryption, while all keys are tried during decryption to ensure files encrypted at different times can be successfully decrypted.
Backup Custom Encryption Keys
In the Encryption Key group box of the Document Encryption Algorithm Settings dialog, click Backup to export and save key information to a specified location.

Click Import to import previously backed-up key information. During import, you can choose to use either:

· Local Custom Key as Current Key
· Imported Custom Key as Current Key.
If redeploying the server and you want to import the backup keys from the old server as custom keys and use them, follow these steps:
1) When importing the backup keys, select Import Custom Key as Current Key in the dialog.
2) In the Encryption Key settings, select Use Custom Document Encryption Key, leave Generate New Custom Key unchecked, and click OK to complete the setup.
[image: image659.bmp] Note 
The configured keys apply to Windows, Mac, and Linux clients.
[image: image660.bmp] Note
Using this feature requires two conditions:
1. The server must be registered with a valid license.
2. The console must be started in the server environment.
21.19 Encrypted Document Backup
Users can deploy an encrypted document backup server to centrally back up encrypted files from all clients in plaintext. This ensures that even if encrypted files on a client are lost or damaged, they can be recovered from the server.
[image: image661.bmp] Note 
The backup server supports file backups from Windows, Mac, and Linux clients.
21.19.1 Document Backup Server
Installation
The encrypted document backup server can be installed on the same machine as the main server or on a separate machine. Run the installer by double-clicking it. Steps:
1) Double-click AnySecuraBackup.exe, select the installation language, and click OK.
2) The welcome screen will appear; click Next to continue.
3) The installer will prompt you to confirm the installation path; you can also choose a different path.
4) Select the Start Menu folder for shortcuts and click Next.
5) Confirm the settings and click Install. After files are copied, the installation is complete. Click Finish to complete the setup.
View Backup Server Status
The encrypted document backup server icon displays its current operational status. The specific statuses are:
	Icon Status
	Description
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	Document backup server is starting.
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	Document backup service is stopped.
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	Run parameters not set (including connection, backup, or storage settings), or authorization with the server has not been verified.
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	Successfully connected to the server and authorized.
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	Successfully connected to the server but not authorized.
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	Disconnected from the server, or storage space has reached the warning limit.
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	Disconnected from the server and not authorized.
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	Backup stopped, or communication error occurred.


Right-click the encrypted document backup server icon and select Status from the menu to view more detailed server status information.
Server Parameter Settings
Right-click the encrypted document backup server icon, go to Tools -> Options, and the Server Parameter Settings dialog will appear for
	Parameter
	Description

	Connection Parameters
	

	Server Address
	Specify the server address to connect to.

	Local Domain Name or IP
	If the backup server and clients are on the same network, leave blank. If they are on different networks, enter the public IP of the backup server’s LAN. The LAN must also have port 8249 mapped for backups to work.

	Backup Library Path
	Specify the storage path for encrypted document backups.

	History Copies
	If checked, specify the maximum number of copies to retain. Only the latest specified number of backup copies will be kept.

	Remaining Space Management
	

	Auto Cleanup
	If checked, and both remaining space size and history copy count are set, then when space falls below the limit, only the latest specified number of copies will be kept.

	Auto Delete Old Backups
	If checked and a number of days is set, backups and copies older than that will be deleted.

	Send Alert
	An alert will be triggered if available space on the backup path drive is below the set value.

	Stop Backup
	Backup will stop if available space on the backup path drive is below the set value. 


[image: image670.bmp] Note
When both alert and stop-backup limits are set, the alert value must be greater than the stop-backup value.
View Runtime Logs
Right-click the encrypted document backup server icon and select Tools -> Runtime Logs to view logs related to the server’s operating status.
Backup Document Management Tool
Right-click the encrypted document backup server icon and select Tools -> Backup Document Management Tool to view backup documents from each client machine.
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21.19.2 Document Backup Management
Authorization
After configuring the connection parameters of the encrypted document backup server, authorization must be granted from the console connected to the corresponding server.

Go to Tools -> Server Management -> Document Backup Server Management. In the list, select the target backup server and click Authorize. Once successful, the backup server status will change to Authorized.

Click Revoke Authorization to return the backup server status to Unauthorized.
Set Scope
The default scope of machines for document backup is none. Click Set Scope to open the selection window, check the computers or computer groups to include for backup, and click OK to complete the configuration.
Set Mode
The default backup mode is Plaintext Mode. The modes are described as follows:
	Mode
	Description

	Plaintext Mode
	Documents triggered for backup are saved on the backup server in plaintext.

	Ciphertext Mode
	Documents triggered for backup are saved on the backup server in encrypted form.

	Original Mode
	Documents triggered for backup retain their original state: plaintext files are saved as plaintext, encrypted files are saved as encrypted.


After selecting a mode, click OK to complete the setup.
Set Backup Conditions
By default, automatic encrypted document backup tasks are not enabled on client machines.

Log in to the console and go to Document Security Management -> Other Permission Settings -> Document Backup Settings. Here, you can enable or disable automatic encrypted document backup tasks on client machines and configure the backup conditions.
	Icon/Button
	Description
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	Change the document backup conditions for the selected computer. 
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	Remove the document backup conditions for the selected computer.


When modifying backup conditions, if Enable Automatic Encrypted Document Backup Task is checked, any changes to encrypted documents or encryption of unencrypted documents will trigger backups according to the following backup restriction conditions for that computer:
	Option
	Description

	Include Files
	Files within this range will be backed up. Enter file names or paths; wildcards are supported (e.g., *.doc, C:*).

	Exclude Files
	Files within this range will not be backed up. Enter file names or paths; wildcards are supported (e.g., *.doc, C:*). Exclusions take priority over inclusions.

	Backup Size Range
	Files with encryption operations within this size range will be backed up.

	Backup Interval
	If a file is modified multiple times within this time range, it will be backed up only once.

	Backup Traffic
	The upload bandwidth for backup files will not exceed this value.

	Backup Time Period
	Files will be uploaded to the backup server only during this time period (e.g., 14:00–18:00).

	Periodic Scan Backup
	Whether to regularly scan and back up encrypted files.

	Scan Date
	Specify the date(s) for periodic scanning.

	Scan Time
	Specify the start and end time for periodic scanning. If scanning is not completed by the end time, the next scan will resume from where it left off. If no end time is specified, scanning continues until all files are processed.

	Allow Client to Enable or Disable Backup
	If checked, the client can choose whether to back up files. Default is unchecked.


[image: image674.bmp] Note
Documents detected for backup during the scan period will only be backed up to the server once the designated backup time period begins.
View Document Backup Logs
In the console, go to Document Security Management -> Document Backup Operation Logs to view the backup operation logs. 
Chapter 22: Windows Encrypted Client
22.1 Client Operating Status
After enabling encryption on the client, an icon appears in the system tray.
	Icon Status
	Descroption
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	Running
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	Stopped
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	Offline
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	Offline Authorized
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	Backup Mode


If encryption authorization is disabled and the client is restarted, the encryption icon in the system tray will disappear.
22.2 File Explorer
In File Explorer, encrypted files with the security attribute Public Area – Normal Level display a small lock icon without stripes in the lower-right corner. Encrypted files with other security attributes display a small lock icon with stripes.
Right-clicking an encrypted file in File Explorer opens a context menu with encryption-related options, such as Decrypt, Request Decryption, Export, and Request Export. The Encryption tab in the Properties dialog allows viewing and modifying the document’s attributes.
22.3 Encrypted Document Scan Tool
In the client system tray, right-click and select Scan Local Files to launch the scan tool.
Within the scan tool, you can specify scan paths, file types, whether to include subfolders, and whether to scan only encrypted files. Click Scan to detect both encrypted and unencrypted files on the local machine. Encrypted files are marked with a small lock icon.
In the scan results, selecting one or more encrypted files allows you to perform actions via the right-click menu, including Encrypt, Decrypt, Request Decryption, Export, Request Export, Export Extraction, and Modify Document Properties.
22.4 Encrypted Files
22.4.1 Quick Encryption
In File Explorer, select a non-encrypted file, right-click, and choose Document Encryption System -> Quick Encryption.

· If the file type is included in the console’s Encryption Authorization Settings -> Document Default Properties policy, the file is encrypted according to the configured attributes.

· If the file type is not included, it defaults to Public Area – Normal Level.

In the scan tool, right-clicking a non-encrypted file and selecting Quick Encryption will also encrypt the file with the same behavior as in File Explorer.
22.4.2 Authorized Encryption
When a client machine is logged in with a user who has permission to modify encrypted document attributes, you can select a non-encrypted file in File Explorer, right-click, and choose Document Encryption System -> Authorized Encryption.

· This allows you to modify the document’s security attributes and permissions.

· You can also set the configured attributes as the default, so they will be applied automatically for future encryptions.

In the scan tool, right-clicking a non-encrypted file and selecting Authorized Encryption has the same effect as encrypting via File Explorer.

Settings for security attributes and user permissions during authorized encryption can be referenced in the sections on Modifying Encrypted Document Security Attributes and Modifying Encrypted Document User Permissions in later chapters.
22.5 Decrypt Files
In File Explorer, select an encrypted file, right-click, and choose Document Encryption System -> Decrypt File to decrypt the file.
In the scan tool, right-clicking an encrypted file and selecting Decrypt File also performs decryption.
22.6 Request Decryption
Clients without decryption permission can request decryption by right-clicking a file, using the scan tool, or dragging the encrypted file into the Decryption Request floating window. Enter a reason and submit the request.

· Online Client: The console receives the request immediately for approval. Once approved, decryption can be performed in View Request Information.

· Offline Client: After submitting the request, export the request file via View Request Information and send it to the administrator. The administrator imports the file in the console for approval. Once approved, receive the authorization file from the administrator, import it on the client, and then decrypt via View Request Information.
22.7 Read-Only Access
For clients with read-only encryption authorization, select an encrypted file and right-click Document Encryption System -> Read-Only Open to view the document.
Alternatively, use Document Encryption System -> Open with Read-Only Mode to choose a program for viewing. The document cannot be modified.
22.8 Export
Clients with direct export permission can generate exportable documents using the right-click menu or the scan tool.
Export Steps:
1) Select the file to be exported, right-click, and choose Export from the context menu.
2) In the Create Export Document window, the added file information is displayed. To add more files, click the Add File[image: image680.png]


 or [image: image681.png]


 Add Folder button in the File Information tab. Both encrypted and unencrypted files can be added.
3) When adding a folder, its subfolders are included automatically, preserving the original directory structure.
4) When adding files or folders at any directory level, the current directory is treated as the parent directory. Double-click a folder to view its subdirectory, and click the[image: image682.jpg]


 or [image: image683.jpg]


 to navigate back to the parent
5) After selecting the target files, switch to the Export Recipients tab and choose the recipients. Use the search box in the top-right corner to quickly locate specific recipients; the search supports fuzzy matching.
6) After selecting the recipients, switch to the Export Settings tab to configure the permissions for the exported document. You can set whether the document allows printing, virtual printing, clipboard copying, screenshots, modifications, limit the number of opens, set a maximum number of opens, define start and end validity times, enable automatic deletion, synchronize with standard time, require a password to view, add a watermark, allow filtering of specific file types, and automatically hide validity, open count, or modification restrictions.
For export settings, click the icon [image: image684.jpg]


 to choose from existing client export templates. Custom settings can be saved as a new client export template by clicking the icon [image: image685.jpg]


.
7) After completing all selections, click Create, choose the export format and save location, and then click OK to complete the export.
[image: image686.bmp]Note
1. Watermark activation and content are configured by the administrator in the console under Document Security Management -> Encryption Settings -> Window Watermark -> Export Watermark. Clients can view but cannot modify these settings during export or export request.
2. If filtered file types are selected in the export settings, when viewing the exported document and performing a Save As operation:                                      Saving as a filtered file type produces a plaintext file.  Saving as a non-filtered file type produces an encrypted file.
3. The Auto Delete option can only be enabled if a validity period or maximum open count is set. When enabled, the exported document will be automatically deleted upon next opening once it exceeds the validity period or reaches the maximum open count.
Client Export Template Management
Clients can create and manage templates for frequently used export configurations.
When performing a direct export or export request, click the Template icon[image: image687.jpg]


 in the Export Settings tab to open the Client Export Template Management interface.
The management process is the same as for console export configuration templates.
[image: image688.bmp]Note
1. Each client can only use and manage the export templates it created; templates from other clients are not visible. However, templates exported from other clients can be imported.
2. If a client’s selected Frequent Export Template conflicts with the export configuration policy issued by the console, the console’s policy takes precedence.
22.9 Request Export
Clients without direct export permission can request export via the right-click menu or scan tool. When submitting a request, a reason must be provided, and the recipients and document permissions must be specified.

· Online Client: The console receives the request immediately for approval. Once approved, the export file can be generated via View Request Information.

· Offline Client: After submitting the request, export the request file via View Request Information and send it to the administrator. The administrator imports the file in the console for approval. Once approved, receive the authorization file from the administrator, import it in the client’s View Request Information, and then generate the export file.
22.10 Export Extraction
Export extraction allows encrypted files within an exported document to be extracted.
Clients with export extraction permission can select an exported file in File Explorer, right-click, and choose Document Encryption System -> Extract Exported Document to extract the encrypted files according to their permissions.
In the scan tool, right-clicking an exported file and selecting Extract Exported File also extracts the encrypted files from the export.
22.11 Modify Encrypted Document Security Attributes
A document’s security attributes include Setting Permissions and Access Permissions:

· Setting Permissions: Defines who can modify the document’s security attributes. Only one security area and level can be assigned.

· Access Permissions: Defines who can open or edit the encrypted document. Multiple security areas and levels can be assigned.

Clients with direct permission to modify encrypted document security attributes can use the Encryption tab in File Explorer or the scan tool, or right-click and select Modify Security Attributes to change the document’s security attributes.
22.12 Modify Encrypted Document User Permissions
Clients with direct permission to modify encrypted document attributes and with user permission control enabled can modify user permissions via the Encryption tab in File Explorer or the scan tool, or by right-clicking and selecting Modify User Permissions.

In the Modify Permissions dialog:

The left panel displays the object search interface. The upper-right panel shows the current document’s objects, with the creator marked by an asterisk (*) and others as readers. Selecting an object displays its permissions for the document in the lower-right panel.

Only reader permissions can be modified; creator permissions cannot be changed. Modifications include adding or removing readers and adjusting their permissions.
Add or Remove Readers 
Manage the readers of a document by adding or removing them.
Add Readers:
1. In the left User Structure tab, select the target objects, or use the Search tab to quickly locate them. Click Add >> to add the selected objects to the current reader list.

2. In the Custom Groups tab, click New Group to create a group and set its name.

· Select a group and click Add All to Group to include all current readers in the group.

· Select a group and click Import Users, enter user accounts separated by commas, semicolons, or new lines, and click OK to add multiple users to the group.

Group information is stored locally on the client. The group can be reused when modifying readers later. Custom groups support import and export.
Remove Readers
In the Current Readers view at the top-right, select the target objects and click << Remove to delete them from the reader list.

Click Clear to remove all current readers at once.
Modify User Permissions
Select a reader in the top-right panel to adjust their permissions. Click Copy to All to apply the selected reader’s permissions to all other readers.
Permission Templates
By default, Permission Templates are not displayed. Users granted Allow Selection of Permission Templates in the console under Directly Modify Encrypted Document Attributes -> Advanced Settings -> Template Settings can choose a template to set permissions for users within its scope.

If the user also has Allow Modifying User Permissions in Template, they can adjust specific permissions after selecting a template. These changes only affect the current document and are not saved to the template itself.
22.13 Request Change of Encrypted Document Attributes
Clients with permission to request changes to encrypted document attributes can submit a request via the right-click menu or scan tool. 
Steps:
1) Select the target file, right-click, and choose Request Change of Document Attributes.
2) In the pop-up request window, go to the Request Reason tab and enter the reason for the request.
3) After entering the request reason, you can review the added file information. To add more files, click the Add File[image: image689.png]


 or Add Folder icons [image: image690.png]


 in the File Information tab.
4) Once the target files are confirmed, switch to the Document Attributes tab and set the updated document security attributes and user permissions.
5) After completing all settings, click Apply to submit the request.
Online Client: After submitting a request to change document attributes, the console immediately receives the notification for approval. Once approved, the document attributes can be modified via View Request Information.
Offline Client: After submitting the request, export the request file via View Request Information and send it to the administrator. The administrator imports the file in the console for approval. Once approved, receive the authorization file from the administrator, import it in the client’s View Request Information, and then modify the document attributes.
22.14 View Document Attributes
In File Explorer or the scan tool, use the Encryption tab or right-click menu View Document Attributes to view an encrypted document’s attributes.

· Setting Permissions: Defines who can modify the document’s security attributes. Only one security area and level can be assigned.

· Access Permissions: Defines who can open or edit the encrypted document. Multiple security areas and levels can be assigned.

· User Permissions: Defines the reader objects who can open the document and their permissions, such as modifying or copying.
[image: image691.bmp]Note
Users granted Allow Direct Modification of Encrypted Document Attributes in the console can modify security attributes. If they also have Enable User Permission Control, they can modify user permissions.
22.15 Request Temporary Offline
For short business trips that can be completed within a few days, it is recommended to use the temporary offline request feature:
1) In the client system tray, right-click and select Temporary Offline -> Request.
2) In the pop-up Temporary Offline Policy Time Settings dialog, enter the start time, offline expiration time, and reason, then click OK.
3) Once the administrator receives and approves the request, the client goes offline and enters Backup Mode, performing encryption and decryption according to the online policies.
If the client leaves the company network before submitting a temporary offline request, notify the administrator via email or phone. The administrator will generate a temporary authorization code for the client to import.
Import Method: In the client system tray, right-click Temporary Offline -> Import, enter the temporary offline authorization code, and click OK.
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If Start Time is not selected during the request, the client enters temporary offline mode immediately after approval once it goes offline. If Start Time is selected and a specific time is set, the client will enter temporary offline mode only at the designated time, even after going offline.
22.16 View Request Information
In the client system tray, right-click View Request Information to check the status of decryption, external sharing, and temporary offline requests and approvals.
	Button
	Description

	View
	View detailed information of decryption and offline requests.

	Import Approval
	When offline, import the approval file provided by the console to obtain the approval result.

	Offline Request
	Generate an offline request file and send it to the console for approval.

	Cancel Request
	Cancel a decryption or external sharing request.


Decryption Request
You can view the request’s time, status, file name, size, quantity, security area, and level.

· Double-click a request record to see detailed information and perform actions such as Decrypt, Generate Offline Request File, or Cancel Request.

· For approved requests, click Decrypt or Complete Request to decrypt the file. You can choose to decrypt to the original location or another directory.

· For requests submitted while offline, click Offline Request to generate a request file and send it to the console for approval.
External Sharing Request
You can view the request’s time, status, file name, size, quantity, security area, and level.

· Double-click a request record to see detailed information and perform actions such as Create External File, Generate Offline Request File, or Cancel Request.

· For approved requests, click Create External Document or Complete Request to generate the external file. You can choose the output directory.

· For requests submitted while offline, click Offline Request to generate a request file and send it to the console for approval.
Document Attribute Change Request
You can view the request’s time, status, file name, size, quantity, security area, and level.

· Double-click a request record to see detailed information and perform actions such as Modify Document Attributes, Generate Offline Request File, or Cancel Request.

· For approved requests, click Modify Document Attributes or Complete Request to update the document’s attributes.

· For requests submitted while offline, click Offline Request to generate a request file and send it to the console for approval.
Temporary Offline Request
You can view the request’s time, status, file name, size, quantity, security area, and level.

· Double-click a request record to see detailed information, including the request time, offline expiration time, approving administrator, and approval time.

· If the client is offline when submitting a temporary offline request, approval can only occur once the client reconnects to the server.

· Therefore, when offline, if temporary offline functionality is needed, the client should notify the administrator via phone or email, and the administrator will generate an authorization code for the client to import.
22.17 Encrypted System Information
In the client system tray, right-click and select “Encryption System Information” to view the current authorized processes, current security objects, and encryption system details.
Current Authorized Processes
Under transparent encryption authorization, it shows the software currently opening encrypted documents.The process list is sorted alphabetically (A–Z).Under read-only encryption authorization, it shows software currently opening encrypted documents in read-only mode, marked with a “!” symbol.
Current Security Objects
Displays the client’s encryption authorization information, including general permissions, authorized software, security areas, and default document properties.This information is consistent with the encryption authorization settings on the console.

View Encryption System Logs
Shows system logs reporting failures such as encryption or decryption errors, as well as encryption system events.

Example: Opening an encrypted document in read-only mode under read-only encryption authorization.
View Offline Information
Displays long-term offline authorization time, temporary offline authorization time, and disaster recovery remaining time.
22.18 Offline Authorization Login
When the client is offline, its offline encryption and decryption permissions require login authorization to function properly.

· In the client system tray, right-click and select “Offline Authorization Login”.

· Enter the security password and click OK to enter offline authorization mode.
22.19 Import License File
In the system tray, right-click the client icon and select “Import License File.” Choose an offline license file generated by the console to obtain offline access.
You can also import an emergency license file generated by a backup server to gain emergency access.
22.20 Login and Logout of the Encryption System
For clients permitted to log out of the encryption system, right-click the client icon in the system tray and select “Logout from Encryption System.” After logout, all encryption functions are disabled and encrypted files cannot be opened.
To log in, right-click the client icon in the system tray and select “Login to Encryption System.” Enter the security password to log in successfully and restore full encryption functions.
22.21 Parameter Settings
Right-click the client icon in the system tray and select “Options.” You can configure the security password, encryption system login, system log retention period, display of decryption request pop-up windows, and application management settings.
22.21.1 Security Password Settings
Set a security password
The security password serves the following purposes:
1. To prevent unauthorized decryption or external sharing by others using this client. A password must be entered for each decryption or external sharing.

2. When the client is offline, the password is required to log in to offline authorization mode to use offline encryption and decryption, enhancing document security while offline.

3. When the client is online and logs out of the encryption system, encryption functions are disabled. Re-login with the security password is required to restore functionality, strengthening system security.

The default security password is empty. To change it, open “Options” → “Security Password Settings,” then enter the current and new passwords.
Clear Security Password
If a user forgets their security password, it can be cleared with administrator assistance using the client tool. Steps:

1) On the client machine, hold Ctrl+Alt+Shift and type “secureat” to open the client tool.

2) Select “Clear Encryption Security Password” and click [Generate Operation Code].

3) A “Verify Operation Code” dialog will appear. Report the original operation code to the administrator.

4) In the console, the administrator goes to Tools → Client Tool → Confirmation Code Generator and enters the client’s operation code. The client operation and related information will be displayed.

5) After verification, the administrator clicks [Generate Confirmation Code].

6) The administrator provides the confirmation code to the client. The client enters the correct confirmation code in the tool, and the security password will be cleared.
22.21.2 Security Password Input Settings
Click “Security Password Input Settings” in the Options dialog to configure how the security password is entered:
	Option
	Description

	Require input for every operation
	The password must be entered each time a file is decrypted or externally shared.

	Require input for first operation only
	When the client starts, the password is required the first time the encryption system is logged into, or the first time a file is decrypted or externally shared. No password is required for subsequent operations.

	No input required after login
	Once the client logs into the encryption system online or into offline authorization mode, decryption and external sharing do not require password entry.


22.21.3 Encryption System Login Settings
Online Login Settings
If the client has permission to log out of the encryption system, encryption functions are disabled after logout. The client must log back in to restore functionality.
You can choose the login mode when the client starts.
Parameter Description:
	Option
	Description

	Manual login required
	Each time the client starts, it remains logged out. The user must manually enter the correct security password to log in.

	Use previous state
	If the client was logged out during its last online session, it will remain logged out after restart. If it was logged in, it will remain logged in.

	Auto login
	The client automatically logs into the encryption system at each startup.


Offline Login Settings
If the client has offline encryption/decryption permissions, it must log into offline authorization mode after going offline to use these functions.
You can select the login mode for offline authorization.
Parameter Description:
	Option
	Description

	Manual login required
	Each time the client starts, it remains logged out of offline authorization mode. The user must manually enter the correct security password to log in.

	Use previous state
	If the client was logged out of offline authorization mode in the previous offline session, it will remain logged out after restart. If it was logged in, it will remain logged in.

	Auto login
	The client automatically logs into offline authorization mode at each startup.


22.21.4 Data Retention Settings
In Options, you can set how long client system logs are retained. The default is 3 days.
22.21.5 Decryption Request Pop-up Settings
You can configure whether to display the decryption request pop-up, remember its last position, and adjust its transparency.
22.21.6 Application Management Settings
By default, after decryption or document attribute change requests are approved, the operations must be completed manually.

You can enable automatic completion for document attribute changes and decryption requests, so approved actions are executed automatically.
22.21.7 Right-Click Menu Settings
By default, when a document is selected, the first-level right-click menu includes “Request Decryption” and “Request External Sharing”, while other functions are placed in the second-level “Document Encryption System” menu. You can customize which functions appear in the first-level menu based on your preferences.
22.22 Using the Encryption USBKey
22.22.1 USBKey Authentication Login
After inserting the encryption USBKey, the client automatically opens the USBKey login window.
The login dialog includes the following elements:
	Field
	Description

	Device
	The encryption USBKey device to log in.

	Password
	Default password is 123456. After logging in, the password can be changed via Right-click client encryption icon → USBKey Management → Change Login Password.

	Remember Password
	If checked, the password will be remembered for future USBKey logins. After logging in, you can clear the remembered password via Right-click client encryption icon → USBKey Management → Clear Remembered Password; the next login will require entering the password.

	Auto Login
	If checked, the next USBKey login will use the previous password automatically. Clearing the remembered password will disable auto login for the next session.


After USBKey login, the client’s permissions combine its own permissions with those granted by the USBKey.
To log out of USBKey authentication, right-click the client encryption icon and select USBKey Management → Logout USBKey Authentication. After logout, the client loses the permissions provided by the USBKey.
22.22.2 View USBKey Information
Right-click the client encryption icon and select USBKey Management → View USBKey Information to see details of the USBKey inserted in the client, including device ID, status, initial registration time, validity period, permissions, and last modification time.
22.22.3 Import USBKey License File
Right-click the client icon in the system tray and select “Import USBKey License File.” Choose a USBKey license file generated by the console to update the local USBKey database.
22.23 Proxy Administrator
If an administrator grants a client proxy administrator access, the client can log in to the proxy console on that machine to approve decryption requests, external sharing requests, and temporary offline requests.
22.23.1 Login
Clients with proxy administrator permission can right-click the client icon in the system tray, select “Approval Management Platform,” and enter the administrator account and password to log in to the proxy console. The proxy console supports automatic startup.
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When logging into the proxy console, checking “Auto Start” will make the console automatically launch and display the login dialog the next time the client starts and connects to the server. You can also enable this in the proxy console via Menu → Application Management → Options → Basic Settings → Login Settings → Auto Start.

If both “Auto Start” and “Auto Login” are checked and the correct administrator account and password are entered, the proxy console will automatically log in in the background when the client starts and connects to the server. The main console window will not appear, but users can open it from the client’s system tray menu.
22.23.2 Approval Management
The proxy console’s approval management functions are the same as the main console. It allows viewing and approving decryption, external sharing, temporary offline, and document attribute change requests; importing request files and exporting approval files; and viewing or delegating approval permissions.
22.23.3 Lock
To prevent others from using the proxy console for approvals, the administrator can lock it when away. While locked, the proxy console still receives pop-up notifications for decryption and external sharing requests, but a password is required to approve them. There are three lock modes: Direct Lock, Lock on Away, and Minimized Lock.
Direct Lock:
Select Menu → Actions → Lock to lock immediately.
Lock on Away:
Go to Menu → Application Management → Options, check “Automatically lock when user is away,” and set the delay in minutes before locking (default is 15 minutes).
Minimized Lock:
Go to Menu → Application Management → Options and check “Lock when minimized to tray.”
22.24 Force Update Policy
When the number of licenses is large, policy distribution may slow down. In this case, the client can right-click the system tray icon and select “Force Update Policy” to retrieve the latest policies from the server. A notification pop-up will appear once the update is successful.
Chapter 23: Linux Encrypted Client
The Linux client currently supports only a subset of encryption features.
23.1 Encrypted Document Scanning Tool
On the Linux client, right-click menu operations are not supported, so encryption, decryption, decryption requests, and temporary offline requests must be performed in the encryption scanning tool.
On Linux systems with a GUI, right-click the client tray icon and select “Scan Local Files” to launch the scanning tool.
[image: image694.bmp]Note
On some Linux versions, such as Ubuntu 12.04 and later, the client icon may not appear in the system tray. If the icon is missing, run the following command in the terminal to launch the scanning tool:/usr/local/bin/LSDHelper。 
In the scanning tool, select the scan path, file types, whether to include subfolders, and whether to scan only encrypted files, then click “Scan” to locate both encrypted and unencrypted files on the system.

On Linux systems without a GUI, run LSDHelper_CUI to use the scanning tool.
	Scan Command
	Description

	-p
	Source file path, required.

	-o
	Destination path; if omitted, defaults to the source path (omitting means both the -o option and its parameter are skipped).

	-t
	File types to scan; if omitted, all file types are scanned.

	-e
	Scan only encrypted files; if omitted, both encrypted and unencrypted files are scanned.

	-s
	Do not scan subfolders; if omitted, subfolders are scanned by default.

	-l
	List the scanned files; if omitted, files are not listed by default.

	-E
	Encrypt files matching the scan criteria; if omitted, only scanning is performed.

	-D
	Decrypt files matching the scan criteria; if omitted, only scanning is performed (the client must have decryption permission to succeed).


[image: image695.bmp] Note
1. All characters in the commands must be in English and are case-sensitive. Separate the option -x and its parameter xxx with a single space. Users can combine options as needed.
2. Each program launch executes only one command.
Linux Command Scan Example 1
To scan all files in a directory (e.g., /root/Desktop/test), enter the following command in the terminal:
LSDHelper_CUI -p /root/Desktop/test
Press Enter, and the total number of scanned files will be returned.
Linux Command Scan Example 2
To scan a specific file type (e.g., txt) in a directory (e.g., /root/Desktop/test) and display detailed file information, enter the following command in the terminal:
LSDHelper_CUI -p /root/Desktop/test -t txt -l

Press Enter, and the results will show detailed information for the txt files, including filename, directory, status, size, and modification time.
23.2 Encryption
In the scanning tool, select one or more unencrypted files from the scan results, right-click, and choose “Encrypt” to encrypt them. By default, encrypted files are set to the Public Security Zone at Normal level, and their security attributes cannot be modified on Linux.
On Linux systems without a GUI, files can be encrypted using commands.
Linux Command Encryption Example
To encrypt a specific file type (e.g., txt) in a directory (e.g., /root/Desktop/test), enter the following command in the terminal:
LSDHelper_CUI -p /root/Desktop/test -t txt -E

23.3 Decryption
In the scanning tool, select one or more encrypted files from the scan results, right-click, and choose “Decrypt” to decrypt them.
On Linux systems without a GUI, files can be decrypted using commands.
Linux Command Decryption Example
To decrypt all files in a directory (e.g., /root/Desktop/test), enter the following command in the terminal:
LSDHelper_CUI -p /root/Desktop/test -D
23.4 Request Decryption
Clients without decryption permission can select one or more encrypted files from the scan results, right-click, and choose “Request Decryption.” Enter a reason and submit. When the client is online, the console receives the request immediately for approval. Once approved, go to “View Request Information” and select “Complete Request” to decrypt the files.
On Linux systems without a GUI, decryption requests cannot be submitted.
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The Linux encryption client currently does not support offline decryption requests. 
23.5 View Request Information
In the client system tray, right-click and select “View Requests”, or open the scanning tool, click the button [image: image697.png]


 , and choose “View Requests” from the menu to see decryption requests and their approval status.
	Button
	Description

	Complete Request
	Execute the request after approval. For decryption requests, completing the request decrypts the file.

	View
	View detailed information of the decryption request.

	Cancel Request
	Cancel the decryption request.


Decryption Requests
You can view the request time, status, filename, size, quantity, security zone, and level of decryption requests.

Select a request and click [View] to see detailed information. You can also cancel the request or perform other actions.

For approved decryption requests, click [Complete Request] to decrypt the files. You can choose to decrypt them to the original directory or to another location.
Chapter 24: Mac Encrypted Client
The Mac client currently supports only a subset of encryption features.
24.1 Encrypted Document Scanning Tool
On the Mac client, right-click menu operations are not supported, so encryption, decryption, decryption requests, and temporary offline requests must be performed in the encryption scanning tool.
On Mac systems, right-click the client tray icon and select “Scan Local Files” to launch the scanning tool.
In the scanning tool, choose the scan path, file types, whether to include subfolders, and whether to scan only encrypted files, then click “Scan” to locate both encrypted and unencrypted files.
24.2 Encryption
In the scanning tool, select one or more unencrypted files from the scan results, right-click, and choose “Encrypt” to encrypt them. By default, encrypted files are set to the Public Security Zone at Normal level, and their security attributes cannot be modified on Mac.
24.3 Decryption
In the scanning tool, select one or more encrypted files from the scan results, right-click, and choose “Decrypt” to decrypt them.
24.4 Request Decryption
Clients without decryption permission can select one or more encrypted files from the scan results, right-click, and choose “Request Decryption.” Enter a reason and submit. When the client is online, the console receives the request immediately for approval. Once approved, go to “View Request Information” and select “Complete Request” to decrypt the files.。
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The Mac encryption client currently does not support offline decryption requests. 
24.5 View Request Information
In the client system tray, right-click and select “View Requests”, or open the scanning tool, click the [image: image699.png]


 button, and choose “View Requests” from the menu to see decryption requests and their approval status.
	Button
	Description

	Complete Request
	Execute the request after approval. For decryption requests, completing the request decrypts the file.

	View
	View detailed information of the decryption request.

	Cancel Request
	Cancel the decryption request.


Decryption Requests
You can view the request time, status, filename, size, quantity, security zone, and level of decryption requests.

Select a request and click [View] to see detailed information. You can also cancel the request or perform other actions.

For approved decryption requests, click [Complete Request] to decrypt the files. You can choose to decrypt them to the original directory or to another location.
Chapter 25: USB Encrypted Client
By turning a USB drive into a USB Encrypted Client, you can use its encryption features on any computer simply by plugging it in. No additional client installation is needed, offering quick and convenient access to encryption functions.
25.1 Launch and Exit
Launch
Insert the USB Encrypted Client into a computer, open the USB drive, and run USDAgent.exe. For the first use on a computer, the program requires initialization. Wait for the initialization to complete and then restart the computer.
For a USB client being used for the first time, after restarting, run USDConf.exe from the USB drive and click [Update Policy Online]. A dialog will appear to enter the server IP. After entering and confirming, the client will automatically fetch and import policies from the server.
Once the policy import is successful, run USDAgent.exe to open the USB Encrypted Client login dialog.
The login dialog includes the following elements:
	Field
	Description

	Removable Drive
	The current drive letter of the USB client.

	Device Name
	The device name set when the USB Encrypted Client was authorized.

	Password
	Default password is 123456. After login, it can be changed via Right-click encryption tray icon → Advanced → Change Password.

	Remember Password
	If checked, the client will remember the password for future logins. To clear it, go to Right-click encryption tray icon → Advanced → Clear Remembered Password and click [OK]. The next login will require entering the password.

	Auto Login
	If checked, the next login will use the previous password automatically. If the remembered password has been cleared, auto login will not occur.

	Reset Password
	If the login password is forgotten, click “Reset Password” and send the original operation code from the dialog to the administrator. The administrator uses Console → Tools → Client Tool → Confirmation Code Generator to generate a confirmation code. Enter this code in the dialog and click [OK] to reset the password. After resetting, the login password returns to the default 123456.


[image: image700.bmp]Note
For a USB client used for the first time, policies must be imported once before it can be launched. This step is not required for USB clients that have been used before.
After a successful login, the encryption client icon appears in the system tray, and encryption functions operate the same as the standard client.
Exit 

Right-click the client icon in the system tray and select “Secure Exit” to close the USB Encrypted Client.
25.2 Update Policy
Automatic Update
When the USB Encrypted Client is running and can communicate with the server, it will automatically sync the policies set on the server.
Online Update Policy
Run USDConf.exe from the USB drive and click [Update Policy Online]. The tool will update the USB with the latest policies from the server.
[image: image701.bmp]Note
The online update function can be used even if the USB Encrypted Client is not running.
Offline Policy Update
When the USB Encrypted Client is offline, update policies as follows:
1) The administrator logs into the console, selects the USB Encrypted Client in the computer tree, and chooses “Export Policy” from the right-click menu. Alternatively, go to Tools → Client Management → USB Encrypted Client Management, select the USB client, and choose “Export Policy File”. The policy file is exported in .ipz format.
2) The user runs USDConf.exe from the USB drive, clicks [Import Policy], and selects the exported policy file to import.
3) After importing, exit the USB Encrypted Client and log in again to apply the updated policies.
Chapter 26: External Viewer
The External Viewer is a tool installed on computers outside the enterprise, used to view externally shared documents.
26.1 Installation
Run the installer, choose the installation directory, and complete the installation.
26.2 Authorization
Authorize External Viewer
Steps:
1) Run OEAViewer.exe from the installation directory, or go to Start → All Programs → AnySecura OeaViewer → AnySecura External Document Viewer to launch the viewer.

2) Click [Settings] at the bottom right of the viewer interface to open the External Viewer settings window.
3) Click [Load] to import the general authorization file and enter the company information.
4) The authorization list will display which companies have granted authorization to this viewer and the authorization validity period.
Authorize External USBKey
Steps:
1) Go to Start → All Programs → AnySecura OeaViewer → AnySecura External Document Viewer to launch the viewer.

2) Click [Settings] at the bottom right of the viewer interface to open the External Viewer settings window, then select “USBKey Management”.
3) Click [Load] to import the authorization file and enter the company information.
4) The authorization list will show which companies have granted authorization to this USBKey and the authorization validity period.
Obtain Identification Code
Click [Settings] at the bottom right of the viewer interface to open the External Viewer settings window. On the Authorization Management page, locate the identification code. For USBKeys, find the identification code on the USBKey Management page and send it to the administrator to bind the authorization to the computer or the external USBKey.
26.3 Time Synchronization
The time synchronization feature prevents users from extending the usage of time-limited external documents by changing the system time, thereby better controlling document access.
Synchronization Methods:
	Method
	Description

	Direct Internet Connection
	If the computer can connect to the Internet, select this method and click [Update] to synchronize with the correct Internet time.

	Using a Time Synchronization Tool
	If the computer cannot access the Internet, select this method. On a computer that can access the Internet, run the time synchronization tool, enter the operation code from the External Viewer to generate a confirmation code, then enter this code in the External Viewer and click [Update] to synchronize the time.


26.4 USBKey Management
The External USBKey management feature allows management of external USBKeys. When an external USBKey is inserted into the computer, its ID, identification code, and authorization list are automatically retrieved.
Password Settings
The default password of an external USBKey is empty and can be changed.
	Button
	Description

	Change Password
	Modify the login password of the external USBKey by entering the old password and the new password.

	Clear Remembered Password
	If “Remember Password” was selected during USBKey login, the next login will automatically use the previous password. This operation clears the remembered password, requiring manual entry for the next login.


26.5 View External Documents
For external documents with the extensions .oeax and .oedx, there are two ways to open them:：
1）Double-click the document to launch the External Viewer. In the file list, double-click the file to open it, or click “Open With” to select an application. 
2) Launch the External Viewer first, then drag the external document into the viewer. In the file list, double-click to open, or use “Open With” to choose an application. 
For external documents with the extension .exe, double-clicking the file will launch the External Viewer, and subsequent viewing works the same as for .oeax and .oedx files.
When viewing external documents in multi-level directories, double-click a folder to enter a subdirectory. Click the[image: image702.jpg]
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 buttons to navigate back to the parent directory.
For 3D design software such as UG or Proe, different vendors use varying file format standards. When opening files from different vendors, it is often necessary to first import the file into the software to convert it to a compatible format. To view external files created from such varied formats, follow these steps:
1) Open the external document and click [Open With Program].

2) Select the program to open the file and click [OK].

3) Wait for the selected program to launch, then use File → Open within the program to locate and open the extracted file from the external document’s directory.
For computers using a USBKey, insert the USBKey authorized for the external recipient first. Launch the External Viewer and log in to the USBKey to access external documents.
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If the USBKey password is empty, the External Viewer will automatically log in to the USBKey upon startup.
Chapter 27: Backup Encryption Server
A backup server ensures that encryption clients can maintain online encryption and decryption policy permissions if the primary server fails or is stopped.
A primary server can have multiple backup servers deployed, but each backup server can only connect to one primary server at a time.
27.1 Installation and Operation
A backup server can be installed on the same machine as the primary server or on a different machine. Once running, its icon appears in the system tray.
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The backup server should run continuously, just like the primary server, rather than being started only when the primary server fails.
27.2 Check Backup Server Status
The backup server’s tray icon indicates its current status:
	Icon Status
	Description
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	Service not started.
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	Parameters not set, including server IP or connection password, or authorization with the primary server not completed.
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	Connecting to the server.
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	Disconnected from the server and in backup mode.
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	Authorization error; the backup server cannot connect to the primary server.


Right-click the backup server and select “Status” to view whether it is connected to the primary server, whether backup authorization is obtained, and the last time it retrieved all client information from the primary server.
27.3 Login Password Settings
Right-click the backup server’s tray icon, then go to Tools → Set Login Password to configure whether a password is required when using the backup server.

Once set, accessing any submenu under Tools in the backup server’s right-click menu will require entering the password. The login password can be modified later through Tools → Set Login Password in the backup server menu.
27.4 Backup Server Configuration
After installation, a backup server is not associated with any primary server by default. To deploy a backup server for a primary server, you must first configure its access scope and connection password in the console.
Once the access scope and connection password are set in the console, corresponding parameters must also be configured on the backup server itself.
27.4.1 Server Connection Configuration
1) Steps:

2) Right-click the backup server tray icon, go to Tools → Set Connection Parameters, and select the Server Connection tab.

3) Enter the primary server’s IP address and connection password, then click [OK].
Following these steps, the backup server will connect to the corresponding primary server and successfully obtain backup authorization.
27.4.2 Active Polling
The active polling feature can be used in two scenarios:
1) When the encryption system enters backup mode, the network is normal, but clients appear offline and cannot access backup mode, causing online policies to be ineffective. Enabling active polling allows the backup server to automatically connect to clients.
2) If the primary server experiences a failure before a backup server is deployed, installing a backup server and enabling active polling allows it to automatically connect to clients.
To enable active polling:

Right-click the backup server tray icon, go to Tools → Set Connection Parameters, select the Active Polling tab, and check Enable Active Polling.

By default, active polling detects all clients across all subnets. If a detection range is specified, only clients within the defined IP range will be checked.
27.5 View Client Status
Once the backup server is connected to the primary server and has synchronized client and computer group information, right-click the backup server and go to Tools → Client Status to view all clients on the primary server, including their names and IP addresses.
For clients that have previously connected to the backup server, the Client Connection Status section shows the most recent time each client connected to the backup server.
27.6 View Connection List
When the primary server fails, a backup server with valid backup authorization enters backup mode, and clients on the primary server also switch to backup mode, connecting to the backup server.
At this point, right-click the backup server tray icon and go to Tools → Connection List to view information on clients currently connected to the backup server.
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If the backup server was disconnected from the primary server (due to manual stop or network issues) for more than 30 minutes before the primary server stopped, it is considered not to have valid backup authorization, and clients will not connect to that backup server.
27.7 Create Backup Mode Authorization File
If a client cannot connect to the backup server due to network issues or other reasons after the backup server has entered backup mode, a Backup Mode Authorization File can be generated on the backup server and imported into the client to force it into backup mode.
The authorization file can only be generated while the backup server is in backup mode.

Steps:
1) Right-click the backup server tray icon, go to Tools → Advanced → Create Backup Mode Authorization File, to open the Generate Offline Backup Mode Authorization File dialog.

2) Set a file password. When importing the emergency authorization file, the client must enter this password to succeed. This step is optional, but setting a password is recommended to prevent unauthorized clients from importing the emergency authorization file and executing online encryption policies.

3) Set the validity period. The imported emergency authorization file will only be effective within this period. Once expired, a new backup mode authorization file must be generated and re-imported.
27.8 Super Authorization
If the primary server fails before the backup server is fully deployed, use the Super Authorization feature on the backup server to submit a request.
Super Authorization is one-to-one: an approval granted for one backup server can only be used for that specific server and cannot be applied to another backup server.
If multiple backup servers need deployment, each server must generate its own request file and submit it separately.
27.8.1 Request Super Authorization
Steps:
1) Install and run the backup server.
2) Right-click the backup server tray icon, go to Tools → Advanced → Super Authorization to open the Super Authorization request dialog.

3) Enter the primary server's serial number in the dialog, click Create Request File, and send the generated request file to us via email.
27.8.2 Apply Super Authorization
After receiving your request file, we will generate a Super Authorization File and send it to you.

To apply it:

1. Right-click the backup server tray icon, go to Tools → Advanced → Set Super Authorization.

2. In the Super Authorization dialog, locate the file and click Set Super Authorization to import it.

3. You can enter the primary server's verification code either during the import or after the file is successfully imported.

Once the Super Authorization File is imported, the backup server enters backup mode.
27.8.3 Set Verification Code
To ensure clients on the primary server can successfully connect to the backup server:

1. Right-click the backup server tray icon, go to Tools → Advanced → Set Verification Code.

2. In the dialog, enter the primary server’s verification code.

Backup servers entering backup mode via a Super Authorization File do not need the primary server connection parameters but must enable the active polling feature.
Chapter 28: Document Storage Request
Clients can upload decryption, external sharing, and document attribute change request files to the Document Storage Server. When the client is offline, approvers can preview and review requests by accessing files on either the Document Storage Server or the client.
28.1 Installation and Deployment
28.1.1 Installation
1）Right-click the installer OapprBackup.exe and run as Administrator. Select the installation language and click OK.
2）The welcome screen will appear. Click Next to continue.
3）The installer will prompt for the installation path. A default path is provided, or you can set a custom path. After setting the path, click Next.
4）On the HTTPS setup page, import the certificate file server.crt and key file server.key, and set the HTTPS port (default is 443). Click Next.
5）On the component selection page, choose the standard installation (default), which includes installing the MySQL database. Click Next.
6）Choose the Start Menu installation folder and click Next.
7）Review the settings, and click Install to begin the installation.
8）Wait for the installation to complete. Once finished, a prompt will appear. Click Finish.
28.1.2 Initialization
After installing the Application Document Storage Server, log in to the server management interface via a browser using the built-in account: admin (password is blank).
Server address examples:
1、IP + HTTP default port: http://192.168.2.112:9001
2、IP + HTTPS default port: https://192.168.2.112:443 or 
                      https://192.168.2.112

3、IP + non-default port: http://192.168.2.112:8086 or 
                   https://192.168.2.112:8089
After successful login, go to the Storage Settings page, click the [image: image712.png]


 button, and enter an existing storage path (e.g., D:\backup). Only one drive letter path is supported; if multiple paths are set, only the first will be recognized. 
[image: image713.bmp]Note
1. The default HTTP port is 9001, and the default HTTPS port is 443.
2. The data storage path must be set for the application document upload function to work properly.
28.1.3 Enable Application Document Upload
Currently, document upload is supported for encryption applications and desktop applications. After initializing the Application Document Storage Server, you need to enable the upload settings on the console.
Encryption Applications
On the console, go to Encryption Parameter Settings -> Application Document Upload Settings, check Enable, and enter the Application Document Storage Server address. Configure the Include Files, Exclude Files, and File Size settings.
Desktop Applications
On the console, go to Application Permissions -> Desktop Application Document Upload Settings, click the [image: image714.jpg]


 button to modify the settings. Check Enable, enter the Application Document Storage Server address, and configure Include Files, Exclude Files, and File Size.
28.2 WEB Management
28.2.1 Login
Enter the account and password on the login page to access the Application Document Storage Server management interface. The built-in account is admin with an empty password.
After logging in, click admin at the top-right corner of the navigation bar to Change Password.
28.2.2 Home Page
After logging in, the home page is displayed by default. It shows an overview of uploaded documents, including the number of uploads today, total size uploaded today, total historical uploads, and total historical upload size.
28.2.3 Storage Settings
On the Storage Settings page, configure the data storage path and disk space management parameters. Click the  [image: image715.png]


 button to edit, then click Save to apply changes or Cancel to discard.
Parameter Description:
	Setting
	Description

	Data Storage Path
	Path to store backup documents. Enter an existing path, e.g., D:\backup. Only one drive letter is supported; if multiple paths are set, only the first is recognized.

	Auto Cleanup
	Automatically cleans backup documents when disk space falls below the set value (in MB). Cleanup executes within 1 minute. Default: not set.

	Auto Cleanup Documents Older Than
	Set the number of days; the system automatically deletes backup documents whose last backup time is older than the set days. Cleanup is checked daily at 00:00. Must be a positive integer. Default: not set.

	Send Alert
	Sends an alert when disk space falls below the set value. A warning appears when logging into the server. Unit: MB.

	Stop Upload
	Stops uploading when disk space falls below the set value. Unit: MB. Default: 1024 MB.


[image: image716.bmp] Note
1. The data storage path must be set for the document upload function to work.
2. Ensure all parameters are correctly configured to guarantee normal operation of the Application Document Storage Server.
Chapter 29: Cloud Document Backup Server
The Cloud Document Backup Server can back up specified types of documents to prevent the loss of important data. It supports deploying multiple backup servers, but each client machine can upload its backup documents to only one server. Administrators can view and manage data through the web management interface and can assign different permission levels to users, allowing them to access and view backup data within their authorized scope.
29.1 Installation and Deployment
After installing the Cloud Document Backup Server, perform the necessary initialization and configure the relevant policies for the server to function properly.
29.1.1 Installation
The Cloud Document Backup Server can be installed on the same machine as the main server or on a separate machine. To install, simply double-click the setup program and follow these steps:
1) Double-click FileCloudBackupServer.exe, select the installation language, and click OK.
2) A welcome screen will appear. Click Next to continue.
3) The license agreement will be displayed. Read it carefully, then check I agree to the User Agreement and I agree to the Privacy Policy, and click Next.
4) Confirm or select the installation path for the server.
5) Set the AnySecura server IP and the Cloud Document Backup Server port (default is 80), then click Next.
6) Choose the Start Menu folder for shortcuts and click Next.
7) Review the settings and click Install.
8) Select the components to install. Keep all options checked. If MySQL is not installed on the current system, the installer will automatically install it. If MySQL is already installed, the installer will skip it.
9) Wait for the installation to complete, then click Finish to complete the setup.
After installation, the Cloud Document Backup Server icon will appear in the system tray.
[image: image717.bmp]Note
If MySQL was installed using the setup program, the username is root and the password is mysql.
Checking Cloud Document Backup Server Status
The Cloud Document Backup Server icon in the system tray indicates the current server status. Detailed states are as follows:
	Icon Status
	Description
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	Cloud Document Backup Server is starting

	[image: image719.jpg]



	Cloud Document Backup Server is stopped
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	Cloud Document Backup Server not initialized
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	Connected to server and authorized
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	Connected to server but not authorized
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	Disconnected from server
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	Disconnected from server and not authorized

	[image: image725.jpg]



	Backup stopped or communication error


Right-click the Cloud Document Backup Server icon in the system tray and select Status to view the current running status, whether it is connected to the main server, and whether it has obtained backup authorization.
View Cloud Document Backup Server Logs
Right-click the Cloud Document Backup Server tray icon and select Tools → Run Logs to view logs related to the server’s operation.
Modify Cloud Document Backup Server Port
Right-click the Cloud Document Backup Server tray icon, go to Tools → Options to change the port. After modification, the server must be restarted: right-click the tray icon, select Cloud Document Backup Server → Stop, then select Cloud Document Backup Server → Start to restart the server.
29.1.2 Database Connection Settings
After installing and deploying the Cloud Document Backup Server, the first login requires database connection setup. Once connected, the server will create the Cloud Document Backup database. Open a browser and enter the server address to access the database connection settings interface.
Server address examples:
1. IP + default port 80: 192.168.2.203
2. IP + non-default port 8080: 192.168.2.203:8080
3. Domain + mapped port: tec.oicp.net:10941
4. With http prefix: http://192.168.2.203
The port number refers to the port manually set during the Cloud Document Backup Server installation (default is 80). For the default port, specifying it is optional; for non-default ports, the port must be appended after the IP. Only the HTTP protocol is supported (http prefix is optional); HTTPS is not supported.
The Database Connection Settings interface requires the following information:
	Parameter
	Description

	Account
	The database account used for connection, e.g., root.

	Password
	The password for the database account. When installed via the Cloud Document Backup Server installer, the default password for the root account is mysql.

	Port
	The database port. When installed via the Cloud Document Backup Server installer, the default port is 3306.


29.1.3 Initialize Cloud Backup Server
After completing the database connection settings, the first login requires initialization. Enter the server address in a browser to open the initialization interface.
The first login initialization interface requires the following information:
	Parameter
	Description

	AnySecura Server Address
	The address of the connected AnySecura server, e.g., 192.168.2.236

	Account
	Administrator account with "Cloud Document Backup Server → Configuration Permission"

	Password
	Password of the administrator


After the first successful login, the Cloud Document Backup Server must be restarted.
29.1.4 Cloud Backup Server Parameter Settings
Log in to the Cloud Backup Server web management interface, go to Settings → Parameter Settings, and configure the required parameters.

To ensure the Cloud Backup Server operates correctly, make sure all parameters are properly set and valid.
29.1.5 Authorize Cloud Backup Server
After initializing the Cloud Document Backup Server, it must be authorized through the AnySecura console connected to the corresponding server.
In the console, go to Tools → Server Management → Cloud Backup Server Management, select the corresponding Cloud Backup Server from the list, and click Authorize. Once successful, the server status will change to Authorized. Clicking Revoke Authorization will revert the server status to Unauthorized.
29.1.6 Set Backup Scope
The default backup scope for client machines is empty. In the console, go to Tools → Server Management → Cloud Backup Server Management, select the Cloud Backup Server, and click Set Scope. In the pop-up selection window, check the computers or computer groups whose documents you want to back up, then click OK to complete the configuration. The documents from the selected machines will be backed up to this Cloud Backup Server.
29.1.7 Set Associated Users
The Cloud Document Backup Server only backs up documents from computers with associated users.
If a domain structure has been synchronized via the console (Tools → Server Management → Organization Sync), domain users who log in to a client machine for the first time will automatically become associated users for that computer.
For client machines without automatically associated users, administrators can manually associate users in the console under Tools → Server Management → User System Management → Association Info.
29.1.8 Set Backup Policies
By default, document backup on client computers is disabled. Log in to the console under Advanced → Cloud Document Backup to enable or disable backup for specific computers and configure backup conditions.
	Icon/Button
	Description
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	Modify the cloud backup policy for the selected computer(s).
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	Delete the cloud backup policy for the selected computer(s).


When modifying backup conditions, if “Enable Cloud Document Backup Task” is checked, any new or modified documents on the computer will be backed up to the Cloud Document Backup Server according to the following backup restriction conditions:
	Option
	Description

	Included Files
	Files within this scope will be backed up; enter file names or paths, wildcards are supported (e.g., *.doc, c:\*).

	Excluded Files
	Files within this scope will not be backed up; enter file names or paths, wildcards are supported (e.g., *.doc, c:\*). Exclusions take precedence over inclusions.

	Backup Size Range
	Files with new or modified content within this size range will be backed up.

	Backup Interval
	If multiple new or modified files occur within this time range, only one backup will be performed.

	Backup Traffic
	The upload traffic for backup documents will not exceed this value.

	Backup Time Period
	Only during this time period will backups be uploaded to the Cloud Document Backup Server (e.g., 14:00–18:00).

	Scheduled Scan Backup
	Determines whether files are periodically scanned for backup.

	Scan Date
	Specifies the date(s) for the scheduled scan.

	Scan Time Period
	Specifies the start and end time for the scheduled scan. If the scan is not completed by the end time, it will resume from where it left off next time. If no end time is specified, scanning continues until all files are processed.


[image: image728.bmp]Note

1. Modified documents include: renaming, editing content, copy-and-overwrite, drag-and-overwrite.
New documents include: creating files, "Save As", copy-to, drag-to, move-to.
2. Files identified for backup during a scan period will only be uploaded to the Cloud Document Backup Server once the specified backup time period begins. 
29.2 WEB Management Portal
29.2.1 Home Page
After logging into the Cloud Document Backup Server via a browser, you will enter the web management portal home page. The home page primarily displays the server’s authorization status, backup overview, and disk usage.
29.2.2 Backup Browsing
In the organizational tree on the left, select the corresponding user. The right-side view will display the backup documents for that user.
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The backup files in the right-side view are displayed according to their actual storage paths on the client. Selecting a specific directory will show the backup files within that directory. Clicking a file name allows you to view detailed information about the file. If the file has duplicates, you can click the corresponding icon to view them. By selecting one or multiple files, you can click Download to download the selected files to your local machine, or click Delete to remove the selected files from the Cloud Document Backup Server.
29.2.3 File Search
The left side displays the search panel, and the right side shows the search results. By default, the search condition is File Name. Clicking Advanced Search will reveal additional search criteria.
	Field
	Description

	File Name
	The name of the file.

	User
	The user who performed the operation on the file; only one user can be selected per query.

	Computer
	Can be selected only after specifying the user; selects the computer under the chosen user.

	Modification Time
	The time the file was modified; a time range can be set.

	File Size
	The size of the file; a size range can be set.


Operations on files in the search results view are the same as those in the backup browsing view.
29.2.4 Settings
Role Management
Role management is used to manage and set permissions for domain users based on roles. The interface is divided into upper and lower sections: the upper section displays the list of roles, and the lower section displays the view for viewing/setting parameters.
Click the [image: image730.png]


 in the upper section to make the settings in the lower section editable. After configuring the parameters, click the [image: image731.png]w



 to save and successfully add the role.
The settings items are described as follows:
	Setting
	Description

	Role Name
	Set the name of the role.

	Remark
	Set remarks or notes for this role.

	Assigned Objects
	Set the objects assigned to this role. Click the button next to the selection box to choose users. You can use the fuzzy search function to quickly locate the target objects.

	User Permissions
	Set the document permissions for this role.

	View Documents
	Specify whether users assigned to this role can view backup documents. Default is allowed.
Allowed: Users assigned to this role can open and view backup documents.
Prohibited: Users assigned to this role cannot view documents.
Not Set: Users assigned to this role will inherit the permission from their parent group role. If the inherited permission is “Allowed,” it is allowed; if “Prohibited,” it is prohibited. If no inherited permission exists, “Not Set” is treated as “Prohibited.” 

	Download Documents
	Specify whether users assigned to this role can download backup documents. Default is Not Set.
Allowed: Users assigned to this role can download backup files.
Prohibited: Users assigned to this role cannot download backup files.
Not Set: Users assigned to this role will inherit the permission from their parent group role. If the inherited permission is “Allowed,” it is allowed; if “Prohibited,” it is prohibited. If no inherited permission exists, “Not Set” is treated as “Prohibited.”

	Delete Documents
	Specify whether users assigned to this role can delete backup documents. Default is Not Set.
Allowed: Users assigned to this role can delete backup files.
Prohibited: Users assigned to this role cannot delete backup files.
Not Set: Users assigned to this role inherit the permission from their parent group role. If the inherited permission is “Allowed,” it is allowed; if “Prohibited,” it is prohibited. If no inherited permission exists, “Not Set” is treated as “Prohibited.”

	Management Scope
	Defines the scope of management for this role. Users assigned to this role can only manage backup documents within this scope. Default is empty. When the scope is empty, users assigned to this role can only manage their own documents.
Click the button next to the setting box to select the management scope; fuzzy search can be used to quickly locate target objects. 


In the upper view, select a role from the role list; the lower view will display the settings for that role in a read-only state. To modify the role, select it and click the[image: image732.png]


 on the far right—this makes the settings editable. After making changes, remember to save. Clicking the[image: image733.png]


 allows you to delete the role.
Role Permission Priority
When a user is assigned multiple roles, if there is a conflict in user permissions within the same management scope, the priority is as follows: Prohibit > Allow > Not Set.
Example scenario:
1. User A is in the “Test Subgroup” and is assigned to both Role Alpha and Role Beta.

2. Role Alpha permissions for User A: View Documents (Allow), Download Documents (Prohibit), Delete Documents (Prohibit); Management Scope: Empty (can only view their own backup documents).

3. Role Beta permissions for User A: View Documents (Allow), Download Documents (Prohibit), Delete Documents (Allow); Management Scope: Test Subgroup.
When User A logs into the Cloud Document Backup Server, they can see the backup documents of all users in the Test Subgroup.

· For their own backup documents: view (allowed), download (prohibited), delete (prohibited).

· For other users’ backup documents in the Test Subgroup: view (allowed), download (prohibited), delete (allowed).

User Permission Management
User Permissions Management on Cloud Document Backup Server.在On the left-side organizational tree, select the target user. The right-side view displays the user’s permissions, including assigned roles, management scope, and permissions to view, download, or delete backup files. A fuzzy search can be used to quickly locate the desired user.
In the Assigned Roles column:

· Black font indicates the role was assigned to the user/group’s parent group when created, meaning it is an inherited role.

· Blue font indicates the role was assigned directly to the user/group when created, meaning it is a direct role.

In the right-side view, select a record and hover over the Assigned Roles column to display a button, which allows adding or removing roles. Inherited roles cannot be removed.
If a user belongs to multiple roles, by default only the Assigned Roles are shown; the management scope and other document permissions appear empty. Click the [+] before the user’s name to expand and view detailed permissions for each role.
Administrator Blacklist and Whitelist Settings
The administrator blacklist and whitelist settings are used to restrict which administrators can log in to the Cloud Document Backup Server. By default, all administrators are unrestricted. You can choose to configure either a blacklist or a whitelist.
Click the button [image: image734.png]


 to configure, check the corresponding option, and enter administrator names. Multiple names can be separated by “;” or “；” or “,” or “，”. After input, click [image: image735.png]w



 Save.
	Setting
	Description

	Administrators prohibited from logging in
	Administrators in this list are not allowed to log in to the Cloud Document Backup Server.

	Administrators allowed to log in
	Only administrators in this list can log in; all others are denied access.


[image: image736.bmp] Note
The admin account can be included in the blacklist. If admin is blacklisted, it can only access the administrator blacklist/whitelist settings and has no other permissions.
29.2.5 Parameter Settings
In the Cloud Document Backup Server WEB management interface, go to Settings -> Parameter Settings to configure various parameters. Click the button[image: image737.png]


 to edit the settings. After editing, click Save to apply the changes or Cancel to discard them.

The parameters are explained as follows:
	Parameter
	Description

	Authorization Settings
	AnySecura server authorization settings.

	AnySecura Server Address
	The AnySecura server address entered during Cloud Document Backup Server initialization. 
If the address changes after initialization, it can be modified here. For a new address, it is recommended to test the connection first. Testing requires an AnySecura administrator account with “Cloud Document Backup Server -> Configuration Permission.”

	Domain Account Password Verification Settings
	The Cloud Document Backup Server allows domain users on client machines to log in and view their own backup files. Relevant domain server information must be configured. 
After setup, it is recommended to test the connection using a domain user account with permissions equivalent to the domain server.

	Domain Server Address
	The IP address of the domain server.

	Domain Name
	The name of the domain server.

	Is AD Domain
	Supports both AD and LDAP servers. Select “Yes” for AD, “No” for LDAP.

	Organizational Structure Sync Settings
	The Cloud Document Backup Server periodically syncs user organizational data with the AnySecura server. Sync settings can be configured here.

	Sync Interval
	Default sync interval is 1 day. It can be modified, or click “Sync Now” to sync immediately.

	Last Sync Time
	Displays the last time the Cloud Document Backup Server synced with the AnySecura server.

	Backup Storage Settings
	Configure storage parameters for backup documents.

	Data Storage Path
	The storage path for backup documents. In edit mode, click and enter an existing path, e.g., D:\backup. Multiple drive paths can be set. The path marked with is the current storage path. When the current path cannot store data (e.g., insufficient space), backup will switch to the next path.

	Number of Historical Copies
	If “Maximum Number of Historical Copies” is checked and a number is set, the oldest backup copies exceeding this number will be deleted to maintain the specified number of copies.

	Disk Space Cleanup
	Settings for disk space management, including:
1. Specify the number of historical copies to retain when disk space falls below a certain value. This setting is disabled by default.
2. Automatically delete backup documents and copies older than a specified number of days based on the last backup time. Cleanup occurs daily at 00:00. The number of days must be a positive integer. This setting is disabled by default.
3. Send an alert when available space on the storage path falls below a specified value. This setting is disabled by default.
4. Stop backup when available space on the storage path falls below a specified value. If multiple drive paths are set, backup stops on any drive below the threshold and automatically switches to the next path until all drives are full. Default threshold is 4GB.

	Port Mapping Settings
	

	Domain Name
	Devices outside the same network (including AnySecura server and clients) must use a domain name to access the Cloud Document Backup Server for proper communication. Enter the domain name that allows devices on different networks to access the Cloud Document Backup Server successfully.


[image: image738.bmp] Note
1. Storage paths support only local paths on the Cloud Document Backup Server.
2. To ensure proper operation of the Cloud Document Backup Server, make sure all parameters are set correctly.
29.2.6 Database Backup Settings
Database backup allows the entire database used by the Cloud Document Backup Server to be backed up to a specified path. This ensures that if the Cloud Document Backup Server database encounters issues, the backup can be restored promptly to maintain normal operation.
Set the parameters in “Settings” -> “Database Backup Settings” as follows:
	Parameter
	Description

	Backup File Storage Path
	Set the path for storing Cloud Document Backup Server database backups, e.g., C:\backup.

	Backup Now
	Click to perform an immediate database backup.

	Auto Backup on Database Update
	When checked, after upgrading the Cloud Document Backup Server, any database update prompts will be bypassed, and backup will run automatically before updating the database.

	Scheduled Database Backup
	Configure automatic scheduled database backups.

	Time Interval
	Set the interval for scheduled backups. Use the dropdown on the right to select the unit (month, week, day, hour, or minute) and enter the value in the box on the left.

	Last Backup Time
	Displays the time of the most recent database backup.


29.2.7 System Logs
Click “System Logs” in the top navigation bar to access the system log query page. System logs record operations of automatic document cleanup, allowing users to view records of automatic cleanup actions within a specified time period. By default, logs from the past month are displayed.
Query Parameter Descriptions:
	Query Parameter
	Description

	Start Time
	The start date for querying cleanup logs.

	End Time
	The end date for querying cleanup logs.

	Operation Type
	The type of cleanup operation. Currently, only automatic disk cleanup is supported.

	Description
	Details in the log, including the number of documents cleaned and space freed. Supports fuzzy search.


After entering the query parameters, click the “Search” button to view results. The result list includes operation log type, time, and details. Each page displays up to 25 entries; if exceeded, additional entries appear on the next page. Use the “Previous” and “Next” buttons to navigate.
[image: image739.bmp] Note
Each automatic cleanup operation performed by the system generates a corresponding cleanup log entry.
29.3 WEB Audit Client
The WEB Audit Client primarily records logs of administrator actions on the Cloud Document Backup Server, making it easy to track what operations administrators have performed. Audit administrators with “Cloud Document Backup Server” permissions can log in to the server to view audit logs.
29.3.1 Audit Logs
Audit administrators can view audit logs, which include Cloud Document Backup Server login activity and administrator operation logs.

Audit logs record the following information:
	Field Name
	Description

	Operation Log
	The type of operation performed.

	Time
	The specific time of the operation.

	Login Computer
	The name of the computer used to log in to the Cloud Document Backup Server.

	Login User
	The username used to log in to the Cloud Document Backup Server.

	Details
	Description of the administrator’s actions on the console.


Audit administrators can query logs by time range, operation type, or file name.
	Field Name
	Description

	Time Range
	Set a time range to query audit logs within that period.

	Operation Type
	The type of administrator operation.

	File Name
	The name of the file involved in the administrator’s operation.


29.3.2 Auditor Blacklist/Whitelist Settings
Auditor blacklist/whitelist settings are used to restrict audit administrators from logging into the Cloud Document Backup Server. By default, all audit administrators are unrestricted. You can choose to set a blacklist or whitelist.
Click the [image: image740.png]


 to configure, check the appropriate options, and enter the audit administrator names. Separate multiple names with “;”, “；”, “,”, or “，”, then click the [image: image741.png]w



 to save.
	Setting
	Description

	The following auditors are prohibited from logging in
	Administrators in this list cannot log in to the Cloud Document Backup Server.

	The following auditors are allowed to log in
	Only administrators in this list can log in to the Cloud Document Backup Server; all others are denied access.


[image: image742.bmp] Note
Administrators can set “audit” in the blacklist. When set to “audit,” this account can only access the auditor blacklist/whitelist settings and has no other permissions.
29.4 Cloud Document Backup Scan Tool
Administrators can set scan tasks on multiple clients via the console to scan local disks and back up specified files to the Cloud Document Backup Server. Each client can have multiple scan tasks, executed in the order they were created.
Administrators with “Function Permission – Cloud Document Backup Server – Scan Task Management” can log in to the console, go to “Tools – Cloud Document Backup Scan Tasks,” and configure full-disk scan backup tasks.
[image: image743.bmp] Note 
Mac and Linux clients do not currently support Cloud Document Backup scan tasks.
29.4.1 Scan Task Settings
Steps to set up a Cloud Document Backup scan task:
1) Click the add button [image: image744.jpg]T



 in the top right to open the task creation dialog.
2) On the “General” tab, configure the general settings.
3) Switch to the “Advanced” tab to configure advanced settings.
4) After completing the settings, click “OK” to successfully create the Cloud Document Backup scan task.
General Settings Instructions:
	Setting Option
	Description

	Task Name
	The name of the current task. The system auto-fills a default value, which can be modified.

	Select Target
	Select target computers.

	Scan Path
	Configures the specific path(s) to scan. Defaults to all hard drives. Supports local paths, network paths, and mapped drives. Multiple paths should be separated by commas or semicolons.

• Specific Paths: Define exact drive letters (e.g., C:\;D:\) to scan only those specific drives.
• Fixed Identifiers: Use the following keywords to scan specific types of drives:
- _local: Scans all local fixed drives.
- _portable: Scans removable devices (e.g., USB flash drives, secure USBs, encrypted disks, external HDDs). Does not support encrypted workspaces, mobile phones, or optical drives.
- _map: Scans all locally mapped network drives.

	Included Files
	Files within this scope will be scanned and backed up.
Select from predefined file types.
Click the[image: image745.png]


 button to manually enter paths, supporting wildcards (e.g., *.doc, C:\*, D:\test\*.txt).

	Excluded Files

	Files within this scope will be excluded from scanning and backup.
Select from predefined file types.
Click the [image: image746.png]


 button to manually enter paths. Wildcards are supported (e.g., *.doc, C:\*, D:\test\*.txt).


[image: image747.bmp] Note
For included and excluded files, the priority rule is: Exclusion rules override inclusion rules.
Advanced Settings Description:
	Setting
	Description

	Performance Settings
	Configure task performance during execution.

	Scan Speed – Task Priority
	Scanning is faster but may impact system performance. Recommended for non-working hours.

	System Performance Priority
	Scanning is slower to reduce resource consumption and maintain system performance. Recommended for working hours.

	Scan Only When Idle
	Scanning and encryption occur only when the client is idle; no scanning or encryption at other times. Idle means the console shows the client status as “Running (Idle).”

	Scan Time Period
	Set the start time for scanning and encrypting. Use the dropdown to select a time category as defined in Time Type Management.

	Backup Bandwidth
	Limits the bandwidth used when uploading backup files.

	File Size
	Only files within this size range will be scanned and backed up.


[image: image748.bmp] Note 
1. A scan backup task cannot be created if the file list or selected client objects are empty.
2. Once a full-disk scan backup task is created, its settings cannot be modified. Ensure all settings are correct before creating the task.
29.4.2 View Task Information / Task Logs
After a full-disk scan backup task is created, it is divided into multiple tasks and distributed to each client. A single client may have multiple scan backup tasks, which are executed in the order they were created.
View Task Information
In the upper view of the Cloud Document Backup Scan Task interface, you can see the basic information of the decomposed tasks.
	Field
	Description

	Task Name
	The name of the full-disk scan backup task.

	Computer
	The client computer name.

	Computer Group
	The name of the group the client belongs to.

	User
	The last logged-in user on the client machine.

	User Group
	The group of the last logged-in user on the client machine.

	Associated User
	The associated user on the client machine.

	Computer Status
	The running status of the client machine.

	Start Time
	The start time when the client begins this full-disk task.

	End Time
	The end time when the client completes this full-disk task.

	Task Status
	The current status of the full-disk scan backup task on the client:
1. After creation, if there is no preceding task, status is “Starting”; once initialization is complete, it becomes “Started.”

2. If a preceding task is running, subsequent tasks remain “Starting” until they become the current task, then status changes to “Started.”
3.During execution, if the task is disabled, status changes to “Paused”; re-enabling the task changes status back to “Started.”

4.During start or pause operations, status shows “Starting” / “Pausing Soon.”

5.After the scan task completes, status is “Completed.”

	File Count
	Total number of files scanned in this client task.

	File Size
	Total size of files scanned in this client task.

	Progress
	Completion progress of this scan backup task on the client, automatically updated.


Select a task, and in the “Task Information” tab in the lower view of the Cloud Document Backup Scan interface, you can view detailed information for that client task, including all settings configured when the task was created.
View Task Logs
In the Cloud Document Backup Scan interface, select a task and go to the “Task Logs” tab in the lower view to see the logs of that client’s task execution. Use the refresh button on the toolbar to update the logs.
	Field
	Description

	Time
	The time when this log entry was generated.

	Task Name
	The name of the currently executing task.

	Content
	Includes the current task status, progress, execution results, and other details.


29.4.3 Other Task Operations
Disable / Enable Task
By default, a client’s scan task is enabled after creation. In the Cloud Document Backup Scan interface, select one or more tasks and click the disable button[image: image749.jpg]


 or choose “Disable Scan Task” from the right-click menu to pause the selected tasks.
Select one or more disabled tasks, click the enable button [image: image750.jpg]


 or choose “Enable Scan Task” from the right-click menu to start the selected tasks.
Delete Task
Select one or more tasks, click the delete button [image: image751.jpg]


 or choose “Delete Scan Task” from the right-click menu to remove the selected tasks.
Query Task
Click the query button [image: image752.jpg]


 to open the selection dialog. Choose the specified computer or computer group and click “OK.” The task list will then display only tasks matching the query criteria for targeted viewing.
29.5 Cloud Document Backup Operation Logs
In the console, go to “Logs” -> “Cloud Document Backup Operations” to view backup operation logs. 
The logs include the following information:
	Field
	Description

	Type
	Upload log type, including Scan Start, Scan End, File Upload Start, File Upload Success, File Upload Failure, Upload Aborted.

	Time
	The time when this log entry was generated.

	Computer
	The name of the client computer.

	Computer Group
	The group the client computer belongs to.

	User
	The user logged in on the client computer when the log was generated.

	User Group
	The group of the user logged in when the log was generated.

	Associated User
	The associated user on the client computer.

	File
	The name of the file being backed up.

	Backup Server
	The Cloud Document Backup Server where the file is stored, including computer name and IP.

	Backup Size
	The size of the uploaded backup file.

	Description
	If the backup fails, displays the error reason and error code.


29.6 Upgrading the Cloud Document Backup Server
The Cloud Document Backup Server can be upgraded using the installation package. Run the upgrade installer in the server environment, and on the installation settings page, select “Upgrade” to perform the upgrade.
After upgrading the Cloud Document Backup Server, if the server detects a database update, the database must be updated before you can continue to log in to the server’s WEB management interface.
When logging into the server WEB interface, a “Cloud Backup Database Update” prompt appears. Click “Update” to open the “Cloud Backup Database Backup” prompt, where you can choose whether to back up the existing database before updating. Set the backup path and click “Backup” to start; once the backup is complete, the server automatically updates the database. If no backup is needed, click “Do Not Backup” to proceed directly with the database update.
After the database update is complete, you can log in to the Cloud Document Backup Server WEB management interface.
Chapter 30: Reporting System
The Reporting System provides query and statistical analysis of various logs. It supports multiple combinations of conditions and presents results using charts, helping administrators comprehensively monitor computer activities, provide a solid basis for policy deployment, and track policy execution in real time.
30.1 Terminology
Periodic Report
Generates reports automatically at specified intervals based on set conditions.
Query
Select a report type, enter query criteria, and generate the report in real time.
Statistical and Trend Reports
Each module provides both statistical and trend reports. Statistical reports show results that meet the query criteria, while trend reports display the value trends over a selected time period.

For convenience, the system predefines statistical and trend reports for both periodic and query reports, organized by report type.

30.2 Reporting Console
30.2.1 Logging into the Reporting Console
Log in to the console and select “Tools -> Login Reporting System” to launch the reporting console.
The reporting console interface includes:
	Interface Area
	Description

	Menu Bar
	Contains all system menus and serves as the entry point for each functional window.

	Toolbar
	Includes commonly used functions.

	Navigation Bar
	Located on the left side of the window, showing all periodic reports, query reports, and group information. The system predefines statistical and trend reports for all report types, organized by report type.

	Data Display Area
	The core view of the system, where all data is displayed. 

Divided into three sections:

	Query Bar
	Provides query criteria.

	Chart Area
	Located below the query bar, displays statistical charts of query results.

	Data Grid
	Located below the chart area, shows detailed query result data.


After logging into the reporting console, the data display area defaults to the homepage, which shows statistical information for specific logs across the network.
The statistics include: printed pages, sent email sizes, files written to removable disks, and uploaded file sizes. The time range for statistics is from 00:00 of the current day to the time displayed in the top-right corner of the interface. The homepage also displays the 10 most recently generated reports.
30.2.2 Data Display Area
The data display area contains many common elements.
Result View
All reports and query results are displayed in the data display area with charts above and list data below by default. Right-click in the data display area and select “Result View -> Maximize Chart” to show only the chart, or “Result View -> Maximize List” to show only the list data.
Charts
In the top-right corner of a chart, you can select the number of data items to display and switch the chart type. By default, all data is shown, or you can choose the top 5, 10, 20, or a custom number. Statistical reports default to bar charts, while trend reports default to line charts. The chart type can also be changed via the right-click menu. 
Right-click and select “Chart Settings” to configure legend items and the number of horizontal axis labels.
Lists
Below the chart, detailed data is displayed in a list format. You can choose which columns to display. Right-click a column header to add or remove data columns.
Detail Information
In each report’s result list, double-click a row or select a row and choose “Details” from the right-click menu to view specific details. For comprehensive data reports containing multiple data types, double-click different cells in a selected row to view the details corresponding to that cell.
Within the detail list, double-click a detail entry to view the specific log record.
30.2.3 Utility Functions
Import / Export
Generated reports and query results, along with their corresponding detail tables, can be exported and saved as electronic documents.
Reports and Query Results
In the data display area of periodic or query reports, right-click and select “Export -> Export Statistical Report” to export the current statistics, including charts. Right-click and select “Export -> Export Detail Table” to export all detailed data of the current statistics.
Detail Results
Double-click a row to enter the detail information view. Right-click and select “Export -> Export Current Page Records” to export only the logs on the current page (default 20 records), matching the console’s page display setting. Administrators can change the maximum records per page in the console under “Tools -> Options -> Console Settings -> Log View.” Right-click and select “Export -> Export All Records” to export all records.

Exported documents can be saved in four formats: Text (.CSV), HTML, MHT, or Excel.
Print / Print Preview
Generated reports and query results can be printed for record-keeping. Right-click in the data display area and select “Print” to print the current statistics, or “Print Preview” to view a preview before printing.
30.3 Predefined Reports and Queries
The system provides predefined periodic and query reports for supported report types, each including corresponding statistical and trend tables, organized by report type. Statistical reports are preset as standard monthly tables, and trend reports are preset as standard quarterly tables.
The reporting system supports the following report types:
	Report Type
	Description

	Print Report
	Statistics of print logs.

	Instant Messaging Report
	Statistics of instant messaging logs.

	Web Browsing Report
	Statistics of web browsing logs.

	Document Operation Report
	Statistics of document operation logs.

	Removable Media Report
	Statistics of removable media logs.；
In addition to the predefined removable media operation report, three storage-related reports are preset by statistical conditions:
1. Standard Removable Media Operation Group Report: Statistics of USB usage by computer group.
2. Standard Removable Media Insertion Count Group Report: Statistics of USB insertion counts by computer group.
3. Standard Removable Media Insertion Count Report: Statistics of USB insertion counts by computer. 
All three reports can be modified using the same report to adjust statistical conditions.

	Application Report
	Statistics of application logs.

	Email Report
	Statistics of email logs.

	Policy Log Report
	Statistics of policy logs.

	Encrypted Document Operation Report
	Statistics of encrypted document operation logs.

	Asset Report
	Statistics of software and hardware assets.

	Indicator Report
	Statistics of indicator event logs, i.e., logs matching indicator conditions. Indicator conditions can be set in “Reports -> Indicator Condition Settings.”

	Comprehensive Report
	Comprehensive log statistics, including all logs except indicator reports. Includes outbound document statistics covering email, removable media, upload, print, and IM outbound actions.

	Sensitive Information Report
	Statistics of sensitive information logs.


[image: image753.bmp] Note
1. Predefined reports do not include the Policy Log Report. 
2. Predefined reports, groups, and other settings can be modified or deleted.
3. Comprehensive reports include only statistical tables and do not have trend charts.
30.4 General Report Settings
When creating periodic or query reports, condition and statistical settings are required.
	Setting
	Description

	Condition Settings
	Includes computer scope, user scope, and advanced condition settings. Advanced conditions vary by report type.

	Statistical Settings
	Includes selection of statistical type and specific statistical configurations.


30.4.1 Condition Settings
Condition settings include computer scope, user scope, and advanced condition settings. Advanced conditions vary by report type.
A common advanced condition is the Time Type, used to set the statistical time range. Selecting a time category displays all categories defined in the console under “Category Management -> Time Type.”

The following describes other advanced conditions for each report type.
Print Report
	Advanced Condition
	Description

	Printer Type
	Four types: Local, Shared, Network, and Virtual printers. By default, Local, Shared, and Network are selected.

	Included Printers
	Printer names included in the statistics. You can specify a printer on a network computer, e.g., “\server*” for all printers on \server; “SomePrinter” for a printer named SomePrinter.

	Excluded Printers
	Printer names excluded from the statistics.

	Included Print Jobs
	Print job names included in the statistics, supports wildcards.

	Excluded Print Jobs
	Print job names excluded from the statistics, supports wildcards.

	Included Applications
	Print programs included in the statistics, supports wildcards and application category selection.

	Excluded Applications
	Print programs excluded from the statistics, supports wildcards and application category selection.

	Pages Greater Than
	Enter a positive integer; only print records with pages greater than this value are counted.

	Pages Less Than
	Enter a positive integer; only print records with pages less than this value are counted.


Instant Messaging Report
	Advanced Condition
	Description

	Chat Tool
	Chat tools included in the statistics.

	Chat Type
	Chat types included in the statistics; options: one-on-one or group chat.

	Included Content
	Chat content included in the statistics, supports wildcards.

	Excluded Content
	Chat content excluded from the statistics, supports wildcards.

	Included User ID or Nickname
	User IDs or nicknames included in the statistics, supports wildcards.

	Excluded User ID or Nickname
	User IDs or nicknames excluded from the statistics, supports wildcards.


Web Browsing Report
	Advanced Condition
	Description

	Included Websites
	Websites included in the statistics, supports wildcards.

	Excluded Websites
	Websites excluded from the statistics, supports wildcards.


Document Operation Report
	Advanced Condition
	Description

	Included Source Path
	Source file paths included in the statistics, supports wildcards.

	Excluded Source Path
	Source file paths excluded from the statistics, supports wildcards.

	Included Source Name
	Source file names included in the statistics, supports wildcards.

	Excluded Source Name
	Source file names excluded from the statistics, supports wildcards.

	Source Drive Type
	Source drive types included in the statistics; options: Hard Disk, Floppy, CD/DVD, Removable Media, Network Drive.

	File Size Greater Than (>=KB)
	Enter a positive integer; files larger than this value are counted.

	File Size Less Than (<=KB)
	Enter a positive integer; files smaller than this value are counted.

	Included Target Path
	Target file paths included in the statistics, supports wildcards.

	Excluded Target Path
	Target file paths excluded from the statistics, supports wildcards.

	Included Target Name
	Target file names included in the statistics, supports wildcards.

	Excluded Target Name
	Target file names excluded from the statistics, supports wildcards.

	Target Drive Type
	Target drive types; options: Hard Disk, Floppy, CD/DVD, Removable Media, Network Drive.

	Operation Type
	Select from Copy, Move, Delete, Access, Modify, Upload, and Download.

	Included Applications
	Application names included in the statistics, supports wildcards and application category selection.

	Excluded Applications
	Application names excluded from the statistics, supports wildcards and application category selection.

	Included Title
	Titles included in the statistics, supports wildcards.

	Excluded Title
	Titles excluded from the statistics, supports wildcards.


Removable Media Report
	Advanced Condition
	Description

	Encrypted Drive Type
	Options: All, Unencrypted, Encrypted, Dedicated.

	Included Removable Media
	Removable media included in the statistics; can select one or more devices or categories from the removable media repository.

	Excluded Removable Media
	Removable media excluded from the statistics; can select one or more devices or categories from the removable media repository.

	Removable Media Operation Type
	Removable media operations included in the statistics: Insert, Copy To, Move To, Copy Out, Move Out, Delete, Access, Modify, Upload, Download.

	Included Source Path
	Source file paths included in the statistics, supports wildcards.

	Excluded Source Path
	Source file paths excluded from the statistics, supports wildcards.

	Included Source Name
	Source file names included in the statistics, supports wildcards.

	Excluded Source Name
	Source file names excluded from the statistics, supports wildcards.

	File Size Greater Than (>=KB)
	Enter a positive integer; files larger than this value are counted.

	File Size Less Than (<=KB)
	Enter a positive integer; files smaller than this value are counted.

	Included Target Path
	Target file paths included in the statistics, supports wildcards.

	Excluded Target Path
	Target file paths excluded from the statistics, supports wildcards.

	Included Target Name
	Target file names included in the statistics, supports wildcards.

	Excluded Target Name
	Target file names excluded from the statistics, supports wildcards.

	Included Applications
	Application names included in the statistics, supports wildcards and application category selection.

	Excluded Applications
	Application names excluded from the statistics, supports wildcards and application category selection.


Application Report
	Advanced Condition
	Description

	Included Applications
	Application names included in the statistics, supports wildcards and application category selection.

	Excluded Applications
	Application names excluded from the statistics, supports wildcards and application category selection.


Email Report
	Advanced Condition
	Description

	Mail Direction
	Mail directions included in the statistics; options: Sent or Received.

	With Attachment
	Option to include emails with or without attachments.

	Included Sender
	Sender email addresses included in the statistics, supports wildcards.

	Excluded Sender
	Sender email addresses excluded from the statistics, supports wildcards.

	Included Recipient
	Recipient email addresses included in the statistics, supports wildcards; includes To, CC, and BCC.

	Excluded Recipient
	Recipient email addresses excluded from the statistics, supports wildcards; includes To, CC, and BCC.

	Included Subject
	Email subjects included in the statistics, supports wildcards.

	Excluded Subject
	Email subjects excluded from the statistics, supports wildcards.

	Mail Size Greater Than (>=KB)
	Enter a positive integer; emails larger than this value are counted.

	Mail Size Less Than (<=KB)
	Enter a positive integer; emails smaller than this value are counted.

	Included Attachment Name
	Mail attachment names included in the statistics, supports wildcards.

	Excluded Attachment Name
	Mail attachment names excluded from the statistics, supports wildcards.


Encrypted Document Operation Report
	Advanced Condition
	Description

	Operation Type
	Operation types included in the statistics: Encrypt File, Decrypt File, Generate External Document, Modify Document Security Properties, Request Decrypt File, Request Generate External Document, Request Modify Document Security Properties, etc.

	File Name
	File names included in the statistics, supports wildcards.

	Application
	Application names included in the statistics, supports wildcards.

	File Size Greater Than (>=KB)
	Enter a positive integer; files larger than this value are counted.

	File Size Less Than (<=KB)
	Enter a positive integer; files smaller than this value are counted.


Policy Log Report
	Advanced Condition
	Description

	Policy Log Type
	Selectable policies for statistics, including: Basic Policy, Application Control Policy, Web Browsing Control Policy, Device Control Policy, Print Control Policy, Screen Control Policy, Log Recording Policy, Remote Control Policy, Traffic Control Policy, Network Control Policy, Email Control Policy, IM File Transfer Policy, Upload Control Policy, Document Control Policy, System Alarm Policy, Removable Media Authorization Policy.

	Alarm Level
	Alarm levels included in the statistics; options: Normal, Important, Critical.

	Included Alarm Content
	Alarm content included in the statistics, supports wildcards.

	Excluded Alarm Content
	Alarm content excluded from the statistics, supports wildcards.


Indicator Report
	Advanced Condition
	Description

	Indicator Condition
	Indicator conditions included in the statistics.


Comprehensive Report
Includes the advanced condition settings of all report types above, except the Indicator Report.
External Document Report
Includes the advanced condition settings of the Print Report, Email Report, Removable Media Report, and Document Operation Report.
Sensitive Information Report
	Advanced Conditions
	Description

	Operation Type
	Select the operation types within the statistics scope, options include: Copy to removable media, IM file transfer, Send email, Upload file, Scan file.

	Information Classification
	Select sensitive information categories within the statistics scope.

	File Name (Include)
	File names to include in the statistics, supports wildcards.

	File Name (Exclude)
	File names to exclude from the statistics, supports wildcards.

	File Path (Include)
	File paths to include in the statistics, supports wildcards.

	File Path (Exclude)
	File paths to exclude from the statistics, supports wildcards.

	File Size Greater Than (>=KB)
	Enter a positive integer; files larger than this value are counted.

	File Size Less Than (>=KB)
	Enter a positive integer; files smaller than this value are counted.

	File Access Time Greater Than
	Check the box and click the button [image: image754.png]


 to select a date; files accessed after this time are counted.

	File Access Time Less 
Than


	Check the box and click the button [image: image755.png]


 to select a date; files accessed before this time are counted.

	File Modification Time 
Greater Than


	Check the box and click the button [image: image756.png]


 to select a date; files modified after this time are counted.

	File Modification Time 
Less Than


	Check the box and click the button [image: image757.png]


 to select a date; files modified before this time are counted.

	Prohibit
	Choose whether to count only prohibited actions.

	Warning
	Choose whether to include logs with warnings in the statistics.

	Chat Tool
	Include chat tool types within the statistics scope.

	Sender (Include)
	Include sender email addresses within the statistics scope, supports wildcards.

	Sender (Exclude)
	Exclude sender email addresses within the statistics scope, supports wildcards.

	Recipient (Include)
	Include recipient email addresses within the statistics scope, supports wildcards.

	Recipient (Exclude)
	Exclude recipient email addresses within the statistics scope, supports wildcards.

	Subject (Include)
	Include subject names within the statistics scope, supports wildcards.

	Subject (Exclude)
	Exclude subject names within the statistics scope, supports wildcards.


30.4.2 Statistical Settings
Statistical settings include the selection of statistical type and specific settings. Some settings vary depending on the report type.
General Settings
	Setting
	Description

	Statistical Type Selection
	

	By Computer Statistics
	Includes two methods:
Statistics by individual computer: generates a result set for each computer;
Statistics by computer group: generates a result set for each computer group, which sums the statistics of all computers within that group. 

	By User Statistics
	Includes two methods:
Statistics by individual user: generates a result set for each user;
Statistics by user group: generates a result set for each user group, which sums the statistics of all users within that group.

	Specific Statistical Settings
	

	Computer Group Statistical Level
	Select the hierarchical level of computer groups to which the data will be aggregated.

	User Group Statistical Level
	Select the hierarchical level of user groups to which the data will be aggregated.


Print Report Statistical Type
	Setting Item
	Description

	Statistical Type
	

	By Printer
	Aggregate results for each printer.

	By Computer + Printer
	Aggregate results by computer (or group) and printer; each computer (or group) with each printer forms one data set.

	By User + Printer
	Aggregate results by user (or group) and printer; each user (or group) with each printer forms one data set.

	Specific Statistical Settings
	

	Printer Settings
	Select the printers to include in the statistics.


[image: image758.bmp] Note
When using By Computer + Printer or By User + Printer statistics, the print count and page count for each printer must be switched for viewing in the top-right corner of the statistics view.
Instant Messaging Report
	Setting
	Description

	Statistics Type
	

	By Chat Tool
	Generate statistics for each chat tool.

	By Computer + Chat Tool
	Generate statistics for each computer (or group) combined with each chat tool; each computer (or group) has a set of data per chat tool.

	By User + Chat Tool
	Generate statistics for each user (or group) combined with each chat tool; each user (or group) has a set of data per chat tool.

	Detailed Settings
	

	Chat Tool Settings
	Select the chat tools to include in the statistics.


[image: image759.bmp] Note
When using "By Computer + Chat Tool" or "By User + Chat Tool," the number of messages and characters in the chat tool data can be viewed by switching in the top-right corner of the statistics view.
Web Browsing Report
	Setting
	Description

	Statistics Type
	

	By Website
	Two methods:
1. By Website – generate statistics for each individual website.
2. By Website Category – generate statistics for each website category; the result is the sum of all websites within that category.

	By Computer + Website
	Four methods:
1. By Computer + Website

2. By Computer + Website Category

3. By Computer Group + Website

4. By Computer Group + Website Category

Statistics are generated for each computer (or computer group) combined with each website (or website category); each computer (or group) has a set of data per website (or category).

	By User + Website
	Four methods:
1. By User + Website
2. By User + Website Category
3. By User Group + Website
4. By User Group + Website Category
Statistics are generated for each user (or user group) combined with each website (or website category); each user (or group) has a set of data per website (or category).

	Detailed Settings
	

	Website Category Level
	Select the hierarchy level of website categories for statistics.

	Website Settings
	Select the websites to include in the statistics; wildcard input is supported.


Document Operation Report
The report only includes general statistics type settings.
	Setting
	Description

	Statistics Type
	

	By Document
	Generate statistics for operations on each document. Tracked operations include: create, copy, move, rename, restore, delete, access, modify, upload, download, and burn.


[image: image760.bmp] Note
When using "By Document," the query may cover a large range and volume of data, which can take time. For better performance, set precise query conditions.
Removable Media Report
	Setting
	Description

	Statistics Type
	

	By Removable Media
	Two methods:
1. By Removable Media – generate statistics for each individual removable media.

2. By Removable Media Category – generate statistics for each media category; the result is the total of all media within that category.

	By Computer + Removable Media
	Four methods:
1. By Computer + Removable Media
2. By Computer + Removable Media Category
3. By Computer Group + Removable Media
4. By Computer Group + Removable Media Category
Statistics are generated for each computer (or computer group) combined with each removable media (or category); each computer (or group) has a set of data per media (or category).

	By User + Removable Media
	Four methods:
1. By User + Removable Media
2. By User + Removable Media Category
3. By User Group + Removable Media
4. By User Group + Removable Media Category
Statistics are generated for each user (or user group) combined with each removable media (or category); each user (or group) has a set of data per media (or category).

	Detailed Settings
	

	Removable Media Category Level
	Select the hierarchy level of removable media categories for statistics.


[image: image761.bmp] Note
When using "By Computer + Removable Media" or "By User + Removable Media," data such as insert count, write, read, delete, access, and file modification must be viewed by switching in the top-right corner of the statistics view.
Application Report
	Setting
	Description

	Statistics Type
	

	By Application
	Two methods:
1. By Application – generate statistics for each individual application.

2. By Application Category – generate statistics for each application category; the result is the total of all applications within that category.

	By Computer + Application
	Four methods:
1. By Computer + Application
2. By Computer + Application Category
3. By Computer Group + Application
4. By Computer Group + Application Category
Statistics are generated for each computer (or computer group) combined with each application (or category); each computer (or group) has a set of data per application (or category).

	By User + Application
	Four methods:
1. By User + Application
2. By User + Application Category
3. By User Group + Application
4. By User Group + Application Category
Statistics are generated for each user (or user group) combined with each application (or category); each user (or group) has a set of data per application (or category).

	Detailed Settings
	

	Application Category Level
	Select the hierarchy level of application categories for statistics.

	Application Settings
	Select the applications to include in the statistics; wildcard input is supported.


Email Report
The report only includes general statistics type settings.
Encrypted Document Operation Report
The report only includes general statistics type settings.
Hardware Asset Report
	Setting
	Description

	Statistics Type
	

	By CPU Model


	One method:
1. By Computer Group + CPU Model – generate statistics for each computer group combined with each CPU model; each computer group has a set of data per CPU model.

	By Memory Model


	One method:
1. By Computer Group + Memory Model – generate statistics for each computer group combined with each memory model; each computer group has a set of data per memory model.

	By Hard Drive Model


	One method:
1. By Computer Group + Hard Drive Model – generate statistics for each computer group combined with each hard drive model; each computer group has a set of data per hard drive model.

	By Motherboard 
Model


	One method:
1. By Computer Group + Motherboard Model – generate statistics for each computer group combined with each motherboard model; each computer group has a set of data per motherboard model.

	By Graphics Card 
Model


	One method:
1. By Computer Group + Graphics Card Model – generate statistics for each computer group combined with each graphics card model; each computer group has a set of data per graphics card model.

	By Computer Model


	One method:
1. By Computer Group + Computer Model – generate statistics for each computer group combined with each computer model; each computer group has a set of data per computer model.

	By Computer 
Manufacturer


	One method:
1. By Computer Group + Computer Manufacturer – generate statistics for each computer group combined with each manufacturer; each computer group has a set of data per manufacturer.

	Detailed Settings
	

	Computer Group Statistics Level
	Select the hierarchy level of computer group categories for statistics.


Software Asset Report
	Setting
	Description

	Statistics Type
	

	By Windows System Software
	One method:
1. By Computer Group + System Software – generate statistics for each computer group combined with each system software; each computer group has a set of data per system software.

	By Antivirus Software
	One method:
1. By Computer Group + Antivirus Software – generate statistics for each computer group combined with each antivirus software; each computer group has a set of data per antivirus software.

	By Operating 
System


	One method:
By Computer Group + Operating System – generate statistics for each computer group combined with each operating system; each computer group has a set of data per operating system.

	By Application 
Software


	One method:

By Computer Group + Application Software – generate statistics for each computer group combined with each application software; each computer group has a set of data per application software.

	Detailed Settings


	

	Computer Group 
Statistics Level


	Select the hierarchy level of computer group categories for statistics.


Hardware Asset Change Report
	Setting
	Description

	Statistics Type
	

	By Computer + Asset Category
	Two methods:
1. By Computer + Asset Type – generate statistics for each computer combined with each asset type.
2. By Computer Group + Asset Type – generate statistics for each computer group combined with each asset type.
Statistics are generated for each computer (or computer group) with each asset type; each computer (or group) has a set of data per asset type.

	Detailed Settings
	

	Computer Group Statistics Level
	Select the hierarchy level of computer group categories for statistics.


Indicator Report
	Setting
	Description

	Statistics Type
	

	By Computer + Indicator Level
	Two methods:
1. By Computer + Indicator Level – generate statistics for each computer combined with each indicator level.
2. By Computer Group + Indicator Level – generate statistics for each computer group combined with each indicator level.
Statistics are generated for each computer (or computer group) with each indicator level; each computer (or group) has a set of data per level.

	By User + Indicator Level
	Two methods:

1. By User + Indicator Level – generate statistics for each user combined with each indicator level.
2. By User Group + Indicator Level – generate statistics for each user group combined with each indicator level.
Statistics are generated for each user (or user group) with each indicator level; each user (or group) has a set of data per level.

	By Indicator Type + Indicator Level
	Statistics are generated for each indicator type combined with each indicator level; each indicator type has a set of data per level.

	By Computer + Indicator Type
	Two methods:
1. By Computer + Indicator Type – generate statistics for each computer combined with each indicator type.
2. By Computer Group + Indicator Type – generate statistics for each computer group combined with each indicator type.
Statistics are generated for each computer (or computer group) with each indicator type; each computer (or group) has a set of data per type.

	By User + Indicator Type
	Two methods:
1. By User + Indicator Type – generate statistics for each user combined with each indicator type.
2. By User Group + Indicator Type – generate statistics for each user group combined with each indicator type.
Statistics are generated for each user (or user group) with each indicator type; each user (or group) has a set of data per type.

	Detailed Settings
	

	Indicator Condition Settings
	Select the indicator conditions to include in the statistics.


Comprehensive Data Report
The report only includes general statistics type settings.
External Document Report
The report only includes general statistics type settings.
Sensitive Information Report
	Setting
	Description

	Statistics Type
	

	By Sensitive Information
	Generate statistics by sensitive information.

	By Computer + Sensitive Information
	Two methods:
1. By Computer + Sensitive Information – generate statistics for each computer combined with each sensitive information item.
2. By Computer Group + Sensitive Information – generate statistics for each computer group combined with each sensitive information item.
Statistics are generated for each computer (or computer group) with each sensitive information item; each computer (or group) has a set of data per item.

	By User + Sensitive Information
	Two methods:
1. By User + Sensitive Information – generate statistics for each user combined with each sensitive information item.
2. By User Group + Sensitive Information – generate statistics for each user group combined with each sensitive information item.
Statistics are generated for each user (or user group) with each sensitive information item; each user (or group) has a set of data per item.

	Detailed Settings
	

	Computer Group Statistics Level
	Select the hierarchy level of computer group categories for statistics.

	User Group Statistics Level
	Select the hierarchy level of user group categories for statistics.


30.5 Report Statistics Content
The supported statistics for each report are as follows:
Print Report
Statistics include: number of prints, number of pages printed.
Email Report
Statistics include: number of sent emails, size of sent emails, number of received emails, size of received emails, total email count, total email size.
Removable Media Report
Statistics for Removable Media Operation Report, Standard Removable Media Operation Group Report, Standard Removable Media Insert Count Group Report, and Standard Removable Media Insert Count Report include:

· Insert count

· Number of files written to removable media

· Size of files written to removable media

· Number of files read from removable media

· Size of files read from removable media

· Number of files deleted

· Size of files deleted

· Number of files modified

· Size of files modified

· Number of files accessed

· Size of files accessed
Document Operation Report
Statistics include: number of files uploaded, size of uploaded files, number of files downloaded, size of downloaded files, number of files deleted, size of deleted files, number of files copied, size of copied files, number of files moved, size of moved files, number of files modified, size of modified files, number of files accessed, size of accessed files.
Application Report
Statistics include: system uptime, active time, active time percentage, application usage time, application usage time percentage.
Web Browsing Report
Statistics include: browsing time, browsing time percentage.
Policy Log Report
Statistics include: number of alerts.
Instant Messaging Report
Statistics include: number of chat messages, number of chat characters, number of chat sessions.
Encrypted Document Operation Report
Statistics include: number of encrypted files, size of encrypted files, number of decrypted files, size of decrypted files, number of external files generated, size of external files generated, number of document security attribute modifications, size of document security attribute modifications, number of decryption requests, size of decryption requests, number of external file generation requests, size of external file generation requests, number of document security modification requests, size of document security modification requests.
Asset Reports
Hardware Asset Report
Statistics include: CPU model, memory model, hard drive model, motherboard model, graphics card model, computer model, computer manufacturer. Default is CPU model.

Software Asset Report
Statistics include: Windows system software, antivirus software, operating system, application software. Default is application software.

Hardware Asset Change Report
Statistics include: motherboard, graphics card, CPU, memory, and hard drive. All are displayed by default.

Indicator Report
Statistics include: number of indicator occurrences.
Comprehensive Report
Statistics include: number of pages printed, size of sent emails, size of files written to removable media, size of uploaded files, application usage time, web browsing time, number of alerts.
External Document Report
Statistics include: number of external files, size of external files, number of attachments sent, size of attachments sent, number of files written to removable media, size of files written to removable media, number of files uploaded, size of files uploaded, number of prints, number of pages printed.
Sensitive Information Report
Statistics include: number of files copied to removable media, size of files copied to removable media, number of files copied to network drives, size of files copied to network drives, number of files sent via IM, size of files sent via IM, number of emails sent, size of emails sent, number of files uploaded, size of files uploaded, number of external operations, size of external operations.
30.6 Template Management
Templates include condition settings and statistical settings. By clicking Reports → Template Management, administrators can predefine report templates.The system provides default templates for each module’s statistical and trend reports (Comprehensive Report only has statistical report templates).
System-defined templates are view-only and cannot be modified or deleted.
30.7 Period Management
Period Management includes settings for the report data time range, report generation time, and whether to perform pre-statistics.
By clicking Reports → Period Management, administrators can customize the periods for periodic reports.
Default periods include standard yearly, quarterly, monthly, weekly, and daily cycles. System default periods can be modified but not deleted. Selecting any period and clicking the [image: image762.png]


 button will restore it to the standard settings for that period type.
The settings for each period are described as follows:
	Setting
	Description

	Report Data Time Range
	The start and end dates of the data to be included in the report.

	Report Generation Time
	The time when the periodic report is generated; statistics for the specified data time range will be generated at this time.

	Pre-Statistics Before Report Generation
	When checked, and with a start time and interval set, the system will pre-calculate statistics from the start time. Once the interval duration is reached, the statistics for that period will be pre-generated.


Example for Pre-Statistics Before Report Generation
Suppose a monthly print statistics report is created with the following month-cycle settings:
Start Date: 1st of the month

End Date: 31st of the month

Report Generation Time: 31st of the month at 23:59
Using October as an example:
If Pre-Statistics Before Report Generation is not enabled, the report will generate October’s print statistics only on October 31 at 23:59. Before this time, October will not appear as an available selection in the report date picker.
To allow the administrator to view up-to-date statistics throughout October:

1. Enable Pre-Statistics Before Report Generation.

2. Set a Start Time for pre-statistics, e.g., October 7.

3. Set the Statistical Interval to 1 week.

With this setup:

· On October 7, the system will generate statistics from October 1 to October 7.

· One week later (October 14), it will generate updated statistics from October 1 to October 14.

· Each new pre-statistics result overwrites the previous one until the final report is generated on October 31.

This ensures that each pre-generated dataset increasingly approximates the final report results, allowing administrators to view near-real-time statistics during the month.
[image: image763.bmp] Note
For reports configured to send emails in the mail settings, only the final report generated at the scheduled report generation time will be sent. Pre-statistics generated during the period will not trigger email delivery.
30.8 Indicator Management
Indicators are predefined metrics that define alert levels based on operation limits within a specified time. Indicator levels are classified as Severe, Important, and General.

· Example: For print operations:

· Printing more than 100 pages per day → Severe

· Printing more than 50 pages per day → Important

· Printing more than 20 pages per day → General

Indicator conditions include General and Filter settings:

· General: Set time intervals and threshold values for each level.

· Filter: Define relevant filtering criteria.

When creating an Indicator Report or Trend Report, administrators must select the indicator conditions. Data that meets the filter criteria and reaches the threshold within the specified time interval will be included in the statistics.
By clicking Reports → Indicator Condition Management, administrators can predefine indicator conditions for reports. Supported data types for indicators include:

· USB copy logs

· Print operation logs

· Instant messaging logs

· Web browsing logs

· Document operation logs

· Application usage logs

· Email logs

· Sensitive information external transfer logs

By default, indicator conditions are defined for:

· Email logs

· USB copy logs

· Print operation logs

· Document operation logs

System-defined indicator conditions can be modified or deleted.
30.9 Periodic Reports
Periodic reports are located under the Reports node in the navigation bar. In periodic reports, predefined statistical reports are standard monthly reports, while trend reports are standard quarterly reports. If predefined reports do not meet requirements, they can be modified or new custom reports can be created.
30.9.1 Creating Reports
There are three ways to create a periodic report:From Template、From Existing Report、From Query Conditions
Create from Template
When creating a periodic report from a template, you can select a template to inherit its condition and statistical settings, which can also be modified as needed.
Example: Creating a Print Statistical Report
1) In the navigation bar, go to Reports, right-click and select New Report → Create from Template to open the report creation interface.

2) Select Print Report Template → Standard Print Statistics or choose another custom print statistics template, then click Next.

3) Condition Settings: Includes general computer and user scope, as well as advanced conditions. The template’s default conditions are displayed but can be modified. After setting, click Next.
4) Statistical Settings: Includes statistics type selection and detailed settings. Defaults from the template are shown but can be modified. After setting, click Next.
5) Report Generation Period: Open the dropdown to view existing periods. Select a period, and if needed, click Modify Settings on the right to adjust values. After setting, click Next.
6) Basic Report Information: Set the report name, location, and remarks. After completing these settings, click Finish.
[image: image764.bmp] Note
1. When creating a report from a template, the selected template’s condition and statistical settings are used by default and can be modified. Modifications only apply to the current report; the template itself remains unchanged.
2. For any report creation method, after selecting an existing period, changes to values within that period only affect the current report; the original period settings remain unchanged.
Create from Existing Report
When creating a report from an existing report, you can select a previously created periodic report. The new report will inherit the selected report’s condition settings, statistical settings, period settings, and display settings, all of which can be modified as needed.

· In the navigation bar, go to Reports, right-click and select New Report → Create from Report.

· The creation steps are similar to creating a report from a template.
Create from Query Conditions
When creating a report from query conditions, you can select an existing query. The new report will inherit the query’s condition settings, statistical settings, and display settings, which can also be modified.

· In the navigation bar, go to Reports, right-click and select New Report → Create from Query Conditions.

· The creation steps are similar to creating a report from a template.
30.9.2 Viewing Reports
To view a report, select it under the Reports node in the navigation bar. The data will appear in the display area on the right.
Report Date Selection: The dropdown lists all available time periods that have been calculated. For example, if a periodic report for September 2016 is created with a standard monthly period, once the report is generated, September 2016 will appear in the dropdown. After generating the October report, October 2016 will also appear.

Statistics Type Selection: You can switch between available statistics types. Only the statistics types set when creating the periodic report will appear in this dropdown.
Displaying Results: After selecting a report date and statistics type, the corresponding chart will be displayed. In the top-right corner of the chart, you can choose the number of data items to display and the chart style. By default, all data is shown, with bar charts for statistical reports and line charts for trend reports.
Viewing Details: Below the chart, detailed data is displayed. Double-clicking a data row shows the detailed contents. Right-clicking a column header allows you to add or remove displayed data columns.
30.9.3 Modifying Reports
After a report is created, you can modify its settings by selecting the target report and choosing Modify Report from the right-click menu.
The right-click menu also allows you to rename, delete, or move the selected report.
30.9.4 Enable and Pause
By default, reports are enabled after creation, meaning they will be generated according to the configured period.

· To stop report generation, select the target report and choose Pause from the right-click menu.

· To resume periodic generation, select the report and choose Enable from the right-click menu.
30.9.5 Other Operations
On the right side of the statistical conditions in the data display area, you can perform the following operations on the selected statistical report.
Save Statistical Conditions
Click Save to store the currently selected statistical conditions. The next time the report is selected, the previously saved conditions and corresponding results will be displayed. Saved conditions can include default displayed columns, chart type, number of displayed items, and similar settings.
View Report Information
Click Report Information to view key details of the current report, including condition and statistical settings. User-modified settings are displayed, while system default settings are not. To view the complete settings, select the report and choose Modify Report from the right-click menu.
30.10 Query
30.10.1 Creating a Query
Example: Creating a Print Query
1) In the navigation bar, go to Query, right-click and select New Query to open the query creation interface.
2) Select Print Report Template → Standard Print Statistics, or choose another custom print statistics template, then click OK.
Once the query is created, it inherits the selected template’s condition and statistical settings. The right-click menu allows you to rename, delete, or move the query.
30.10.2 Performing a Query
To perform a query, select a query under the Query node in the navigation bar. At the top of the data display area on the right, you can modify the query conditions and statistics type. After making changes, click Save at the top-right. The next time this query is selected, the saved conditions and statistics type will be applied by default.
Query Conditions: Include date range, computer scope, user scope, and advanced conditions.

Statistics Type:
· For trend queries, you can also select the statistical unit. Available time units are: Day, Week, Month, Quarter, Year.

· Example: If the query condition is set to the previous month:

· Selecting Day as the statistics type will generate results for each day.

· Selecting Week will generate results for each week.
After selecting the query conditions and statistics type, click Statistics to start the calculation. Once complete, the results will be displayed as a chart and table.

· Viewing Details: Double-click a row in the statistical table to view detailed log entries.

· Adjusting Columns: Right-click a column header to add or remove displayed columns.
30.10.3 Other Operations
On the right side of the query conditions in the data display area, you can perform the following operations on the selected query:
Reset
Click Reset to restore the query conditions and statistics type to the last saved state.
Save
Click Save to store the current query conditions and statistics type. The next time this query is selected, the saved conditions and type will be applied by default.
Save Results
After running a query with a selected set of conditions and statistics type, click Save Results. After specifying a name, the results can be found under Reports → Data Center.
Save as Template
Click Save as Template, enter a name, and a template creation dialog will appear. The new template inherits the current query’s conditions and statistics type but can be fine-tuned as needed. Saved templates can be found under Reports → Template Management.
Generate Report
Click Generate Report to open the periodic report creation dialog. The new report will inherit the current query’s conditions and statistics type, which can be modified if necessary.
30.11 Historical Reports
30.11.1 Generating Historical Reports
A historical report refers to a report for a past time period. Periodic reports only start generating after their creation, so past reports are not generated automatically. The Generate Historical Report feature allows you to create reports for previous periods.
Select the start and end dates for the data, choose the reports to generate, and specify whether to Regenerate Already Generated Reports, then click Save.
If Regenerate Already Generated Reports is unchecked, only periods without existing reports will be generated. If checked, even periods with previously generated reports will be regenerated.
30.11.2 Historical Task Management
After scheduling historical report generation, you can manage the existing historical report tasks under Reports → Historical Task Management.
Function Button Description 

	Icon Butto
	Description
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	Search Button: Click to open the search box, allowing you to query historical tasks by report name and status.
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	Enable Button: Starts a paused task.
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	Disable Button: Pauses a running task.
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	Add Button: Creates a new historical report task.
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	Delete Button: Deletes the selected task. For tasks not yet completed, any reports that were not generated will no longer be created.


Once a historical report task is created, it is immediately executed, with its status shown as “In Progress.”
Only one task can run at a time. If multiple tasks exist, they are executed in the order they were added. Later tasks will show the status “Pending.” When the previous task is completed (“Completed”) or stopped (“Paused”), the earliest pending task will start, changing its status to “In Progress,” and the sequence continues.
30.12 Email Reports
Periodic reports can be sent to designated email addresses via the mail server, allowing administrators to receive the latest report results promptly.

Before using the email report feature, the system administrator must configure the mail server in the console under “Tools → Options → Email Report Server Settings.”

Once the mail server is configured, email report settings can be managed. In the report console, under “Reports → Email Reports,” administrators can view, add, and modify email report settings.
	Icon Button  
	Action 
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	Add an email report configuration.
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	Delete an email report configuration.


Email report requires the following parameters:
	Parameter
	Description

	Configuration Name
	A user-defined description for this email configuration.

	Report
	Select the periodic report to be sent via email.

	Email Subject
	Set the subject of the email report.

	Recipient Address
	The email address that will receive the report.

	Include Report in Body
	If checked, the email body will include the report content, including condition settings, statistics type, charts, and data results.

	Generate Detail Table
	If checked, the email body will include detailed report information.

	Send Report as Attachment
	If checked, the report will be sent as an attachment, with the attachment type specified.

	Email Body
	Content entered here will appear in the email body.

	Send Test Email
	Sends a test email to the recipient.

	Compress Attachment
	If checked, the report attachment will be sent as a compressed file, and a decompression password can be set.


[image: image772.bmp]Note
The selected report is sent immediately upon generation; that is, an email containing only this report will be sent as soon as its latest statistics are completed.
30.13 Data Center
In the menu “Reports → Data Center,” you can view system-generated reports, including each periodic report and reports generated by clicking “Save Results” during a query.
By default, all reports are displayed, but administrators can also set various filters for querying.
	Query Parameter
	Description

	Data Time Range
	The time range of the data included in the report; start and end times can be set.

	Report Scope
	Select the scope of reports or queries; default is All.

	Report Type
	The type of report; default is All.

	Report Period
	Select the report period: year, quarter, month, week, or day; default is All.


[image: image773.bmp] Note
The Data Time Range refers to the period of data covered in the report, not the report’s generation date.
For example, if a print report for September 1–30, 2016, was generated on November 1, 2016, selecting November 1, 2016, as the start date in a query will not return this report, because its data range does not include that date. The start date should be set to September 1, 2016, or earlier.
Chapter 31: WEB Console
31.1 Logging in to the WEB Console
Enter the server address in the browser’s address bar to access the login page.
Examples of server addresses:
1、IP + default port 80：192.168.2.203 
2、IP + non-default port 8080：192.168.2.203:8080
3、Domain name + mapped port：tec.oicp.net:10941
4、With “http” prefix: http://192.168.2.203 

31.2 Introduction to the WEB Console
After logging in to the WEB console, the interface appears as shown below:
[image: image774.png]@ AnySecura

Data Dashboard GApprtwal management Report system & Admin ~

Home page Statistical ime: 2025-09-01 09:56:33
Statistics o B - - - . " .

Operation Policy Alarm File Upload/Send File Print Mobile Storage ‘Outgoing Mail
Events Log

Running Agents Online Agent Count Critical Upload File Count Upload File Size Today Print Times Today Print Pages Write File Count Write File Size Outgoing Mail File Outgoing Mail File
Encryption Log

102 1 0 0 0 0 0 0 0 0 0
Monitoring

0s: undefined: Last Week's Printing: Usage Distribution: ‘Outgoing File Count Top5:
Policy

Y High
Encryption “ “
0
Visual perception 2 2
© Windows No Data o Registe No Data

Category library @ Mac Low [ Unregis.

8/26 8/27 8/28 8/29 /30 /31 9/1
Asset Management 0
— Print Times ~ — Print Pages

Asset operation and

maintenance
File Encryption File Decryption ‘Authorized Use Information

Settings

Encrypted File Count  Encrypted File Size File Decryption Co. File Decryption Size Main Function  { 250

0 0 0 0 . Transparent
= Encryption ( 250
Operation Type: Operation Type: Read-only
Encryption 050
Sensitive
@ Information  { 2/50
Identification
No Data No Data W Secure Desktop 0150
Udisk Encrypted
@ Doiskbncpte 0/50

Agent





The WEB console interface includes:
	Interface Area
	Description

	Function Bar
	Located at the top right of the page; displays the currently logged-in administrator and provides access to related functions.

	Navigation Bar
	Located at the lower left of the function bar; contains all system menus for quick navigation.

	Computer/User Panel
	Located to the right of the navigation bar; hidden by default. Click the button at the top right of the navigation bar to expand and view all computers with installed clients, user lists, and group information.

	Data Display Area
	The core view of the system, where all data is displayed.

	Chart Panel
	Available only in statistical functions; displays charts.

	Query Bar
	Located at the top of the data display area; provides a time range for general queries and allows selection of additional conditions in advanced queries.


[image: image775.bmp]Note
1. You can customize whether Admin and Audit accounts are allowed to log in to the WEB console.
2. The WEB console only supports viewing and searching logs; modification and deletion are not supported.
3. The display of function menus in the WEB console interface can be controlled based on the modules included in the AnySecura server’s serial number.
Explanation of Icons in the Computer Panel
	Computer Icon
	Status Description
	Encryption Authorization Description
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	Running / Online
	Encryption authorization not enabled
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	Running / Online
	Transparent encryption enabled
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	Running / Online
	Read-only encryption enabled
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	Running (Idle)
	Encryption authorization not enabled
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	Running (Idle)
	Transparent encryption enabled
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	Running (Idle)
	Read-only encryption enabled

	[image: image782.png]



	Offline
	Encryption authorization not enabled
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	Offline
	Transparent encryption enabled

	[image: image784.png]



	Offline
	Read-only encryption enabled
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	Uninstalled
	Encryption authorization not enabled

	[image: image786.png]



	Uninstalled
	Transparent encryption enabled
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	Uninstalled
	Read-only encryption enabled


Explanation of Icons in the User Panel
	User Panel Icon

	Description
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	Online
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	Offline


31.3 Computer and User Operations
Click the button[image: image790.png]


 in the first row of the data display area to expand the default-hidden computer and user tree.
Currently, only basic information viewing and searching are supported for computers and users.
View Basic Information
In the navigation bar, select “Statistics → Basic Information,” then choose a computer (group), user (group), or role to view basic information. The content of basic information matches that in the console.
Search
Click the[image: image791.png]


 above the tree view to quickly locate a specified computer or user and view its related data.
31.4 Policy Roles
Click the button[image: image792.png]


 in the first row of the data display area to expand the default-hidden role tree.
View Basic Information
In the navigation bar, select “Statistics → Basic Information,” then choose a role or policy set to view basic information. The content matches that in the console.
Configure Policy Sets
In the navigation bar, under “Statistics → Basic Information” or “Statistics → Policy Roles,” select a policy set node in the role tree. Then click the [image: image793.png]


 button in the right-hand view to edit the policy set properties, including assigned computers, users, roles, and remarks.

The policy set settings are the same as those in the console.
Configure Roles
In the navigation bar, under “Statistics → Basic Information” or “Statistics → Policy Roles,” select a role node in the role tree. Then click the button[image: image794.png]


 in the right-hand view to edit role properties, including assigned computers, users, policy sets, and remarks.

Role settings are the same as those in the console.
31.5 Home
The Home page displays statistics for various logs across the entire network. The data includes: number of running clients, basic event logs, application logs, web browsing logs, document operation logs, shared document logs, document print logs, and removable storage logs.
The statistical time range is from 00:00 of the current day to the time shown in the top-right corner of the interface.

Double-clicking a statistic type icon will navigate to the corresponding detailed log view.
31.6 Statistics
Statistics display reports and charts for applications, web browsing, and network traffic, providing a basis for evaluating employee activity.

In the navigation bar, select “Statistics” to query the usage of applications, web browsing, and network traffic for computers (groups) or users (groups) within a specified time period. By default, the system shows statistics for the current day. Each statistic mode matches the console, and data is displayed only in bar chart format.
31.7 Logs
In the navigation bar, select “Logs” to query various operation logs, including: basic event logs, application logs, website browsing logs, document operation logs, disc burning logs, shared document logs, remote desktop logs, document print logs, removable storage operation logs, document cloud backup operation logs, asset change logs, Windows system logs, policy logs, system event logs, instant messaging logs, email logs, and sensitive information logs.
Select a log entry and click “Details” at the end to view its specific content.
31.8 Encryption Logs
In the navigation bar, select “Encryption Logs” to view operation logs related to the encryption system, including document operation logs, document backup logs, and encryption system login logs.
Select a log entry and click “Details” at the end to view its specific content.
31.9 Monitoring
Real-Time Screenshots
In the navigation bar, select “Monitoring → Screenshots.” Administrators can view and track real-time screenshots of a specific computer or user.
Related Icon Descriptions
	Button Icon
	Description
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	If a computer has more than one logged-in user or a user is logged in to multiple computers, the administrator can select and view the screenshot of a specific session.
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	Screenshots refresh automatically. The refresh interval can be viewed and modified in the console under “Tools → Options → Real-Time Information.” The WEB console does not support modifying this setting.
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	Adjusts the screenshot to fit the window size.
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	Displays the screenshot at its original size.


31.10 Policies
In the navigation bar, select “Policies” to view policy information for computers (groups) and users (groups), and to add, modify, delete, or move policies. Policies include: basic policies, device control, application control, screen recording, log recording, remote control, client configuration, system alerts, software installation management, document control, print control, print watermark control, screen watermark control, removable storage control, sensitive information export control, sensitive information storage control, web browsing, traffic control, network control, email control, IM file transfer control, upload control, and document cloud backup policies.

Select a specific policy in the navigation bar, choose a computer (group) or user (group) in the object selection area, and the policy settings page will appear in the rightmost view.
Click the [image: image799.png]


 button on the far right to add a policy.
Click the [image: image800.png]


 button to move a policy up.
Click the [image: image801.png]


 button to move a policy down.
Click the [image: image802.png]


 button to delete a policy.
Click the [image: image803.png]


 button to reload policies.
Click the [image: image804.png]


 button to save policies.
31.11 Encryption Policies
In the navigation bar, select “Encryption Policies” to view policy information for computers (groups) and users (groups), and to set, modify, or delete policies. Policies support inheritance (stacking) and include: encryption authorization settings, encryption parameter settings, document backup settings, long-term offline authorization, and secure communication settings.
In the object selection area, choose an object and click the[image: image805.png]


 button:
Select Encryption Authorization Management → Enable Transparent Encryption to enable encryption authorization for the client.

Select Encryption Authorization Management → Enable Read-Only Encryption to enable read-only encryption for the client.
Select Encryption Authorization Management → Revoke Encryption Authorization to revoke encryption authorization for the client.
Select a specific encryption policy in the navigation bar and a computer (group) in the object selection area. The rightmost view will display the policy settings page, where you can click the button on the far right to set or modify the policy.

Encryption policy settings are the same as those in the console.
31.12  Category Library
In the navigation bar, select “Category Library” to view category library information. Category libraries include: application library, removable storage, software installation packages, time types, watermark templates, sensitive information, websites, software uninstallation, network addresses, network ports, and email categories.
Select a specific category library in the navigation bar and click the query button[image: image806.png]


 to perform a custom query.
Currently, only the application library, website library, and removable storage library support add, delete, and modify operations; the others are view-only.
31.12.1  Application Categories
Select “Category Library → Applications” in the navigation bar to open the application category window. The system defines two default categories: System Applications and Unclassified.
Application Classification
After creating a new category, you can group applications of the same type into it. Click the[image: image807.png]


 button to perform operations on the selected category, including: Create (Category)、Create Identification Rule、Delete (Category)、Rename (Category)、Move to (Category)、Import Identification Rules、Export Identification Rules

[image: image808.bmp] Note
The System Applications and Unclassified categories cannot be deleted, nor can subcategories be created under them.
Application Identification Rules
Select an application category; the application identification rule list will appear at the top of the right-hand view. Available operations include: export, batch delete, and hide (show) rules.
Hover over a rule at the end of its row to access additional actions: Details, Edit, Move to Group, Delete.
Applications
Select an application category; the application list will appear at the bottom of the right-hand view. Available operations include: export and batch delete.
Hover over an application at the end of its row to access additional actions: Details, Rename, Set Category, Delete.

Settings for application identification rules and applications are the same as those in the console.
31.12.2 Website Categories
Select “Category Library → Websites” in the navigation bar to open the website category window. By default, no categories are defined; administrators must manually add website categories and website identification entries. Website identification supports wildcards.
Website Classification
After creating a new category, you can group websites of the same type into it. Click the button[image: image809.png]


 to perform operations on the selected category, including: Create (Category)、Delete (Category)、Rename (Category)、Move to (Category)、Create Website Identifier、Import Website Library、Export Website Library、Import Website Identifiers
Websites
Select a website in a category; hover over it at the end of its row to access actions: Edit, Move, Delete.

Website category and website settings are the same as those in the console.
31.12.3 Removable Media Categories
Select “Category Library → Removable Media” in the navigation bar to open the removable media category window. By default, there are two categories: “Registered” and “Unregistered.” All newly detected removable media devices are placed in the “Unregistered” category, while registered devices are moved to the “Registered” category. Administrators can manually add new categories under “Registered,” but no categories can be created under “Unregistered.”
Removable Media Classification
After creating a new category, click the[image: image810.png]


 button to perform operations on the selected category, including: Create (Category)、Delete (Category)、Rename (Category)、Move to (Category)、Configure Identification Rules、Registration Management、Import Removable Media Library、Export Removable Media Library
Removable Media
Select a registered removable media device; hover over it at the end of its row to access actions: View Details, Move To, Delete, Deregister, (Cancel) Report Loss, Modify Registration Info, View Usage.

Select an unregistered removable media device; hover over it at the end of its row to access actions: View Details, Delete, View Usage, Register.

Removable media categories and device settings are the same as those in the console.
31.13 Settings
When a system administrator logs in to the WEB console, they can configure server parameters under “Settings” in the navigation bar.
The WEB server must be deployed on the machine where the AnySecura server is installed, and the logged-in administrator must have system administrator privileges. Only then will the “Settings” option appear in the navigation bar menu.
31.13.1 Server Settings
Select “Settings → Server Settings” in the navigation bar to open the server parameter configuration interface. Currently supported settings include: approval request email notifications, automatic grouping, and domain-verified accounts.

When modifying one feature, you must save or cancel the changes before configuring another feature.
Approval Request Email Notification
This feature adds email notifications for approval requests. After a client submits a request, the approver’s email will receive a notification to ensure timely approval.

Supported request types include:

· Encrypted document requests (decryption requests, external sharing requests, temporary offline requests, security attribute change requests)

· Desktop management requests (print requests, device requests, removable media requests, watermark requests)

First, configure the mail report server in the console under “Tools → Options → Email Report Server Settings.” Then, log in to the WEB console, select “Settings → Server Settings → Approval Request Email Notification,” check “Enable,” set the required parameters, and save to activate the feature.
Corresponding Parameter Settings
	Parameter
	Description

	Enable
	Whether to enable the feature. Must be checked before editing other options.

	Email Subject
	The subject of the notification email. Optional; if empty, the email subject shows only the system default format: Computer (User) – Request Type (Specific Type).

	Email Matching Rules
	Rules for recipient email addresses, including default and custom rules. When both exist, custom rules take priority; if no match, default rules are applied. Click the top-right Add button to create a custom rule, specifying the administrator and email address. Click on the administrator or email information to edit; hover over an item and click the X button to delete it.

	Default Rule
	Required. Format: *@[email domain], e.g., *@gmail.com, *@outlook.com. The approver’s name replaces *. For example, if the default rule is *@gmail.com and approvers are test1 and test2, both test1@ gmail.com and test2@ gmail.com will receive notifications.

	Custom Rule
	Optional. Must specify the full email address; * cannot be used. Each administrator corresponds to one email. For example, if the default rule is default=*@tec.org and the custom rule is Administrator test = 123@ gmail.com, only 123@ gmail.com receives notifications for test; test@tec.org does not.

	WEB Approval Server Address
	URL to access the WEB approval server. Optional.

	Number of Attachments Displayed
	Number of attachments shown in the email. 0 shows all; empty defaults to 5.

	Language
	Language of the notification email. Options: Default (based on server OS language), Simplified Chinese, Traditional Chinese, English, Japanese.


The email interface includes the email subject and body content:

· Email Subject: Administrator-defined title – Computer (User) – Request Type

· Body Content: Request information (computer, computer group, user, user group, request time, reason, document name) and a link to “Go to Approval.”
Automatic Grouping
The automatic grouping feature allows you to assign IPs or IP ranges to specific groups. Newly installed client computers will be automatically assigned to the group that matches their IP. Computers already in “Ungrouped” are unaffected.
Log in to the WEB console and select Settings → Server Settings → Automatic Grouping to access the automatic grouping setup page. Click the + button to add a group name and corresponding IP information. To modify a group name or IP, click the information field to edit. To delete an entry, hover over it and click the X button. After configuring, click Confirm to save.
Format Settings:
· IP addresses can be single IPs, IP ranges, or a combination of IPs and ranges. Multiple IP conditions are separated by commas.

· IP ranges can span multiple subnets, e.g., 192.168.1.1–192.168.3.106.

· When multiple rules are set, they are matched from top to bottom. Once a match is found, lower rules are ignored.

· If multiple groups have the same name in the computer tree, matched computers are randomly assigned to one of them.

· If no rules match, the computer is assigned to “Ungrouped.”
Domain-Verified Account Feature
The domain account verification feature ensures that only the owner of a domain account can use it, preventing creators from gaining elevated permissions by creating new accounts. It supports multi-platform login verification, including the console, proxy console, WEB console, WEB approval, approval app, report console, WEB reports, and distributed master console.

Log in to the WEB console and select Settings → Server Settings → Domain-Verified Account to access the domain verification account settings page. The parameter descriptions are as follows:
	Setting
	Description

	Enable
	Check to activate this feature. Only when this option is enabled can the settings below be edited and take effect.

	Domain Name
	Required. Enter the full domain name of the domain server.

	Domain Server Address
	Required. Enter the IP address of the domain server.


Changes take effect only after restarting the AnySecura server. Currently, only one domain server is supported.

After enabling domain account verification, the built-in accounts Admin and Audit continue to use their console-set passwords for login. All other accounts must use their domain passwords, and the console cannot modify these passwords. If an administrator account name does not exist on the domain server, login will be denied.
Chapter 32: WEB Approval
Log in to the WEB console and click Approval on the right side of the top menu bar to enter the approval management interface. Clicking the logged-in account information on the top-right menu will display a dropdown; select Console to return to the WEB console interface.
WEB Approval supports approvals for both Desktop Request Management and Encryption Request Management.
32.1 Desktop Request Management
In the top menu bar, select Desktop Request Management to switch to the desktop request management view.
Desktop Request Management includes: watermark requests, print requests, device requests, and removable media requests.
View Pending Approvals
Select Pending Approval on the left side below the menu bar to view requests awaiting approval by the currently logged-in administrator.
The top-left of the Pending Approval interface has a Query Conditions toggle button, which is collapsed by default. Click it to select conditions for querying. Supported query conditions include: request type, request time range, workflow name, approver, and target object scope.
[image: image811.bmp] Note
After modifying query conditions, you can click Reset to restore them, but the time range will not revert to the default.
View Request Overview
Select Request Overview on the left side below the menu bar. By default, it displays all requests from the past month. You can also use query conditions to filter results. Supported conditions include: status, request type, request time range, approver, and workflow name.
Approval
Double-click a request or click the[image: image812.png]


next to it to open the request details page. Information available includes: request information, request content, valid period, approval information, and change history.

Administrators can perform Approve, Reject, or Veto actions but cannot modify other request details. To approve multiple requests at once, select them and click the Batch Approval button at the top-left of the list.
32.2 Encryption Request Management
In the top menu bar, select Encryption Request Management to switch to the encryption request management view.
Encryption Request Management includes: decryption requests, offline requests, external sharing requests, and security attribute change requests.
View Pending Approvals
Select Pending Approval on the left side below the menu bar to view requests awaiting approval by the currently logged-in administrator.

The top-left of the Pending Approval interface has a Query Conditions toggle button, which is collapsed by default. Click it to select conditions for querying. Supported query conditions include: request type, request time range, file name, workflow name, approver, and target object scope.
[image: image813.bmp] Note
After modifying query conditions, you can click Reset to restore them, but the time range will not revert to the default.
View Request Overview
Select Request Overview on the left side below the menu bar. By default, it displays all requests from the past month. You can also use query conditions to filter results. Supported conditions include: status, request type, request time range, file name, approver, and workflow name.
Approval
Double-click a request or click the[image: image814.png]


 next to it to open the request details page. Available information includes: request information, file information, and approval information.

Administrators can perform Approve or Reject actions but cannot modify other request details. To approve multiple requests at once, select them and click the Batch Approval button at the top-left of the list.
Download Files
Decryption requests, external sharing requests, and security attribute change requests support file downloads. In the request details page, under the File Information tab, select a file and click the[image: image815.png]


 button to download it.
Preview Files
Decryption requests, external sharing requests, and security attribute change requests support file preview. Currently, only txt, doc, docx, ppt, pptx, and pdf files are supported. In the request details page, under the File Information tab, select a file and click the[image: image816.png]


 button to preview it.
[image: image817.bmp] Note
Files can only be downloaded or previewed successfully when the client is online and the file exists. If the client is offline, or the file has been modified, renamed, or deleted, downloading or previewing will fail, and a corresponding notification will be shown.
Chapter 33: WEB Reports
Log in to the WEB console and click Reports on the right side of the top menu bar to enter the reports interface. Clicking the logged-in account information on the top-right menu will display a dropdown; select Console to return to the WEB console interface.
[image: image818.bmp] Note
WEB Reports only supports viewing already generated reports. Querying or other configuration functions are not supported.
33.1 Home
The home page displays statistics for specific logs across the entire network.
Data Statistics Include:
· Number of printed pages

· Size of sent emails

· Size of files written to removable media

· Size of uploaded files

The time range for statistics is from 00:00 of the current day to the time shown at the top-right of the interface.

The home page also displays information for the 10 most recently generated reports.
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33.2 Reports
In the left navigation bar, select Reports to expand the report structure tree. You can view existing report data and filter it by report date, statistic type, chart style, and data quantity. Clicking Report Information displays key details of the current report, including condition settings and statistical settings.
Supported Report Types:
· Print reports

· Instant messaging reports

· Web browsing reports

· Document operation reports

· Removable media reports

· Application reports

· Email reports

· Policy log reports

· Encrypted document operation reports

· Indicator reports

· Comprehensive reports

Each report type includes both statistical tables and trend charts.
33.3 Data Center
In the left navigation bar, select Data Center. The right data display area will show information for each report, including: report name, report group, data time range, report type, report period, and generation date.
Double-clicking a report opens a new window displaying the detailed data of that report.
Chapter 34: Software Center
The Software Center provides end users with a trusted and compliant channel for downloading software installation packages, ensuring both the security of the software and convenience for users. Administrators can upload software to the Software Center server, and users can install or uninstall software via the Software Center client.
The Software Center supports distributed deployment, allowing multiple relay servers to share the load of the main Software Center server.
34.1 Installation & Deployment
34.1.1 Deploying the Software Center Server
Install Software Center Server
The Software Center server can be installed on the same machine as the AnySecura server or on a separate machine. To install, double-click the installation program and follow these steps:
1) Double-click SoftwareCenter.exe, select the installation language, and click OK.
2) A welcome screen will appear; click Next.
3) The license agreement will be displayed. Read it carefully, check I agree to the User Agreement and I agree to the Privacy Policy, then click Next.
4) Select the server type: choose Software Center Main Server, then click Next.
5) Confirm the installation path, or choose a custom path.
6) Enter the IP address of the connected AnySecura server and set the Software Center server port (default is 80), then click Next.
7) Select installation components. Keep all selected by default. If MySQL is not installed on the system, the installer will automatically install it. If MySQL is already installed, it will be skipped. Click Next.
8) Choose the Start Menu shortcut directory and click Next.
9) Review all settings, then click Install.
10) Wait for the installation to complete, and finally click Finish.
[image: image820.bmp]Note

1. The configured port must be manually added to the firewall exceptions; otherwise, other machines may be unable to access the Software Center.
2. If MySQL is installed via the installer, the default username is root and the password is mysql.
System Initialization
The first time logging into the Software Center server, initialization settings must be performed. Enter the server address in a browser, and the initialization interface will appear.
Example of server addresses:
1. Software Center server IP + default port:127.0.0.1

2. Software Center server IP + non-default port: 127.0.0.1:8081
3. Add http before the address: http://127.0.0.1
Initialization Database Settings:
	Field Name
	Description

	Network Address
	The address of the database, default is 127.0.0.1.

	Port
	The port for database connection, default is 3306.

	Account
	The username for database connection, default is root.

	Password
	The password for the database account, default is mysql.


Initialization Administrator Settings:
	Field Name
	Description

	AnySecura Server Address
	The IP address of the connected AnySecura server.

	System Administrator Account
	The account in the AnySecura system with system administrator privileges. After initialization, this account will have all permissions on the Software Center server, except for audit logs.

	Password
	The password for the system administrator account.


After successful initialization, please restart the Secure SoftCenter WebService service. Once restarted, you can log in to the backend management system using the administrator account and password set during initialization.
34.1.2 Deploying Software Center Relay
Installing the Software Center Relay
Double-click the installer to begin the installation. The detailed steps are as follows:
1) Double-click SoftwareCenter.exe, select the installation language, and click OK.
2) A welcome screen will pop up. Click Next to continue.
3) The license agreement will appear. After reading it, check I agree to the User Agreement and I agree to the Privacy Policy, then click Next.
4) Choose the server type for installation. Select Software Center Relay and click Next to continue.
5) Confirm the installation path, or choose a custom path.
6) Enter the address of the main Software Center server, e.g., 192.168.2.4:8080 or http://192.168.2.4:8080

7) . Set the port for the Software Center relay (default port is 80), then click Next.
8) Choose the installation components. By default, Software Center will be installed. MySQL can also be selected. Click Next.
9) Choose the installation components. You can leave all options checked. If MySQL is not installed in the current environment, the installer will automatically install MySQL. If MySQL is already installed, it will not be installed. Click Next.
10) Choose the directory for the Start Menu shortcuts, and click Next.
11) Confirm the settings, then click Install.
12) Wait for the installation to complete, then click Finish.
[image: image821.bmp]Note

1. The configured port needs to be manually added to the firewall exception rules. Otherwise, other machines may not be able to access the Software Center.
2. The MySQL installed via the installer uses root as the username and mysql as the password.
System Initialization
After setting up the environment, the first login requires initialization. Enter the Software Center Relay address in the browser, and the initialization screen will appear for the setup.
Examples of Relay Address:
1. Software Center Relay IP + default port:127.0.0.1
2. Software Center Relay IP + non-default port: 127.0.0.1:8081
3. Add http at the beginning:http://127.0.0.1
	Field Name
	Description

	Network Address
	The address of the database, default is 127.0.0.1

	Port
	The port for database connection, default is 3306

	Account
	The account for database connection, default is root

	Password
	The password for the database account, default is mysql


After the relay initialization is complete, you will be redirected to the Software Center Management console. The admin user in the AnySecura system, administrators with System Administrator privileges, and administrators with Software Center Server Login privileges can log in.
34.2 Software Center Server
34.2.1 Software Management
In the Software Management page, administrators can add, edit, delete, and view the software that has been approved within their management scope, and perform operations to list or unlist the software.
Add Software
Click Software Management -> Add, and the page will redirect to the Add Software page.
Explanation of Adding Software Information:
	Field Name
	Field Description

	Basic Information
	

	Software Name
	The name of the software defined by the administrator. This field is required and cannot have duplicates.

	Software Information
	The name displayed for the corresponding software in the control panel. This field is optional and cannot have duplicates.

	Software ID
	A unique identifier for the software. You can download the Software Information Checker Tool from the Software Management main page by clicking Download Auxiliary Tool. Run the tool to obtain the software ID. The tool fetches software information from the installed machine. If you need the ID for a specific software, install the software on a machine first and then use the tool to retrieve it.

	Software Architecture
	The architecture of the software installation package. You can select "No Limit," "32-bit," or "64-bit." The combination of software ID and software architecture is unique.

	File
	The installation package that needs to be uploaded. Only .exe, .msi, .zip, and .rar formats are allowed. The package size cannot exceed 200GB (IE8/9 allows a max upload of 2GB, and IE10/11 allows a max of 4GB). This field is required.

	Software Size
	Displays the size of the selected installation package if the chosen file is an installation package.

	Main Executable Program
	If the selected file is a .zip file, the Main Executable Program field will appear. This field is required.
If the main executable program is in the root 
directory of the zip file, simply enter the program 
name (e.g., Setup.exe). If it's in a subdirectory 
(e.g., install folder), specify the path (e.g., 
install\Setup.exe).



	Icon
	Set the software icon. If no icon is uploaded, the default icon will be used. Supported formats include png, jpg, jpeg, bmp, and gif. The image size must not exceed 2MB.

	Vendor
	The name of the software vendor.

	Version
	The version of the software. This field is required.

	Category
	The category to which the software belongs. This field is required.

	Description
	A description of the software, displayed in the client software list. Supports multiple languages.

	Remarks
	Notes about the software from the administrator. This is only displayed in the server-side software list.

	License Information
	

	Copyright Information
	The administrator can specify the copyright status of the software, with options: Free, One-time Charge, or Annual Charge.

	License Status
	The administrator can specify the license status of the software. This option appears when the copyright status is not "Free."

	Default Function Permissions
	Default permissions applied to the software when no installation management policy is in place. The default is View and Install. The administrator can set this according to management requirements.

	Platform Information
	

	Supported Operating Systems
	The operating systems that the software supports for installation. Software will not appear in the software library for clients using unsupported systems. The dropdown options are: All, x86 OS, x64 OS, Custom. The default selection is All. When Custom is selected, custom system options will be displayed.

	Installation Settings
	

	Installation Parameters
	Command parameters used during software installation, such as the common /S parameter for silent installation of .exe files.

	Upgrade Parameters
	Command parameters used during software upgrade, such as the common /S parameter for silent installation of .exe files.

	Installation User Identity
	Specifies the user identity to execute the installation. The default is Current User. This field is required.


After the administrator finishes the setup, if they have Software Review permissions, they can click List to immediately list the software. If they do not have Software Review permissions, they should click Submit for Review, and the software will be listed after approval. Pending software listing applications can be viewed under My Applications.
[image: image822.bmp]Note

Adding software requires existing category information. If no category information is available when adding software, a prompt will appear. Clicking OK will automatically redirect to the category settings page. For details on setting categories, refer to the Settings - Category Management section.
Edit Software
In the Software Management page, select any software and click View. The page will redirect to the software details page. Click the Edit button to enter editing mode. The left side will display the original software information, which cannot be modified. The right side will show a copy of the left-side information, where you can modify the software details. After modifying any software information, you must submit the application again.
Delete Software
In the Software Management page, select any software and click the Delete button. A confirmation prompt will appear. After confirming, the selected software will be deleted, and it will no longer appear in the client after the refresh. Clicking Cancel will return to the Software Management page.
Batch software deletion is supported. You can select multiple software items and click the Delete button to execute the confirmation.
List Software
In the Software Management page, software with the status Unlisted can be listed by administrators with review permissions. They can click the List button under the Actions column to list the software. After successfully listing, the software status will update to Listed, and the client software library will refresh to display the newly listed software.
Unlist Software
In the Software Management page, software with the status Listed can be unlisted by administrators with review permissions. They can click the Unlist button under the Actions column to unlist the software. A confirmation prompt will appear, and after selecting Confirm, the software will be unlisted. After successfully unlisting, the software status will update to Unlisted, and the client software library will no longer display the unlisted software after the refresh.
34.2.2 Software Review
Administrators with Software Review permissions can review software listing applications. Only the software that passes the review will be listed and displayed. The Software Review page will list the pending software listing applications.
Application Type Description:
	Software Status
	Description

	Listing Application
	The listing application submitted by the administrator for newly added software.

	Modification Application
	The modification application submitted by the administrator after editing an existing software.

	Modification and Listing Application
	The application submitted by the administrator after modifying software that is in the Unlisted state, to modify and then list the software.


Approve Application
Administrators in the Software Review page can select the Listing Application record and click the Approve button. A confirmation prompt will appear, and after confirmation, the software will be successfully listed. The software status will update to Listed in the Software Management page, and the newly listed software will be visible in the client software library.

When the approval administrator selects the Modification Application record and clicks the Approve button, a confirmation prompt will appear. After confirmation, the software modification will be successful, and the updated software details will be visible in the Software Management page. The software status remains unchanged.

When the approval administrator selects the Modification and Listing Application record and clicks the Approve button, a confirmation prompt will appear. After confirmation, the software modification will be successful, and the updated software details will be visible in the Software Management page. The software status will change from Unlisted to Listed, and the software can be viewed in the client software library.

Batch approval is supported. Multiple application records can be selected, and by clicking the Approve button, the confirmation will be executed.
Reject Application
In the Software Review page, administrators can click the Delete button for the Listing Application, Modification Application, or Modification and Listing Application records. A confirmation prompt will appear, and after confirmation, the software listing will fail. In the applicant's My Applications page, the software approval status will update to Rejected, the software information will remain unchanged, and the software status will be empty.

Batch rejection is supported. Multiple application records can be selected, and by clicking the Reject button, the confirmation will be executed.
34.2.3 My Edits
Administrators with Edit Software permissions can save drafts when adding or modifying software information. The saved drafts can be viewed, added, edited, or revoked in the My Edits page.
Only the drafts saved by the administrator can be viewed and operated on.
Add Draft
There are two ways for administrators to add a draft:
1. In the My Edits page, click the Add button. Fill in the software information on the Add Software page, and click the Save Draft button. After saving successfully, return to the My Edits page to see the newly added draft entry.
2. In the Software Management page, select any software, edit the software information, and click the Save Draft button. After saving successfully, return to the My Edits page to see the newly added draft entry.

[image: image823.bmp]Note
1. Saving a draft will validate the entered software information. The required fields for the software must not be left empty, and the software name, software information, and software ID cannot duplicate existing software.
2. Drafts saved by adding new software can only be seen by the administrator who created them; other administrators cannot view them. Drafts saved by modifying existing software can be seen by all administrators in the Software Management page under the software details. If multiple administrators modify the same software simultaneously, the last modification will overwrite the previous changes, and the drafts of other administrators will be lost.
Edit Draft
In the My Edits page, select any draft and click View. You will be redirected to the software details page, where you can directly modify the software information. After completing the changes, click the Save Draft button. The modified draft will be displayed in the My Edits page.
Cancel Draft
In the My Edits page, select any draft and click the Cancel Draft button. A confirmation prompt will appear, and after confirming, the draft will be deleted.
Alternatively, select the draft and click the View button, then click the Cancel Draft button at the bottom of the detailed information. After confirmation, the draft will be deleted, and you will no longer see the deleted draft in the My Edits page.

Batch cancellation of drafts is supported. You can select multiple draft records at once and click the Cancel Draft button to execute the confirmation.
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After confirming that the software information is correctly filled in the draft page, if you click Submit Listing Application, the draft record will also be deleted.
34.2.4 My Applications
Administrators can view the software listing applications they have submitted for review. They can perform actions such as viewing, editing, and withdrawing their applications.

Applications that have not been reviewed will have a status of Pending Approval. Applications that have been reviewed and rejected will have a status of Rejected. Applications that have been reviewed and approved will have a status of Approved. The My Applications page will display all applications with the status Pending Approval and Rejected, and will only keep Approved applications that have been approved within the last 30 days.
Submit Application
After an administrator submits a software listing application, a new record with the application type Listing Application will appear on the My Applications page.
When an administrator submits a software modification application, a new record with the application type Modification Application will appear.
When an administrator submits a software modification and listing application, a new record with the application type Modification and Listing Application will appear.
Edit Application
When an administrator selects an Approved or Rejected application record on the My Applications page, clicks View, and then clicks Edit, they can modify the software information and resubmit the application.
Withdraw Application
When an administrator selects a Pending Approval application on the My Applications page, clicks View, and then clicks the Withdraw button at the bottom of the page, the application record will be deleted. After withdrawing the application, approval administrators will no longer see the application record in the Software Review page. The software content will automatically be saved as a draft and can be viewed in the My Edits page.
34.2.5 Installation Management
Administrators with Installation Management Policy permissions can set software usage permissions for users, computers, and roles, including view and install permissions.
Add Policy
In the Installation Management Policy page, click the New button to enter the Add Installation Management Policy page.
Explanation of Installation Management Policy Information:
	Setting Items
	Description

	Status
	Check to enable the policy. If unchecked, the policy will not be executed.

	Policy Name
	Set the name of the policy. Policy names must be unique.

	Action
	Set the action corresponding to this policy—whether to block or allow a certain software for a specific object.

	Select Software
	Choose the software that this policy will apply to. The default is all software.

	Application Object
	Choose the object to which this policy will apply. Options include Computers, Users, and Roles.

	Permission
	Set the permissions for the object to apply to the selected software. The permissions include View and Install.

	Remarks
	Set additional notes or information.
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1. If no installation policy is set, the ability to install software will be limited by the software's default permissions.
2. When an installation policy is set, the installation policy takes precedence over default permissions.
Delete Policy
In the Installation Management Policy page, select any installation policy and click the Delete button. A confirmation prompt will appear. After confirming, the selected policy will be deleted, and it will no longer take effect on the application objects.
When deleting multiple policies, you can select multiple policies at once, click the Delete button, and confirm the deletion.
Enable Policy
In the Installation Management Policy page, policies with the status Disabled can be enabled by clicking the Enable button under Actions. After successful enabling, the software status will update to Enabled, and the policy will take effect on the application objects.
Disable Policy
In the Installation Management Policy page, policies with the status Enabled can be disabled by clicking the Disable button under Actions. After successful disabling, the software status will update to Disabled, and the policy will no longer take effect on the application objects.
34.2.6 Settings - Category Management
Select Settings -> Category Management to enter the category management page. Administrators can create different categories to manage different software.
Add Category
Click Add to enter the Add Category page.
Category Information Description:
	Setting Items
	Description

	Icon
	Select a personalized icon. The icon style is system-provided.

	Name
	The name cannot be empty and must be no longer than 200 characters.

	Description
	This field is optional, with a maximum of 200 characters.
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After submitting the information, the page will redirect to the Category Management page. In the Software Center client, click the Refresh button to update the data.
Edit Category
In the Category Management page, select any category and click Edit. The page will redirect to the Edit Category page.
After editing the information, click Submit to save the changes. The updated category will be visible. After refreshing in the Software Center client, the data will also be updated.
Delete Category
In the Category Management page, select any category and click the Delete button. A prompt will appear. Click Confirm to delete the category, or click Cancel to keep the category. The page will then refresh.
If the category contains software, it cannot be deleted. You must first delete all software under that category before deleting the category.
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To delete all software under a category, go to the Software Management page, filter by the specified category, select all the software, and then delete them.
Adjust Category Order
In the Category Management list, move the mouse over the Icon column of a category. Hold down the mouse button to drag and adjust the order of the category.
34.2.7 Settings - User Management
Select Settings -> User Management to enter the User Management page. You can view the current administrator information for the Software Center server and add or manage users.
Add User
Click the Add button to enter the Add User page.
User Information Description:
	Setting Items
	Description

	Account
	The account to be added. Only system administrators or accounts with Software Center Server Login permissions in the AnySecura server can be added.

	Display Name
	The name displayed for the user in the Software Center.
By default, this field is empty. In this case, the user's name will display as it appears in the AnySecura server. Once set, the display name will show the custom name.

	Email
	Set the user's email address, which will be used for receiving software application or review result emails.

	Remarks
	Add notes or descriptions about the user.


After filling in the user information, click Save to successfully add the user. The User Management page will update to display the newly added user's information.
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Newly created users only have permissions to view Software Management and Category Management. To adjust permissions, go to Settings -> Permission Management.
Delete User
In the User Management page, select any user and click the Delete button. A confirmation prompt will appear. Click Confirm to successfully delete the user, and the user list will be updated.
34.2.8 Settings - Permission Management
Select Settings -> Permission Management to enter the Permission Management page, where you can assign permissions to users.

User permissions are divided into two major modules: Function Permissions and Category Management Scope.
Function Permissions
	Permission
	Description

	Software Management
	Permissions related to software management.

	Category Management
	Permissions for viewing and managing software categories, including View Category, Edit Category, and Delete Category.

	Software Management
	Permissions for viewing and managing software in the software management page, including View Software, Edit Software, and Delete Software.

	Software Review
	Permissions for reviewing software listing applications.
Administrators with this permission can approve software listing applications, and new software added by them will be listed directly without requiring review. Administrators without this permission will need to wait for approval before their newly added software is listed.；

	User Permissions
	Permissions related to user management.

	User Management
	Administrators with this permission can add, edit, and delete users in the User Management page.

	Permission Management
	Permissions to manage user permissions in the Permission Management page.

	Installation Management Policy
	Permissions for viewing and setting installation management policies, including View Policy and Set Policy.

	Advanced Settings
	Administrators with this permission can make settings in the Advanced Settings page.

	Batch Import
	Administrators with this permission can perform batch import operations.

	Batch Export
	Administrators with this permission can perform batch export operations.


Management Scope
Select the management scope for the user; this field cannot be left empty. Administrators can only view software information for categories within their own permission scope. When adding software, they can only select categories within their permitted management scope.
34.2.9 Settings - Advanced Settings
Server Settings
Administrators can configure synchronization with the AnySecura server’s organizational structure and enable automatic synchronization. Once initialized, automatic synchronization is enabled by default with a sync interval of 24 hours.
Server Setting Information Description:
	Setting Items
	Description

	AnySecura Server Address
	Enter the address of the AnySecura server to be synchronized.

	Account
	Enter the account with administrator privileges on the AnySecura server.

	Password
	Enter the password for the above account.

	Enable Auto-Sync
	Check this option to automatically synchronize the AnySecura organizational structure based on the set sync interval.

	Sync Interval
	Set the interval for automatic synchronization, in hours. Only positive integers are allowed.

	Test Connection Button
	After setting the AnySecura server address, account, and password, click this button to test if the connection is successful.

	Last Sync Time
	The time of the last synchronization of the organizational structure.


Click the Test Connection button to attempt a connection to the AnySecura server using the entered server address, account, and password. This will confirm whether the connection is successful.

Click the Sync Now button to immediately synchronize the organizational structure from the AnySecura server.
Personalized Settings
Administrators can customize the system icon and name for the Software Center, the taskbar icon for the Software Center client, and set reminders in the footer of the Software Center client.
Setting Items Description:
	Setting Items
	Description

	Title
	The default title is Software Center, and it supports multi-language settings.

	Icon
	The system icon displayed. The uploaded system icon image supports jpg, jpeg, png, gif, and icon formats. The image size must not exceed 200KB.

	Taskbar Icon
	The taskbar icon must be in png format and the image size should not exceed 200KB. It is recommended to upload an icon with 48x48 pixels or corresponding multiples. Otherwise, the icon may become distorted after compression. If a Software Center shortcut is configured, the shortcut icon will match the taskbar icon.

	Enable Footer
	When checked, the client will enable the footer and display the set content.

	Display Content
	The text displayed in the footer. This field cannot be empty. Multi-language support is available (see the appendix for multi-language settings).

	Redirect Link
	Set the URL that the footer text will redirect to when clicked. This field can be left empty. The format should be a valid webpage address, such as:http://www.baidu.com/ 。


Installation Restriction Tips
When there is software in the Software Center client that a user has view permissions for but not installation permissions, no prompt is displayed by default. Administrators can configure a prompt for this restriction.
Restriction Installation Tip Information Description:

	Setting Items
	Description

	Enable
	When checked, a button will appear when the mouse cursor is moved over the software information area for which the user has view permissions but not installation permissions. Clicking the button will display the prompt message.

	Prompt Message
	Set the content of the prompt message.


Email Notification Settings
When a software application is submitted, administrators can enable the email reminder function to ensure they receive timely notifications for review and processing. By enabling the email reminder function, administrators can be selected to receive email notifications. When a submitter applies for software, the selected administrators will receive an email about the software application, allowing them to review and process it promptly. The submitter will also receive an email with the review result.

Click More Advanced Settings >> to expand and configure the email templates.
	Setting Items
	Description

	Administrators Receiving Applications
	Select the administrators who will receive the software application emails. Only administrators with software review permissions will receive the emails. Administrators without review permissions will not receive emails.

	Email Subject for Submitted Applications
	Set the Email Subject for Software Applications
Default Template:
You have received a software application for $AppName$ of $ApplicationType$ $SCUrl$

You can customize the email subject, where special characters represent the following content:
$AppName$ (Applicant Name)
$ApplicationType$ (Application Type)
$AppName$ (Software Name)

	Email Body for Submitted Applications
	Set the Email Body for Software Applications
Default Template:
Administrator $UserName$ has submitted a software application for $AppName$ of $ApplicationType$.
Please click the following link to review:
$SCUrl$

You can customize the email body, where special characters represent the following content:
$AppName$ (Applicant Name)
$ApplicationType$ (Application Type)
$AppName$ (Software Name)
$SCUrl$ (Software Center Server URL)

	Email Subject for Review Results
	Set the Email Subject for Software Review Results
Default Template:
You have received the review result for $AppName$ $SCUrl$

You can customize the email subject, where special characters represent the following content:
$AppName$ (Software Name)
$State$ (Review Status)

	Email Body for Review Results
	Set the Email Body for Software Review Results
Default Template:
Administrator $UserName$ has $State$ the software $AppName$ of $ApplicationType$.
Please click the following link for details:
$SCUrl$

You can customize the email body, where special characters represent the following content:
$UserName$ (Reviewer Name)
$AppName$ (Software Name)
$ApplicationType$ (Application Type)
$SCUrl$ (Software Center Server URL)
$State$ (Review Status)
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Administrators who wish to receive software application or review result emails must set their email address in the User Management page.
Email Sending Settings
Configure the settings for the sending email address. All email functionalities on the Software Center server will use the specified email address and mail server to send emails. Proxy server settings are also supported.
Email Sending Settings Description:
	Setting Items
	Description

	Email Address for Sending
	The email address used for sending emails.

	Mail Server Address
	The address of the mail server, supporting IP or domain names.

	Port
	The port of the mail server, with the default SMTP port being 25.

	Requires Secure Connection
	By default, this is not checked. If checked, the specified mail server will use a secure connection (SSL) to send emails.

	SMTP Account
	The SMTP account that is allowed to log into the mail server.

	Password
	The password for the SMTP account.

	Enable Proxy Server
	Supports configuring a proxy server. By default, this is not checked.

	Type
	Supports socks4 and socks5 protocols.

	Address
	The address of the proxy server, supporting IP or domain names.

	Port
	The port of the proxy server.

	Account
	The user account allowed to connect to the proxy server.


API Configuration Settings
When third-party systems need to call the Software Center's API, they will require an API credential, which can be generated in the API configuration settings.
34.2.10 Settings - Batch Export
Administrators with batch export permissions and a classification management scope of "All" can access the software export interface through Settings -> Batch Export to perform batch software exports from the server.
Export Software
1. The Export Software page will display information for all software on the server. After selecting the software to export, click Next.

2. The Export Path page allows you to choose the directory on the server where the software will be exported. Click Select, choose the specific path in the server path window, and then click Start Export.
3. The Export Result page shows the final export status of each software. Successfully exported software can be found in the chosen export path. Click Back to return to the export software page.

34.2.11 Settings - Batch Import
Administrators with batch import permissions and a classification management scope of "All" can access the software import interface through Settings -> Batch Import to perform batch software imports from the software repository directory stored on the server.
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Only software repositories exported using the Software Center export function are supported for import.
Import Software
1. The software repository needs to be placed in a local directory on the server before it can be imported. Click Select, choose the specific location of the local software repository in the server path window, and then click Next.

2. The Import Software page will display information about the software available for upload from the repository. After selecting the software to import, click Start Import.

3. The Import Result page shows the final import status for each software.
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The status of successfully imported software depends on the administrator's permissions:
1. If the administrator does not have software review permissions, after the software is successfully imported, it will enter a "pending approval" state and can only be listed after the review is approved.
2. If the administrator has software review permissions, the software will be listed immediately after a successful import without requiring further review.
34.2.12 Audit Logs
Audit administrators with "Software Center Server Login Permissions" in the AnySecura system, after logging into the Software Center server, will access the Audit Logs Management interface. They can view the operation records of all users who have logged into the backend management system. Detailed information includes the operation time, operation type, administrator name, login IP, and summary.
34.3 Software Center Client
34.3.1 Start Software Center
To start the Software Center on the client, add the Software Center launch configuration in Console -> Policy -> Custom Configuration. Once configured, the Software Center tab will appear in the right-click menu of the client system tray.
	Configuration Name
	Configuration Content

	softcenter_url
	The address of the Software Center server or relay to which the client connects. Multiple server addresses can be configured, separated by semicolons. Domain name server addresses are also supported.


34.3.2 Software Repository
The Software Repository displays all the software within the current object's permission scope. Users can select the software to install or upgrade.

Click the Install button next to the software to start the download. During the download, a progress bar and installation time will be shown, along with the protocol being used (P2P or HTTP). Once the download is complete, the software installation page will automatically pop up. After the software is installed, the button next to the software in the repository will change to Installed. For software marked as Installed, users can perform a reinstall operation.
34.3.3 Software Upgrade
If the software version on the Software Center server is higher than the corresponding software version installed locally, the software in the Software Center client repository will show the Upgrade status. Clicking the Upgrade button will download and install the upgrade. After a successful upgrade, the software button will change to Installed.

You can switch to the Upgrade tab to view all available upgrades and perform the upgrade operation. Batch upgrades of multiple software are supported. Select multiple software and click the One-click Upgrade button. The uninstall and upgrade tasks will be executed sequentially.
34.3.4 Software Uninstall
Switch to the Uninstall tab to view all software installed on the computer. Users can select the software they want to uninstall.

Check any software, click the Uninstall button, and the software uninstall page will appear with the Uninstalling status. Once the uninstall is successful, the software will show as Uninstalled, and after refreshing the uninstall page, the uninstalled software will no longer appear.

Batch uninstallation of multiple software is supported. Select multiple software, click the One-click Uninstall button, and the uninstallation tasks will be executed in sequence.
34.3.5 Upgrade Reminder
When there is software available for upgrade on the client, a reminder will notify the user of the available upgrade after the system starts, based on the configured reminder interval. By default, the reminder occurs once per day, but users can adjust this setting.
34.3.6 Menu
In the top-right corner of the Software Center client page, click the ☰ button to access two options: Settings and About.
About
Click About to open the "About" page, where you can view the current version of the Software Center client.
Settings
Click Settings to open the "Settings" page, where you can adjust settings for downloads and upgrades.
In the Download Settings page, users can decide whether to enable the P2P function, which is enabled by default.
In the Upgrade Settings page, if the administrator has allowed users to adjust the reminder interval, users can modify this interval on this page.
34.4 Software Center Client Logs
The Software Center client logs record operations related to installing or upgrading software through the Software Center client process on the client computer. Administrators with the "Logs -> Software Center Client Logs" permission can view this log.
The types of logs recorded by the Software Center client include the following:
	Setting
	Description

	Start Installation
	Software installation or reinstallation using the Software Center client.

	Cancel Installation
	Cancelling the installation during download/installation.

	Installation Failed
	Manual termination of the installation wizard or an error occurred during software installation.

	Installation Successful
	Software successfully installed through the Software Center client.

	Start Upgrade
	Software upgrade using the Software Center client.

	Cancel Upgrade
	Cancelling the upgrade during download/upgrade.

	Upgrade Failed
	Manual termination of the upgrade wizard or an error occurred during software upgrade.

	Upgrade Successful
	Software successfully upgraded through the Software Center client.


The default content displayed in the Software Center client logs includes: Type, Time, Computer, Computer Group, User, User Group, Software Name, Version, Vendor, and Description. Additional content that can be displayed via right-click includes: Display Name, Software ID, Software Architecture, Copyright Status, Platform, and Supported Operating Systems.
Chapter 35: Security Viewer
The Security Document Viewer allows mobile smart devices to view encrypted documents under authorized conditions. Without authorization, encrypted documents cannot be accessed, effectively reducing the risk of data leakage while facilitating the widespread adoption of smart office solutions.
35.1 Software and Hardware Requirements
The recommended operating systems and hardware configurations for the Security Viewer are as follows:
	Item
	Basic Requirements

	Smart Device Type
	Smart Device Type

	Operating System
	Android 4.0.3 and above; iOS 6.0 and above

	Configuration
	Minimum: 512MB RAM
Recommended: 1GB RAM

	Supported Encrypted Document Types
	Text (pdf, txt, c, h, cpp, hpp, doc, docx, xls, xlsx, ppt, pptx)

Images (bmp, png, jpg)

Web Pages (htm, html)

Special: iWork (pages, key, numbers)


35.2 Installation
Enter the download URL for the Security Document Viewer in a browser, or directly scan the QR code on a mobile browser to access the website. You can then choose to download the version for Android or iOS.

Download URL for the Security Document Viewer:
http://www.tec-development.com/apps/download.html
QR Code for downloading the Security Document Viewer:
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After installing the Security Document Viewer app on iOS, a "Trust" action is required:
For iOS versions between 8.0 and 9.0: After installation, open the app, and a prompt will appear asking whether to trust the app. Simply click Trust.
For iOS 9.0 and above: After installation, a prompt saying "Untrusted Enterprise Developer" will appear. You need to go to Settings > General > Profiles and trust the app there.
35.3 Authorization
The Security Viewer needs to connect to the server and be authorized by the administrator before it can open encrypted documents.
The specific steps are as follows:
1) Launch the Security Viewer, enter the server address (either IP or domain name), and click the Connect button after entering the address.
2) The authorization status screen will appear. Click Apply for Authorization.
3) On the authorization application page, enter the user information and reason for the request, then click Submit. After successful submission, the system will automatically return to the authorization status page, showing "Your application has been submitted and is waiting for approval".
Once the administrator approves the request via the console, the authorization status page in the Security Viewer will update to "Application Approved, Authorization Successful". Click the Enter button to go to the main interface of the Security Viewer.
35.4 Viewing Encrypted Files
After successful authorization, open the Security Viewer to enter the main interface. Select Storage to navigate to the location of the encrypted documents. If there are many files in the target directory, click Search at the bottom of the current path and enter the file name for quick location, supporting fuzzy search. Click on the encrypted file to automatically open it in the document content page.
In addition to opening encrypted files within the Security Viewer, you can also open them in other apps. Simply select the encrypted file, choose Security Viewer from the available options in the pop-up to open the encrypted document.
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The search function in the Security Document Viewer currently only supports searching within the current directory.
35.5 Encrypting/Decrypting Files
The Security Viewer allows you to encrypt and decrypt files.
Encryption
The encryption feature in the Security Viewer is enabled by default, and the security attribute of encrypted files is set to "Public - Normal".
The bottom navigation bar of the main page in the Security Viewer displays the Encrypt button. Select a file, click the Encrypt button, and the file will be encrypted. Encrypted files will display an icon with a small lock.
Decryption
The decryption feature in the Security Viewer is disabled by default. The administrator needs to enable it in the console by setting the smart terminal policy under Smart Terminal Encryption Management > Encryption > General, and check Allow direct decryption of documents.
The bottom navigation bar of the main page in the Security Viewer will display the Decrypt button. Select an encrypted file, click the Decrypt button, and the file will be decrypted. Decrypted files will no longer display the small lock icon.
35.6 Sharing Files
In the main interface of the Security Viewer, select a file and click More > Share. A sharing options menu will appear, allowing you to share the file with other apps. The encryption/decryption status of the shared file will remain unchanged.
35.7 Recent and Favorites
Recent
In the main interface of the Security Viewer, select Recent to view a list of recently opened files, organized by the time they were accessed. Click on a document to open it directly. Click the Clear button in the top-left corner to clear the recent list.
Favorites
In the Recent list, each document has a star (☆) on the far right, indicating its favorite status. A gray star means not favorited, while a blue star means it is favorited. Clicking the star toggles the status between favorited and not favorited.
In the main interface, select Favorites to view all favorited documents for quick access to commonly used files. To remove a document from the favorites list, click Edit, select the file, click Delete, and then click Save.
35.8 Settings
In the main interface of the Security Viewer, click the settings icon [image: image835.png]


 in the top-right corner to configure some general settings for the viewer.
	Option
	Description

	Communicate Only on Wi-Fi
	Enable this option to communicate with the server only when the smart device is connected to Wi-Fi. If disabled, the viewer will communicate with the server whenever there is a network connection.

	Modify Server Address
	Selecting this option will take you to the server address settings page, where you can modify the server connection address.

	Set Password
	Set a password to access the Security Viewer. After setting a password, this option allows you to modify it. By default, no password is required to use the Security Viewer.

	About
	Selecting this option will show the current version of the Security Viewer.


35.9 Resetting Password
If a password is set, the Security Viewer will prompt for the password each time it is opened. After entering the correct password, click Enter to proceed to the main interface.
If you forget the login password, follow these steps to reset it:
1) On the password login page of the Security Viewer, click Reset Password to go to the reset password page.

2) A string of original operation codes will be displayed on the page. Provide this code to the administrator.
3) The administrator will input the operation code in the console under Tools > Client Tools > Confirmation Code Generator to decode the client's operation and corresponding information.
4) After confirming, the administrator will click Generate Confirmation Code.
5) The administrator will provide the confirmation code to the user. The user will enter the code in the Security Viewer and click OK to directly access the viewer's interface.
After resetting the password, the login password will be reset to the default value, which is empty.

Chapter 36: Security Approval App
The Security Approval App enables approval of desktop and document security management requests on smart devices.
36.1 Software and Hardware Requirements
The recommended operating systems and hardware configurations for the Security Approval App are as follows:
	Item
	Basic Requirements

	Smart Device Type
	Smart Device Type

	Operating System
	Android 4.0.3 and above;
iOS 6.0 and above

	Configuration
	Minimum: 512MB RAM
Recommended: 1GB RAM


36.2 Installation
Enter the download URL for the Security Approval App in a browser, or scan the QR code on a mobile browser to access the website. You can then choose to download the version for Android or iOS.
Download URL for the Security Approval App:
http://www.tec-development.com/apps/download.html
QR Code for downloading the Security Approval App:
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After installing the Security Approval App on iOS, a "Trust" action is required:
For iOS versions between 8.0 and 9.0: After installation, open the app, and a prompt will appear asking whether to trust the app. Simply click Trust.
For iOS 9.0 and above: After installation, a prompt saying "Untrusted Enterprise Developer" will appear. You need to go to Settings > General > Profiles and trust the app there.
The Security Approval App requires the installation and deployment of the WEB Approval Server to function properly.
36.3 Login
Upon first running the Security Approval App, you will need to enter the WEB Approval Server address, along with the administrator account and password that has approval permissions.
The server address format is:
WEB server IP/domain:port
The port number refers to the port manually set during the installation of the WEB server (default is 80). If using the default port, it can be omitted.For non-default ports, the port must be specified after the IP.Only HTTP protocol is supported (HTTP can be omitted); HTTPS is not supported.
Examples of valid server addresses:
1、IP + default port 80: 192.168.2.203 
2、IP + non-default port 8080: 192.168.2.203:8080
3、Domain + mapped port:  tecyexh.oicp.net:10941
4、Adding http:  http://192.168.2.203 
After logging out of the Security Approval App, the server address and administrator account from the previous session will still be saved. The next time you log in, you only need to enter the correct password to access the app.
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After a successful login, if the app is closed using the system's built-in "exit" function, the current account will remain logged in. The next time the app is launched, it will automatically log in with the last used account.
36.4 Application Management
Application management supports both desktop and encryption request management. You can switch between Desktop Application Management and Encryption Application Management via the options at the top of the interface for viewing and approval.
36.4.1 Desktop Application Management
The desktop application management page is divided into two sections: Pending Approval and Application Overview.

· Pending Approval displays the requests currently awaiting approval.

· Application Overview shows all requests.
Viewing Pending Requests
Click Pending Approval to switch to the list of requests awaiting approval. Click on a request to view its specific details.
The Search function can be used to quickly locate a specific request.
Quick Search
Search conditions only support searching by Process Name. Enter the process name in the search box and click [image: image839.png]


 to search.
Advanced Search
The search conditions for advanced search are collapsed by default. Click the Expand button to reveal the conditions. Select your criteria and click Search to complete the search. Multiple conditions can be combined. The search criteria include request type, time, and process name. Click Reset to reset the conditions to their default state.
Viewing Application Overview
Click Application Overview to switch to the list of all requests, which defaults to showing requests from the past month. Click on any request to view its details.
The Application Overview also supports quick search functionality, which works the same way as the Pending Approval list.
Approving Requests
The administrator selects a request, double-clicks to enter the detailed information page, and can then perform approval actions. Click Agree to approve the request or Reject to deny it.
The approval process supports printing requests, watermark requests, device requests, and mobile storage requests.
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Modifying application information is not supported.。
36.4.2 Encryption Application Management
The encryption application management page is divided into two sections: Pending Approval and Application Overview.

· Pending Approval displays the requests currently awaiting approval.

· Application Overview shows all requests.
Viewing Pending Requests
Click Pending Approval to switch to the list of requests awaiting approval. Click on a request to view its specific details.
The Search function can be used to quickly locate a specific request:
Quick Search
Search conditions only support searching by Process Name. Enter the process name in the search box and click [image: image841.png]


 to search.
Advanced Search
The search conditions for advanced search are collapsed by default. Click the Expand button to reveal the conditions. Select your criteria and click Search to complete the search. Multiple conditions can be combined. The search criteria include request type, time, and process name. Click Reset to reset the conditions to their default state.
Viewing Application Overview
Click Application Overview to switch to the list of all requests, which defaults to showing requests from the past month. Click on any request to view its details.
The Application Overview also supports quick search functionality, which works the same way as the Pending Approval list.
Approving Requests
The administrator selects a request, double-clicks to enter the detailed information page, and can then perform approval actions. Click Agree to approve the request or Reject to deny it. Multiple requests can be selected for bulk approval.
The approval process supports decryption requests, external sharing requests, security attribute change requests, and temporary offline requests.
[image: image842.bmp] Note
Modifying application information is not supported.
Previewing Files
Decryption requests, external sharing requests, and security attribute change requests support file previews. Currently, previews are only supported for txt, doc, docx, ppt, pptx, and pdf files. Excel files are not supported at this time.
Click on a request to enter the detailed information page, then click on the File Information section to view the details of the requested file. The file name and size are displayed by default. Click to view the file's security attributes. Click the button[image: image843.png]


 to view the file.
[image: image844.bmp] Note
1. The file preview feature requires that the WEB server has Java and OpenOffice components installed during deployment.
2. Files cannot be previewed if the client is currently offline or if the file has been moved.
36.5 Settings
In the main interface of the Security Approval App, click the icon [image: image845.png]


 in the top-right corner, and from the dropdown menu, select Settings to configure some general usage options for the app.
	Option
	Description

	Receive New Message Notifications
	Enabled by default, linked to other notification settings (such as notifications only on Wi-Fi, sound, and vibration). If you disable Receive New Message Notifications, other notification settings will be hidden and cannot be configured. The app will not receive new application notifications.

	Notify Only on Wi-Fi
	Disabled by default. When enabled, the app will only receive new application notifications when connected to Wi-Fi. It will not receive notifications in a mobile data environment.

	Sound
	Enabled by default, with the default system sound. It cannot be modified.

	Vibration
	Enabled by default, using the system's default vibration.

	Show Running Status
	This feature ensures that the Security Approval App runs in the background to receive approval notifications. It is enabled by default, showing a "Running" notification in the phone’s notification bar. If disabled, the app may exit and miss approval notifications.

	Clear Cache
	Clears the app's cache files, such as cookies, etc.

	Help
	Selecting this option will show related help content.

	About
	Selecting this option will show the current version information of the Security Approval App.


[image: image846.bmp] Note
Tablets do not have vibration functionality, so the Vibration option will not be displayed.
36.6 Account
In the main interface of the Security Approval App, click the icon [image: image847.png]


 in the top-right corner, and from the dropdown menu, select Account to view the currently logged-in account information.
	Option
	Description

	Login Account
	Displays the information of the currently logged-in administrator account.

	Password Settings
	Click this option to enter the password change screen. Enter the old password, then the new password, and re-enter the new password in the confirmation field to ensure both entries match. Click Done in the top-right corner to successfully change the password.

	Server Address
	Displays the information of the currently connected WEB Approval Server.


[image: image848.bmp] Note
If the administrator account password is changed in the Security Approval App, the modified password must also be used for logging into other platforms, such as the console.
Click the Logout button to exit the current account. Click the Close button to close the Security Approval App.
Chapter 37: Dedicated Burning Tool
The SBurner tool is a dedicated burning tool for AnySecura, designed to be simple and user-friendly, capable of handling most burning tasks. This specialized burning tool requires the machine to have the AnySecura client installed in order to function properly. Without the client, burning is not possible, and only configuration files can be operated.
37.1 Interface Overview
Double-click to run the dedicated burning tool SBurner.exe to enter the main interface of the tool, as shown below:
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The main interface includes the following areas:
	Area
	Description

	Menu Bar
	Contains all system menus, serving as the entry points for various function windows.

	Toolbar
	Contains commonly used functions: New, Open, Save, Burn, Eject Disc.

	Disc Display Area
	The left side shows the hierarchical structure of the disc directory. Selecting a node will display the files and folders within that directory on the right side.

	Function Keys (on the top of the right-side view)
	Allows you to perform related operations on the files and folders in the current directory.


Toolbar Function Buttons:
	Icon
	Description

	[image: image850.png]



	New Button: Creates a new empty disc directory, which can also be viewed as creating a new configuration file.

	[image: image851.png]



	Open Button: Opens an existing configuration file.
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	Save Button: Saves the current disc directory as a configuration file.
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	Burn Button: Burns the contents of the current disc directory to a disc.
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	Eject Disc Button: Ejects the disc from the optical drive.


Function Icons in the Right-Side View of the Disc Display Area:
	Icon
	Description
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	Back: Return to the previous directory (not the root directory).
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	New Folder: Create a new folder in the current directory.
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	Rename: Rename the selected file or folder.
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	Add: Add files or folders to the current directory.
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	Delete: Delete the selected file or folder.


37.2 Burning
To burn a disc using the dedicated burning tool, follow these steps:
1) Run SBurner.exe on a machine with the client installed, and connect a CD/DVD drive to the machine. Insert a blank disc.
2) In the dedicated burning tool, build the disc directory according to the burning requirements:
In the Menu Bar, select Edit > Add, choose files or folders to add. You can also drag and drop the target files or folders into the right-side view of the disc display area to add them.
3) Once the disc directory is constructed, select Tools > Burn from the Menu Bar, or click the Burn button [image: image860.png]


 on the toolbar to open the "Burn Settings" window.
Select Burner: Choose the burner connected to the client and used for burning the disc.
Write Speed: Select the burning speed (options include fastest, 24X, 20X, 16X, 10X, etc.).
Disc Format: Choose between ISO-9660 and UDF.
Burn Copies: Specify the number of copies to burn.
Remarks: Provide relevant backup information for this burning session (this is a required field). 

4) After completing the burn settings, click Burn to start the burning process.
5) During the burning process, the progress will be displayed, showing the current burn progress, elapsed time, remaining time, write speed, and the number of copies being burned. The burning is complete when the progress reaches 100%.
6) Once burning is complete, select Tools > Eject Disc from the Menu Bar, or click the Eject Disc button [image: image861.png]


 on the toolbar to eject the disc from the burner.
[image: image862.png]


 Note
When choosing the disc format in the burn settings, the ISO-9660 format has a file size limit of 2GB per file. UDF format does not have this limitation.
37.3 Configuration File
The configuration file is primarily used to save the current directory contents and corresponding file information, making it easier to burn the same data again in the future. For a directory that has been built, you can save it by selecting File > Save from the Menu Bar, or by clicking the Save button [image: image863.png]


 on the toolbar. This will save the current directory information as a configuration file.
For the next burn session, you can select File > Open from the Menu Bar, choose the previously saved configuration file, and the files from the directory will be imported for direct burning.
If the directory in the opened configuration file has changed since it was saved, a prompt will appear. If an entire folder has been modified, it will display changes for each file within that folder.

· A "Modified" prompt means the file contents in the directory have been edited.

· A "Missing" prompt means the file has been deleted or renamed from the saved directory.

If changes are detected in the files to be burned and the configuration file is not saved, you will receive a prompt each time you reopen the file. If you proceed without saving, the burning process will use the updated files (missing files will not be burned), and the configuration file will automatically be updated to reflect the latest contents.
Chapter 38: Access Gateway
The desktop management system of AnySecura can audit and strictly control computer operations in detail. However, some users still try to bypass behavior monitoring by methods such as reformatting and reinstalling the operating system, setting up personal firewalls, etc. Even when administrators identify such activities, redeploying the desktop management client can be a tedious and frustrating task. Additionally, due to management requirements, enterprises often mandate that computers meet certain criteria, such as installing antivirus software or running designated processes, before granting access to the network.

The Access Gateway Control System was created to address these issues.

The Access Gateway system is a specialized hardware-software integrated solution that works in conjunction with the desktop management system. It effectively prevents internal PCs from bypassing the desktop management system's control, enhances network access monitoring, ensures the enforcement of internal security policies, and eliminates the risk of data leaks caused by unauthorized access.
38.1 Network Architecture
The control functionality of the Access Gateway system relies primarily on the hardware gateway access controller (hereinafter referred to as the Access Device). The Access Device operates in two modes: Bridge Mode and Routing Mode.
Bridge Control Mode
In Bridge Mode, no changes are required to the network structure or configuration. The Access Device is simply connected in series to the part of the network that needs control, typically at critical application servers or gateways, to monitor and control the network communications passing through them.
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Bypass Control Mode
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Routing Mode
In Routing Mode, policy routing is enabled on the core switch to control cross-segment access. This method of control does not affect the existing network architecture but requires the core switch to support policy-based routing.
Bypass Mirroring Mode
In this mode, a mirror port and an observation port are set up on the core switch. Access control is implemented by analyzing the data from the mirror port. This control method does not affect the existing network architecture but requires the core switch to support port mirroring functionality.
38.2 Device Introduction
The Access Device comes in the following models: 1700F, 2500F, 3300F, 3500F, 4300F, and 4500F.
1700F：

Four RJ45 ports, including one set of BYPASS (ETH0 and ETH1).
The management port is EMP.
[image: image866.jpg].-
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2500F：
Six RJ45 ports, including two sets of BYPASS (ETH0 and ETH1, ETH2 and ETH3).
The management ports are EMP1 and EMP2.
[image: image867.jpg]



3300F：
Six RJ45 ports, including two sets of BYPASS (ETH0 and ETH1, ETH2 and ETH3).
The management ports are EMP1 and EMP2.
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3500F：
Six RJ45 ports, including two sets of BYPASS (ETH0 and ETH1, ETH2 and ETH3).
The management ports are EMP1 and EMP2.
[image: image869.jpg]-3 500F sees




4300F：
Six RJ45 ports, including two sets of BYPASS (ETH0 and ETH1, ETH2 and ETH3).
Two SFP ports (ETH4 and ETH5).
The management ports are EMP1 and EMP2.
[image: image870.jpg]- -
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4500F：
Six RJ45 ports, including two sets of BYPASS (ETH0 and ETH1, ETH2 and ETH3).
Two SFP ports (ETH4 and ETH5).
The management ports are EMP1 and EMP2.
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[image: image872.bmp] Note
1. All devices support gigabit network speeds.
2. Initial configuration uses the management ports:
For devices with only one management port (EMP), the IP is fixed to 190.190.190.190.
For devices with two management ports (EMP1 and EMP2), the IP for EMP1 is fixed to 190.190.190.190, and the IP for EMP2 is fixed to 191.191.191.191. 
3. BYPASS function: In the event of a controller power failure or crash, the BYPASS function allows the two ends connected to the controller to remain physically connected, ensuring that the network continues to operate without disruption.
38.3 Device Deployment
38.3.1 Setting Device IP
Choose the control method based on actual conditions, determine the deployment location for the Access Device, and assign the appropriate IP based on the deployment point. Once the IP is determined, proceed to configure the Access Device IP.
For devices with a management port, use the management port for configuration. The specific steps are as follows:
1) Disconnect Computer A from the internal network environment. Change the IP of Computer A so it can communicate with the Access Device. For example:
IP Address: 190.190.0.1
Subnet Mask:255.255.0.0
Default Gateway: Optional
2) Use a network cable to directly connect Computer A to the Access Device's management port (if it's an IPG-1000, any port can be used). On Computer A, use a browser to access the URL http://190.190.190.190 , which will open the device's management login page.
3) The username is admin, and the password is initially empty. Click OK to enter the management interface.
4) In the left-side menu, select Network Parameters > Basic Settings, choose the access mode for the Access Device’s network connection, and set the corresponding IP information. After setting, click Save.
After successfully modifying the IP, the device needs to be restarted.
[image: image873.bmp] Note
When setting the IP, for devices of the 2500F model and above, an additional mode option called "Bridge (Dual Machine Backup [Primary])" will appear. This setting is required only if the main device in a bridge mode is configured for dual-machine hot standby.
38.3.2 Pre-Network Connection Settings
If Bridge Deployment Mode is chosen and the Access Device is deployed between switches connected in TRUNK mode, and you need to configure forwarding when blocked, you must enable the TRUNK function on the Access Controller. For details, refer to Network Parameters > VLAN Settings. If this is not your network environment, there's no need to enable this function.
If Bridge Deployment Mode is chosen and the Access Device is deployed between a Layer 2 switch and a Layer 3 switch, where there are multiple subnets (not VLANs) on the PCs in the Layer 2 switch and corresponding IPs for those subnets on the gateway, you will need to enable the Multiple IP Binding configuration to allow forwarding when blocked. For details, refer to Network Parameters > Multiple IP Configuration. If this is not your network environment, there's no need to enable this function.
If Bypass Deployment Mode is chosen, you will need to configure policy-based routing on the switch. For specific configuration details, please consult a technical engineer.
38.3.3 Connecting the Device to the Network
After setting the IP for the Access Device, it can be connected to the previously planned deployment point.
The connection methods outlined below apply to all models: 1700F, 2500F, 3300F, 3500F, 4300F, and 4500F.
Bridge Mode
Connection Method: Use two ports of the device to connect it to the network. You can choose any two ports from ETH0, ETH1, and ETH2.
Routing Mode
Connection Method: Use the ETH0 port of the device to connect to the switch.
If you wish to change the incoming port from ETH0 to another port, follow these steps:
Go to System Tools > Configuration Management > Advanced Configuration. Click Settings and enter the following configuration:
[PRP]

PRP=ethX

Where X represents the specific communication port number (e.g., eth3).
Bypass Mirroring Mode
Connection Method:

· Use the ETH2 port to connect to the device’s observation port.

· Use ETH0 to connect to the switch, which will enable normal communication with the entire network interface.
To change the observation port to another port, follow these steps:
Go to System Tools > Configuration Management > Advanced Configuration. Click Settings and enter the following configuration:
[monitor]

monitor_port=ethX
Where X represents the specific communication port number (e.g., eth3).
After the device is connected to the network, you can access the device’s management login page using a browser by visiting its IP address, e.g.,http://192.168.2.190.
38.4 Management Interface Overview
After logging into the gateway device, you will see the following interface view:
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The management interface consists of the following areas: 

	Interface Area
	Description

	Top Bar
	The top horizontal bar area displays the product logo and product name on the left, and the current logged-in account information and system details on the right.
Account Info: Displays the currently logged-in administrator account. The Access Gateway only has one administrator account, admin. Clicking the dropdown menu here allows you to perform actions like "Change Password" and "Logout".
About: The dropdown menu contains options like: 

· About Access Gateway Info: View detailed version information of the Access Gateway.

· Language Settings: Switch the language of the management interface.

	Navigation Menu
	The left side contains all the system's functional menus. Clicking the [image: image875.png]


 button in the top horizontal bar allows you to expand or collapse the menu.

	Content View:
	The right side displays the specific content view, depending on the selected function menu.




38.5 Home Page
Selecting "Home" allows you to perform the "Enable/Disable Access Control Function" operation, as well as view the device's basic information, IP statistics, and the latest 24-hour device traffic data.
Control Function
By default, the Access Control function is disabled.
Click the[image: image876.png]


 button to enable the control. The button will change to[image: image877.png]


 and the control status in the basic information will show as "In Control".
Click the[image: image878.png]


 button again to stop the access control function. The button will change back to[image: image879.png]


 , and the control status in the basic information will show as "Disabled".
[image: image880.bmp] Note
To avoid disruptions during the deployment process, it is recommended to configure the relevant settings for the Access Device and AnySecura security policies before enabling the Access Control function.
Basic Information
The device's basic information includes the following:
	Attribute
	Description

	Hardware Model
	The hardware model information of the Access Device.

	Current Version
	The current functional software version. Initially, it shows the factory version. If any upgrade or downgrade has been performed, it reflects the version after the operation.

	Uptime
	The total running time of the Access Device.

	Control Status
	The status of whether the Access Control function is enabled on the device.


For more detailed device information, you can visit "About > About Access Gateway Info".
IP Statistics
IP count information includes the following:
	Attribute
	Description

	Current Online IP Count
	The number of IPs that are actively communicating through the Access Device.

	Total IPs Passed Through
	The total number of IPs that have passed through the Access Device during the current session. The count resets after a device reboot.

	Blocked IP Count
	The number of IPs that have been blocked or detected as illegal by the Access Device.

	Online Visitor Count
	The number of visitor IPs currently logged in.


Latest 24-Hour Device Traffic Information
Displays the traffic data for the last 24 hours that has passed through the Access Device.
38.6 Network Parameters
38.6.1 Basic Settings
By selecting "Network Parameters -> Basic Settings", you can configure the Access Device's connection mode and IP address.
If the device does not have an IP set, you need to connect to the Access Device using the management port to perform the settings.

If the device already has an IP configured, you can directly set it while it is connected to the network.

After configuring and saving the settings, a reboot of the Access Device is required for the changes to take effect.
[image: image881.bmp] Note
1. When using Bridge Mode and connecting to the network via TRUNK mode, the IP, subnet mask, and gateway configuration of the device must belong to Native VLAN or defaultVLAN.                                         2. After setting and saving, a reboot of the Access Device is required for the settings to take effect.
38.6.2 VLAN Settings
In Bridge Mode, if the Access Device is deployed between switches connected via TRUNK mode, and the forwarding function for blocked traffic needs to be enabled, the TRUNK function of the Access Controller must be activated.
To enable this, select "Network Parameters -> VLAN Settings", check "Enable Trunk", and add the VLAN configuration.
VLAN Configuration Details include:
	Attribute
	Description

	ID
	VLAN ID (VlanID)

	IP Address
	Enter an IP address that does not conflict under the specified VLAN ID.

	Subnet Mask
	Subnet mask for the IP address.


[image: image882.bmp] Note
1. When adding VLAN configurations, only VLANs other than Native VLAN or defaultVLAN can be added; doing otherwise may cause network issues.
2. When connected in TRUNK mode, the device’s IP, subnet mask, and gateway configuration must belong to Native VLAN or defaultVLAN.
3. If no manual changes are made to the switch, Native VLAN or defaultVLAN is typically VLAN 1.
38.6.3 Multi-IP Configuration
In Bridge Mode, if the Access Device is deployed between a Layer 2 switch and a Layer 3 switch, with multiple VLANs or IPs that are isolated from each other, and PCs on the Layer 2 switch are in different subnets (not VLANs), and the gateway has corresponding IPs for these subnets, then enabling the forwarding function for blocked traffic requires the Multi-IP Binding Configuration.
If the network does not match the above environment, this feature does not need to be enabled.
To enable, select "Network Parameters -> Multi-IP Configuration", toggle the "Enable Multi-IP Binding" switch to On, and add the required IP addresses to bind.
Multi-IP Binding Configuration Details include:
	Attribute
	Description

	IP Address
	The IP address that does not conflict within the specified subnet.

	Subnet Mask
	The subnet mask for the IP address.


[image: image883.bmp] Note
When adding Multi-IP Binding configurations, do not add the IP address of the Access Device’s own subnet, as this will cause conflicts.
38.7 Access Gateway Configuration
38.7.1 Management Scope
Select "Access Gateway Configuration -> Management Scope" to define the management scope of the access device. This feature supports IP addresses (or ranges).
By default, the management scope is empty, meaning all computers that communicate through the access device will be shown in the "Status Information" view.

After setting the management scope, only computers within the specified scope will appear in the "Status Information" view when they communicate through the access device.
38.7.2 Control Scope
Select "Access Gateway Configuration -> Control Scope" to define the control scope of the access device. This feature supports IP addresses (or ranges).

· By default, the control scope is empty, meaning no computers are controlled.

· After setting the control scope, computers without the client installed or those that do not meet the relevant security conditions will be blocked. Their access to networks protected by the access device will be restricted.
38.7.3 Protection Scope
Select "Access Gateway Configuration -> Protection Scope" to define the protection scope of the access device. This feature supports IP addresses (or ranges), IP+port (ranges), domain names, domain+port (ranges), and ports (ranges).

· By default, the protection scope is empty, meaning the access device protects all network addresses.

· After setting the protection scope, access control will be applied only when controlled computers access IP addresses within the protected range. If the access is outside this range, access control will not be enforced.
38.7.4 Exception Rules
Exception Rules define IP addresses and ports (including TCP and UDP) that are accessible to all computers. These rules can be used for:

· Public servers within the enterprise that do not contain sensitive information and have no specific access requirements.

· Network devices within the enterprise that do not have fixed IP addresses but require specific communication ports for normal network operations, even though they do not involve sensitive information.

You can configure exception rules by selecting "Access Gateway Configuration -> Exception Rules".
[image: image884.bmp] Note
Exception TCP ports and Exception UDP ports apply to all IP addresses within the network.
38.7.5 Warning Page
The Warning Page is designed to redirect computers that do not meet access requirements to a specific page. If a computer that does not meet the access rules tries to access a protected network, and the target address or port is categorized as a "trigger warning port," the user will be directed to the warning page. On this page, the user can view the access requirements and download the AnySecura client to fix the issue, enabling them to pass the network access control authentication and gain normal access to the network.
You can configure the Warning Page by selecting "Access Gateway Configuration -> Warning Page." The settings in this section are divided into three main parts:
1. Warning Page Settings
2. Trigger Warning Ports
3. Other Settings
The warning page settings allow you to choose different types of warning pages. Settings for trigger warning ports and other configurations will apply to any selected warning page type.
Warning Page Settings
There are three types of warning page content to choose from: "Default Warning Content," "Custom Warning Link," and "Upload HTML Compressed File."
Default Warning Content
When this option is selected, the following settings can be configured:
	Setting
	Description

	Display Image
	The image at the top center of the warning page. By default, it’s a predefined system image, which can be changed.

	Warning Title
	The warning title on the page. The default is predefined, but it can be modified.

	Warning Content
	The warning message on the page. The default is predefined, but it can be modified.

	Client Download Link
	The download link for the client, default is empty. This link will serve as the hyperlink for "Download Network Management Client" on the warning page.
Client Download Link:
1. You can enter the download link after uploading the client installer to a third-party HTTP server, such as: http://company.com/download/Agent.exe;

2. You can enter the shared directory address where the client installer is stored, such as: \\192.168.1.1\Agent\Agent.exe.


Custom Warning Link
If you want to use an existing HTTP server page as the warning page, select this option and enter the webpage address in the required field "Custom Warning Link."
[image: image885.bmp] Note
If you choose a custom warning link, ensure that the address of the HTTP server is added to the exception range so that blocked computers can properly redirect to the webpage.
Upload HTML Compressed File
If you want to design the layout and style of the warning page freely without using a third-party HTTP server, choose this option. In this case, the initial default warning page will be empty, and the visitor login form will use the system's predefined style.

You can design the page content and the visitor login form controls according to your needs. 
The steps to modify are as follows:
1) In the "Access Gateway Configuration -> Warning Page" section, select "Upload HTML Compressed File" under the warning page settings. Click the filename in "Choose File" (hover your mouse over the end[image: image886.png]


 for a prompt) to download the default compressed file default.zip.
2) Extract the default.zip file. The extracted contents will include the following three files:

· css folder: Contains login.css (CSS for login form style)

· js folder: Contains LoginForm.js (JS for generating visitor login controls)

· index.html: The HTML template for the warning page (make your style modifications directly within this template)
3) Open index.html to modify the warning page and visitor login form style.
· Add the HTML code for your new warning page content between the <body> </body> tags.

· Modify the visitor login form style within loginForm.init; if needed, adjust the content in login.css as well.
4) After modifying the index.html file, package the css folder, js folder, index.html, and any additional files you added during the style modification process into a ZIP file. Note the following about the ZIP package:
1. It must be in ZIP format; other formats are not supported.
2. The root directory of the ZIP file should directly contain the css folder, js folder, index.html, and any other files.
5) In the gateway management interface, go to "Access Gateway Configuration -> Warning Page -> Upload HTML Compressed File." Check "Use Custom Login Form Style" and save the settings. The modified webpage and visitor login form style will be displayed on the warning page.
Trigger Warning Page Port
Computers that do not meet the requirements will be automatically redirected to the warning page when accessing target addresses or ports that belong to "Trigger Warning Ports." You can modify this as needed, with the option to distinguish between HTTP and HTTPS protocols.
Other Settings
Hide Visitor Login Information
For all warning page types in the "Warning Page Settings," the default page shows a visitor login form on the right for login operations. If you wish to hide the visitor login form, select this option. When selected, the visitor login form will not appear on the right side of the warning page.
Use Custom Login Form Style
For all warning page types in the "Warning Page Settings," the default visitor login form style is the system's predefined style. If you want to use a custom modified login form style (as modified in the "Upload HTML Compressed File" section, refer to the appendix), select this option when editing the corresponding warning page type.
38.7.6 Active Authentication
In general, when the client is disconnected from the server, the access gateway will block the client from connecting to the network. Similarly, if the client starts up and does not immediately connect to the server, it may cause a temporary network access blockage. Enabling the access gateway to receive client authentication information can resolve these issues.

By default, the access gateway does not receive client authentication information. To enable this, go to the access gateway management interface and select "Access Gateway Configuration -> Active Authentication," then check "Trust Client Authentication."
Other settings for active authentication are explained below:
	Setting
	Description

	Trust Client Authentication
	Check this option to allow the access gateway to receive client-sent active authentication information.

	Only Trust Clients from Connected Servers
	If unchecked, the gateway will accept authentication information from all clients. If checked, it will only accept authentication information from clients connected to the trusted server, and will ignore information from other servers' clients.

	Disable Network Address Translation (NAT)
	If unchecked, in a NAT environment (such as with routers or wireless routers), once one computer successfully authenticates, other devices connected to that NAT device will also be allowed access to the protected network. If checked, no computer on the NAT device will be able to authenticate.
※This does not support virtual environments: Regardless of whether this option is checked, if a virtual environment connects to the network through NAT mode via a physical host, its access to the protected network will be the same as the physical host.

	Compatible with Non-Secure Detection Clients
	This option is checked by default. If checked, the gateway will accept authentication information from all clients. If unchecked, it will only accept authentication information from clients that support secure detection functionality.


38.7.7 Whitelist
For network devices that cannot install the client, such as network printers, you can allow these devices to access the network by configuring a whitelist in "Access Gateway Configuration -> Whitelist." The whitelist supports control based on IP addresses and MAC addresses.
[image: image887.bmp] Note
Only machines within the same VLAN as the access gateway can be set to the MAC address whitelist.
38.7.8 Blacklist
To enforce stricter management, certain compliant clients may still require control over their access to specific environments. This can be achieved by configuring a blacklist in "Access Gateway Configuration -> Blacklist." Computers on the blacklist will be blocked from accessing the protected network of the access gateway, except for exception addresses that can still be accessed.
38.8 Server Management
When a server is connected to the access device, compliant clients on the server can access the protected network managed by the access device.

After successfully adding the access device in the console under "Tools -> Access Gateway Management," you can view the connected servers in the access device's web management interface under "Server Management." You can modify disaster recovery settings between the server and the access device, as well as enable/disable the server. When disabled, the connection between the server and the access device will be disconnected, and the disaster recovery settings will not take effect.
38.9 Guest Login Management
38.9.1 Account Management
For external devices that temporarily need to access the network protected by the access device, but cannot install the client, a guest account can be provided. When the device is blocked and redirected to the system's warning page, the guest can enter the guest account and password for authentication. Upon successful login, the device can access the network.

Guest accounts are temporary. If there is no network activity within a certain period after successful login, the authentication will expire, and the user will need to authenticate again for the next visit.

In "Guest Login Management -> Guest Management," you can manage guest accounts, including adding, deleting, enabling, or disabling accounts, as well as modifying guest account details. When adding a guest account, the following options are available:
	Settings
	Description

	Account
	Guest account information settings

	Username
	The name of the guest account, required

	Password
	The password for the guest account, required, cannot be empty

	Remarks
	Additional remarks for the guest account, optional

	Validity Period
	The duration during which the guest account is valid

	Login
	Guest login settings

	Allow Single Login
	If unchecked, the guest account can log in from multiple IPs. If checked, the guest account can only log in from one IP at a time.

	Allow Login Only from Specified IP
	If unchecked, the guest account can log in from any IP. If checked, and a specific IP is set, the guest account can only log in from that IP.

	Do Not Allow Login on Non-Compliance Clients
	If unchecked, the guest account can log in from non-compliant clients. If checked, the guest account cannot log in from non-compliant clients.


[image: image888.bmp] Note
 Machines set to the blacklist cannot allow guest logins.
38.9.2 Access Scope
Once a guest is granted access, by default, they can access all networks protected by the entry gateway. To restrict the networks accessible by the guest account, go to Guest Login Management -> Access Scope.
	Setting
	Description

	Action
	Choose either "Deny" or "Allow".

	IP Address
	Input the access range, supporting IP segments. Use commas to separate multiple ranges, e.g., 192.168.1.1-192.168.1.100,192.168.2.102.

	Remark
	Optional remark for the entry.


[image: image889.bmp] Note
Multiple access ranges can be set. New settings are added at the end of the list. Matching is performed from top to bottom, meaning once an IP matches the first rule, no further matching occurs.
38.9.3 Guest Settings
Go to Guest Login Management -> Guest Settings to configure the guest authentication mechanism.
	Setting
	Description

	Login Validity Time
	After the guest's network activity stops for the specified time, the current authentication will expire. The next access will be blocked, requiring re-authentication. The default is 5 minutes.

	Guest Log Cleanup
	By default, guest logs are not cleared. Check this option and set a time to automatically delete guest logs older than the specified number of days.


38.9.4 Guest Logs
Go to Guest Login Management -> Guest Logs to view the logs of guest accounts, providing audit evidence. The guest log includes the following details:
	Attribute Name
	Description

	Time
	The time when the guest account performed the related action.

	IP Address
	The network address from which the guest account performed the action.

	Type
	The type of guest login: account authentication or SMS verification.

	Account
	The guest account name.

	Action
	The type of action: login or logout.


38.9.5 Guest Administrator
Supports individual management of guest accounts.
Guest Administrator Account Management
Enter http://<Access Gateway IP>/Set in the browser to log into the guest administrator account management page. By default, there is only one guest administrator account, visitor, which can be enabled or disabled on this page. The password can also be reset, and after resetting, the password will be blank.
Guest Management
Enter http://<Access Gateway IP>/Visitor in the browser to log into the guest management page. Since there is only one independent guest administrator account, visitor, log in using that account's password. The initial password for visitor is blank. Upon first login or after resetting the password, you will be redirected to change the password. After the password is successfully updated, you will directly enter the guest management page.

The operations on the independent guest management page are the same as those in the main administrator interface.
[image: image890.bmp] Note
The access URLs for the guest administrator account page and the independent guest management page are case-sensitive.
38.10 Status Information
You can view the device's relevant status information, including:IP information passing through the device、Device traffic information、CPU usage information、Memory usage information、Disk usage information
38.10.1 IP Information
In the IP information section, you can view details about the computers currently passing through the gateway device, including: network address, last online time, block status, and current status indicator.
	Attribute Name
	Description

	IP Address
	The network address of the computer.

	Last Online Time
	The last time the computer communicated through the gateway device.

	Block Status
	The current block status of the computer. If blocked, the status is "Blocked"; if not, the status is empty.

	Block Time
	The most recent time the computer was blocked.

	Current Status
	The current status identifier of the computer.


Different types of computers are associated with a specific current status, and each status corresponds to a blocking state. The details are as follows:
	Current Status
	Description
	Corresponding Block Status

	Empty
	No client installed
	Computers within the control range will show "Blocked", those outside will show empty

	Compliant (Authorized)
	Client installed and complies with security policies. Currently authorized by the server
	Empty, not blocked

	Compliant (Trusted)
	Client installed and complies with security policies. Currently authorized by trust package
	Empty, not blocked

	Compliant (Authorized + Trusted)
	Client installed and complies with security policies. Currently authorized by both server and trust package
	Empty, not blocked

	Client (Non-Compliant)
	Client installed but does not comply with security policies
	Blocked

	Compliant (Temporary)
	Client installed and complies with security policies, but temporarily allowed after being offline
	Empty, not blocked

	Compliant (Offline)
	Client installed and complies with security policies, but no communication through the gateway device
	Empty, not blocked

	Whitelist
	Computer added to the whitelist
	Empty, not blocked

	Blacklist
	Computer added to the blacklist
	Blocked

	Visitor
	Computer accessing the network via visitor authentication
	Empty, not blocked

	Disaster Recovery Open
	Computer allowed access due to disaster recovery settings
Note: In the device's web management interface, the "Server Management" section will show the servers connected to the device. When a connection issue occurs, disaster recovery settings will take effect.
	Empty, not blocked


Current Status
A computer may have multiple statuses at the same time, and the priority of these statuses is as follows:
Blacklist > Whitelist > Visitor > Client (Compliant and Non-Compliant)
When a computer has more than one status, the status with the highest priority takes precedence, and the corresponding blocking state is applied. For example, if a client computer does not meet the security conditions but is also added to the whitelist, its current status will be "Whitelist," and the blocking state will be "empty."
38.10.2 Device Traffic Information
You can view the traffic-related information for the current device. It allows you to switch between viewing real-time, last 10 minutes, last 1 hour, last 24 hours, last 7 days, and last 30 days' data.
38.10.3 CPU Usage Information
You can view the current CPU usage information of the device. It allows you to switch between viewing real-time, last 10 minutes, last 1 hour, last 24 hours, last 7 days, and last 30 days' data.
38.10.4 Memory Usage Information
You can view the current memory usage information of the device. It allows you to switch between viewing real-time, last 10 minutes, last 1 hour, last 24 hours, last 7 days, and last 30 days' data.
38.10.5 Disk Usage Information
You can view the current disk usage information of the security gateway device.
38.11 System Management
38.11.1 System Configuration
Scheduled Reboot
Select "System Management -> System Configuration -> Scheduled Reboot" to enable the scheduled reboot feature. Toggle the "Scheduled Reboot" switch to "On", set the reboot cycle and time, and click [Save]. The device will automatically reboot at the specified time.
System Time Settings
Select "System Management -> System Configuration -> System Time Settings", click the 
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 to modify the current time of the device, and save to apply the changes.
Advanced Configuration
Select "System Management -> System Configuration -> Advanced Configuration" to enable auxiliary functions and configure related parameters. Different functions have different parameters and requirements, depending on the specific feature.
38.11.2 System Tools
Version Upgrade
Select "System Management -> System Tools -> Version Upgrade" to import an upgrade package and upgrade the device software. A restart is required for the upgrade to take effect.
Import/Export Configuration
Select "System Management -> System Tools -> Configuration Management" to import or export the current configuration of the device. Supported configurations include: Management Range, Control Range, Exception Addresses, Active Authentication, Whitelist, Blacklist, and Visitor List. You can select specific configurations to import.
Device Restart
Select "System Management -> System Tools -> Device Restart". In the confirmation popup, click the "Restart" button to reboot the device.
Restore Factory Settings
Select "System Management -> System Tools -> Restore Factory Settings" to reset the device to its factory default settings.
Install Patch
Select "System Management -> System Tools -> Install Patch". Choose "Install Patch" to import a patch package. Click "Install" to quickly update software, install dynamic libraries, modify system configuration files, or scripts.
38.12 Access Gateway Logs
38.12.1 Gateway Operation and Settings
The gateway operation and settings logs record user settings and changes to the gateway configuration, as well as the gateway's own operation status, providing an audit trail for administrators.

Log information includes the following:
	Attribute
	Description

	Type
	Categories of gateway operation and settings logs, including login, logout, policy settings, parameter settings, system, and maintenance.

	Time
	The time the administrator or system performed the action.

	Network Address
	The IP address of the machine used by the administrator to perform the operation. If it's a system log, the network address will be blank.

	Description
	A detailed explanation of the log entry's content.


38.12.2 Illegal IP Detection and Blocking
The illegal IP detection and blocking logs record the situation where a terminal IP is blocked by the access gateway and the detection of terminal IPs by the access gateway, providing an audit trail for administrators.

Log information includes the following:
	Attribute
	Description

	Type
	Categories of the log, including detection passed, blocked, illegal IP found, and IP status changes.

	Time
	The time when the IP was detected or blocked.

	Network Address
	The IP address that was detected or blocked.

	Object Type
	The status of the detected or blocked terminal, including blacklist, whitelist, client, visitor, illegal terminal, exception rules, or others.

	Description
	Records changes in object type, target address accessed, and other relevant details.


38.13 Other Operations
38.13.1 Change Password
In the top header area, under the admin account information, select "Change Password" from the dropdown menu to modify the admin account's login password. Since the access gateway only has one admin account (admin), this action is equivalent to changing the access gateway's connection password.
38.13.2 Logout
In the top header area, under the admin account information, select "Logout" from the dropdown menu to log out of the current web management interface.
38.14 Super Mode
If an upgrade fails causing the system to become unresponsive, or if the login password for the access device is forgotten, you can select "System Tools -> Super Mode" to enter super mode for clearing the login password or performing a factory reset.

To use super mode, the computer must be directly connected to the access device's management port, as follows:
1) Disconnect computer A from the internal network and change its IP to allow communication with the access device, e.g.:
IP Address:190.190.0.1
Subnet Mask:255.255.0.0
Default Gateway: Optional
2) Use a network cable to directly connect computer A to the management port of the access device. Then, open a browser on computer A and visithttp://190.190.190.190/reset to access the super mode interface.
3) Choose "Clear Login Password" to reset the login password to empty, or select "Restore Factory Settings" to restore the access device to its default factory settings.
For the 1000 model device, there is no fixed management port. After setting the IP used to connect to the network, the portless IP is 190.190.190.190.
If the login password for the 1000 device is forgotten, the recommended procedure is as follows:
1) Export the current backup:
IP Address: 190.190.0.1
Subnet Mask: 255.255.0.0
Default Gateway: Optional
2) Disconnect the device from the network and use the RESET button to restore factory settings.
3) Reconfigure the IP information, import the backup, and reconnect to the network.
38.15 Usage Example
Enterprise Setup:
1. All internal network servers (e.g., SVN server, JIRA server, VoIP server, etc.) are deployed in Subnet 1.
2. The access gateway is connected to the network in a serial configuration, with an IP address of 192.168.2.1. All machines from non-Subnet 1 will pass through the access gateway when accessing the internal network servers.
Requirements to Implement:
1. Employees' computers need to have the AnySecura client installed and be running the company’s internal communication tool RTX to access internal network servers.
2. Network printers and IP phones should function normally.
3. For certain executives, these restrictions are not necessary.
4. For occasional partners visiting the company for communication, their computers are not suitable for installing the AnySecura client. When these partners connect to the company’s wireless network, they will use IP addresses in the range of 192.168.3.1-192.168.3.20.
For the above requirements, the following settings can be made:
Settings on the Access Gateway:
① Access Gateway Configuration -> Control Range: Set the control range to include all company network addresses except for the 1 subnet.
② Access Gateway Configuration -> Exception Rules: Add the IP addresses of the network printers and IP phones.
③ Access Gateway Configuration -> Warning Page: Choose the system warning page and modify the page content as needed.
④ Access Gateway Configuration -> Whitelist: Add the IP addresses of the executives' machines that do not require restrictions.
⑤ Visitor Login Management -> Visitor Management: Add visitors, set the account name, password, and comments, then in the login settings, check “Only allow login from specified IP addresses” and enter the specified IP range: 192.168.3.1-192.168.3.20.
Settings on the AnySecura Console:
① Tools -> Access Gateway Management: Add the Access Gateway with the IP 192.168.2.1.
② Security Detection -> Security Detection Conditions: Add a new security detection condition:
   Enter the condition name, such as “RTX Installation”.
   In the security detection condition settings window, select the “Program Check” tab, check “All of the following programs must be running”, and add the process RTX.exe.
③ For all clients, Security Detection -> Security Detection Settings: Add a policy:
   Choose the previously added RTX Installation security condition.
   In the policy attributes on the right, check “Block Access”.
After completing these settings, enable the Access Gateway control function.
Chapter 39: Secure Access Gateway
To improve work efficiency through IT, many enterprises deploy information management systems such as ERP, OA, CRM, and PLM. These systems store critical company data, including customer information, R&D plans, and financial reports, making them highly valuable. The Secure Access Gateway ensures the security of these applications, preventing confidential corporate information from being easily leaked. It provides comprehensive protection for encrypted documents during upload, download, and transmission through upload decryption, download encryption, and communication encryption.
The Secure Access Gateway has two main functions: Application System Protection and Shared File Protection.
Application System Protection
It protects files on servers of applications like OA, PLM, and SVN. Unauthorized users or programs cannot access the protected servers. Authorized users and programs can access normally, with uploaded files decrypted on the server and downloaded files encrypted on local machines.
Shared File Protection
It protects shared file servers, functioning similarly to application system protection. Unauthorized users or programs cannot access protected servers, while authorized users can. Uploaded files to a designated directory on the shared server are decrypted, and downloaded files from that directory are encrypted. Files in other unspecified directories are not processed.
39.1 Network Architecture
The control functionality of the Secure Access Gateway primarily relies on hardware-based gateway devices. There are two working modes for these devices: Bridge Mode and Router Mode.
Bridge Mode
In Bridge Mode, the network structure and configuration remain unchanged. The Secure Access Gateway device is simply inserted into the network at the point where control is needed, typically in front of critical application servers or gateways. This setup allows seamless integration without modifying existing network infrastructure.
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Routing Mode
Enable policy-based routing on the core switch to control inter-subnet access. This control method does not affect the existing network architecture and requires the core switch to support policy-based routing.
Bypass Mirror Mode
Set up mirror and monitoring ports on the core switch to analyze mirrored traffic for access control. This method does not affect the existing network architecture and requires the core switch to support port mirroring.
39.2 Device Overview
The Secure Access Gateway devices come in the following models: 1800S、2600S、3400S、3600S、4400S、4800S。
1800S：

Four RJ45 ports, including one Bypass set (ETH0 and ETH1)
Management port: EMP
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2600S：
Six RJ45 ports, including two Bypass sets (ETH0 & ETH1, ETH2 & ETH3)
Management ports: EMP1 and EMP2
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3400S：
Six RJ45 ports, including two BYPASS pairs (ETH0 & ETH1, ETH2 & ETH3)
Management ports: EMP1 and EMP2
[image: image896.jpg]



3600S：
Six RJ45 ports, including two BYPASS pairs (ETH0 & ETH1, ETH2 & ETH3)
Management ports: EMP1 and EMP2
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4400S：
Six RJ45 ports, including two BYPASS pairs (ETH0 & ETH1, ETH2 & ETH3)
Two SFP ports (ETH4 and ETH5)
Management ports: EMP1 and EMP2
[image: image898.jpg]



4800S：
Six RJ45 ports, including two pairs of BYPASS (ETH0 & ETH1, ETH2 & ETH3)
Two SFP ports (ETH4 and ETH5)
Management ports: EMP1 and EMP2
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[image: image900.bmp] Note
1. All devices support Gigabit networking.
2. Initial configuration uses the management port:
For devices with a single management port (EMP), the IP is fixed at 190.190.190.190.
For devices with two management ports (EMP1 and EMP2), the IP for EMP1 is fixed at 190.190.190.190, and for EMP2, the IP is fixed at 191.191.191.191.
3. The BYPASS function allows the two connected ends to remain physically connected if the controller loses power or crashes, ensuring uninterrupted network operation.
39.3 Device Deployment
39.3.1 Setting Device IP
Choose the appropriate control method based on your deployment plan and set the IP address for the Secure Access Gateway device accordingly. Once the IP is finalized, follow these steps to configure the device's IP:
1) Disconnect Computer A from the internal network and modify its IP to enable communication with the Secure Access Gateway device. For example:
IP Address:190.190.0.1
Subnet Mask:255.255.0.0
Default Gateway: Optional
2) Use a network cable to directly connect Computer A to the management port of the Secure Access Gateway device. Open a browser on Computer A and visit http://190.190.190.190 to access the device's management login page.
3) The default username is admin, and the password is initially blank. Click [OK] to enter the management interface.
4) In the left menu, navigate to Network Parameters -> Basic Settings, choose the appropriate network access mode, and configure the device's IP information. Save the settings once done.
After modifying the IP, a reboot of the Secure Access Gateway device is required.
[image: image901.bmp] Note
For devices starting from the 2600S model, the mode selection options will include an additional setting: "Bridge (Dual Machine Backup [Primary])". This setting is necessary only for the primary device in a dual-machine hot backup configuration when using bridge mode.
39.3.2 Pre-Network Connection Settings
If the bridge deployment mode is selected and the Secure Access Gateway device is deployed between switches connected via TRUNK, the TRUNK functionality on the device needs to be enabled. This can be done in Network Parameters -> VLAN Settings. If your network environment does not require this setup, you can skip this step.
If the bridge deployment mode is chosen and the device is deployed between a Layer 2 switch and a Layer 3 switch, with multiple subnets (non-VLAN) on the Layer 2 switch's PCs and corresponding IPs on the gateway, the multi-IP binding configuration needs to be enabled. This can be done in Network Parameters -> Multi-IP Configuration. If this is not applicable to your environment, you can skip this step.
If the bypass deployment mode is selected, policy routing must be configured on the switch. For detailed assistance, please consult a technical engineer.
39.3.3 Device Network Connection
Once the IP settings for the Secure Access Gateway device are configured, it can be connected to the pre-planned deployment point.
Bridge Mode
Connection Method: Use two ports on the device to connect it to the network. You can choose any two ports from ETH0, ETH1, or ETH2.
Routing Mode
Connection Method: Use the ETH0 port of the device to connect to the switch.

If you need to change the connection port from ETH0 to another port, you can do so by following these steps:
Navigate to System Tools -> Configuration Management -> Advanced Configuration. Click Set and input the following configuration content:
[PRP]

PRP=ethX

Where X represents the specific communication port number, for example, eth3.
Bypass Mirror Mode
Connection Method: Use the device's ETH2 port to connect to the observation port. Use the ETH0 port to connect to the switch for normal communication across the network.
If you need to change the observation port to another one, follow these steps:
Navigate to System Tools -> Configuration Management -> Advanced Configuration. Click Set and enter the following configuration:
[monitor]

monitor_port=ethX
Where X represents the specific communication port number, such as eth3.
Once the device is connected to the network, you can access its management interface by entering the device's IP address in a browser, e.g., http://192.168.2.190.
39.4 Basic Information
In the "Basic Information" section, you can perform the operation to "Enable/Disable Secure Access Gateway functions." To avoid disrupting work during deployment, it is recommended to configure the security gateway settings and AnySecura security communication policies before enabling the gateway function.
In the basic information section, you can view the relevant details of the Secure Access Gateway device, including control function information, statistical information, security gateway details, and time settings.
Control Function Information includes the following:
	Attribute Name
	Description

	Secure Access Gateway Function
	The current control status of the Secure Access Gateway device, which can either be "Enabled" or "Disabled."

	Protected Application System IP
	IP information of the protected application systems. This can be configured in "Security Management -> Application System Protection."

	Protected File Sharing IP
	IP information of the protected file sharing servers. This can be configured in "Security Management -> File Sharing Protection."


Statistical Information includes the following details:
	Attribute Name
	Description

	Total IP Count
	The total number of IPs passing through the Secure Access Gateway device.

	Online Count
	The number of IPs continuously communicating through the Secure Access Gateway device.

	Blocked Count
	The number of IPs blocked by the Secure Access Gateway device.


Secure Access Gateway Information includes the following details:
	Attribute Name
	Description

	Software Version
	The functional software version of the Secure Access Gateway device.

	Factory Version
	The functional software version of the Secure Access Gateway device when it was shipped.

	Current Version
	The current functional software version. Initially, it is the factory version; if an upgrade or downgrade has occurred, it reflects the post-operation version.

	Web Version
	The current version of the device's web frontend page.

	Operating Platform
	The platform information for the functional software.

	Hardware Model
	The hardware model of the Secure Access Gateway device.

	Validation Result
	The factory validation result for the program, typically marked as OK.


Time Information includes the following details:
	Attribute Name
	Description

	Current Time
	The current time of the Secure Access Gateway device, which is synchronized to the network before leaving the factory. It can be modified in the “System Tools -> Modify Time” section.

	Startup Time
	The time when the Secure Access Gateway device was last started.

	Uptime
	The duration of continuous operation since the device was last powered on.


39.5 Network Parameters
39.5.1 Basic Settings
By selecting “Network Parameters -> Basic Settings”, you can configure the connection mode and IP address of the Secure Access Gateway device. If the device does not have an IP address set, you need to use the management port to connect to the device and configure it. If the device already has an IP address set, you can configure it directly while connected to the network. After making changes, save the settings, and a reboot of the device is required for the settings to take effect.
39.5.2 VLAN Settings
In bridge mode, if the Secure Access Gateway device is deployed between switches connected via TRUNK mode, you need to enable the TRUNK function.
To enable the TRUNK function, go to “Network Parameters -> VLAN Settings”, check “Enable Trunk”, and add the VLAN configuration.

VLAN Configuration Information includes the following:
	Attribute Name
	Description

	ID
	VLAN ID

	IP Address
	Enter an IP address that does not conflict within the corresponding VLAN ID

	Subnet Mask
	Subnet mask for the IP address


[image: image902.bmp] Note
1. When adding VLAN configurations, only VLANs other than the Native VLAN or defaultVLAN should be added. Adding configurations to these VLANs could result in network instability.
2. When connecting via TRUNK mode, the IP address, subnet mask, and gateway configuration of the device must belong to either the Native VLAN or defaultVLAN.
3. If no manual changes are made to the Native VLAN or defaultVLAN on the switch, the default VLAN is usually VLAN 1.
39.5.3 Multi-IP Configuration
In bridge mode, when the security gateway device is deployed between a Layer 2 switch and a Layer 3 switch, with multiple VLANs or isolated IP networks, the PCs on the Layer 2 switch are spread across different subnets (non-VLAN), and the gateway also needs to have corresponding IPs for these subnets. In this case, you must enable the Multi-IP Binding configuration.

If the network setup does not meet the above criteria, then enabling Multi-IP binding is unnecessary.

To configure Multi-IP binding:

1. Navigate to "Network Parameters -> Multi-IP Configuration".

2. Check the option "Enable Multi-IP Binding".

3. Add the required IP addresses that are compatible with the isolated subnets.
Multi-IP Binding Configuration Information:
	Attribute Name
	Description

	IP Address
	The IP address to bind, which should not conflict with the other IP addresses in the same subnet.

	Subnet Mask
	The subnet mask corresponding to the IP address.


[image: image903.bmp] Note
Do NOT add the security gateway device's current IP network when configuring Multi-IP binding, as this may lead to conflicts.
39.5.4 Forwarding Rule Settings
If a server is deployed in the cloud and public machines need to access the cloud server, while being protected by a security gateway deployed in the corporate intranet, the forwarding feature of the security gateway can be used. When this feature is enabled, the security gateway acts like a gateway device, meaning the cloud server’s IP address is not exposed, and users only know the security gateway's address. The access is made directly to the security gateway, which then performs address translation to redirect to the cloud server.
Setting Forwarding Addresses
In the Secure Access Gateway's web management interface, go to “Network Parameters -> Forwarding Rule Settings,” click “Forwarding Address Settings,” and add the forwarding addresses.
Forwarding address settings include the following:
	Attribute Name
	Description

	Forwarding Address
	Only IP addresses are supported. The Secure Access Gateway will use this IP, which must be in the same subnet as the device. Duplicate forwarding addresses are not allowed, but multiple forwarding addresses can be configured.


Setting Forwarding Rules
In the Secure Access Gateway's web management interface, go to “Network Parameters -> Forwarding Rule Settings,” click “Add,” and configure the forwarding rule by entering the target address, target port, selecting the forwarding address, forwarding port, and adding remarks. Then save.
Forwarding rule settings include the following:
	Attribute Name
	Description

	Target Address
	Only IP addresses are supported. Domain names are not supported. This field is required.

	Target Port
	The corresponding port of the target address. This field is required.

	Forwarding Address
	Select from the network addresses set in the forwarding address configuration. This field is required.

	Forwarding Port
	Can be selected from a dropdown or manually entered. The default is the corresponding port. Dropdown options include the corresponding and historical ports. Manual input allows any port number.


[image: image904.bmp] Note
Multiple forwarding rules can be set, and one forwarding address can have multiple forwarding rules.
39.6 Scope Settings
Set the relevant scope for the Secure Access Gateway functionality. The scope settings here apply to both application system protection and file sharing protection.
39.6.1 Management Scope
Go to “Scope Settings -> Management Scope” to set the management scope of the Secure Access Gateway device.
The management scope is empty by default, meaning all computers that communicate through the Secure Access Gateway device will appear in the corresponding “Status Information” view of the device. Once the management scope is set, only computers within the management scope will appear in the “Status Information” view if they communicate through the device.
39.6.2 Control Scope
Go to “Scope Settings -> Control Scope” to set the control scope of the Secure Access Gateway device.
The control scope is empty by default, meaning no computers are controlled. Once the control scope is set, machines within this scope that use non-secure processes to access protected application system servers will be blocked.
39.6.3 Whitelist
For network terminal devices that cannot install the client, such as network printers, you can allow these devices to access protected servers by configuring the whitelist in “Scope Settings -> Whitelist.” The whitelist supports IP address and MAC address control.
[image: image905.bmp] Note
Only machines within the same VLAN as the Secure Access Gateway can be added to the MAC address whitelist.
39.7 Application System Protection
Application system protection, used in conjunction with the encryption client, ensures that only specified processes can access the protected application system server. Additionally, files uploaded locally by the client to the protected server will be decrypted, while files downloaded from the server to the client will be encrypted.
39.7.1 Protection Scope
Go to “Application System Protection -> Protection Scope” to set the application system servers protected by the Secure Access Gateway device. The setup details are as follows:
	Attribute Name
	Description

	IP Address and Port
	Set the IP and port parameters for the application system server. Supports setting IP ranges and port ranges. The format can be as follows:
IP:Port, e.g., 192.168.1.50:8080

IP:Port Range, e.g.,192.168.1.50:80-8080

IP Range:Port, e.g., 192.168.1.50-192.168.1.60:80

IP Range:Port Range, e.g.,192.168.1.50-192.168.1.60:80-8080

	Remarks
	Optional remarks.


Protected application system servers can only be accessed via secure processes. Therefore, after setting up the protected servers, encryption must be enabled for clients in the AnySecura console. Additionally, in “Encryption -> Secure Communication Settings -> Application System Protection,” enable “Protection for Application Systems” and set the secure processes.
39.7.2 Warning Page
The warning page serves the purpose of redirecting users who attempt to access the protected range without using a secure process. This page provides relevant notification information.
Go to “Application System Protection -> Warning Page” to configure the settings. The configuration options for the warning page are as follows:
	Attribute Name
	Description

	Default Warning Content
	By default, the warning page is a system forwarding page with a pre-configured layout. The system warning page allows guest login. Administrators can modify the page content or reset it to the default layout.

	Custom Warning Link
	If you want to use an existing HTTP server page, you can choose another forwarding page and enter the webpage address.


39.7.3 Product Binding
By default, no product ID is bound, meaning any secure process can access the protected application system. When a specific product ID is bound, only clients with that product ID can access the protected application server through a secure process. Clients with other product IDs will not be able to access the server through a secure process.
39.8 File Sharing Protection
File sharing protection, used in conjunction with the encryption client, ensures that only specified machines can access the protected network shared document directory. Additionally, files copied from the client to the protected shared directory are decrypted, while files copied from the shared directory to the client are encrypted.

Go to “File Sharing Protection” to set the IP and port information of the file sharing server protected by the Secure Access Gateway device.
The configuration options for file sharing protection are as follows:
	Setting Item
	Description

	Port Settings
	Default Ports: Select this option to protect the common shared ports 139 and 445 (this option is selected by default).
All Ports: Select this option to protect all ports.
Custom Ports: Select this option and enter the port number to protect the entered port.

	Disable NAT (Network Address Translation)
	If this option is not selected, in a NAT device (router, wireless router, etc.) architecture, as long as one computer can access the protected shared folder, other devices connected to that NAT device will also be allowed access.
If this option is selected, no devices in the NAT architecture will be able to access the protected shared folder.
This setting does not support virtual environments: Whether or not this option is selected, if the virtual environment connects to the network via NAT mode through a physical host, the virtual environment's access to the shared folder will be the same as the host.

	IP Settings
	Set the IP addresses of the file sharing servers protected by the Secure Access Gateway. Supports entering IP ranges, and multiple IP addresses should be separated by commas (e.g., 192.168.1.1-192.168.1.100,192.168.2.102).
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To use this feature, once the protected file sharing server is set, encryption must be enabled for clients in the AnySecura console. Additionally, in “Encryption -> Secure Communication Settings -> Network Shared Document Protection,” enable “Protection for Network Shared Document Directory” and configure the necessary settings.
39.9 Status Information
View the device's related status information, including the IP information of devices passing through, traffic data, CPU usage, memory usage, and disk usage.
39.9.1 IP Information
In the IP information section, you can view the relevant details of computers currently passing through the Secure Access Gateway, including: network address, startup time, last online time, status, last block time, current identity, and whether access to shared folders is allowed.
	Attribute Name
	Description

	Network Address
	The network address of the computer.

	Startup Time
	The time when the computer first communicated through the Secure Access Gateway.

	Last Online Time
	The time when the computer last communicated through the Secure Access Gateway.

	Status
	The current status of the computer. If blocked by the Secure Access Gateway, “Blocked” is displayed. If this column is empty, it means the computer is not blocked.

	Last Block Time
	The last time the computer’s access to the protected application system server was blocked.

	Current Identity
	Currently, the only identity for the Secure Access Gateway is “Whitelist.”
If the computer is set to the whitelist, this column will display “Whitelist.” If empty, the computer is not on the whitelist.

	Allowed to Access Shared Folder
	If the computer can access the protected shared file server, this column will display a “√.” If empty, access to the shared file server is not allowed.


39.9.2 Device Traffic Information
iew the current traffic information of devices passing through the Secure Access Gateway. You can toggle to view real-time data, the last 10 minutes, the last 1 hour, the last 24 hours, the last 7 days, or the last 30 days.
39.9.3 CPU Usage Information
View the current CPU usage information of the Secure Access Gateway device. You can toggle to view real-time data, the last 10 minutes, the last 1 hour, the last 24 hours, the last 7 days, or the last 30 days.
39.9.4 Memory Usage Information
View the current memory usage information of the Secure Access Gateway device. You can toggle to view real-time data, the last 10 minutes, the last 1 hour, the last 24 hours, the last 7 days, or the last 30 days.
39.9.5 Disk Usage Information
View the current disk usage information of the Secure Access Gateway device.
39.10 System Tools
39.10.1 Change Password
Go to “System Tools -> Change Password” to modify the password for logging into the Secure Access Gateway device.
39.10.2 Upgrade
Go to “System Tools -> Upgrade” to import an upgrade package and update the Secure Access Gateway device software. A reboot is required for the upgrade to take effect.
39.10.3 Device Reboot
Go to “System Tools -> Reboot Device,” and click the “Reboot Secure Access Gateway” button to restart the device.
39.10.4 Scheduled Reboot
Go to “System Tools -> Scheduled Reboot” to enable the scheduled reboot function. Check the “Enable Scheduled Reboot” option and set the date (daily or specific days of the week) and time for the reboot. Click the “Save” button to apply. The device will automatically reboot at the set time.
39.10.5 Time Settings
Go to “System Tools -> Time Settings” to modify the current time of the Secure Access Gateway device. Save the changes to apply.
39.10.6 Restore Factory Settings
Go to “System Tools -> Restore Factory Settings” to reset the Secure Access Gateway device to its default factory settings.
39.10.7 Configuration Management
Go to “System Tools -> Configuration Management” to import and export the current configuration of the Secure Access Gateway device. Configurations that can be imported and exported include: management scope, control scope, application system protection, file sharing protection, warning page, product binding, and whitelist. You can select specific configurations to import during the process.
39.10.8 Logout
Go to “System Tools -> Logout” to log out of the web management interface.
39.11 Super Mode
If an upgrade fails, preventing normal operation, or if the login password for the Secure Access Gateway device is forgotten, you can enter super mode to clear the login password or restore the factory settings.
To use super mode, the computer must be directly connected to the management port of the Secure Access Gateway device. The steps are as follows:
1) Disconnect Computer A from the internal network and modify its IP to enable communication with the Secure Access Gateway device. For example:
IP Address: 190.190.0.1
Subnet Mask:255.255.0.0
Default Gateway: Not required
2) Use an Ethernet cable to directly connect Computer A to the management port of the Secure Access Gateway device. On Computer A, open a browser and visit http://190.190.190.190/reset to access the Secure Access Gateway super mode interface.
3) Select “Clear Login Password” to reset the login password of the Secure Access Gateway device to empty. Select “Restore Factory Settings” to reset the device to its factory settings.
39.12 Usage Example
Company Setup:
1. OA System: Primarily used for daily work. The system IP is 192.168.1.2, and the port is 8080.
2. File Sharing Server: Used to store daily work materials and documents. The file sharing server IP is 192.168.1.1, with important company documents stored in the \192.168.1.1\private directory, which should not be shared without proper authorization.
3. Secure Access Gateway: The device is connected in a series, with an IP of 192.168.2.6. All machines accessing the OA system and the file sharing server pass through the Secure Access Gateway.

Required Implementation:
1. Restrict access to the OA system so that it can only be accessed via Internet Explorer (IE). Other browsers should be blocked. Documents on the OA system should remain in plain text while on the server. However, when employees download files from the OA system to their local machines, the files must be encrypted.
2Files in the private directory of the file sharing server should be encrypted when moved from the shared location to a local machine.
3. For specific leaders, the above restrictions should not apply.
For the Above Requirements, the Following Settings Can Be Applied:
Settings on the Secure Access Gateway:
1  Security Management -> Control Scope: Set the control scope to include the entire company’s network address.

② Security Management -> Application System Protection: Add the IP address: 192.168.1.2:8080.

③ Security Management -> File Sharing Protection: Choose the default port and add the IP address: 192.168.1.1.

④ Security Management -> Whitelist: Add the IP addresses of leaders who are exempt from the restrictions.
Settings on the AnySecura Console:
① Enable encryption for all clients.
② For all clients, go to Encryption -> Secure Communication Settings -> Application System Protection, and set:
   Check the “Enable Protection for Application Systems” option.
   Add the secure process as iexplore.exe and set the encryption mode to “Forced Mode.”
③ For specific employee clients, go to Encryption -> Secure Communication Settings -> Network Shared Document Protection, and set:
   Check the “Enable Protection for Network Shared Document Directory” option.
   Add the Secure Access Gateway address: 192.168.2.6
   Add the protected shared document directory as:\\192.168.1.1\private
Once the settings are complete, enable the control function on the Secure Access Gateway.
Appendix: Module Function Descriptions
	Module
	Sub-Function
	Detailed Function Description

	Basic Functions
	Basic Information
	Collect basic information about client machines, including computer name, network address, operating system, logged-in user, current status, and more.

	
	Basic Control
	Allows the control end to lock, shut down, restart, log off, and send notification messages to any client machine within the network.

	
	Basic Logs
	Record events such as client machine startup/shutdown, user login/logout, dial-up connections, and other related events.

	
	System Policies
	Set local system operation permissions on client machines, including control panel, computer management, system management, network properties, plugin management, and all computer properties. It can also bind the client's IP and MAC addresses.

	
	Policy Alarms
	Set alarms when the client machine’s system status changes, including hardware changes, storage and communication device plug/unplug events, software installations/uninstalls, system information and network configuration changes, and more.

	
	Policy Logs
	Record operation logs of client machines when executing policies, such as blocking, alarming, warning, and locking the machine.

	
	Security Detection Features
	Check whether the client machine's status matches the detection conditions set by the console. The detection results can be displayed on both the console and the client. Detection contents include antivirus software use, patches, software installation, program usage, system service status, and other conditions (such as registry checks).

	Application Control
	Application Logs
	Detailed logs of application startups and exits. Records window switching and title changes. Allows querying by time range, computer scope, application name, application path, and window title.

	
	Application 

Statistics


	Various methods to track the usage time and usage percentage of different applications, displayed in both list and chart formats. Includes statistics by application category, name, detailed breakdown, and by computer-specific statistics.

	
	Application Control
	Limit the use of specific programs on specified computers within a set time frame. Alarms can be sent to the console when restricted programs are running.

	
	Software Installation Management
	Manage the installation and uninstallation of software.

	Web Access Control
	Web Browsing Logs
	Detailed records of URLs and titles visited by each computer (user), with query capabilities.

	
	Web Browsing Statistics
	Track web browsing activity in various ways, displaying results in both list and chart formats. Includes statistics by website category, detailed statistics, and computer-specific breakdown.

	
	Website Browsing Control
	Control specified clients’ access to designated websites or URLs within a set time range.

	
	Upload Control
	Manage network upload activities, including sending web emails, forum posts, and FTP uploads.

	Network Traffic Control
	Network Traffic Statistics
	Track client network traffic within a specified time range, including total traffic and detailed traffic by protocol and address. Statistics can be by address, protocol, port, or computer-specific breakdown.

	
	Network Traffic Control
	Limit client network speed by setting time ranges, network addresses, port ranges, and send/receive directions to ensure reasonable use of network bandwidth.

	Document Control
	Document Operation Logs
	Record all document operations on the local machine, including creation, access, modification, copy, move, deletion, recovery, renaming, etc., across hard drives, removable storage, network paths, and shared directories. Logs can be queried based on recorded information.

	
	Shared Document Operation Logs
	Record operations on shared documents by users from other machines.

	
	Document Operation Control
	Control client machine permissions for reading, modifying, and deleting specified documents on designated disk types or networks.

	
	Document Backup
	Backup documents to prevent accidental deletion or tampering before the content is altered or corrupted.

	Print Control
	Print Operation Logs
	Record all printing activities in detail, including time, terminal, user, application, pages, printer type, and name. Queries can be made by time, file name, computer, and other criteria.

	
	Print Content Recording
	Capture the complete print image on all types of printers, allowing review of the original printed content.

	
	Print Control
	Control application printing permissions to block unauthorized applications; control terminal printing permissions to restrict access to specific printer types or designated printers. Supports backing up printed content.

	
	Watermark Control
	Protect intellectual property by adding watermarks to printed content.

	Screen Monitoring
	Real-time Screen Snapshot
	View real-time screen snapshots of client machines. Supports monitoring of multiple user logins and multi-monitor setups. Allows centralized monitoring of a group of computers simultaneously.

	
	Screen History
	Record historical screen images on the client machine with variable-frequency recording for different applications. Works with log records to view screen conditions at specific times. Supports exporting screen history as a common video file, which can be played by other tools.

	Remote Maintenance
	Remote Maintenance
	View real-time client system information, remotely analyze client performance and troubleshoot issues. Remote operations can be performed to help resolve problems.

	
	Remote Control
	Connect to the client machine's desktop remotely to perform direct operations, facilitating remote assistance or demonstration.

	Device Control
	Device Control
	Manage client device usage permissions. Any newly added device can be blocked.
• Communication devices: Serial/parallel ports, SCSI, 1394, Bluetooth, infrared, modem, direct link cables, etc.
• Storage devices: Floppy drives, optical drives, burners, tape drives, removable storage, etc.
• USB devices: USB keyboards, mice, modems, imaging devices, storage, optical drives, hard drives, and other USB devices.
• Network devices: Wireless NICs, plug-and-play NICs, virtual NICs, etc.
• Other devices: Audio devices, virtual optical drives, etc.
Newly added devices can be blocked.

	Network Access Control
	Network Communication Control
	Manage internal network usage permissions by setting communication direction, IP address range, and network port range.
Control network communication for specified clients.
Control network communication for specified protocols and address ranges.
Control network communication with external computers.

	
	Intrusion Detection
	Detect unauthorized computers accessing the network and trigger an alarm, while blocking the unauthorized access.

	
	Network Control in Security Detection
	Based on security detection results, disconnect clients that do not meet security criteria, with the ability to set exception addresses. The control will be automatically lifted once the client meets the security conditions.

	Email Control
	Email Logs
	Record recipient, sender, body, and full attachments for emails sent/received via standard protocols, Exchange, webmail, and Lotus.

	
	Email Control
	Control email sending based on conditions such as sender, recipient, subject, attachments, and email size. Block sending to unauthorized recipients and prevent sending attachments with specific names or exceeding size limits.

	Instant Message Monitoring
	Instant Messaging Logs
	Fully log conversations from mainstream instant messaging tools like MSN, QQ, TM, RTX, ICQ, Yahoo Messenger, Sina UC, PoPo, Skype, Lotus Sametime, Alibaba Trade, Aliwangwang, etc., including conversation time, participants, and content.

	
	Instant Messaging Document Control
	Control the sending of documents via instant messaging tools based on document name and size criteria. Documents can be backed up during transmission (refer to Document Operation Control for more details).

	IT Asset Management
	Asset Management
	Automatically scans and records detailed hardware and software asset information for each endpoint, including change history. Supports custom asset attributes for additional information management, and management of non-IT assets via custom asset categories.

	
	License Management
	Collects and classifies information on installed software, records software procurement, and tracks license usage of paid software.

	
	Patch Management
	Automatically scans client systems for Microsoft product patch status, downloads patches according to policies, and distributes/installs them automatically.

	
	Vulnerability Check
	Automatically scans for security vulnerabilities on client systems, providing analysis reports and solutions.

	
	Software Distribution
	Automatically deploys and installs software, executes programs, or distributes documents. Supports breakpoint resume, background installation, and interactive installation.

	
	Software Uninstallation
	Scans whether target software is installed and executes uninstallation tasks.

	Removable Media Control
	Removable Media Auditing
	Detects all removable media devices connected to the network, records detailed device information, and tracks their usage. Supports classification management, such as assigning company-owned devices by department.

	
	Removable Media Authorization
	Controls read/write permissions for each removable media device, blocking unauthorized external devices within the enterprise.

	
	Removable Media Encryption
	Formats standard removable media devices into encrypted drives usable only within the enterprise. If lost, files remain inaccessible. Files copied onto the device are automatically encrypted and can only be decrypted on authorized computers.

	
	Device Registration Management
	Manages the lifecycle of removable media devices, including registration, classification, reporting loss, and deactivation.

	Security Audit Reports
	Risk Audit Report
	Statistics Table: Analyzes and reports each operation behavior, such as printing, email, removable storage, document operations, software use, web browsing, instant messaging, etc., from multiple dimensions, helping to quickly understand internal network computer activities.
Trend Table: Visually displays the trend of user behavior changes.
Sign Table: A hierarchical alert system that automatically records warning events and their levels when behavior reaches predefined thresholds, notifying administrators to pay attention and take action.

	Cloud Document Backup
	Automatic Backup
	Backs up data from endpoint computers and uploads it to the document cloud backup server for centralized storage and management. Supports scheduled, triggered, and full-disk scan backups. Backup versions can be retained as a single document or multiple versions as needed.

	
	Hierarchical Management
	Assigns different document management permissions and scopes to different users to prevent unauthorized access to important documents.

	
	
	

	
	Backup Audit
	Logs all operations related to document cloud backup, including starting upload, upload success, upload failure, starting scan, and scan completion. Administrators can review detailed processes in the logs.

	Software Center
	Software Management
	Administrator: Add and manage software through the software center. Can set user permissions to view and install software. New software must be approved by the system administrator before being made available for users to download.

End Users: Install, upgrade, and uninstall software within their permissions through the software center.

	
	Management Audit
	Supports auditing actions of administrators, such as login/logout, software changes, policy modifications, and user settings.

	Watermarking & Document Tracing
	Screen Watermark
	Add a watermark to the full screen or specific application windows with specified content.

	
	Print Watermark
	Protect intellectual property by adding a watermark to printed content.

	
	Document Watermark
	Automatically add specified watermark and circulation information for downloaded and external documents, with the option to manually add document watermarks.

	Document Tagging
	Landing Add
	Detect landing behavior and automatically apply specified document labels and confidentiality levels. Also supports manually adding document labels and confidentiality levels.

	
	External Transmission Control
	Block or audit external transmission of files with specified document labels and confidentiality levels (e.g., copying to removable drives, network drives, email, IM, etc.).
Automatically apply protective measures such as encryption and watermarking when creating or editing documents containing sensitive information.

	
	Document Label Logs
	Record logs of document label and confidentiality level assignments, including those triggered by document label policies and manually added by clients.

	Sensitive Content Inspection
	Sensitive Content Definition
	Supports defining sensitive information through combinations of keywords, regular expressions, etc. Also supports extracting feature information from sample documents to define sensitive information.

	
	Sensitive Content Discovery
	Supports local and remote scanning to detect sensitive information. Full network-wide scans can be conducted to identify sensitive content.

	
	Sensitive Content Monitoring
	An alert is triggered upon detection of sensitive content when a document is created and downloaded to a computer, or when a document containing sensitive information is transmitted through distribution channels.

	
	Sensitive Content Protection
	When a document containing sensitive information is externally transmitted (e.g., copied to removable drives or network drives, sent via email, or transferred through instant messaging), blocking or auditing measures are enforced.

When creating or editing a document containing sensitive information, protective measures are automatically applied, such as encryption or watermarking.

	AI Visual Perception
	Mobile Photography Detection
	When a user takes a photo of the screen with a mobile phone, protective measures such as screen masking, locking the computer, and alerting the administrator are triggered.

	
	Photography Logs
	Logs the activity of taking screenshots of the computer screen. Logs include information on the photographer and the screen content captured.

	Transparent Encryption
	Transparent Encryption
	Uses high-strength encryption technology to enforce transparent encryption, ensuring documents are always stored in encrypted form. In authorized environments, documents are automatically decrypted without affecting user habits; in unauthorized environments, encrypted documents cannot be opened or used. Prevents users from stealing encrypted document content via clipboard, screenshots, or virtual printing.

	
	Permission Control
	Based on the importance of the document, encrypted documents are categorized into different security zones and levels, allowing different departments and positions to access them. A departmental and hierarchical confidentiality mechanism is established. Users can adjust document areas and levels, and for important documents, higher levels can be set to prevent regular user access.

	
	Offline Authorization
	Grants users the ability to access encrypted documents when leaving an authorized environment. Users can have different encryption software categories and document usage rights set for offline access.

	
	External Transmission Management
	Encrypts documents for external transmission, allowing only authorized external personnel to view them, preventing secondary leaks. Specifies the viewing period, access count, and usage rights for external documents.

	
	Disaster Recovery Backup
	The backup server design ensures resilience against hardware and system failures, guaranteeing continuous operation of the encryption system. The document backup server also stores encrypted documents in plaintext, ensuring users' documents remain accessible even in case of an accident.

	
	Multi-level Approval
	Meets the requirements of multi-level office approval workflows, ensuring that applications are reviewed and verified by managers at each level.

	Encryption Read-Only
	Read-Only Encryption
	Encrypts important documents to provide protection. In a read-only authorized environment, encrypted documents can be opened but not modified or saved as a new file. In non-read-only environments, encrypted documents cannot be opened. Prevents users from stealing encrypted document content through clipboard, screenshots, or virtual printing.

	
	Permission Control
	Based on the importance of the document, encrypted documents are categorized into different security zones and levels, allowing different departments and positions to access them. A departmental and hierarchical confidentiality mechanism is established. Users can adjust document areas and levels, and for important documents, higher levels can be set to prevent regular user access.

	
	Offline Authorization
	Grants users the ability to access encrypted documents when leaving an authorized environment. Users can have different encryption software categories and document usage rights set for offline access.

	Encrypted Secure Access Gateway
	Application Server Protection
	Only secure processes can access protected servers. Machines without the client installed, or those not using secure processes to access the protected servers, will be blocked.

	
	Network Shared Folder Protection
	Automatically decrypt uploaded encrypted files to network shared folders and automatically encrypt files when downloaded.

	Network Access Control
	Access Control
	Non-compliant computers cannot access protected servers. Non-compliant computers can be added to a whitelist or provided with guest accounts for temporary access.

	
	Access Control Based on Security Detection
	Based on security detection results, access control is applied to computers that do not meet security requirements. Exception addresses can be configured. Once a computer meets the security conditions, access is automatically granted.


Technical Support
Thank you for your support and trust in our product. Providing high-quality technical support to our customers is our commitment. If you have any technical issues that this manual cannot resolve, please send an email to our technical support department, and we will respond to your questions as soon as possible:
support@anysecura.com
Your feedback and suggestions are important to us, and we will continuously improve our products based on your recommendations.

AnySecura SOFTWARE PTE. LTD.
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